/[smecontribs]/rpms/plague/contribs8/plague.spec
ViewVC logotype

Annotation of /rpms/plague/contribs8/plague.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.6 - (hide annotations) (download)
Tue Sep 9 20:10:09 2008 UTC (16 years ago) by slords
Branch: MAIN
CVS Tags: plague-0_4_5_5-1_el5_sme_1
Changes since 1.5: +14 -5 lines
Plague updates

1 slords 1.6 # $Id: plague.spec,v 1.3 2008/04/02 15:22:03 slords Exp $
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 BuildArch: noarch
6    
7     Summary: Distributed build system for RPMs
8     Name: plague
9 slords 1.6 Version: 0.4.5.5
10 slords 1.5 Release: 1%{?dist}.1
11 slords 1.4 License: GPLv2+
12 slords 1.1 Group: Development/Tools
13 slords 1.4 #Source: http://fedoraproject.org/projects/plague/releases/%{name}-%{version}.tar.bz2
14     Source: %{name}-%{version}.tar.bz2
15 slords 1.5 Patch0: plague-0.4.5.4-pushscript-extras.patch
16 slords 1.1 URL: http://www.fedoraproject.org/wiki/Projects/Plague
17     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
18 slords 1.4 BuildRequires: python
19     Requires: createrepo >= 0.4.7
20     # get the version of the sqlite api thats available to us
21     %if 0%{?rhel}
22     Requires: python-sqlite
23     %else
24     Requires: python-sqlite2
25     %endif
26    
27 slords 1.1 Requires: %{name}-common = %{version}-%{release}
28     Requires(post): /sbin/chkconfig
29     Requires(post): /sbin/service
30     Requires(preun): /sbin/chkconfig
31     Requires(preun): /sbin/service
32    
33    
34     %description
35     The Plague build system is a client/server distributed build system for
36     building RPM packages. This package provides the plague server.
37    
38    
39     %package common
40     Summary: Common resources for the Plague build system
41     Group: Development/Tools
42     Requires: pyOpenSSL
43    
44     %description common
45 slords 1.4 This package includes the common Python module that all Plague services
46     require.
47 slords 1.1
48    
49     %package builder
50     Summary: Builder daemon for Plague builder slaves
51     Group: Development/Tools
52     Requires: %{name}-common = %{version}-%{release}
53 slords 1.4 Requires: yum >= 2.2.1
54     Requires: mock >= 0.8
55 slords 1.1 Requires(post): /sbin/chkconfig
56     Requires(post): /sbin/service
57     Requires(preun): /sbin/chkconfig
58     Requires(preun): /sbin/service
59     Requires(pre): /usr/sbin/useradd
60    
61     %description builder
62     The Plague builder does the actual RPM package building on slave machines.
63    
64     %package client
65     Summary: Package queueing client for the Plague build system
66     Group: Development/Tools
67     Requires: %{name}-common = %{version}-%{release}
68    
69     %description client
70 slords 1.4 Client program for enqueueing package builds and interrogating the build
71     system.
72 slords 1.1
73    
74     %package utils
75     Summary: Utility programs for the Plague build system
76     Group: Development/Tools
77     Requires: %{name}-common = %{version}-%{release}
78 slords 1.4 Requires: %{name} = %{version}-%{release}
79 slords 1.1
80     %description utils
81     This package includes user utilities for the Plague build system, including
82     the interface to the build server.
83    
84    
85     %prep
86     %setup -q
87 slords 1.5 %patch0 -p1 -b .extras
88     find www -name \*.extras | xargs rm
89 slords 1.1
90    
91     %build
92     make
93    
94    
95     %install
96     rm -rf $RPM_BUILD_ROOT
97 slords 1.4 make DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p" install
98     chmod +x $RPM_BUILD_ROOT%{_bindir}/*
99     install -p -D -m 0644 etc/plague-builder.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-builder
100     install -p -D -m 0755 etc/plague-builder.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-builder
101     install -p -D -m 0644 etc/plague-server.config $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}-server
102     install -p -D -m 0755 etc/plague-server.init $RPM_BUILD_ROOT%{_initrddir}/%{name}-server
103     mkdir -p $RPM_BUILD_ROOT/var/lib/plague/builder
104 slords 1.1
105    
106     %clean
107     rm -rf $RPM_BUILD_ROOT
108    
109    
110     %post
111     /sbin/chkconfig --add plague-server
112     /sbin/service plague-server condrestart >> /dev/null || :
113    
114     %preun
115     if [ $1 = 0 ]; then
116     /sbin/service plague-server stop &> /dev/null
117     /sbin/chkconfig --del plague-server
118     fi
119    
120     %pre builder
121 slords 1.4 /usr/sbin/useradd -G mock -s /sbin/nologin -M -r -d /var/lib/plague/builder plague-builder 2>/dev/null || :
122 slords 1.1
123     %post builder
124     /sbin/chkconfig --add plague-builder
125     /sbin/service plague-builder condrestart >> /dev/null || :
126    
127     %preun builder
128     if [ $1 = 0 ]; then
129     /sbin/service plague-builder stop &> /dev/null
130     /sbin/chkconfig --del plague-builder
131     fi
132    
133     %files
134     %defattr(-, root, root)
135     %{_bindir}/%{name}-server
136     %dir %{_datadir}/%{name}/server
137     %{_datadir}/%{name}/server/*.py*
138     %dir %{_sysconfdir}/%{name}/server
139     %dir %{_sysconfdir}/%{name}/server/certs
140     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-server
141     %{_initrddir}/%{name}-server
142 slords 1.4 %doc www
143 slords 1.1
144     %files common
145     %defattr(-, root, root)
146     %doc README ChangeLog
147     %dir %{_sysconfdir}/%{name}
148     %dir %{_datadir}/%{name}
149     %dir /usr/lib/python?.?/site-packages/%{name}
150     /usr/lib/python?.?/site-packages/%{name}/*.py*
151    
152     %files builder
153     %defattr(-, root, root)
154     %{_bindir}/%{name}-builder
155     %dir %{_datadir}/%{name}/builder
156     %{_datadir}/%{name}/builder/*.py*
157     %dir %{_sysconfdir}/%{name}/builder
158     %dir %{_sysconfdir}/%{name}/builder/certs
159     %config(noreplace) %{_sysconfdir}/sysconfig/%{name}-builder
160     %{_initrddir}/%{name}-builder
161 slords 1.4 %dir /var/lib/plague
162     %attr(0755, plague-builder, plague-builder) /var/lib/plague/builder
163 slords 1.1
164     %files client
165     %defattr(-, root, root)
166     %{_bindir}/%{name}-client
167    
168     %files utils
169     %defattr(-, root, root)
170 slords 1.4 %{_bindir}/%{name}-user-manager
171     %{_bindir}/%{name}-certhelper
172 slords 1.1
173    
174     %changelog
175 slords 1.6 * Tue Sep 9 2008 Shad L. Lords <slords@mail.com> - 0.4.5.5-1.1
176     - add the optional pushscript-extras patch
177    
178     * Mon Sep 8 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.5-1
179     - update to 0.4.5.5
180 slords 1.5
181 slords 1.6 * Sun Sep 07 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.4-1
182     - update to 0.4.5.4 to make it work with MySQL 5
183    
184     * Sun Sep 7 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-2
185 slords 1.5 - fix mod_user in plague-user-manager for sqlite2/3
186    
187 slords 1.4 * Fri Sep 5 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5.3-1
188     - update to 0.4.5.3 for sqlite2 compatibility fixes for Fedora
189     - merge fedora pkg spec changes
190     - include the www tree as server pkg docs
191    
192     * Thu Sep 04 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.2-1
193     - fix bug in find option to plague-user-manager
194    
195     * Wed Sep 03 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5.1-1
196     - update to 0.4.5.1 applying Michael schwendt's logging and mock patches
197     - using pysqlite2 on fedora and python-sqlite on RHEL
198     - requires mock > 0.8
199     - requires createrepo >= 0.4.7
200    
201     * Wed Sep 3 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.5-2
202     - add the patches from 0.4.5-0.4 (sqlite3, mock08, logtail)
203     - merge more spec changes
204 slords 1.1
205 slords 1.4 * Tue Sep 02 2008 Dennis Gilmore <dennis@ausil.us> - 0.4.5-1
206     - update to 0.4.5 lots of fixes
207 slords 1.1
208 slords 1.4 * Thu May 22 2008 Seth Vidal <skvidal at fedoraproject.org> - 0.4.4.1-6
209     - licensing tag fix
210 slords 1.1
211 slords 1.4 * Tue Sep 18 2007 Michael Schwendt <mschwendt@fedoraproject.org> - 0.4.4.1-5
212 slords 1.1 - Add dirs /etc/plague and /usr/share/plague to plague-common
213     since "plague-builder" and "plague" use them (#233904).
214    
215     * Fri Dec 15 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.4.1-4
216     - Small fix for a change in python 2.5's xmlrpc library. The patch has been
217     upstreamed.
218    
219     * Thu Dec 14 2006 Jason L Tibbitts III <tibbs@math.uh.edu> - 0.4.4.1-3
220     - Rebuild for new Python
221    
222     * Thu Sep 14 2006 Dennis Gilmore <dennis@ausil.us> 0.4.4.0-2
223     - add patch for bad umask setting
224    
225     * Mon Mar 13 2006 Dan Williams <dcbw@redhat.com> 0.4.4.1-1
226     - Update to 0.4.4.1
227     - Fix createrepo dep to >= 0.4.3 (#rh170531)
228    
229     * Sun Mar 12 2006 Dan Williams <dcbw@redhat.com> 0.4.4-1
230     - Update to 0.4.4 release
231     - Don't use pyOpenSSL's sendall() call, but simulate it to achieve
232     timeouts, better error handling, and more efficient CPU usage
233     - Fix up initscripts and lifecycle management
234     - Implement a TERM handler in server & builder for clean shutdown
235     - Ensure jobs don't hang around on builders if they get left there for
236     some reason (ie, server didn't unlock repo for the job)
237     - Make Additional Package Arches really work (kmod support)
238     - Own /usr/lib/python?.?/site-packages/plague (#rh172794#)
239     - Require createrepo >= 4.3 (#rh170531#)
240    
241     * Tue Jan 24 2006 Dan Williams <dcbw@redhat.com> 0.4.3-6
242     - Increase build server builder thread sleep time to work around SSL issues
243     - Spawn mock in a new process group, and when killing jobs kill the entire
244     process group. Hopefully fix orphaned rpmbuild processes on job kill
245    
246     * Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-5
247     - Restore builder connection timeout
248    
249     * Mon Jan 23 2006 Dan Williams <dcbw@redhat.com> 0.4.3-4
250     - Revert SSL fixes from last build
251    
252     * Sun Jan 22 2006 Dan Williams <dcbw@redhat.com> 0.4.3-3
253     - Don't traceback when killing jobs on builders
254     - Work around SSL hanging issues
255    
256     * Tue Nov 29 2005 Dan Williams <dcbw@redhat.com> 0.4.3-2
257     - Move README and ChangeLog to -common package
258     - Traceback/debug functionality added in server, depends on
259     threadframe module from elsewhere. Disabled by default.
260    
261     * Thu Nov 24 2005 Dan Williams <dcbw@redhat.com> 0.4.3-1
262     - Add socket timeouts for fileserver and xmlrpc bits
263    
264     * Fri Nov 18 2005 Dan Williams <dcbw@redhat.com> 0.4.2-7
265     - Suspend builders on hard errors such as running out of disk space
266     - Retry downloads from server/builder 5 times, not 3
267     - Log retried downloads on the server
268     - Add socket timeouts to downloads to work around hanging issues
269     when downloading from the builder (the downloading/done issue)
270    
271     * Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> 0.4.2-5
272     - Log kill requests on the server
273    
274     * Mon Nov 14 2005 Dan Williams <dcbw@redhat.com> 0.4.2-4
275     - In the builder, close files we open before exec-ing the
276     child process. Fixes massive file descriptor leaks.
277    
278     * Sun Nov 13 2005 Dan Williams <dcbw@redhat.com> 0.4.2-3
279     - Hopefully fix builds not moving past downloading/done
280     - Immediately kill jobs in the 'waiting' state when requested
281     - Utilize pthread_sigmask python module, if present, on Python
282     2.3 and earlier to work around signal blocking issues in
283     Python
284    
285     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-2
286     - Make builders retry downloads from the server up to 3 times
287    
288     * Tue Nov 1 2005 Dan Williams <dcbw@redhat.com> 0.4.2-1
289     - Fix job download from the builders
290     - Fix RPM copy to the repository on the server
291    
292     * Mon Oct 31 2005 Dan Williams <dcbw@redhat.com> 0.4.1-1
293     - Fail jobs on restart if we can't access the original SRPM
294     - For the server, honor config file location passed in on
295     the command line (Jeff Sheltren)
296     - Catch another mock failure case (Alexandr Kanevskiy)
297    
298     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-6
299     - Retry downloads from builders up to 3 times before failing
300     the job
301    
302     * Tue Oct 25 2005 Dan Williams <dcbw@redhat.com> 0.4-5
303     - Add a MySQL database backend (Jeff Sheltren)
304     - Trap repo copy errors rather than doing a traceback
305     - On the builder, deal correctly with jobs in 'downloaded' state
306     that have been killed
307    
308     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-4
309     - Really fix client's "allow_uploads" problem
310    
311     * Wed Oct 19 2005 Dan Williams <dcbw@redhat.com> 0.4-3
312     - Fix errors in client's 'job detail' function
313     - Ignore missing "allow_uploads" option in client config file
314     - Fix server when the Additional Package Arches section is missing
315     from a target config file
316     - Make server more robust against random builder SSL issues
317    
318     * Mon Oct 17 2005 Dan Williams <dcbw@redhat.com> 0.4-2
319     - Increase field size of 'username' and 'status' fields when
320     we initially create them on the server. Server ops will
321     need to increase manually or blow away their jobdb.
322    
323     * Sun Oct 16 2005 Dan Williams <dcbw@redhat.com> 0.4-1
324     - Version 0.4
325     o Server:
326     - Per-target config files, new format
327     - Support PostgreSQL as a database backend
328    
329     o Builder:
330     - Multiple concurrent builds with one builder process
331     - Better tracking of mock child processes
332     - Autodetect supported architectures and number of
333     concurrent build processes
334     - Per-target config files, new format
335    
336     o Client:
337     - Ability to upload packages to server
338    
339     o Utilities:
340     - New distro-rebuild.py utility
341     - Fixes for certhelper.py
342    
343     * Tue Aug 23 2005 Dan Williams <dcbw@redhat.com> 0.3.4-1
344     - Version 0.3.4
345     o Make repo scripts actually work
346     o Don't traceback when cleaning up job files if we have none
347    
348     * Mon Aug 19 2005 Dan Williams <dcbw@redhat.com> 0.3.3-1
349     - Version 0.3.3
350     o Add repo script support
351     o Fix double-slashes in log URL (Ignacio Vazquez-Abrams)
352     o Clear out old job info when requeueing jobs
353    
354     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-3
355     - Clear out old job info when requeueing jobs
356    
357     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-2
358     - Append %{?dist} to Releases to get correct precedence on FC3, FC4, and Rawhide
359    
360     * Mon Aug 15 2005 Dan Williams <dcbw@redhat.com> 0.3.2-1
361     - Version 0.3.2
362     o Fix errors in enqueue and enqueue_srpm return values
363     o Implement client/server API versioning
364    
365     * Thu Aug 11 2005 Dan Williams <dcbw@redhat.com> 0.3.1-1
366     - Version 0.3.1
367     o Clean up web interface error handling, catches more errors
368     o Clean up builder code, hopefully deal with block mock processes waiting
369     to write to stderr
370     o Use HTTP GET rather than POST for web forms, more back/forward/reload
371     friendly (Ville Skyttä)
372    
373     * Mon Aug 8 2005 Dan Williams <dcbw@redhat.com> 0.3-1
374     - Version 0.3
375    
376     * Sat Jul 16 2005 Dan Williams <dcbw@redhat.com>
377     - Bump version to 0.2
378 slords 1.4 - Grab python files from /usr/lib, not %%{_libdir} until the
379 slords 1.1 multiarch issues get worked out
380    
381     * Sun Jun 26 2005 Dan Williams <dcbw@redhat.com>
382     - first version/packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed