/[smecontribs]/rpms/pootle/contribs8/pootle.spec
ViewVC logotype

Annotation of /rpms/pootle/contribs8/pootle.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Feb 24 16:23:19 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: pootle-2_0_2-1_el5_sme
Changes since 1.1: +7 -5 lines
* Wed Feb 24 2010 Shad L. Lords <slords@mail.com> - 2.0.2-1
- Update to 2.0.2

1 slords 1.1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2    
3     %global fullname Pootle
4    
5     Name: pootle
6 slords 1.2 Version: 2.0.2
7     Release: 1%{?dist}
8 slords 1.1 Summary: Localization and translation management web application
9    
10     Group: Development/Tools
11     License: GPLv2+
12     URL: http://translate.sourceforge.net/wiki/pootle/index
13     Source: http://downloads.sourceforge.net/project/translate/%{fullname}/%{version}/%{fullname}-%{version}.tar.bz2
14     Source1: pootle.conf
15     Source2: README.fedora
16     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17    
18     Patch0: pootle-2.0.0-rc2-fedora-settings.patch
19    
20     BuildArch: noarch
21     BuildRequires: python-devel
22     BuildRequires: translate-toolkit >= 1.4.1
23     Requires: Django >= 1.0
24     # iso-codes is not packaged for EL-5
25     #Requires: iso-codes
26     Requires: memcached
27     Requires: mod_wsgi
28     Requires: python-lxml
29     Requires: python-memcached
30     Requires: python-Levenshtein
31     # EL-5 uses Python 2.4 and thus needs sqlite2
32     Requires: python-sqlite2
33     Requires: translate-toolkit >= 1.5.1
34 slords 1.2 Requires: xapian-bindings-python >= 1.0.13
35     Requires: xapian-core
36 slords 1.1 Requires: zip
37     # This is for /sbin/service
38     Requires(post): initscripts
39     Requires(postun): initscripts
40    
41    
42    
43     %description
44     Pootle is web application for managing distributed or crowdsourced
45     translation.
46    
47     It's features include::
48     * Translation of Gettext PO and XLIFF files.
49     * Submitting to remote version control systems (VCS).
50     * Managing groups of translators
51     * Online webbased or offline translation
52     * Quality checks
53    
54    
55     %prep
56     %setup -q -n %{fullname}-%{version}
57     %patch0 -p1 -b .fedora-settings
58    
59    
60     %build
61     %{__python} setup.py build
62    
63    
64     %install
65     rm -rf $RPM_BUILD_ROOT
66     %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
67    
68     # Create the manpages
69     mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
70     for program in $RPM_BUILD_ROOT/%{_bindir}/*;
71     do
72     case $(basename $program) in
73     PootleServer|import_pootle_prefs)
74     ;;
75     *)
76     LC_ALL=C PYTHONPATH=. $program --manpage \
77     > $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \
78     || rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1
79     ;;
80     esac
81     done
82    
83     install -d $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_datadir}/pootle/ $RPM_BUILD_ROOT%{_sharedstatedir}/pootle $RPM_BUILD_ROOT%{_sysconfdir}/pootle
84     install $RPM_BUILD_ROOT%{_bindir}/PootleServer $RPM_BUILD_ROOT%{_sbindir}
85     rm $RPM_BUILD_ROOT%{_bindir}/PootleServer
86     install -p --mode=644 %{SOURCE1} -D $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/pootle.conf
87     install wsgi.py $RPM_BUILD_ROOT%{_datadir}/pootle/
88     cp -p %{SOURCE2} .
89    
90    
91     %clean
92     rm -rf $RPM_BUILD_ROOT
93    
94    
95     %post
96     /sbin/service httpd restart >/dev/null 2>&1 || :
97     /sbin/service memcached restart >/dev/null 2>&1 || :
98    
99    
100     %postun
101     if [ "$1" -ge "1" ] ; then
102     /sbin/service httpd condrestart >/dev/null 2>&1 || :
103     /sbin/service memcached condrestart >/dev/null 2>&1 || :
104     fi
105    
106    
107     %files
108     %defattr(-,root,root,-)
109     %doc COPYING ChangeLog README README.fedora
110     %{_bindir}/*
111     %{_sbindir}/*
112     %{_mandir}/man1/*
113     %config(noreplace) %{_sysconfdir}/pootle
114     %config(noreplace) %{_sysconfdir}/httpd/conf.d/pootle.conf
115     %{python_sitelib}/*
116     %{_datadir}/pootle
117     # %{_sharedstatedir} doesn't work on EL-5
118     #%attr(-,apache,apache) %{_sharedstatedir}/pootle
119     %attr(-,apache,apache) /var/lib/pootle
120     # We exclude docs as the Pootle installer doesn't do ${name}-${version} as expected in Fedora
121     %exclude %{_datadir}/doc/pootle
122    
123    
124     %changelog
125 slords 1.2 * Wed Feb 24 2010 Shad L. Lords <slords@mail.com> - 2.0.2-1
126     - Update to 2.0.2
127    
128 slords 1.1 * Mon Jan 18 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-5
129     - Require python-sqlite2 as its not included in Python 2.4
130    
131     * Mon Jan 18 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-4
132     - Drop Xapian and ISO code support as they're not packaged for EL-5
133    
134     * Sun Jan 17 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-3
135     - Can't use %%{_sharedstatedir}
136    
137     * Thu Jan 14 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-2
138     - Fixes from spec review
139    
140     * Thu Jan 14 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-1
141     - Update to 2.0.1
142    
143     * Mon Dec 7 2009 Dwayne Bailey <dwayne@translate.org.za> - 2.0.0-1
144     - Update to 2.0.0 final
145     - Prefer running under Apache and drop standalone supporting infrastructure
146    
147     * Fri Nov 27 2009 Dwayne Bailey <dwayne@translate.org.za> - 2.0.0-0.1.rc2
148     - Update to 2.0.0 rc2
149    
150     * Thu Nov 5 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.3
151     - Depend on mod_wsgi
152    
153     * Mon Nov 2 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.2
154     - Update to 1.3.0 beta4
155     - Enable mod_wsgi operation: require httpd, default pootle.conf
156     - Backport DB initialisation
157     - Add dependencies for performance: memcached, Levenshtein, xapian
158     - Fedora README
159    
160     * Thu Jan 8 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.1
161     - Django based Pootle
162    
163     * Mon Oct 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1
164     - Update to final 1.2.0 release
165    
166     * Tue Sep 30 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.5.rc1
167     - Update to RC1
168    
169     * Tue Sep 2 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.4.beta2
170     - Create run_pootle.sh wrapper for server
171    
172     * Wed Aug 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.3.beta2
173     - Create man pages
174     - Rebuild with a refreshed tarball that contains jquery
175    
176     * Wed Aug 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.2.beta2
177     - Update to 1.2.0-beta2
178     - Fix initscript installation location
179    
180     * Sun Aug 24 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.1.beta1
181     - Build for 1.2.0-beta1 release
182     - Create initscripts, sysconfig; create proper logging; configure stats database
183    
184     * Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.2-1
185     - Rebuild for fc9
186    
187     * Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.2-1
188     - Initial packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed