/[smecontribs]/rpms/pootle/contribs8/pootle.spec
ViewVC logotype

Annotation of /rpms/pootle/contribs8/pootle.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Feb 24 16:33:06 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
Changes since 1.2: +4 -0 lines
Update spec

1 slords 1.3 # $Id: pootle.spec,v 1.10 2009/10/20 20:45:22 slords Exp $
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6    
7     %global fullname Pootle
8    
9     Name: pootle
10 slords 1.2 Version: 2.0.2
11     Release: 1%{?dist}
12 slords 1.1 Summary: Localization and translation management web application
13    
14     Group: Development/Tools
15     License: GPLv2+
16     URL: http://translate.sourceforge.net/wiki/pootle/index
17     Source: http://downloads.sourceforge.net/project/translate/%{fullname}/%{version}/%{fullname}-%{version}.tar.bz2
18     Source1: pootle.conf
19     Source2: README.fedora
20     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21    
22     Patch0: pootle-2.0.0-rc2-fedora-settings.patch
23    
24     BuildArch: noarch
25     BuildRequires: python-devel
26     BuildRequires: translate-toolkit >= 1.4.1
27     Requires: Django >= 1.0
28     # iso-codes is not packaged for EL-5
29     #Requires: iso-codes
30     Requires: memcached
31     Requires: mod_wsgi
32     Requires: python-lxml
33     Requires: python-memcached
34     Requires: python-Levenshtein
35     # EL-5 uses Python 2.4 and thus needs sqlite2
36     Requires: python-sqlite2
37     Requires: translate-toolkit >= 1.5.1
38 slords 1.2 Requires: xapian-bindings-python >= 1.0.13
39     Requires: xapian-core
40 slords 1.1 Requires: zip
41     # This is for /sbin/service
42     Requires(post): initscripts
43     Requires(postun): initscripts
44    
45    
46    
47     %description
48     Pootle is web application for managing distributed or crowdsourced
49     translation.
50    
51     It's features include::
52     * Translation of Gettext PO and XLIFF files.
53     * Submitting to remote version control systems (VCS).
54     * Managing groups of translators
55     * Online webbased or offline translation
56     * Quality checks
57    
58    
59     %prep
60     %setup -q -n %{fullname}-%{version}
61     %patch0 -p1 -b .fedora-settings
62    
63    
64     %build
65     %{__python} setup.py build
66    
67    
68     %install
69     rm -rf $RPM_BUILD_ROOT
70     %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
71    
72     # Create the manpages
73     mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
74     for program in $RPM_BUILD_ROOT/%{_bindir}/*;
75     do
76     case $(basename $program) in
77     PootleServer|import_pootle_prefs)
78     ;;
79     *)
80     LC_ALL=C PYTHONPATH=. $program --manpage \
81     > $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \
82     || rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1
83     ;;
84     esac
85     done
86    
87     install -d $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_datadir}/pootle/ $RPM_BUILD_ROOT%{_sharedstatedir}/pootle $RPM_BUILD_ROOT%{_sysconfdir}/pootle
88     install $RPM_BUILD_ROOT%{_bindir}/PootleServer $RPM_BUILD_ROOT%{_sbindir}
89     rm $RPM_BUILD_ROOT%{_bindir}/PootleServer
90     install -p --mode=644 %{SOURCE1} -D $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/pootle.conf
91     install wsgi.py $RPM_BUILD_ROOT%{_datadir}/pootle/
92     cp -p %{SOURCE2} .
93    
94    
95     %clean
96     rm -rf $RPM_BUILD_ROOT
97    
98    
99     %post
100     /sbin/service httpd restart >/dev/null 2>&1 || :
101     /sbin/service memcached restart >/dev/null 2>&1 || :
102    
103    
104     %postun
105     if [ "$1" -ge "1" ] ; then
106     /sbin/service httpd condrestart >/dev/null 2>&1 || :
107     /sbin/service memcached condrestart >/dev/null 2>&1 || :
108     fi
109    
110    
111     %files
112     %defattr(-,root,root,-)
113     %doc COPYING ChangeLog README README.fedora
114     %{_bindir}/*
115     %{_sbindir}/*
116     %{_mandir}/man1/*
117     %config(noreplace) %{_sysconfdir}/pootle
118     %config(noreplace) %{_sysconfdir}/httpd/conf.d/pootle.conf
119     %{python_sitelib}/*
120     %{_datadir}/pootle
121     # %{_sharedstatedir} doesn't work on EL-5
122     #%attr(-,apache,apache) %{_sharedstatedir}/pootle
123     %attr(-,apache,apache) /var/lib/pootle
124     # We exclude docs as the Pootle installer doesn't do ${name}-${version} as expected in Fedora
125     %exclude %{_datadir}/doc/pootle
126    
127    
128     %changelog
129 slords 1.2 * Wed Feb 24 2010 Shad L. Lords <slords@mail.com> - 2.0.2-1
130     - Update to 2.0.2
131    
132 slords 1.1 * Mon Jan 18 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-5
133     - Require python-sqlite2 as its not included in Python 2.4
134    
135     * Mon Jan 18 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-4
136     - Drop Xapian and ISO code support as they're not packaged for EL-5
137    
138     * Sun Jan 17 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-3
139     - Can't use %%{_sharedstatedir}
140    
141     * Thu Jan 14 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-2
142     - Fixes from spec review
143    
144     * Thu Jan 14 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-1
145     - Update to 2.0.1
146    
147     * Mon Dec 7 2009 Dwayne Bailey <dwayne@translate.org.za> - 2.0.0-1
148     - Update to 2.0.0 final
149     - Prefer running under Apache and drop standalone supporting infrastructure
150    
151     * Fri Nov 27 2009 Dwayne Bailey <dwayne@translate.org.za> - 2.0.0-0.1.rc2
152     - Update to 2.0.0 rc2
153    
154     * Thu Nov 5 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.3
155     - Depend on mod_wsgi
156    
157     * Mon Nov 2 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.2
158     - Update to 1.3.0 beta4
159     - Enable mod_wsgi operation: require httpd, default pootle.conf
160     - Backport DB initialisation
161     - Add dependencies for performance: memcached, Levenshtein, xapian
162     - Fedora README
163    
164     * Thu Jan 8 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.1
165     - Django based Pootle
166    
167     * Mon Oct 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1
168     - Update to final 1.2.0 release
169    
170     * Tue Sep 30 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.5.rc1
171     - Update to RC1
172    
173     * Tue Sep 2 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.4.beta2
174     - Create run_pootle.sh wrapper for server
175    
176     * Wed Aug 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.3.beta2
177     - Create man pages
178     - Rebuild with a refreshed tarball that contains jquery
179    
180     * Wed Aug 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.2.beta2
181     - Update to 1.2.0-beta2
182     - Fix initscript installation location
183    
184     * Sun Aug 24 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.1.beta1
185     - Build for 1.2.0-beta1 release
186     - Create initscripts, sysconfig; create proper logging; configure stats database
187    
188     * Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.2-1
189     - Rebuild for fc9
190    
191     * Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.2-1
192     - Initial packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed