/[smecontribs]/rpms/pootle/contribs8/pootle.spec
ViewVC logotype

Annotation of /rpms/pootle/contribs8/pootle.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Wed Feb 24 17:30:09 2010 UTC (14 years, 3 months ago) by slords
Branch: MAIN
CVS Tags: pootle-2_0_2-2_el5_sme, HEAD
Changes since 1.3: +6 -4 lines
* Wed Feb 24 2010 Shad L. Lords <slords@mail.com> - 2.0.2-2
- Enable xapian tools and iso-codes

1 slords 1.4 # $Id: pootle.spec,v 1.3 2010/02/24 16:33:06 slords Exp $
2 slords 1.3 # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6    
7     %global fullname Pootle
8    
9     Name: pootle
10 slords 1.2 Version: 2.0.2
11 slords 1.4 Release: 2%{?dist}
12 slords 1.1 Summary: Localization and translation management web application
13    
14     Group: Development/Tools
15     License: GPLv2+
16     URL: http://translate.sourceforge.net/wiki/pootle/index
17     Source: http://downloads.sourceforge.net/project/translate/%{fullname}/%{version}/%{fullname}-%{version}.tar.bz2
18     Source1: pootle.conf
19     Source2: README.fedora
20     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
21    
22     Patch0: pootle-2.0.0-rc2-fedora-settings.patch
23    
24     BuildArch: noarch
25     BuildRequires: python-devel
26     BuildRequires: translate-toolkit >= 1.4.1
27     Requires: Django >= 1.0
28 slords 1.4 Requires: iso-codes
29 slords 1.1 Requires: memcached
30     Requires: mod_wsgi
31     Requires: python-lxml
32     Requires: python-memcached
33     Requires: python-Levenshtein
34     # EL-5 uses Python 2.4 and thus needs sqlite2
35     Requires: python-sqlite2
36     Requires: translate-toolkit >= 1.5.1
37 slords 1.2 Requires: xapian-bindings-python >= 1.0.13
38     Requires: xapian-core
39 slords 1.1 Requires: zip
40     # This is for /sbin/service
41     Requires(post): initscripts
42     Requires(postun): initscripts
43    
44    
45    
46     %description
47     Pootle is web application for managing distributed or crowdsourced
48     translation.
49    
50     It's features include::
51     * Translation of Gettext PO and XLIFF files.
52     * Submitting to remote version control systems (VCS).
53     * Managing groups of translators
54     * Online webbased or offline translation
55     * Quality checks
56    
57    
58     %prep
59     %setup -q -n %{fullname}-%{version}
60     %patch0 -p1 -b .fedora-settings
61    
62    
63     %build
64     %{__python} setup.py build
65    
66    
67     %install
68     rm -rf $RPM_BUILD_ROOT
69     %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
70    
71     # Create the manpages
72     mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
73     for program in $RPM_BUILD_ROOT/%{_bindir}/*;
74     do
75     case $(basename $program) in
76     PootleServer|import_pootle_prefs)
77     ;;
78     *)
79     LC_ALL=C PYTHONPATH=. $program --manpage \
80     > $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1 \
81     || rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/$(basename $program).1
82     ;;
83     esac
84     done
85    
86     install -d $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_datadir}/pootle/ $RPM_BUILD_ROOT%{_sharedstatedir}/pootle $RPM_BUILD_ROOT%{_sysconfdir}/pootle
87     install $RPM_BUILD_ROOT%{_bindir}/PootleServer $RPM_BUILD_ROOT%{_sbindir}
88     rm $RPM_BUILD_ROOT%{_bindir}/PootleServer
89     install -p --mode=644 %{SOURCE1} -D $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/pootle.conf
90     install wsgi.py $RPM_BUILD_ROOT%{_datadir}/pootle/
91     cp -p %{SOURCE2} .
92    
93    
94     %clean
95     rm -rf $RPM_BUILD_ROOT
96    
97    
98     %post
99     /sbin/service httpd restart >/dev/null 2>&1 || :
100     /sbin/service memcached restart >/dev/null 2>&1 || :
101    
102    
103     %postun
104     if [ "$1" -ge "1" ] ; then
105     /sbin/service httpd condrestart >/dev/null 2>&1 || :
106     /sbin/service memcached condrestart >/dev/null 2>&1 || :
107     fi
108    
109    
110     %files
111     %defattr(-,root,root,-)
112     %doc COPYING ChangeLog README README.fedora
113     %{_bindir}/*
114     %{_sbindir}/*
115     %{_mandir}/man1/*
116     %config(noreplace) %{_sysconfdir}/pootle
117     %config(noreplace) %{_sysconfdir}/httpd/conf.d/pootle.conf
118     %{python_sitelib}/*
119     %{_datadir}/pootle
120     # %{_sharedstatedir} doesn't work on EL-5
121     #%attr(-,apache,apache) %{_sharedstatedir}/pootle
122     %attr(-,apache,apache) /var/lib/pootle
123     # We exclude docs as the Pootle installer doesn't do ${name}-${version} as expected in Fedora
124     %exclude %{_datadir}/doc/pootle
125    
126    
127     %changelog
128 slords 1.4 * Wed Feb 24 2010 Shad L. Lords <slords@mail.com> - 2.0.2-2
129     - Enable xapian tools and iso-codes
130    
131 slords 1.2 * Wed Feb 24 2010 Shad L. Lords <slords@mail.com> - 2.0.2-1
132     - Update to 2.0.2
133    
134 slords 1.1 * Mon Jan 18 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-5
135     - Require python-sqlite2 as its not included in Python 2.4
136    
137     * Mon Jan 18 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-4
138     - Drop Xapian and ISO code support as they're not packaged for EL-5
139    
140     * Sun Jan 17 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-3
141     - Can't use %%{_sharedstatedir}
142    
143     * Thu Jan 14 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-2
144     - Fixes from spec review
145    
146     * Thu Jan 14 2010 Dwayne Bailey <dwayne@translate.org.za> - 2.0.1-1
147     - Update to 2.0.1
148    
149     * Mon Dec 7 2009 Dwayne Bailey <dwayne@translate.org.za> - 2.0.0-1
150     - Update to 2.0.0 final
151     - Prefer running under Apache and drop standalone supporting infrastructure
152    
153     * Fri Nov 27 2009 Dwayne Bailey <dwayne@translate.org.za> - 2.0.0-0.1.rc2
154     - Update to 2.0.0 rc2
155    
156     * Thu Nov 5 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.3
157     - Depend on mod_wsgi
158    
159     * Mon Nov 2 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.2
160     - Update to 1.3.0 beta4
161     - Enable mod_wsgi operation: require httpd, default pootle.conf
162     - Backport DB initialisation
163     - Add dependencies for performance: memcached, Levenshtein, xapian
164     - Fedora README
165    
166     * Thu Jan 8 2009 Dwayne Bailey <dwayne@translate.org.za> - 1.3.0-0.1
167     - Django based Pootle
168    
169     * Mon Oct 6 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-1
170     - Update to final 1.2.0 release
171    
172     * Tue Sep 30 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.5.rc1
173     - Update to RC1
174    
175     * Tue Sep 2 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.4.beta2
176     - Create run_pootle.sh wrapper for server
177    
178     * Wed Aug 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.3.beta2
179     - Create man pages
180     - Rebuild with a refreshed tarball that contains jquery
181    
182     * Wed Aug 27 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.2.beta2
183     - Update to 1.2.0-beta2
184     - Fix initscript installation location
185    
186     * Sun Aug 24 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.2.0-0.1.beta1
187     - Build for 1.2.0-beta1 release
188     - Create initscripts, sysconfig; create proper logging; configure stats database
189    
190     * Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.2-1
191     - Rebuild for fc9
192    
193     * Thu Feb 14 2008 Dwayne Bailey <dwayne@translate.org.za> - 1.0.2-1
194     - Initial packaging

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed