1 |
slords |
1.2 |
# Redifine to remove /usr/lib/rpm/brp-python-bytecompile |
2 |
|
|
%define __os_install_post \ |
3 |
|
|
/usr/lib/rpm/redhat/brp-compress \ |
4 |
|
|
%{!?__debug_package:/usr/lib/rpm/redhat/brp-strip %{__strip}} \ |
5 |
|
|
/usr/lib/rpm/redhat/brp-strip-static-archive %{__strip} \ |
6 |
|
|
/usr/lib/rpm/redhat/brp-strip-comment-note %{__strip} %{__objdump} \ |
7 |
|
|
/usr/lib/rpm/redhat/brp-java-repack-jars \ |
8 |
|
|
%{nil} |
9 |
|
|
|
10 |
slords |
1.1 |
%define name python-Levenshtein |
11 |
|
|
%define version 0.10.1 |
12 |
|
|
%define release 1 |
13 |
|
|
|
14 |
|
|
Summary: Python extension computing string distances and similarities. |
15 |
|
|
Name: %{name} |
16 |
|
|
Version: %{version} |
17 |
|
|
Release: %{release}%{?dist} |
18 |
|
|
Source0: %{name}-%{version}.tar.gz |
19 |
|
|
License: GNU GPL |
20 |
|
|
Group: Development/Libraries |
21 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
22 |
|
|
Prefix: %{_prefix} |
23 |
|
|
Vendor: Trific soft. |
24 |
|
|
Url: http://trific.ath.cx/python/levenshtein/ |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
|
28 |
|
|
Levenshtein computes Levenshtein distances, similarity ratios, generalized |
29 |
|
|
medians and set medians of Strings and Unicodes. Becuase it's implemented |
30 |
|
|
in C, it's much faster than corresponding Python library functions and |
31 |
|
|
methods. |
32 |
|
|
|
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
%setup |
36 |
|
|
|
37 |
|
|
%build |
38 |
|
|
env CFLAGS="$RPM_OPT_FLAGS" python setup.py build |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES |
42 |
|
|
|
43 |
|
|
%clean |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
|
46 |
|
|
%files -f INSTALLED_FILES |
47 |
|
|
%defattr(-,root,root) |
48 |
|
|
%doc README COPYING NEWS |