1 |
slords |
1.1 |
%define name python-Levenshtein |
2 |
|
|
%define version 0.10.1 |
3 |
|
|
%define release 1 |
4 |
|
|
|
5 |
|
|
Summary: Python extension computing string distances and similarities. |
6 |
|
|
Name: %{name} |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
Source0: %{name}-%{version}.tar.gz |
10 |
|
|
License: GNU GPL |
11 |
|
|
Group: Development/Libraries |
12 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
13 |
|
|
Prefix: %{_prefix} |
14 |
|
|
Vendor: Trific soft. |
15 |
|
|
Url: http://trific.ath.cx/python/levenshtein/ |
16 |
slords |
1.4 |
BuildRequires: python-devel |
17 |
slords |
1.1 |
|
18 |
|
|
%description |
19 |
|
|
|
20 |
|
|
Levenshtein computes Levenshtein distances, similarity ratios, generalized |
21 |
|
|
medians and set medians of Strings and Unicodes. Becuase it's implemented |
22 |
|
|
in C, it's much faster than corresponding Python library functions and |
23 |
|
|
methods. |
24 |
|
|
|
25 |
|
|
|
26 |
|
|
%prep |
27 |
|
|
%setup |
28 |
|
|
|
29 |
|
|
%build |
30 |
|
|
env CFLAGS="$RPM_OPT_FLAGS" python setup.py build |
31 |
|
|
|
32 |
|
|
%install |
33 |
|
|
python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES |
34 |
|
|
|
35 |
|
|
%clean |
36 |
|
|
rm -rf $RPM_BUILD_ROOT |
37 |
|
|
|
38 |
|
|
%files -f INSTALLED_FILES |
39 |
|
|
%defattr(-,root,root) |
40 |
|
|
%doc README COPYING NEWS |