1 |
slords |
1.8 |
# $Id: python-Levenshtein.spec,v 1.7 2008/04/23 19:18:55 slords Exp $ |
2 |
slords |
1.6 |
# Authority: slords |
3 |
slords |
1.5 |
# Name: Shad L. Lords |
4 |
|
|
|
5 |
slords |
1.1 |
%define name python-Levenshtein |
6 |
|
|
%define version 0.10.1 |
7 |
|
|
%define release 1 |
8 |
|
|
|
9 |
|
|
Summary: Python extension computing string distances and similarities. |
10 |
|
|
Name: %{name} |
11 |
|
|
Version: %{version} |
12 |
|
|
Release: %{release}%{?dist} |
13 |
|
|
Source0: %{name}-%{version}.tar.gz |
14 |
|
|
License: GNU GPL |
15 |
|
|
Group: Development/Libraries |
16 |
|
|
BuildRoot: %{_tmppath}/%{name}-buildroot |
17 |
|
|
Prefix: %{_prefix} |
18 |
|
|
Url: http://trific.ath.cx/python/levenshtein/ |
19 |
slords |
1.4 |
BuildRequires: python-devel |
20 |
slords |
1.1 |
|
21 |
|
|
%description |
22 |
|
|
|
23 |
|
|
Levenshtein computes Levenshtein distances, similarity ratios, generalized |
24 |
|
|
medians and set medians of Strings and Unicodes. Becuase it's implemented |
25 |
|
|
in C, it's much faster than corresponding Python library functions and |
26 |
|
|
methods. |
27 |
|
|
|
28 |
|
|
|
29 |
|
|
%prep |
30 |
|
|
%setup |
31 |
|
|
|
32 |
|
|
%build |
33 |
|
|
env CFLAGS="$RPM_OPT_FLAGS" python setup.py build |
34 |
|
|
|
35 |
|
|
%install |
36 |
|
|
python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES |
37 |
|
|
|
38 |
|
|
%clean |
39 |
|
|
rm -rf $RPM_BUILD_ROOT |
40 |
|
|
|
41 |
|
|
%files -f INSTALLED_FILES |
42 |
|
|
%defattr(-,root,root) |
43 |
|
|
%doc README COPYING NEWS |