/[smecontribs]/rpms/python-sqlalchemy/contribs8/python-sqlalchemy.spec
ViewVC logotype

Annotation of /rpms/python-sqlalchemy/contribs8/python-sqlalchemy.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Thu Mar 4 00:55:33 2010 UTC (14 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: python-sqlalchemy-0_4_8-1_el5_sme
Initial import

1 slords 1.1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2     %{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
3    
4     %define srcname SQLAlchemy
5    
6     Name: python-sqlalchemy
7     Version: 0.4.8
8     Release: 1%{?dist}
9     Summary: Modular and flexible ORM library for python
10    
11     Group: Development/Libraries
12     License: MIT
13     URL: http://www.sqlalchemy.org/
14     Source0: http://downloads.sourceforge.net/sqlalchemy/%{srcname}-%{version}.tar.gz
15     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16    
17     BuildArch: noarch
18     BuildRequires: python-devel
19     BuildRequires: python-sqlite2
20     BuildRequires: python-setuptools >= 0.6c3
21    
22     %description
23     SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible,
24     high-level interface to SQL databases. Database and domain concepts are
25     decoupled, allowing both sides maximum flexibility and power. SQLAlchemy
26     provides a powerful mapping layer that can work as automatically or as manually
27     as you choose, determining relationships based on foreign keys or letting you
28     define the join conditions explicitly, to bridge the gap between database and
29     domain.
30    
31     %prep
32     %setup -q -n %{srcname}-%{version}
33    
34    
35     %build
36     CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
37     sed -i 's/\r//' examples/dynamic_dict/dynamic_dict.py
38    
39     %install
40     rm -rf $RPM_BUILD_ROOT
41     mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
42     python setup.py install --skip-build --root $RPM_BUILD_ROOT
43    
44     # remove unnecessary scripts for building documentation
45     rm -rf doc/build
46    
47     %clean
48     rm -rf $RPM_BUILD_ROOT
49    
50     %check
51     export PYTHONPATH=./test
52     python test/alltests.py
53    
54     %files
55     %defattr(-,root,root,-)
56     %doc README LICENSE PKG-INFO CHANGES doc examples
57     %{python_sitelib}/*
58    
59     %changelog
60     * Tue Jan 20 2009 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.8-1
61     - Update to 0.4.8 which fixes bz#478519
62    
63     * Sun Jul 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.7-1
64     - Update to 0.4.7.
65    
66     * Sun Jun 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.6-1
67     - Update to 0.4.6.
68    
69     * Tue Apr 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.5-1
70     - Update to 0.4.5.
71    
72     * Fri Feb 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.3-1
73     - Update to 0.4.3.
74    
75     * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.2-1.p3
76     - Update to 0.4.2p3.
77    
78     * Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.1-1
79     - Update to 0.4.1.
80    
81     * Wed Oct 17 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.0-1
82     - SQLAlchemy-0.4.0 final
83     - Run the testsuite
84    
85     * Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> 0.4.0-0.4.beta6
86     - SQLAlchemy-0.4.0beta6
87    
88     * Tue Sep 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta5
89     - Update to 0.4beta5.
90    
91     * Fri Sep 06 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta4
92     - setuptools has been fixed.
93    
94     * Fri Aug 31 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.3.beta4
95     - setuptools seems to be broken WRT having an active and inactive version
96     of an egg. Have to make both versions inactive and manually setup a copy
97     that can be started via import. (Necessary for the sqlalchemy0.3 compat
98     package.)
99    
100     * Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.2.beta4
101     - Modify setuptools to handle the -devel subpackage split in F-8.
102    
103     * Mon Aug 27 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.0-0.1.beta4
104     - Update to 0.4 beta4.
105    
106     * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-2
107     - Remove python-abi Requires. This is automatic since FC4+.
108    
109     * Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-1
110     - Update to new upstream version 0.3.10
111    
112     * Fri Mar 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.6-1
113     - Update to new upstream version 0.3.6
114    
115     * Sat Mar 10 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.5-1
116     - Update to new upstream version 0.3.5
117     - Simplify the files listing
118    
119     * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-2
120     - Remember to upload the source tarball to the lookaside cache.
121    
122     * Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-1
123     - Update to new upstream version 0.3.4
124    
125     * Mon Jan 01 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.3-1
126     - Update to new upstream version 0.3.3
127    
128     * Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-2
129     - Bump and rebuild for python 2.5 on devel.
130     - BuildRequire: python-devel as a header is missing otherwise.
131    
132     * Fri Nov 24 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-1
133     - Update to new upstream version 0.3.1
134    
135     * Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 0.2.7-2
136     - Rebuild for FC6
137    
138     * Thu Aug 17 2006 Shahms E. King <shahms@shahms.com> 0.2.7-1
139     - Update to new upstream version
140    
141     * Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.2.6-2
142     - Include, don't ghost .pyo files per new guidelines
143    
144     * Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 0.2.6-1
145     - Update to new upstream version
146    
147     * Fri Jul 07 2006 Shahms E. King <shahms@shahms.com> 0.2.4-1
148     - Update to new upstream version
149    
150     * Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.2.3-1
151     - Update to new upstream version
152    
153     * Wed May 31 2006 Shahms E. King <shahms@shahms.com> 0.2.1-1
154     - Update to new upstream version

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed