1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
# Authority: slords |
3 |
|
|
# Name: Shad L. Lords |
4 |
|
|
|
5 |
slords |
1.1 |
%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")} |
6 |
|
|
%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")} |
7 |
|
|
|
8 |
|
|
%define srcname SQLAlchemy |
9 |
|
|
|
10 |
|
|
Name: python-sqlalchemy |
11 |
|
|
Version: 0.4.8 |
12 |
|
|
Release: 1%{?dist} |
13 |
|
|
Summary: Modular and flexible ORM library for python |
14 |
|
|
|
15 |
|
|
Group: Development/Libraries |
16 |
|
|
License: MIT |
17 |
|
|
URL: http://www.sqlalchemy.org/ |
18 |
|
|
Source0: http://downloads.sourceforge.net/sqlalchemy/%{srcname}-%{version}.tar.gz |
19 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
20 |
|
|
|
21 |
|
|
BuildArch: noarch |
22 |
|
|
BuildRequires: python-devel |
23 |
|
|
BuildRequires: python-sqlite2 |
24 |
|
|
BuildRequires: python-setuptools >= 0.6c3 |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
SQLAlchemy is an Object Relational Mappper (ORM) that provides a flexible, |
28 |
|
|
high-level interface to SQL databases. Database and domain concepts are |
29 |
|
|
decoupled, allowing both sides maximum flexibility and power. SQLAlchemy |
30 |
|
|
provides a powerful mapping layer that can work as automatically or as manually |
31 |
|
|
as you choose, determining relationships based on foreign keys or letting you |
32 |
|
|
define the join conditions explicitly, to bridge the gap between database and |
33 |
|
|
domain. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup -q -n %{srcname}-%{version} |
37 |
|
|
|
38 |
|
|
|
39 |
|
|
%build |
40 |
|
|
CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build |
41 |
|
|
sed -i 's/\r//' examples/dynamic_dict/dynamic_dict.py |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
mkdir -p $RPM_BUILD_ROOT%{python_sitelib} |
46 |
|
|
python setup.py install --skip-build --root $RPM_BUILD_ROOT |
47 |
|
|
|
48 |
|
|
# remove unnecessary scripts for building documentation |
49 |
|
|
rm -rf doc/build |
50 |
|
|
|
51 |
|
|
%clean |
52 |
|
|
rm -rf $RPM_BUILD_ROOT |
53 |
|
|
|
54 |
|
|
%check |
55 |
|
|
export PYTHONPATH=./test |
56 |
|
|
python test/alltests.py |
57 |
|
|
|
58 |
|
|
%files |
59 |
|
|
%defattr(-,root,root,-) |
60 |
|
|
%doc README LICENSE PKG-INFO CHANGES doc examples |
61 |
|
|
%{python_sitelib}/* |
62 |
|
|
|
63 |
|
|
%changelog |
64 |
|
|
* Tue Jan 20 2009 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.8-1 |
65 |
|
|
- Update to 0.4.8 which fixes bz#478519 |
66 |
|
|
|
67 |
|
|
* Sun Jul 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.7-1 |
68 |
|
|
- Update to 0.4.7. |
69 |
|
|
|
70 |
|
|
* Sun Jun 1 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.6-1 |
71 |
|
|
- Update to 0.4.6. |
72 |
|
|
|
73 |
|
|
* Tue Apr 8 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.5-1 |
74 |
|
|
- Update to 0.4.5. |
75 |
|
|
|
76 |
|
|
* Fri Feb 22 2008 Toshio Kuratomi <toshio@fedoraproject.org> 0.4.3-1 |
77 |
|
|
- Update to 0.4.3. |
78 |
|
|
|
79 |
|
|
* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.2-1.p3 |
80 |
|
|
- Update to 0.4.2p3. |
81 |
|
|
|
82 |
|
|
* Tue Dec 11 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.1-1 |
83 |
|
|
- Update to 0.4.1. |
84 |
|
|
|
85 |
|
|
* Wed Oct 17 2007 Toshio Kuratomi <a.badger@gmail.com> 0.4.0-1 |
86 |
|
|
- SQLAlchemy-0.4.0 final |
87 |
|
|
- Run the testsuite |
88 |
|
|
|
89 |
|
|
* Wed Oct 3 2007 Luke Macken <lmacken@redhat.com> 0.4.0-0.4.beta6 |
90 |
|
|
- SQLAlchemy-0.4.0beta6 |
91 |
|
|
|
92 |
|
|
* Tue Sep 11 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta5 |
93 |
|
|
- Update to 0.4beta5. |
94 |
|
|
|
95 |
|
|
* Fri Sep 06 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.4.beta4 |
96 |
|
|
- setuptools has been fixed. |
97 |
|
|
|
98 |
|
|
* Fri Aug 31 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.3.beta4 |
99 |
|
|
- setuptools seems to be broken WRT having an active and inactive version |
100 |
|
|
of an egg. Have to make both versions inactive and manually setup a copy |
101 |
|
|
that can be started via import. (Necessary for the sqlalchemy0.3 compat |
102 |
|
|
package.) |
103 |
|
|
|
104 |
|
|
* Tue Aug 28 2007 Toshio Kuratomi <a.badger@gmail.com> - 0.4.0-0.2.beta4 |
105 |
|
|
- Modify setuptools to handle the -devel subpackage split in F-8. |
106 |
|
|
|
107 |
|
|
* Mon Aug 27 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.4.0-0.1.beta4 |
108 |
|
|
- Update to 0.4 beta4. |
109 |
|
|
|
110 |
|
|
* Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-2 |
111 |
|
|
- Remove python-abi Requires. This is automatic since FC4+. |
112 |
|
|
|
113 |
|
|
* Tue Jul 24 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.10-1 |
114 |
|
|
- Update to new upstream version 0.3.10 |
115 |
|
|
|
116 |
|
|
* Fri Mar 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.6-1 |
117 |
|
|
- Update to new upstream version 0.3.6 |
118 |
|
|
|
119 |
|
|
* Sat Mar 10 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.5-1 |
120 |
|
|
- Update to new upstream version 0.3.5 |
121 |
|
|
- Simplify the files listing |
122 |
|
|
|
123 |
|
|
* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-2 |
124 |
|
|
- Remember to upload the source tarball to the lookaside cache. |
125 |
|
|
|
126 |
|
|
* Tue Jan 23 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.4-1 |
127 |
|
|
- Update to new upstream version 0.3.4 |
128 |
|
|
|
129 |
|
|
* Mon Jan 01 2007 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.3-1 |
130 |
|
|
- Update to new upstream version 0.3.3 |
131 |
|
|
|
132 |
|
|
* Sat Dec 09 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-2 |
133 |
|
|
- Bump and rebuild for python 2.5 on devel. |
134 |
|
|
- BuildRequire: python-devel as a header is missing otherwise. |
135 |
|
|
|
136 |
|
|
* Fri Nov 24 2006 Toshio Kuratomi <toshio@tiki-lounge.com> - 0.3.1-1 |
137 |
|
|
- Update to new upstream version 0.3.1 |
138 |
|
|
|
139 |
|
|
* Sat Sep 16 2006 Shahms E. King <shahms@shahms.com> 0.2.7-2 |
140 |
|
|
- Rebuild for FC6 |
141 |
|
|
|
142 |
|
|
* Thu Aug 17 2006 Shahms E. King <shahms@shahms.com> 0.2.7-1 |
143 |
|
|
- Update to new upstream version |
144 |
|
|
|
145 |
|
|
* Fri Aug 11 2006 Shahms E. King <shahms@shahms.com> 0.2.6-2 |
146 |
|
|
- Include, don't ghost .pyo files per new guidelines |
147 |
|
|
|
148 |
|
|
* Tue Aug 08 2006 Shahms E. King <shahms@shahms.com> 0.2.6-1 |
149 |
|
|
- Update to new upstream version |
150 |
|
|
|
151 |
|
|
* Fri Jul 07 2006 Shahms E. King <shahms@shahms.com> 0.2.4-1 |
152 |
|
|
- Update to new upstream version |
153 |
|
|
|
154 |
|
|
* Mon Jun 26 2006 Shahms E. King <shahms@shahms.com> 0.2.3-1 |
155 |
|
|
- Update to new upstream version |
156 |
|
|
|
157 |
|
|
* Wed May 31 2006 Shahms E. King <shahms@shahms.com> 0.2.1-1 |
158 |
|
|
- Update to new upstream version |