1 |
jpp |
1.2 |
%global scl python27 |
2 |
|
|
%scl_package %scl |
3 |
|
|
# Defaults for the values for the python27 Software Collection. These |
4 |
|
|
# will be used when python27-scldevel is not in the buildroot |
5 |
|
|
%{!?scl_python:%global scl_python python27} |
6 |
|
|
%{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-} |
7 |
|
|
|
8 |
|
|
%{?scl:%scl_package python-versiontools} |
9 |
|
|
%{!?scl:%global pkg_name %{name}} |
10 |
|
|
|
11 |
jpp |
1.1 |
%global pypi_name versiontools |
12 |
|
|
|
13 |
jpp |
1.2 |
%define version 1.9.1 |
14 |
|
|
%define release 4 |
15 |
|
|
Name: %{?scl_prefix}python-versiontools |
16 |
|
|
Version: %{version} |
17 |
|
|
Release: %{release}%{?dist} |
18 |
jpp |
1.1 |
Summary: Smart replacement for plain tuple used in __version__ |
19 |
|
|
|
20 |
|
|
License: LGPLv3 |
21 |
|
|
URL: https://launchpad.net/versiontools |
22 |
|
|
Source0: http://pypi.python.org/packages/source/v/versiontools/versiontools-1.9.1.tar.gz |
23 |
|
|
|
24 |
jpp |
1.2 |
BuildArch: x86_64 |
25 |
|
|
#SCL |
26 |
|
|
BuildRequires: scl-utils-build |
27 |
|
|
BuildRequires: %{scl_prefix}scldevel |
28 |
|
|
BuildRequires: %{scl_prefix}build |
29 |
|
|
BuildRequires: %{scl_prefix}python-devel |
30 |
|
|
BuildRequires: %{scl_prefix}python-setuptools |
31 |
jpp |
1.1 |
BuildRequires: python-sphinx |
32 |
jpp |
1.2 |
BuildRequires: %{scl_prefix}python-nose |
33 |
|
|
%{?scl:BuildRequires: %{scl}-build %{scl}-runtime} |
34 |
|
|
%{?scl:Requires: %{scl}-runtime} |
35 |
|
|
|
36 |
jpp |
1.1 |
|
37 |
|
|
%description |
38 |
|
|
Smart replacement for plain tuple used in __version__ |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
%setup -q -n %{pypi_name}-%{version} |
42 |
|
|
# remove bundled egg-info |
43 |
|
|
rm -rf %{pypi_name}.egg-info |
44 |
|
|
# generate html docs |
45 |
|
|
sphinx-build doc html |
46 |
|
|
# remove the sphinx-build leftovers |
47 |
|
|
rm -rf html/.{doctrees,buildinfo} |
48 |
|
|
|
49 |
|
|
|
50 |
|
|
%build |
51 |
jpp |
1.2 |
%{?scl:scl enable %{scl} - << \EOF} |
52 |
|
|
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
53 |
|
|
|
54 |
jpp |
1.1 |
%{__python} setup.py build |
55 |
jpp |
1.2 |
%{?scl:EOF} |
56 |
jpp |
1.1 |
|
57 |
|
|
|
58 |
|
|
%install |
59 |
jpp |
1.2 |
%scl_install |
60 |
|
|
%{?scl:scl enable %{scl} - << \EOF} |
61 |
|
|
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
62 |
jpp |
1.1 |
%{__python} setup.py install -O1 --skip-build --root %{buildroot} |
63 |
jpp |
1.2 |
%{?scl:EOF} |
64 |
|
|
find %{buildroot} -name '*.la' -exec rm -f {} ';' |
65 |
|
|
rm -rf %{buildroot}/etc/rpm/macros.python27-config |
66 |
|
|
rm -rf %{buildroot}/etc/scl/prefixes/python27 |
67 |
|
|
rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp |
68 |
|
|
rm -rf %{buildroot}/opt/rh/python27/root/var/mail |
69 |
jpp |
1.1 |
|
70 |
|
|
|
71 |
|
|
%check |
72 |
jpp |
1.2 |
%{?scl:scl enable %{scl} - << \EOF} |
73 |
|
|
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
74 |
jpp |
1.1 |
%{__python} setup.py nosetests |
75 |
jpp |
1.2 |
%{?scl:EOF} |
76 |
jpp |
1.1 |
|
77 |
|
|
%files |
78 |
|
|
%doc html |
79 |
|
|
%{python_sitelib}/%{pypi_name} |
80 |
|
|
%{python_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info |
81 |
|
|
|
82 |
|
|
|
83 |
|
|
%changelog |
84 |
jpp |
1.2 |
* Sat Mar 24 2018 Jean-Philipe Pialasse <tests@pialasse.com> - 1.9.1-4.sme |
85 |
|
|
- x64 for python27 scl |
86 |
|
|
|
87 |
jpp |
1.1 |
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.1-3 |
88 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
89 |
|
|
|
90 |
|
|
* Fri May 04 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 1.9.1-2 |
91 |
|
|
- Be more explicit in %%files section. |
92 |
|
|
|
93 |
|
|
* Thu May 03 2012 Bohuslav Kabrda <bkabrda@redhat.com> - 1.9.1-1 |
94 |
|
|
- Initial package. |