1 |
jpp |
1.1 |
Summary: a random password generator |
2 |
|
|
%define name randpw |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.0.4 |
5 |
jpp |
1.2 |
%define release 3 |
6 |
jpp |
1.1 |
Epoch: 9 |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
URL: http://www.contribs.org |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
AutoReqProv: no |
16 |
|
|
Requires: openssl |
17 |
|
|
%description |
18 |
|
|
a random password generator created by Hsing-Foo Wang hsingfoo@gmail.com |
19 |
|
|
|
20 |
|
|
%changelog |
21 |
jpp |
1.2 |
* Tue Aug 02 2022 Jean-Philippe Pialasse <tests@pialasse.com> 0.0.4-3.sme |
22 |
|
|
- Initial release to contribs 10 |
23 |
|
|
|
24 |
jpp |
1.1 |
* Tue Aug 18 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.4-2.sme |
25 |
|
|
- Initial release to contribs9 |
26 |
|
|
|
27 |
|
|
* Sat Jul 25 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.4-1 |
28 |
|
|
- openssl is now used to generate the password |
29 |
|
|
- You must give an argument greater or equal than 8 |
30 |
|
|
|
31 |
|
|
* Wed Oct 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.3-1 |
32 |
|
|
- new options added to prevent No argument, a negative number, |
33 |
|
|
- zero and non integer argument or a no integer argument part |
34 |
|
|
- -1 0 123abc and abc by Hsing-Foo Wang hsingfoo@gmail.com |
35 |
|
|
|
36 |
|
|
* Tue Oct 07 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.1-1 |
37 |
|
|
- Initial relase, idea from Hsing-Foo Wang hsingfoo@gmail.com |
38 |
|
|
|
39 |
|
|
%prep |
40 |
|
|
%setup |
41 |
|
|
%build |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
46 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
47 |
|
|
|
48 |
|
|
%clean |
49 |
|
|
cd .. |
50 |
|
|
rm -rf %{name}-%{version} |
51 |
|
|
|
52 |
|
|
%pre |
53 |
|
|
%preun |
54 |
|
|
%post |
55 |
|
|
%postun |
56 |
|
|
|
57 |
|
|
%files |
58 |
|
|
%defattr(-,root,root) |
59 |
|
|
%attr(755, root,root) /usr/bin/randpw |