1 |
stephdl |
1.1 |
Summary: a random password generator |
2 |
|
|
%define name randpw |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.0.4 |
5 |
|
|
%define release 2 |
6 |
|
|
Epoch: 9 |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}%{?dist} |
9 |
|
|
License: GPL |
10 |
|
|
URL: http://www.contribs.org |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
AutoReqProv: no |
16 |
|
|
Requires: openssl |
17 |
|
|
%description |
18 |
|
|
a random password generator created by Hsing-Foo Wang hsingfoo@gmail.com |
19 |
|
|
|
20 |
|
|
%changelog |
21 |
|
|
* Fri Aug 14 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.4-2.sme |
22 |
|
|
- Initial release to contribs8 |
23 |
|
|
|
24 |
|
|
* Sat Jul 25 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.4-1 |
25 |
|
|
- openssl is now used to generate the password |
26 |
|
|
- You must give an argument greater or equal than 8 |
27 |
|
|
|
28 |
|
|
* Wed Oct 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.3-1 |
29 |
|
|
- new options added to prevent No argument, a negative number, |
30 |
|
|
- zero and non integer argument or a no integer argument part |
31 |
|
|
- -1 0 123abc and abc by Hsing-Foo Wang hsingfoo@gmail.com |
32 |
|
|
|
33 |
|
|
* Tue Oct 07 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.1-1 |
34 |
|
|
- Initial relase, idea from Hsing-Foo Wang hsingfoo@gmail.com |
35 |
|
|
|
36 |
|
|
%prep |
37 |
|
|
%setup |
38 |
|
|
%build |
39 |
|
|
|
40 |
|
|
%install |
41 |
|
|
rm -rf $RPM_BUILD_ROOT |
42 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
43 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
44 |
|
|
|
45 |
|
|
%clean |
46 |
|
|
cd .. |
47 |
|
|
rm -rf %{name}-%{version} |
48 |
|
|
|
49 |
|
|
%pre |
50 |
|
|
%preun |
51 |
|
|
%post |
52 |
|
|
%postun |
53 |
|
|
|
54 |
|
|
%files |
55 |
|
|
%defattr(-,root,root) |
56 |
|
|
%attr(755, root,root) /usr/bin/randpw |