1 |
vip-ire |
1.1 |
Summary: a random password generator |
2 |
|
|
%define name randpw |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.0.3 |
5 |
|
|
%define release 1 |
6 |
|
|
Epoch: 9 |
7 |
|
|
Version: %{version} |
8 |
|
|
Release: %{release}.el6 |
9 |
|
|
License: GPL |
10 |
|
|
URL: http://www.contribs.org |
11 |
|
|
Group: SMEserver/addon |
12 |
|
|
Source: %{name}-%{version}.tar.gz |
13 |
|
|
BuildArchitectures: noarch |
14 |
|
|
BuildRoot: /var/tmp/%{name}-%{version} |
15 |
|
|
AutoReqProv: no |
16 |
|
|
|
17 |
|
|
%description |
18 |
|
|
a random password generator created by Hsing-Foo Wang hsingfoo@gmail.com |
19 |
|
|
|
20 |
|
|
%changelog |
21 |
|
|
* Wed Oct 08 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.3-1 |
22 |
|
|
- new options added to prevent No argument, a negative number, |
23 |
|
|
- zero and non integer argument or a no integer argument part |
24 |
|
|
- -1 0 123abc and abc by Hsing-Foo Wang hsingfoo@gmail.com |
25 |
|
|
|
26 |
|
|
* Tue Oct 07 2014 stephane de Labrusse <stephdl@de-labrusse.fr> 0.0.1-1 |
27 |
|
|
- Initial relase, idea from Hsing-Foo Wang hsingfoo@gmail.com |
28 |
|
|
|
29 |
|
|
%prep |
30 |
|
|
%setup |
31 |
|
|
%build |
32 |
|
|
|
33 |
|
|
%install |
34 |
|
|
rm -rf $RPM_BUILD_ROOT |
35 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
36 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
37 |
|
|
|
38 |
|
|
%clean |
39 |
|
|
cd .. |
40 |
|
|
rm -rf %{name}-%{version} |
41 |
|
|
|
42 |
|
|
%pre |
43 |
|
|
%preun |
44 |
|
|
%post |
45 |
|
|
%postun |
46 |
|
|
|
47 |
|
|
%files |
48 |
|
|
%defattr(-,root,root) |
49 |
|
|
%attr(754, root,root) /usr/bin/randpw |
50 |
|
|
|