1 |
# remirepo spec file for roundcubemail, from: |
2 |
|
3 |
# Fedora spec file for roundcubemail |
4 |
# |
5 |
# License: MIT |
6 |
# http://opensource.org/licenses/MIT |
7 |
# |
8 |
# Please preserve changelog entries |
9 |
# |
10 |
|
11 |
%if 0%{?fedora} >= 21 |
12 |
# support for apache / nginx / php-fpm |
13 |
%global with_phpfpm 1 |
14 |
%else |
15 |
%global with_phpfpm 0 |
16 |
%endif |
17 |
|
18 |
%define roundcubedir %{_datadir}/roundcubemail |
19 |
%global _logdir /var/log |
20 |
Name: roundcubemail |
21 |
Version: 1.1.3 |
22 |
Release: 101%{?dist} |
23 |
Summary: Round Cube Webmail is a browser-based multilingual IMAP client |
24 |
|
25 |
Group: Applications/System |
26 |
# Since 0.8 beta, the main code has been GPLv3+ with exceptions and |
27 |
# skins CC-BY-SA. |
28 |
# Plugins are a mix of GPLv3+ and GPLv2. The Enigma plugin contains a |
29 |
# copy of php-Pear-Crypt-GPG (not yet packaged for Fedora), which is |
30 |
# LGPLv2+. The jqueryui plugin contains the entire jQuery UI framework |
31 |
# for the use of roundcube plugins: it is licensed as MIT or GPLv2. |
32 |
# The program/js/tiny_mce directory contains an entire copy of TinyMCE |
33 |
# which is LGPLv2+. |
34 |
# https://github.com/pear/Crypt_GPG |
35 |
# http://jqueryui.com/ |
36 |
# http://www.tinymce.com/ |
37 |
License: GPLv3+ with exceptions and GPLv3+ and GPLv2 and LGPLv2+ and CC-BY-SA and (MIT or GPLv2) |
38 |
URL: http://www.roundcube.net |
39 |
Source0: https://downloads.sourceforge.net/roundcubemail/roundcubemail-%{version}.tar.gz |
40 |
Source1: roundcubemail.httpd |
41 |
Source3: roundcubemail.nginx |
42 |
Source2: roundcubemail.logrotate |
43 |
Source4: roundcubemail-README.rpm |
44 |
# Elegantly handle removal of moxieplayer Flash binary in tinymce |
45 |
# media plugin (see "Drop precompiled flash" in %%prep) |
46 |
Patch0: roundcubemail-1.1.1-no_swf.patch |
47 |
|
48 |
# Non-upstreamable: Adjusts config path to Fedora policy |
49 |
Patch1: roundcubemail-1.1.0-confpath.patch |
50 |
|
51 |
BuildArch: noarch |
52 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root%(%{__id_u} -n) |
53 |
%if %{with_phpfpm} |
54 |
Requires: webserver |
55 |
Requires: nginx-filesystem |
56 |
Requires: httpd-filesystem |
57 |
Requires: php(httpd) |
58 |
%else |
59 |
Requires: httpd |
60 |
Requires: mod_php |
61 |
%endif |
62 |
Requires: php-curl |
63 |
Requires: php-date |
64 |
Requires: php-dom |
65 |
Requires: php-fileinfo |
66 |
Requires: php-gd |
67 |
Requires: php-hash |
68 |
Requires: php-iconv |
69 |
Requires: php-intl |
70 |
Requires: php-json |
71 |
Requires: php-ldap |
72 |
Requires: php-mbstring |
73 |
Requires: php-openssl |
74 |
Requires: php-pcre |
75 |
Requires: php-posix |
76 |
Requires: php-pdo |
77 |
Requires: php-pspell |
78 |
Requires: php-session |
79 |
Requires: php-simplexml |
80 |
Requires: php-sockets |
81 |
Requires: php-spl |
82 |
Requires: php-xml |
83 |
# From composer.json, require |
84 |
# "php": ">=5.3.7", |
85 |
# "roundcube/plugin-installer": "~0.1.6", |
86 |
# "pear-pear.php.net/auth_sasl": "~1.0.6", |
87 |
# "pear-pear.php.net/net_idna2": "~0.1.1", |
88 |
# "pear-pear.php.net/net_sieve": "~1.3.4", |
89 |
# "pear-pear.php.net/mail_mime": "~1.9.0", |
90 |
# "pear-pear.php.net/net_smtp": "~1.6.3", |
91 |
# "patchwork/utf8": "~1.2.3" |
92 |
# not available and optional patchwork/utf8 |
93 |
# not available and doesn't make sense roundcube/plugin-installer |
94 |
Requires: php-pear(Auth_SASL) >= 1.0.4 |
95 |
Requires: php-pear(Mail_Mime) >= 1.8.4 |
96 |
Requires: php-pear(Net_SMTP) >= 1.6.1 |
97 |
Requires: php-pear(Net_Sieve) >= 1.3.4 |
98 |
Requires: php-pear(Net_IDNA2) >= 0.1.1 |
99 |
# From composer.json, require-dev |
100 |
# "pear-pear.php.net/crypt_gpg": "*", |
101 |
# "phpunit/phpunit": "*" |
102 |
# not available (but only for dev) php-pear(Crypt_GPG) >= 1.2.0 |
103 |
# From composer.json, suggest |
104 |
Requires: php-pear(Net_LDAP2) >= 2.0.12 |
105 |
Requires: php-composer(kolab/Net_LDAP3) |
106 |
# mailcap for /etc/mime.types |
107 |
Requires: mailcap |
108 |
|
109 |
# Optional deps |
110 |
# Spell check |
111 |
#Suggests: php-enchant |
112 |
# Caching |
113 |
#Suggests: php-apc |
114 |
#Suggests: php-memcache |
115 |
# EXIF images |
116 |
Requires: php-exif |
117 |
# Upload progress (shock!) |
118 |
#Suggests: php-uploadprogress |
119 |
# ZIP download plugin |
120 |
Requires: php-zip |
121 |
|
122 |
# Gearman support |
123 |
#Optional: php-gearman |
124 |
# PAM password support |
125 |
#Optional: php-pam |
126 |
|
127 |
|
128 |
%description |
129 |
RoundCube Webmail is a browser-based multilingual IMAP client |
130 |
with an application-like user interface. It provides full |
131 |
functionality you expect from an e-mail client, including MIME |
132 |
support, address book, folder manipulation, message searching |
133 |
and spell checking. RoundCube Webmail is written in PHP and |
134 |
requires a database: MySQL, PostgreSQL and SQLite are known to |
135 |
work. The user interface is fully skinnable using XHTML and |
136 |
CSS 2. |
137 |
|
138 |
|
139 |
%prep |
140 |
%setup -q -n roundcubemail-%{version} |
141 |
%patch0 -p1 |
142 |
%patch1 -p1 |
143 |
|
144 |
# fix permissions and remove any .htaccess files |
145 |
find . -type f -print | xargs chmod a-x |
146 |
find . -name \.htaccess -print | xargs rm -f |
147 |
|
148 |
# Fix shebang |
149 |
chmod +x bin/*sh |
150 |
sed -e '/^#!/s:/usr/bin/env php:/usr/bin/php:' \ |
151 |
-i bin/*sh |
152 |
|
153 |
# ??? - Jon, this could do with a comment; fixing carriage returns? (adamw) |
154 |
sed -i 's/\r//' SQL/mssql.initial.sql |
155 |
|
156 |
# Drop precompiled flash |
157 |
find . -type f -name '*.swf' | xargs rm -f |
158 |
|
159 |
# drop file from patch |
160 |
find . -type f -name '*.orig' | xargs rm -f |
161 |
|
162 |
# Wipe bbcode plugin from bundled TinyMCE to make doubleplus sure we cannot |
163 |
# be vulnerable to CVE-2012-4230, unaddressed upstream |
164 |
echo "CVE-2012-4230: removing tinymce bbcode plugin, check path if this fails." |
165 |
test -d program/js/*mce/plugins/bbcode && rm -rf program/js/*mce/plugins/bbcode || exit 1 |
166 |
|
167 |
# Create simple autoloader for PEAR |
168 |
mkdir vendor |
169 |
cat << EOF | tee vendor/autoload.php |
170 |
<?php |
171 |
spl_autoload_register( |
172 |
function (\$class) { |
173 |
if (strpos(\$class, '.') === false) { |
174 |
\$file = str_replace('_', '/', \$class).'.php'; |
175 |
if (\$path = stream_resolve_include_path(\$file)) { |
176 |
require_once(\$path); |
177 |
} |
178 |
} |
179 |
} |
180 |
); |
181 |
EOF |
182 |
|
183 |
|
184 |
%build |
185 |
# Nothing |
186 |
|
187 |
|
188 |
%install |
189 |
rm -rf %{buildroot} |
190 |
install -d %{buildroot}%{roundcubedir} |
191 |
cp -pr * %{buildroot}%{roundcubedir} |
192 |
|
193 |
# Apache with mod_php or php-fpm |
194 |
install -Dpm 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/httpd/conf.d/%{name}.conf |
195 |
|
196 |
%if %{with_phpfpm} |
197 |
# Nginx with php-fpm |
198 |
install -Dpm 0644 %{SOURCE3} %{buildroot}/%{_sysconfdir}/nginx/default.d/%{name}.conf |
199 |
%endif |
200 |
|
201 |
mkdir -p %{buildroot}%{_sysconfdir}/roundcubemail |
202 |
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d |
203 |
cp -pr %SOURCE2 %{buildroot}%{_sysconfdir}/logrotate.d/roundcubemail |
204 |
|
205 |
%if 0%{?rhel} == 5 || 0%{?rhel} == 6 |
206 |
: Remove "su" option from logrotate configuration file - requires logrotate 3.8+ |
207 |
sed -e '/su /d' -i %{buildroot}%{_sysconfdir}/logrotate.d/roundcubemail |
208 |
%endif |
209 |
|
210 |
# Log files |
211 |
mkdir -p %{buildroot}/var/log/roundcubemail |
212 |
# Temp files |
213 |
mkdir -p %{buildroot}/var/lib/roundcubemail |
214 |
|
215 |
cp -pr %SOURCE4 README.rpm |
216 |
|
217 |
# create empty files for ghost to not remove OLD config (0.9.x) |
218 |
touch %{buildroot}%{_sysconfdir}/roundcubemail/db.inc.php |
219 |
touch %{buildroot}%{_sysconfdir}/roundcubemail/main.inc.php |
220 |
# create empty files for ghost for the NEW config |
221 |
touch %{buildroot}%{_sysconfdir}/roundcubemail/config.inc.php |
222 |
|
223 |
# keep any other config files too |
224 |
mv %{buildroot}%{roundcubedir}/config/* %{buildroot}%{_sysconfdir}/roundcubemail/ |
225 |
|
226 |
# clean up the buildroot |
227 |
rm -rf %{buildroot}%{roundcubedir}/{config,logs,temp} |
228 |
rm -rf %{buildroot}%{roundcubedir}/{CHANGELOG,INSTALL,LICENSE,README,UPGRADING} |
229 |
rm %{buildroot}%{roundcubedir}/{composer.json-dist,Dockerfile} |
230 |
|
231 |
|
232 |
%pre |
233 |
# Drop some old config options to ensure new defaults are used |
234 |
if [ -f %{_sysconfdir}/%{name}/main.inc.php ]; then |
235 |
sed -e "/'temp_dir'/d" \ |
236 |
-e "/'mime_types'/d" \ |
237 |
-e "/'log_dir'/d" \ |
238 |
-i %{_sysconfdir}/%{name}/main.inc.php |
239 |
fi |
240 |
|
241 |
|
242 |
%clean |
243 |
rm -rf %{buildroot} |
244 |
|
245 |
|
246 |
%files |
247 |
%defattr(-,root,root,-) |
248 |
%{!?_licensedir:%global license %%doc} |
249 |
%license LICENSE |
250 |
%doc CHANGELOG INSTALL README.md UPGRADING README.rpm |
251 |
%doc composer.json-dist |
252 |
%{roundcubedir} |
253 |
%dir %{_sysconfdir}/%{name} |
254 |
# OLD config files from previous version |
255 |
%ghost %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/db.inc.php |
256 |
%ghost %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/main.inc.php |
257 |
# NEW config file |
258 |
%ghost %attr(0640,root,apache) %config(noreplace) %{_sysconfdir}/%{name}/config.inc.php |
259 |
# Default upstream values, overwritten on update |
260 |
%attr(0640,root,apache) %{_sysconfdir}/%{name}/mimetypes.php |
261 |
%attr(0640,root,apache) %{_sysconfdir}/%{name}/defaults.inc.php |
262 |
%attr(0640,root,apache) %{_sysconfdir}/%{name}/config.inc.php.sample |
263 |
%config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf |
264 |
%if %{with_phpfpm} |
265 |
%config(noreplace) %{_sysconfdir}/nginx/default.d/%{name}.conf |
266 |
%endif |
267 |
%attr(0775,root,apache) %dir /var/log/roundcubemail |
268 |
%attr(0775,root,apache) %dir /var/lib/roundcubemail |
269 |
%config(noreplace) %{_sysconfdir}/logrotate.d/roundcubemail |
270 |
|
271 |
|
272 |
%changelog |
273 |
* Wed Sep 30 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 1.1.3-101.sme |
274 |
- Initial release to contribs9 |
275 |
|
276 |
* Tue Sep 15 2015 Remi Collet <remi@fedoraproject.org> - 1.1.3-1 |
277 |
- update to 1.1.3 |
278 |
- raise dependencies on Mail_Mime 1.9.0, Net_Sieve 1.3.4, |
279 |
Net_SMTP 1.6.3 |
280 |
- drop dependency on Mail_mimeDecode |
281 |
|
282 |
* Tue Aug 11 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-2 |
283 |
- Remove "su" option from logrotate configuration file (requires |
284 |
logrotate >= 3.8.0) to avoid daily logrotate errors with old RHEL |
285 |
|
286 |
* Fri Jun 5 2015 Remi Collet <remi@fedoraproject.org> - 1.1.2-1 |
287 |
- update to 1.1.2 |
288 |
|
289 |
* Wed Mar 25 2015 Robert Scheck <robert@fedoraproject.org> - 1.1.1-2 |
290 |
- switch run-time requirement from php-mcrypt to php-openssl |
291 |
|
292 |
* Fri Mar 20 2015 Remi Collet <remi@fedoraproject.org> - 1.1.1-1 |
293 |
- update to 1.1.1 |
294 |
|
295 |
* Sun Feb 22 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-2 |
296 |
- add optional dependencies for LDAP management on |
297 |
Net_LDAP2 and Net_LDAP3 |
298 |
|
299 |
* Mon Feb 16 2015 Remi Collet <remi@fedoraproject.org> - 1.1.0-1 |
300 |
- update to 1.1.0 |
301 |
|
302 |
* Sun Jan 25 2015 Remi Collet <remi@fedoraproject.org> - 1.0.5-1 |
303 |
- Update to 1.0.5 (security update) |
304 |
|
305 |
* Sun Dec 21 2014 Remi Collet <remi@fedoraproject.org> - 1.0.4-3 |
306 |
- provide Nginx configuration |
307 |
|
308 |
* Sat Dec 20 2014 Adam Williamson <awilliam@redhat.com> - 1.0.4-2 |
309 |
- drop tinymce bbcode plugin for safety (CVE-2012-4230) |
310 |
|
311 |
* Fri Dec 19 2014 Remi Collet <remi@fedoraproject.org> - 1.0.4-1 |
312 |
- Update to 1.0.4 (service release, security) |
313 |
|
314 |
* Tue Sep 30 2014 Remi Collet <remi@fedoraproject.org> - 1.0.3-1 |
315 |
- Update to 1.0.3 (service release) |
316 |
|
317 |
* Tue Jul 22 2014 Remi Collet <remi@fedoraproject.org> - 1.0.2-1 |
318 |
- Update to 1.0.2 (service release) |
319 |
- pull README change from rawhide |
320 |
|
321 |
* Mon Jul 21 2014 Adam Williamson <awilliam@redhat.com> - 1.0.2-1 |
322 |
- Update to 1.0.2 |
323 |
|
324 |
* Mon May 12 2014 Remi Collet <remi@fedoraproject.org> - 1.0.1-1 |
325 |
- Update to 1.0.1 (service release) |
326 |
|
327 |
* Thu May 8 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-2 |
328 |
- cleanup some config option from previous version |
329 |
- requires mailcap for /etc/mime.types |
330 |
|
331 |
* Thu May 8 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1 |
332 |
- Update to 1.0.0 |
333 |
- provide the installer |
334 |
|
335 |
* Tue Oct 22 2013 Remi Collet <remi@fedoraproject.org> - 0.9.5-1 |
336 |
- backport 0.9.5 for remi repo |
337 |
|
338 |
* Tue Oct 22 2013 Jon Ciesla <limburgher@gmail.com> - 0.9.5-1 |
339 |
- Fix for CVE-2013-6172, BZ 1021735, 1021965. |
340 |
|
341 |
* Mon Sep 09 2013 Jon Ciesla <limburgher@gmail.com> - 0.9.4-1 |
342 |
- 0.9.4 |
343 |
- Change httpd dep to webserver, BZ 1005696. |
344 |
|
345 |
* Sat Aug 24 2013 Remi Collet <remi@fedoraproject.org> - 0.9.3-2 |
346 |
- sync with rawhide for remi repo |
347 |
|
348 |
* Fri Aug 23 2013 Adam Williamson <awilliam@redhat.com> - 0.9.3-2 |
349 |
- patch tinymce to cope elegantly with Flash binary being removed |
350 |
|
351 |
* Fri Aug 23 2013 Remi Collet <remi@fedoraproject.org> - 0.9.3-1 |
352 |
- backport 0.9.3 for remi repo in sync with rawhide |
353 |
|
354 |
* Fri Aug 23 2013 Jon Ciesla <limburgher@gmail.com> - 0.9.3-1 |
355 |
- Fix two XSS vulnerabilities: |
356 |
- http://trac.roundcube.net/ticket/1489251 |
357 |
|
358 |
* Fri Aug 16 2013 Jon Ciesla <limburgher@gmail.com> - 0.9.2-3 |
359 |
- Drop precompiled flash. |
360 |
|
361 |
* Tue Jun 18 2013 Remi Collet <remi@fedoraproject.org> - 0.9.1-1 |
362 |
- backport 0.9.2 for remi repo in sync with rawhide |
363 |
|
364 |
* Mon Jun 17 2013 Adam Williamson <awilliam@redhat.com> - 0.9.2-1 |
365 |
- latest upstream |
366 |
- correct License field, add comment on complex licensing case |
367 |
|
368 |
* Sat May 4 2013 Remi Collet <remi@fedoraproject.org> - 0.9.0-1 |
369 |
- backport 0.9.0 for remi repo in sync with rawhide |
370 |
|
371 |
* Wed May 01 2013 Adam Williamson <awilliam@redhat.com> - 0.9.0-1 |
372 |
- latest upstream |
373 |
- drop MDB2 dependencies, add php-pdo dependency (upstream now using |
374 |
pdo not MDB2) |
375 |
- drop the update.sh script as it requires the installer framework we |
376 |
don't ship |
377 |
- update the Fedora README for changes to sqlite and update process |
378 |
- drop strict.patch, upstream actually merged it years ago, just in |
379 |
a slightly different format, and we kept dumbly diffing it |
380 |
- drop references to obsolete patches (all merged upstream long ago) |
381 |
|
382 |
* Thu Mar 28 2013 Remi Collet <remi@fedoraproject.org> - 0.8.6-1 |
383 |
- backport 0.8.6 for remi repo |
384 |
|
385 |
* Thu Mar 28 2013 Jon Ciesla <limburgher@gmail.com> - 0.8.6-1 |
386 |
- Latest upstream, fixes local file inclusion via web UI |
387 |
- modification of certain config options. |
388 |
|
389 |
* Fri Feb 08 2013 Remi Collet <remi@fedoraproject.org> - 0.8.5-1 |
390 |
- Latest upstream, CVE-2012-6121, backport for remi repo |
391 |
|
392 |
* Fri Feb 08 2013 Jon Ciesla <limburgher@gmail.com> - 0.8.5-1 |
393 |
- Latest upstream, CVE-2012-6121. |
394 |
|
395 |
* Mon Jan 21 2013 Remi Collet <remi@fedoraproject.org> - 0.8.4-3 |
396 |
- fix configuration for httpd 2.4 (missing in backport) |
397 |
|
398 |
* Mon Dec 03 2012 Remi Collet <remi@fedoraproject.org> - 0.8.4-2 |
399 |
- improved Requires |
400 |
|
401 |
* Mon Nov 19 2012 Jon Ciesla <limburgher@gmail.com> - 0.8.4-1 |
402 |
- Latest upstream. |
403 |
|
404 |
* Fri Nov 16 2012 Remi Collet <remi@fedoraproject.org> - 0.8.4-1 |
405 |
- new upstream release 0.8.4 |
406 |
|
407 |
* Mon Oct 29 2012 Remi Collet <remi@fedoraproject.org> - 0.8.2-3 |
408 |
- fix configuration for httpd 2.4 (#871123) |
409 |
|
410 |
* Sun Oct 28 2012 Remi Collet <remi@fedoraproject.org> - 0.8.2-2 |
411 |
- add fix for latest MDB2 (#870933) |
412 |
|
413 |
* Wed Oct 10 2012 Jon Ciesla <limburgher@gmail.com> - 0.8.2-1 |
414 |
- Latest upstream. |
415 |
|
416 |
* Thu Aug 30 2012 Adam Williamson <awilliam@redhat.com> - 0.8.1-2 |
417 |
- correct stray parenthesis in strict patch |
418 |
|
419 |
* Mon Aug 20 2012 Jon Ciesla <limburgher@gmail.com> - 0.8.1-1 |
420 |
- Latest upstream. |
421 |
- Updated strict patch. |
422 |
- XSS patch upstreamed. |
423 |
|
424 |
* Mon Aug 20 2012 Jon Ciesla <limburgher@gmail.com> - 0.7.3-1 |
425 |
- 0.7.3, patch for XSS in signature issue, BZ 849616, 849617. |
426 |
|
427 |
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-3 |
428 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
429 |
|
430 |
* Mon Mar 12 2012 Jon Ciesla <limburgher@gmail.com> - 0.7.2-2 |
431 |
- Rediffed strict patch. |
432 |
|
433 |
* Mon Mar 12 2012 Adam Williamson <awilliam@redhat.com> - 0.7.2-1 |
434 |
- new upstream release 0.7.2 |
435 |
|
436 |
* Thu Feb 16 2012 Jon Ciesla <limburgher@gmail.com> - 0.7.1-2 |
437 |
- Fix logrotate, BZ 789552. |
438 |
- Modify error logging for strict, BZ 789576. |
439 |
|
440 |
* Wed Feb 1 2012 Adam Williamson <awilliam@redhat.com> - 0.7.1-1 |
441 |
- new upstream release |
442 |
|
443 |
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7-2 |
444 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
445 |
|
446 |
* Wed Dec 14 2011 Adam Williamson <awilliam@redhat.com> - 0.7-1 |
447 |
- new upstream release |
448 |
- drop all patches except confpath.patch: |
449 |
+ html2text.patch and all CVE fixes were merged upstream |
450 |
+ pg-mdb2.patch no longer necessary as all currently supported |
451 |
Fedora releases have a php-pear-MDB2-Driver-pgsql package new |
452 |
enough to work with this option |
453 |
|
454 |
* Fri Oct 07 2011 Jon Ciesla <limb@jcomserv.net> = 0.6-1 |
455 |
- New upstream. |
456 |
|
457 |
* Tue Sep 06 2011 Jon Ciesla <limb@jcomserv.net> = 0.5.4-1 |
458 |
- New upstream, fixes multiple security issues. |
459 |
|
460 |
* Tue Jul 05 2011 Jon Ciesla <limb@jcomserv.net> = 0.5.3-1 |
461 |
- New upstream. |
462 |
|
463 |
* Tue May 17 2011 Jon Ciesla <limb@jcomserv.net> = 0.5.2-1 |
464 |
- New upstream. |
465 |
|
466 |
* Thu Feb 10 2011 Jon Ciesla <limb@jcomserv.net> = 0.5.1-1 |
467 |
- New upstream. |
468 |
|
469 |
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.2-2 |
470 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
471 |
|
472 |
* Mon Oct 18 2010 Jon Ciesla <limb@jcomserv.net> = 0.4.2-1 |
473 |
- New upstream. |
474 |
|
475 |
* Mon Oct 04 2010 Jon Ciesla <limb@jcomserv.net> = 0.4.1-1 |
476 |
- New upstream. |
477 |
|
478 |
* Mon Feb 01 2010 Jon Ciesla <limb@jcomserv.net> = 0.3.1-2 |
479 |
- Patch to fix CVE-2010-0464, BZ 560143. |
480 |
|
481 |
* Mon Nov 30 2009 Jon Ciesla <limb@jcomserv.net> = 0.3.1-1 |
482 |
- New upstream. |
483 |
|
484 |
* Thu Oct 22 2009 Jon Ciesla <limb@jcomserv.net> = 0.3-2 |
485 |
- Macro fix, BZ530037. |
486 |
|
487 |
* Wed Sep 23 2009 Jon Ciesla <limb@jcomserv.net> = 0.3-1 |
488 |
- New upstream. |
489 |
|
490 |
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.2-3 |
491 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
492 |
|
493 |
* Wed Jul 15 2009 Jon Ciesla <limb@jcomserv.net> = 0.2.2-2 |
494 |
- Incorporated Chris Eveleigh's config changes to fix mimetype bug, BZ 511857. |
495 |
|
496 |
* Wed Jul 01 2009 Jon Ciesla <limb@jcomserv.net> = 0.2.2-1 |
497 |
- New upstream. |
498 |
|
499 |
* Fri Apr 10 2009 Jon Ciesla <limb@jcomserv.net> = 0.2.1-1 |
500 |
- New upstream. |
501 |
|
502 |
* Mon Mar 30 2009 Jon Ciesla <limb@jcomserv.net> = 0.2-9.stable |
503 |
- Patch for PG until php-pear-MDB2 hits 1.5.0 stable. BZ 489505. |
504 |
|
505 |
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-8.stable |
506 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
507 |
|
508 |
* Wed Feb 04 2009 Jon Ciesla <limb@jcomserv.net> = 0.2-7.stable |
509 |
- Patch for CVE-2009-0413, BZ 484052. |
510 |
|
511 |
* Mon Jan 05 2009 Jon Ciesla <limb@jcomserv.net> = 0.2-6.stable |
512 |
- New upstream. |
513 |
- Dropped two most recent patches, applied upstream. |
514 |
|
515 |
* Wed Dec 17 2008 Jon Ciesla <limb@jcomserv.net> = 0.2-5.beta |
516 |
- Security fix, BZ 476830. |
517 |
|
518 |
* Fri Dec 12 2008 Jon Ciesla <limb@jcomserv.net> = 0.2-4.beta |
519 |
- Security fix, BZ 476223. |
520 |
|
521 |
* Thu Oct 09 2008 Jon Ciesla <limb@jcomserv.net> = 0.2-3.beta |
522 |
- New upstream. |
523 |
|
524 |
* Mon Jun 16 2008 Jon Ciesla <limb@jcomserv.net> = 0.2-2.alpha |
525 |
- osx files removed upstream. |
526 |
|
527 |
* Mon Jun 16 2008 Jon Ciesla <limb@jcomserv.net> = 0.2-1.alpha |
528 |
- Fixed php-xml, php-mbstring Requires. BZ 451652. |
529 |
- Removing osx files, will be pulled from next upstream release. |
530 |
|
531 |
* Fri Jun 13 2008 Jon Ciesla <limb@jcomserv.net> = 0.2-0.alpha |
532 |
- Update to 0.2-alpha, security fixes for BZ 423271. |
533 |
- mysql update and pear patches applied upstream. |
534 |
- Patched config paths. |
535 |
|
536 |
* Fri Apr 18 2008 Jon Ciesla <limb@jcomserv.net> = 0.1.1-5 |
537 |
- Added php-pecl-Fileinfo Reqires. BZ 442728. |
538 |
|
539 |
* Wed Apr 16 2008 Jon Ciesla <limb@jcomserv.net> = 0.1.1-4 |
540 |
- Added mcrypt, MDB2 Requires. BZ 442728. |
541 |
|
542 |
* Thu Apr 10 2008 Jon Ciesla <limb@jcomserv.net> = 0.1.1-3 |
543 |
- Patch to fix PEAR path issue, drop symlinks. |
544 |
|
545 |
* Thu Apr 10 2008 Jon Ciesla <limb@jcomserv.net> = 0.1.1-2 |
546 |
- Drop %%pre script that was breaking pear packages. |
547 |
|
548 |
* Wed Apr 09 2008 Jon Ciesla <limb@jcomserv.net> = 0.1.1-1 |
549 |
- New upstream release. |
550 |
- Added patch to fix mysql update. |
551 |
|
552 |
* Tue Mar 18 2008 Jon Ciesla <limb@jcomserv.net> = 0.1-1 |
553 |
- Updgrade to 0.1 final, -dep. |
554 |
- Added new mimeDecode dep. |
555 |
|
556 |
* Mon Feb 04 2008 Jon Ciesla <limb@jcomserv.net> = 0.1-0.10rc2.1 |
557 |
- Changed to upstream -dep tarball, GPL-compliant. |
558 |
|
559 |
* Fri Feb 01 2008 Jon Ciesla <limb@jcomserv.net> = 0.1-0.9rc2.1 |
560 |
- re-removed PEAR components that slipped back in after rc1. |
561 |
|
562 |
* Fri Oct 26 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.8rc2 |
563 |
- Upgrade to 0.1-rc2 |
564 |
|
565 |
* Thu Aug 16 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.7rc1.1 |
566 |
- License tag correction. |
567 |
|
568 |
* Tue Jul 03 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.6rc1.1 |
569 |
- New upstream release, all GPL, all current languages included. |
570 |
|
571 |
* Mon May 14 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.5.beta2.2 |
572 |
- Fixed source timestamps, added Russian langpack. |
573 |
- Added logpath fix to main.inc.php |
574 |
- Fixed logrotate filename. |
575 |
|
576 |
* Fri May 11 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.4.beta2.2 |
577 |
- Cleanup/elegantization of spec, .conf. |
578 |
|
579 |
* Thu May 10 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.3.beta2.2 |
580 |
- Fixed bad chars in script. |
581 |
|
582 |
* Thu May 10 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.2.beta2.2 |
583 |
- Added all langpacks. |
584 |
|
585 |
* Thu May 10 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-0.1.beta2.2 |
586 |
- Versioning fix. |
587 |
|
588 |
* Wed May 09 2007 Jon Ciesla <limb@jcomserv.net> = 0.1-beta2.3 |
589 |
- Fixed generation of DES. |
590 |
- Cleanup re patch. |
591 |
|
592 |
* Mon May 07 2007 Jon Ciesla <limb@jcomserv.net> - 0.1-beta2.2.3 |
593 |
- Removed duplicate docs. |
594 |
- Moved SQL to doc. |
595 |
- Fixed perms on log dir, sysconfdir. |
596 |
- Fixed Requires. |
597 |
- Fixed config. |
598 |
- Fixed changelog spacing. |
599 |
|
600 |
* Fri May 04 2007 Jon Ciesla <limb@jcomserv.net> - 0.1-beta2.2.2 |
601 |
- Created new source tarball with PEAR code removed. Added script for creation. |
602 |
|
603 |
* Tue Feb 13 2007 Jon Ciesla <limb@jcomserv.net> - 0.1-beta2.2.1 |
604 |
- Excluded Portions from PEAR, included as dependancies |
605 |
- Fixed log/temp issues, including logrotate |
606 |
|
607 |
* Tue Jan 30 2007 Jon Ciesla <limb@jcomserv.net> - 0.1-beta2.2 |
608 |
- Initial packaging. |