1 |
jpp |
1.1 |
#%global git_commit 4a068f565b21f313cb39d9e855d84c886ecfe393 |
2 |
|
|
#%global git_date 20130403 |
3 |
|
|
|
4 |
|
|
#%global git_short_commit %(echo %{git_commit} | cut -c -8) |
5 |
|
|
#%global git_suffix %{git_date}git%{git_short_commit} |
6 |
|
|
|
7 |
|
|
# git clone git://git.osmocom.org/gr-osmosdr |
8 |
|
|
# cd %%{name} |
9 |
|
|
# git archive --format=tar --prefix=%%{name}-%%{version}/ %%{git_commit} | \ |
10 |
|
|
# bzip2 > ../%%{name}-%%{version}-%%{git_suffix}.tar.bz2 |
11 |
|
|
|
12 |
|
|
Name: rtl-sdr |
13 |
|
|
URL: http://sdr.osmocom.org/trac/wiki/rtl-sdr |
14 |
|
|
Version: 0.5.3 |
15 |
|
|
Release: 3%{?dist} |
16 |
|
|
License: GPLv2+ |
17 |
|
|
BuildRequires: cmake |
18 |
|
|
BuildRequires: libusbx-devel |
19 |
|
|
#BuildRequires: libusb1-devel |
20 |
|
|
Requires(pre): shadow-utils |
21 |
|
|
Requires(post): /sbin/ldconfig |
22 |
|
|
Requires(postun): /sbin/ldconfig |
23 |
|
|
Group: Applications/Communications |
24 |
|
|
Summary: SDR utilities for Realtek RTL2832 based DVB-T dongles |
25 |
|
|
Source0: https://github.com/steve-m/librtlsdr/archive/v%{version}.tar.gz#/librtlsdr-%{version}.tar.gz |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
This package can turn your RTL2832 based DVB-T dongle into a SDR receiver. |
29 |
|
|
|
30 |
|
|
%package devel |
31 |
|
|
Summary: Development files for rtl-sdr |
32 |
|
|
Group: Applications/Communications |
33 |
|
|
Requires: %{name}%{?_isa} = %{version}-%{release} |
34 |
|
|
|
35 |
|
|
%description devel |
36 |
|
|
Development files for rtl-sdr. |
37 |
|
|
|
38 |
|
|
%prep |
39 |
|
|
%setup -q -n librtlsdr-%{version} |
40 |
|
|
rm -f src/getopt/* |
41 |
|
|
rmdir src/getopt |
42 |
|
|
|
43 |
|
|
%build |
44 |
|
|
mkdir build |
45 |
|
|
cd build |
46 |
|
|
%cmake .. -DDETACH_KERNEL_DRIVER=ON |
47 |
|
|
make %{?_smp_mflags} |
48 |
|
|
|
49 |
|
|
%install |
50 |
|
|
cd build |
51 |
|
|
make install DESTDIR=%{buildroot} |
52 |
|
|
|
53 |
|
|
# remove static libs |
54 |
|
|
rm -f %{buildroot}%{_libdir}/*.a |
55 |
|
|
|
56 |
|
|
# Fix udev rules and allow access only to users in rtlsdr group |
57 |
|
|
sed -i 's/MODE:="0666"/MODE:="0660", ENV{ID_SOFTWARE_RADIO}="1"/' ../rtl-sdr.rules |
58 |
|
|
install -Dpm 644 ../rtl-sdr.rules %{buildroot}%{_prefix}/lib/udev/rules.d/10-rtl-sdr.rules |
59 |
|
|
|
60 |
|
|
%post -p /sbin/ldconfig |
61 |
|
|
|
62 |
|
|
%postun -p /sbin/ldconfig |
63 |
|
|
|
64 |
|
|
%files |
65 |
|
|
%doc AUTHORS COPYING |
66 |
|
|
%{_bindir}/* |
67 |
|
|
%{_libdir}/*.so.* |
68 |
|
|
%{_prefix}/lib/udev/rules.d/10-rtl-sdr.rules |
69 |
|
|
|
70 |
|
|
%files devel |
71 |
|
|
%{_includedir}/* |
72 |
|
|
%{_libdir}/*.so |
73 |
|
|
%{_libdir}/pkgconfig/*.pc |
74 |
|
|
|
75 |
|
|
%changelog |
76 |
|
|
* Fri Aug 29 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 0.5.3-3 |
77 |
|
|
- Migrated udev rule to dynamic ACL management |
78 |
|
|
- Fixed udev rule location |
79 |
|
|
- Group rtlsdr is no more used / created |
80 |
|
|
|
81 |
|
|
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.3-2 |
82 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild |
83 |
|
|
|
84 |
|
|
* Tue Jul 1 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 0.5.3-1 |
85 |
|
|
- New version |
86 |
|
|
Resolves: rhbz#1114342 |
87 |
|
|
- Dropped rtl-sdr-0-lib64-fix patch (upstreamed) |
88 |
|
|
- Enabled detaching of kernel driver |
89 |
|
|
|
90 |
|
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-0.4.20130403git4a068f56 |
91 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild |
92 |
|
|
|
93 |
|
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-0.3.20130403git4a068f56 |
94 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild |
95 |
|
|
|
96 |
|
|
* Sun Apr 7 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 0-0.2.20130403git4a068f56 |
97 |
|
|
- Preserve timestamp of 10-rtl-sdr.rules during install |
98 |
|
|
- Added isa to devel subpackage requirement |
99 |
|
|
- Removed bundled getopt |
100 |
|
|
|
101 |
|
|
* Wed Apr 3 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 0-0.1.20130403git4a068f56 |
102 |
|
|
- Initial version |