/[smecontribs]/rpms/rtl_433/contribs10/rtl_433.spec
ViewVC logotype

Annotation of /rpms/rtl_433/contribs10/rtl_433.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Fri Jul 14 15:26:58 2023 UTC (10 months, 2 weeks ago) by jpp
Branch: MAIN
CVS Tags: rtl_433-19_08-1, HEAD
Initial import

1 jpp 1.1 #
2     # spec file for package rtl_433
3     #
4     # Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
5     # Copyright (c) 2017, Martin Hauke <mardnh@gmx.de>
6     #
7     # All modifications and additions to the file contributed by third parties
8     # remain the property of their copyright owners, unless otherwise agreed
9     # upon. The license for this file, and modifications and additions to the
10     # file, is the same license as for the pristine package itself (unless the
11     # license for the pristine package is not an Open Source License, in which
12     # case the license is the MIT License). An "Open Source License" is a
13     # license that conforms to the Open Source Definition (Version 1.9)
14     # published by the Open Source Initiative.
15    
16     # Please submit bugfixes or comments via http://bugs.opensuse.org/
17     #
18    
19     %define version 19.08
20     %define release 1
21     %define version_unconverted %{version}
22     Name: rtl_433
23     Version: %{version}
24     Release: %{release}
25     Summary: Turns RTL2832 dongle into a 433.92MHz generic data receiver
26     License: GPL-2.0-only
27     Group: Productivity/Hamradio/Other
28     URL: https://github.com/merbanan/rtl_433.git
29     Source: %{name}-%{version}.tar.gz
30     Patch0: rtl_433-disable-test.diff
31     BuildRequires: cmake
32     BuildRequires: pkgconfig
33     BuildRequires: pkgconfig(librtlsdr)
34     BuildRequires: doxygen libusb1-devel libusb1
35    
36     %description
37     An application using librtlsdr to decode the temperature from
38     wireless temperature sensors (433.92MHz)
39    
40     %package devel
41     Summary: Turns RTL2832 dongle into a 433.92MHz generic data receiver
42     Group: Development/Libraries/C and C++
43     Requires: %{name} = %{version}
44    
45     %description devel
46     Turns RTL2832 dongle into a 433.92MHz generic data receiver.
47    
48     This subpackage contains header files for developing applications that want
49     to make use of rtl_433.
50    
51     %prep
52     %setup -q
53     # %patch0 -p1
54    
55     %build
56     %cmake -DBUILD_TESTING=OFF
57     make VERBOSE=1 %{?_smp_mflags}
58    
59     %install
60     %make_install
61    
62     %files
63     %defattr(-,root,root)
64     #%license COPYING
65     %doc AUTHORS README.md
66     /usr/share/man/man1/
67     %{_bindir}/rtl_433
68     /usr/etc/rtl_433/
69    
70     %files devel
71     %{_includedir}/rtl_433.h
72     %{_includedir}/rtl_433_devices.h
73    
74     %changelog
75     * Sun Sep 01 2019 Jean-Philipe Pialasse <tests@pialasse.com> 19.08-1.sme
76     - first import for SME [SME: 10800]
77     - fix spec file to build
78     - Update to version 19.08
79     * Added MQTT output (#1016)
80     * Added stats reporting (#733)
81     * Added SoapySDR general keyword settings option, e.g. antenna
82     * Added new model keys option
83     * Changed Normalize odd general keys on devices (#1010)
84     * Changed Use battery_ok instead of battery for newmodel
85     * Added report model description option (#987)
86     * Added pulse data text file support (#967)
87     * Added color to console help output
88     * Fixed CF32 loader; addeded CS8, CF32 dumper
89     * Added CurrentCost EnviR support (#1115)
90     * Added ESIC-EMT7170 power meter (#1132)
91     * Added LaCrosse-TX141Bv3 support (#1134)
92     * Added channel to inFactory-TH (#1133)
93     * Added man page rtl_433.1 (#1121)
94     * Added color to console help output
95     * Added support for Philips AJ7010 (#1047)
96     * Added frequency hopping signal support for win32 (#1128)
97     * Added Holman WS5029 decoder
98     * Added Acurite Rain 899 support
99     * Added support for Oregon scientific THGR328N and RTGR328N (#1107) (#1109)
100     * Added frequency hop on USR1 signal
101     * Added '-E hop' option
102     * Added option for multiple hop times
103     * Added sensor similar to GT-WT-02 (#1080)
104     * Added Rubicson 48659 Cooking Thermometer
105     * Added TFA Dostmann 30.3196 decoder (#983)
106     * Added support for HCS200 KeeLoq encoder (#1081)
107     * Added channel output to lacrosse_TX141TH_Bv2 (#1097)
108     * Added IKEA Sparsnäs decoder.
109     * Added support for Eurochron weather station sensor (#1090)
110     * Added MQTT topic format strings (#1079)
111     * Added two EV1527 based sample configurations (#1087)
112     * Added DirecTV RC66RX Remote Control
113     * Added support for Ecowitt temperature sensor
114     * Added Companion WTR001 decoder (#1055)
115     * Changed Thermopro TP12 also supports TP20 (#1061)
116     * Added configuration for PIR-EF4 sensor (#1049)
117     * Added Alecto WS-1200 v1/v2/DCF decoders to Fineoffset (#975)
118     * Added TS-FT002 decoder (#1015)
119     * Added Fine Offset WH32B support (#1040)
120     * Added LaCrosse-WS3600 support, change LaCrosse-WS to LaCrosse-WS2310
121     * Added LaCrosse WS7000 support (#1029) (#1030)
122     * Changed Omit humidity on Prologue if invalid
123     * Added MQTT output (#1016)
124     * Added stats reporting (#733)
125     * Added Interface Specification for data output (#827)
126     * Added checksum to Ambient Weather TX-8300
127     * Added Interlogix glassbreak subtype
128     * Added Jansite TPMS support (#1020)
129     * Added Oregon Scientific RTHN129 support (#941)
130     * Changed Use battery_ok instead of battery for newmodel
131     * Changed Update battery_low, temperatureN keys
132     * Changed Normalize odd general keys on devices (#1010)
133     * Fixed Efergy-e2 current reading exponent
134     * Added FS20 remote decoder (#999)
135     * Added SoapySDR general keyword settings option
136     * Added option to select antenna on SoapySDR devices (#968)
137     * Fixed CF32 loader; added CS8, CF32 dumper
138     * Added ASAN to Debug builds
139     * Changed tfa_twin_plus_30.3049: Add mic to output
140     * Added new model keys option
141     * Enhanced Kedsum, S3318, Esperanza with MIC (#985)
142     * Added support for XT300/XH300 soil moisture sensor (#946)
143     * Changed Schrader unit from bar to kPa
144     * Added report model description option (#987)
145     * Added native scale for SDRplay
146     * Added Chungear BCF-0019x2 example conf
147     * Changed GT-WT-02 to support newer timings; changed model name
148     * Added pulse data text file support (#967)
149     * Added Digitech XC0346 support to Fine Offset WH1050 (#922)
150     * Added bitbuffer NRZI(NRZS/NRZM) decodes
151     * Added Rosenborg/WH5 quirk to Fineoffset
152     * Added support for Silverline doorbells (#942)
153     * Changed TPMS Toyota to match shorter preamble
154     * Changed TPMS Citroen data readings
155     * Changed TPMS Renault data readings
156     * Added Digitech XC-0324 temperature sensor decoder (#849)
157     * Added sample rate switching
158     * Added Mongoose
159    
160     * Sat Aug 18 2018 mardnh@gmx.de
161     - Update to version 18.05+git.20180806:
162     * Clean up copyright notes
163     * Change flex to more robust opt arg parse
164     * Fix bitbuffer_parse to be sane about empty row specs
165     * Tweak timings for Kerui
166     * Fill id string for Bresser device.
167     * Add battery event for Kerui
168     * Update style for chuango
169     * Update style for akhan
170     * Update style and add cmds to Kerui
171     * Update code style for wssensor
172     * Add Hyundai WS SENZOR (#779)
173     * Add fix for TEK377E, issue #776
174     * Fix Makefile devices to match CMakeLists
175     * Add CS16 input and output (#773)
176     * Add device: M-Bus (EN 13757-4) - Data Link layer (#768)
177     * Fix for Autotools
178     * Rewrite debug_mode to load_mode and dump_mode
179     * Fix typo
180     * Fix indents
181     * Clean up baseband, optimize FM, add baseband-test (#770)
182     * Rewrite ambient_weather for robustness and style
183     * Remove some unwanted BITBUF_COLS uses
184     * Change radiohead to unify the applications
185     * Fix Sensible Living merge
186     * Sensible Living protocol added. (#742)
187     * Fix SOCKET(_TYPE) for syslog
188     * Win32 syslog client patches (#762)
189     * Make printout aligned (#761)
190     * Make the frequency setting clearer. (#760)
191     * Add real protocol number to startup output (#744)
192     * Convert intertechno to data_make (#726)
193     * see #755
194     * FineOffset WH0530: Add battery low detection, correct rain factor (#765)
195     * Add prototype for 'nice_freq()' (#759)
196     * Add a "pretty-printer" of a frequency (#758)
197     * No "Variable Length Arrays" for MSVC (#755)
198     * Remove <strings.h> (#756)
199     * More MSVC fixes (#754)
200     * [MSVC] patch include/data.h (#753)
201     * Include <stdlib.h> (#752)
202     * Add support for Oregon Scientific UVR128 UV sensor (#738)
203     * Update code style for RadioHead
204     * DSC Sensors break out status bits
205     * acurite_986: fix temperature type to enable conversion feature to work
206     * Fri Jun 1 2018 mardnh@gmx.de
207     - Update to version 18.05+git.20180525:
208     * New devices: Euroster 3000TX, Elro DB270 (#683)
209     * Add flex spec for Byron BY doorbells (#686)
210     * change array separator in csv to ";" otherwise RadioHead ASK output will break csv parsers (#687)
211     * create flex dev adhoc and enable csv output (#688)
212     * calc stop_time late; better exit messages (#689)
213     * add proper reset and gap limit to Quhwa; use repeated rows; add csv output; style update (#691)
214     * fix short char buffer
215     * Adding interlogix devices driver (#649)
216     * fix bitbuffer_extract_bytes clipping unaligned bits
217     * fix Interlogix; style
218     * Added decoder for Dish Network UHF Remote 6.3 (#700)
219     * use actual max protocols
220     * Update acurite.c (#704)
221     * Acurite 06045M structured data (data_make) cleanup, decoding improvements. (#707)
222     * Adjust alarm from 1 second to 3 second
223     * Acurite 986 convert to JSON/data_make * Add hack from my branch to work around missing bit
224     * Fix typos/misspellings
225     * Add conversion hPA/inHG, kPa/PSI (#711)
226     * Fix acurite raw_str termination
227     * Touch up waveman code style, add missing time field
228     * Add PiWM decoding (#724)
229     * SimpliSafe Sensor (#721)
230     * SimpliSafe style updates
231     * Add Pacific PMV-C210 TMPS support (#717)
232     * Add preamble option to flex decoder
233     * Make intertechno decoder work with ITT-1500 (#694)
234     * Convert DSC to structured data (#725)
235     * Regularize and extend Acurite 6045M comments (#728)
236     * DSC data_make additions. (#730)
237     * Indents
238     * Acurite TXR/6045 fixes
239     * Acurite cosmetics fixes
240     * Mon Feb 26 2018 mardnh@gmx.de
241     - Create subpackge for header files
242     * Thu Feb 15 2018 mardnh@gmx.de
243     - Update to version 0.0.1+git.20180213:
244     * fix flex options, add gap_limit for PWM
245     * README.md: Add another Debian dependency (#680)
246     * README.md: Fix typo (#679)
247     * README.md: Add build tools to Debian command (#678)
248     * revert localtime_r to localtime for win32
249     * disable syslog output on win32
250     * remove left over xc0348 device
251     * Fix on_connect signature and topic subscriptions in MQTT examples. (#674)
252     * refactor hostport_param
253     * refactor abuf
254     * allow ipv6 for syslog
255     * add flex device to Makefile
256     * refactor print_array_value
257     * use prettier C99 bool macro
258     * shuffle functions
259     * change aux pattern to composition
260     * remove output_hander_t, printer_ctx indirection
261     * change indent; consistent style
262     * adds a remote syslog output
263     * update readme usage info
264     * default enable x10_sec, timing doc, style
265     * Adds x10_sec device for decoding X10 Security RF signals (#671)
266     * Spelling fix: gague -> gauge (#672)
267     * fix new_template
268     * use localtime_r instead of localtime
269     * reduce false positves with Bresser on LaCrosse TX141TH
270     * add MIC to bresser
271     * freshen up template with more examples
272     * add a flexible general purpose decoder (#647)
273     * remove PWM_TERNARY, use PWM_PRECISE for sync bits
274     * change pulse_detect to use pwm_precise for sync bits
275     * rename CLOCK_BITS to DMC
276     * change fordremore to proper DMC, the output is vastly different
277     * change DMC (clock_bits) demod to add rows on symbol errors
278     * convert Acurite 592TXR from TERNARY to PRECISE
279     * reduce false positives in Thermopro TP12
280     * code style for LaCrosse TX141
281     * convert LaCrosse TX141 from TERNARY to PRECISE
282     * convert Bresser 3CH from RAW to PRECISE
283     * convert LaCrosse TX from RAW to PRECISE
284     * convert Philips Sensor from TERNARY to PRECISE
285     * convert Calibeur from TERNARY to PRECISE
286     * convert Acurite 00275rm from TERNARY to PRECISE
287     * enhance pwm_precise to cover raw and ternary cases
288     * add sync pulse count to bitbuffer
289     * fix Lacrosse TX141TH sync rows
290     * Added device LaCrosse TX141 support to lacrosse_TX141TH_Bv2.c (#670)
291     * add back C99 with ADD_DEFINITIONS
292     * C99 compatibility (#667)
293     * add git version info to usage output if available
294     * let cmake set C99; CMP0025
295     * additional build deps (#668)
296     * wh1080: Fix warning about uninitialized use (#666)
297     * adding asepc, getkwargs helper
298     * fold PWM_precise_parameters into r_device
299     * output pulse_demod_pwm_precise at end of pulses as well
300     * adapt precise param sync width to us
301     * use _XOPEN_SOURCE on string.h for strdup
302     * fix -R 0 fault
303     * use bitbuffer_clear for bitbuffer_parse
304     * refactor bitbuffer_parse
305     * minor
306     * Doxygen EXTRACT_ALL to show all docs, there isn't any notable exported API yet
307     * update 1.7 Doxyfile to 1.8
308     * add Doxygen building to CMake
309     * cleanup
310     * parse number suffixes on e.g. frequency, samplerate, duration, hoptime
311     * relax false positive logic prologue/alecto to allow a single leading pulse
312     * Fix unit conversions for Acurite 5n1 (#651)
313     * fix `-d n` parsing
314     * Add missing brand to OSv1 (#650)
315     * adding FindGperftools cmake module
316     * add Profile build type using GPerfTools
317     * use CMake defaults for optimizations (-O3)
318     * RTGN129 author name (#646)
319     * change grab file name to gNNN_FFFM_RRRk.cu8 (#642)
320     * replace -i <serial> with -d :<serial> (#648)
321     * Clean up WIN32 include/ifdef (#643)
322     * fix read-mode buffer size and allocation, s. #641 (#644)
323     * reduce Alecto/Auriol-v2 false positives in Prologue
324     * enable pedantic warnings; also on Clang
325     * pedantic fix: -Wextra-semi
326     * pedantic fix: replace arithmetic on void* (gnu extension) with sane char* arithmetic; fix function pointer for qsort, bsearch
327     * adding mic to OS SL109h
328     * remove false positives with wg-pb12v1, please report samples if WH2, WH5, Telldus are missing messages
329     * remove debug from wg-pb12v2; add mic to fineoffset
330     * fix GE Color Effects Remote indent and MAX_PROTOCOLS
331     * chmod 644 on source files
332     * add model switch to WH2/WH5/Telldus in fineoffset
333     * Add support for Telldus variants of fineoffset (#639)
334     * merge formatting from PR #615
335     * disable mebus: lacks docs, tests and has false positives
336     * Esperanza, Kedsum, S3318p: relax reset timing, check sync pulses to remove dups
337     * fix OOK_PULSE_CLOCK_BITS pulse_tolerance to µs
338     * fix: require 24 bits data for rain gauge sensors
339     * Update chuango.c
340     * Stop after outputting successful event(s)
341     * Added support to Oregon Scientific RTGN129
342     * Add device NEXA LMST-606 magnetic sensor
343     * added unit (Fahrenheit) to output of Ambient Weather Temperature Sensor
344     * Update rtl_433.h
345     * fixed compile time warnings (formatting related)
346     * change PWM_Precise_Parameters pulse_tolerance to use us instead of samples
347     * fixing schraeder data types
348     * Remove unintended spurious white spaces
349     * Add another schrader TPMS support (corrections)
350     * Add another schrader TPMS support
351     * remove spurious if-statement
352     * Specify device to use via serial number
353     * automatically use first available dongle
354     * define _GNU_SOURCE for strdup
355     * Add support for the Thermopro TP-12. This is based heavily on the code for the Thermopro TP-11, and the modulation is compatible, but the bit layout is fairly different and there are more sensors, so I've made this a separate device.
356     * Addressed code review by @zuckschwerdt
357     * Device handler for GE Color Effects remote control Fixes #569
358     * Wed Nov 1 2017 mardnh@gmx.de
359     - Update to version 0.0.1+git.20171101:
360     * Add support for Philips outdoor temperature sensor
361     * move fprintf call when timer expires
362     * remove check for DEFAULT_HOP_EVENTS
363     * fix edge-case where bytes_to_read is equal to length of bytes read
364     * Fix output formatting
365     * Added support for Ford car remote.
366     * Removed unused code and variables.
367     * Added a ford car remote decoder for the Fiesta and CMAX. device id is a rolling id number that seems to have approx 64 variations. The meaning of the code fields has not been determined.
368     * Fixed output formatting for JSON and csv
369     * Added decoding of X10 CR12A ON/OFF remote commands
370     * Add support for FT-004-B
371     * Make LaCrosse TX141TH sensors return temperature_C so that they are more consistent with other temperature sensors (#606)
372     * Acurite Rain Gague emit structured data
373     * shortend model string to Inovalley kw9015b
374     * added json-support and description for TFA 30.3161 rain sensor
375     * Fixed do_build.sh: forgot to do 'cd ..' before cloning rtl_433_tests.git
376     * Fixed do_build.sh, .travis.yml trying to run 'make test'
377     * Added tests from rtl_433_tests.git repo
378     * Fixed do_build.sh: don't 'make installe'
379     * Fixed .travis.yml: 'sudo: required', 'dist: trusty'
380     * Fixed .travis.yml: added sudo, added apt.sources
381     * Fixed permissions on do_build.sh
382     * Added draft of .travis.yml, do_build.sh
383     * Use default number of buffers to fix crash of two rtl_433 instances
384     * don't restart the timer if we are aborting anyway; cancel timer on rtlsdr_cancel_async
385     * fix unknown `uint` type; whitespace fixes
386     * add merbanan changes
387     * add suggested optimisation
388     * suggested changes
389     * remove test
390     * add infactory sensor
391     * bitbuffer: Handle row overflow a bit more gracefully
392     * pulse_analyzer: Add detection of PWM with multiple packages
393     * explaining dipswitch 2 meaning
394     * message validation fix
395     * shortening output
396     * changes after pull request
397     * Switched to new data API
398     * adding Renault TPMS sensor
399     * adding Ford TPMS sensor
400     * Add option to verify simulated decoding of raw data
401     * reduce false positives by rejecting 0x000000 / 0xffffff
402     * adding Toyota TPMS sensor
403     * reduce false positives, require at least 5 repeats
404     * Sat Jul 8 2017 mardnh@gmx.de
405     - Update to version 0.0.1+git.20170708:
406     * prevent bad messages of all 1 that falsely check ok with crc.
407     * adding IBIS beacon
408     * fix Company name, output flags and tire pressure/temperature
409     * proper units for pressure, units for power, fix OS output fields
410     * adding Oil Ultrasonic Standard protocol
411     * hop interval param added (multiple frequencies)
412     * updated README.md
413     * typo fix
414     * pipe symbol with HTML code
415     * Update README.md
416     * Added data struct for efergye2 (#540)
417     * fix fabsf() in integer context (#551)
418     * adding Citroen TPMS device
419     * bugfix, bitbuffer needs to be initialized
420     * adding Oil Ultrasonic STANDARD using ASK on 915MHz
421     * Honda remote: fix an out of bounds array access
422     * Removed use of pow() (#557)
423     * Possible bugfix for issue #136
424     * Update .gitignore
425     * Fix hex output padding for unit ID field for lightwaverf.
426     * Thermopro TP-11.
427     * Move TP-11 to the end.
428     * Thermopro TP-11 changes: - exit early if not enough matching rows are found - simplify bits_per_row check - local_time_str happens after decoding data
429     * Fix sign error.
430     * Variable declarations are at the top of the function.
431     * Solight TE44 wireless thermometer
432     * Fix spelling in documentation
433     * adding Wireless Smoke and Heat Detector GS 558
434     * adding Generic off-brand wireless motion sensor and alarm system
435     * remove false positives from Esperanza/Kedsum
436     * replace binary literals with hex
437     * fix misc typos and reduce efergy false positives
438     * allow WH2 to miss the first sync bit for WH5 support
439     * reject false positive and fix wrong field index and minimum bit count
440     * fix compiler warnings; possible undef bug; signed/unsigned
441     * Mon May 15 2017 mardnh@gmx.de
442     - Update to version 0.0.1+git.20170515:
443     * Add files via upload
444     * Add support for Fine Offset WH3080 weather station
445     * Updated "quadrant" code for WGR968
446     * Restored 'static' variables
447     * Bump MAX_PROTOCOLS to 78
448     * cleanup: replacing broken sprintf, removing debug code
449     * fix short buffer: sprintf's output is always null-terminated
450     * adding output redirection to files
451     * Sensor GT-WT-02 Change REDME.md
452     * fix sample_file_pos to actually count seconds, each sample is 16 bits (I+Q uint8's)
453     * change data output fields to usual order
454     * add missing "model" data output
455     * add time to data output
456     * Add support for Vaillant calorMatic 340f (VRT 340f) wireless central ceating control (868MHz)
457     * adds a watchdog timer to async callback, abort if async events stop arriving
458     * improving compatibility for Renkforce DM-7511
459     * Vaillant_vrt340f.c: Fix indentation, only whitespace changes
460     * remove synthetic fahrenheit output. use `-C customary` to convert.
461     * harmonize device data output to model instead of device or make, and crc instead of checksum
462     * changing "crc", "checksum" to "mic"
463     * delete stray trailing whitespace
464     * normalize indentation to 4 spaces or one tab, depending on prevalence in each file
465     * Update rtl_433.h
466     * Sat Apr 15 2017 mardnh@gmx.de
467     - Reenable parallel build
468     * Thu Apr 13 2017 mardnh@gmx.de
469     - Update to version 0.0.1+git.20170409:
470     * Include humidity field in CSV format for TX29DHT temperature and humidity sensor. (#486)
471     * Fix parse error on ARM compiling with GCC due to lack of parens. (#490)
472     * Don't convert channel 4 to 3 for the sensor Oregon THGR810 (#489)
473     * Fine Offset W25 Temperature/Humidity/Pressure sensor (#492)
474     * Device for cheap probes where the PCB is marked WG-PB12V1.
475     * Revert "Update pulse_detect.c" (#493)
476     * MQTT: Add example to README and Python test client (#495)
477     * Pulse Analyzer: Add 'Include only' mode (#497)
478     * Fine Offset WH0530: Add new device
479     * DSC: Make less noisy
480     * pulse_demod: Make pwm_precise resilient to short spurious pulses
481     * Acurite 6045, correct temperature decoding * Reduce Msg Type (status bits) to 2 remaining bits. * Remove possible lightning stats/flag bits from distance * output lightning status/flag bits separately for now * Understanding of status/message type bits still a WIP.
482     * Acurite 06045 add docs, refactor decode out of txr_callback
483     * acurite 6045, remove unnecessary variable
484     * Added code for differing impules to KWH values
485     * LaCrosse TX6/7 cleanup
486     * LaCrosse TX6/7 reindent with consistent 4 column spacing
487     * Fix #503
488     * Update util.c
489     * Pull Request Changes ---
490     * FineOffset_WH25: Add debug printout
491     * FineOffset_WH25: Correct decoding of Temperature and ID
492     * FineOffset_WH0530: Fix bug in ID decode
493     * FineOffset_WH25: Additional bitsum check + minor fixes
494     * ELV WS2000: Make it somewhat work...
495     * Corrected conflict in MAX_PROTOCOLS.
496     * erroneous entry in src/Makefile.am
497     * Thu Feb 2 2017 mardnh@gmx.de
498     - Update to version 0.0.1.git1486029687.074cc2f:
499     * Reverse some more stray changes
500     * Ensure analyzer works with auto level as default
501     * Various documentation fixes for auto level
502     * Acurite 6045 lightning prelim. and 609 cleanup.
503     * WH1050 weather station based on WH1080 module.
504     * Honeywell/Ademco Door/Window Security Sensor driver
505     * Honeywell/Ademco Door/Window Security Sensor driver
506     * Honeywell/Ademco Door/Window Security Sensor driver
507     * Honeywell/Ademco Door/Window Security Sensor driver
508     * Honeywell/Ademco Door/Window Security Sensor driver
509     * Honeywell/Ademco Door/Window Security Sensor driver
510     * Honeywell/Ademco Door/Window Security Sensor driver
511     * Honeywell/Ademco Door/Window Security Sensor driver
512     * added json/kv capbilities to Acurite tower sensor
513     * added battery status as OK or LOW
514     * fixes for upstream
515     * fix indent
516     * Update README.md
517     * Added more installation step detail and troubleshooting section.
518     * Correct negative temperatures
519     * Danfoss CFR: Initial decoding attempt
520     * Danfoss: Output data correctly
521     * Danfoss: Enable driver by default
522     * Danfoss: Add proper header search and make decoding byte based
523     * Danfoss: Add CRC check. Remove raw printout.
524     * Danfoss: Reverse engineered unknown nibble :-)
525     * Danfoss: Minor cleanup and fix debug print
526     * add maverick et73x BBQ sensor
527     * Add crc json tag and cvs output
528     * Add crc json tag
529     * Update brennstuhl_rcs_2044.c
530     * Spelling correction (protcols -> protocols)
531     * Improved hideki.c to detect data from the wind/temperature and the rain sensor. Changed pulse_demod_clock_bits to allow a missing short gap at the end of the message which is needed for the new sensor types.
532     * Increase number of protocols to 70
533     * Update pulse_detect.c
534     * Update acurite.c
535     * Segfault on Owl CM160
536     * Added support for RF-tech 433 remote temperature sensor.
537     * Add rftech.c to Makefile.am to support configure/automake.
538     * Added support for LaCrosse temperature/humidity sensor TX141TH-Bv2
539     * Minor cosmetic changes
540     * Implemented recent changes suggested by @merbanan.
541     * move to new internal data format on acurite5n1
542     * remove old acurite5n1 decoder, now uses acurite_txr
543     * normalize temperature key
544     * acurite5n1 battery status
545     * correct acurite5n1 wind speed formula
546     * add raw msg debug output for acurite5n1
547     * acurite5n1: fix battery status
548     * Stop akhan-100F14 catching things that don't belong to it
549     * Add missing return 1.
550     * don't mess up device ordering
551     * remove old, incorrect wind direction mapping
552     * output raw rain counter values, use define for msg type
553     * move all units to native customary/US
554     * remove another unused function
555     * Removed signal quality output
556     * acurite 5n1: output message sequence number
557     * Add protocol definition for oregon scientific THN129 temp only sensor. (#469)
558     * Support for Acurite 00275rm and 00276rm sensors (#467)
559     * Fixed bug in CM160 (#474)
560     * devices: mebus: Use data API for results (#475)
561     * identify F007TH with both 0000000000010100 and 1111111111010100 (#481)
562     * Add support for BTHGN129 (#483)
563     * LaCrosse TX29-IT / TX35DTH-IT weather sensor (#479)
564     * fix typo error (#484)
565     * WH1050 weather station - remove unused fields from csv format. (#485)
566     * Mon Sep 19 2016 mardnh@gmx.de
567     - Update to version 0.0.1.git1474227546.2d7072a:
568     * Adding support for the Bresser 3CH type sensor
569     * Disable acurite rain gauge due to false positive with oregon scientific v1
570     * add -T option to set run duration
571     * Fixed generic_remote to utilized data_acquired_handler to support json output. Not perfectly indented, but works.
572     * use binary mode to open file - fixes decoding on windows
573     * Improved datetime/weather signal type detection.
574     * Fix incorrect handling of negative temperatures in ambient_weather.c (#376)
575     * missing backtick in readme.md, now in LF (#361)
576     * New Springfield Temperature and Soil Moisture decoding (#378)
577     * introduce functionality to decode the Oregon Scientific SL109H Remote Thermal Hygro Sensor (#368)
578     * Added data output (for json/csv/etc.) (#380)
579     * Acurite 606TX Sensor Support (#382)
580     * Cleanup of Acurite 606TX code that should have been done before (#383)
581     * add TFA pool thermometer support (#386)
582     * Enabled low battery detection on FineOffset WH1080 (#387)
583     * Add support for Kedsum Temperature/Humidity sensor (#389)
584     * added support for blyss dc5-uk-wh (#391)
585     * Add FSK_PULSE_MANCHESTER_ZEROBIT
586     * Add initial Schrader TPMS decoder
587     * Better Schraeder TPMS payload meaning
588     * Add Schreader TPMS crc calculation
589     * Add LightwaveRF initial driver (#394)
590     * Added Steelmate TPMS support (#396)
591     * Fix json output and minor rearrangement of code
592     * Add template decoder skeleton
593     * Add initial Elro DB286A support (#398)
594     * Elro DB286A: Correct id_string array length (#399)
595     * Updated README for new efergy_optical sensor and missing recent devices.
596     * Add CRC16-CCITT function
597     * Change to new output system
598     * Add brand parameter to data output format
599     * Add sensor WGR968 parser support
600     * Add Handling of error packet format
601     * Smell and Fix some bad code
602     * Changed CRC calculation to use new function in util.h no longer using lib_crc
603     * added file output support and changed energy to power. only output crc values when using -D argument.
604     * Only output crc when using -D argument
605     * I have kept the crc calculation to be the first 10 bytes. Bytes 11 and 12 are the CRC16_CCITT. The only puzzle left is why does the last byte does as it sometimes change to 80.
606     * Efergy Optical device added. Multiple changes to combine several files into one commit.
607     * Removing lib_crc files
608     * efergy_optical with CRC checks (#400)
609     * Honda Key Remote
610     * formatting changes
611     * Fix review errors,using Kdiff3 to compare the code
612     * Fix build
613     * Honda remote key fob, decodes which button has been pressed.
614     * Honda Keyfob changes
615     * Added Honda Remote decoder.
616     * Added Honda Remote
617     * Fixed to include Honda remote any my deletion of the README.md when trying to fix git conflicts.
618     * Changed author name at the top of the file, removed fprintf that was not behind if debug statement. Added a validater to check that number of bits are 386.
619     * Changed and fixed validation code to suit varying bits per row. Lock command has 394 bits whereas other commands only has 386 bits per row. (#405)
620     * Add THN802 and PCR800a to oregonscientific.c (#410)
621     * unbreak the build (#411)
622     * add battery status (low or ok) to F007TH ambient weather devices (#414)
623     * Add support for another Fine Offset sensor
624     * Convert Acurite "TH" (609TXC) to use data_make * Existing Acurite "TH" sensor now labeled as 609TXC * Use data_make() for JSON, CSV, KV output * minor code cleanup/reorg
625     * Add RadioHead ASK device
626     * Add option to register all devices
627     * Fix MAX_PROTOCOLS when enabling all devices
628     * acurite: disable all old api devices by default
629     * ambient_weather: fprintf cleanup
630     * brennstuhl_rcs_2044: disable all old api devices by default
631     * cardin: disable all old api devices by default
632     * danfoss: disable all old api devices by default
633     * dsc: disable all old api devices by default
634     * ec3k: disable all old api devices by default
635     * efergy_e2_classic: disable all old api devices by default
636     * elv: disable all old api devices by default
637     * gt_wt_02: disable all old api devices by default
638     * inovalley-kw9015b: disable all old api devices by default
639     * intertechno: disable all old api devices by default
640     * lacrosse: fprintf cleanup
641     * lacrossews: fprintf cleanup
642     * lightwave_rf: disable all old api devices by default
643     * mebus: disable all old api devices by default
644     * new_template: fprintf cleanup
645     * silvercrest: disable all old api devices by default
646     * steffen: disable all old api devices by default
647     * valeo: disable all old api devices by default
648     * x10_rf: disable all old api devices by default
649     * Use built in CRC functions
650     * Fix indent (RH ASK)
651     * Declare variables at the begining (RH ASK)
652     * Add CRC=OK (see #416) & fix syntax error (RH ASK)
653     * Fix debug output (RH ASK)
654     * fprintf fixup
655     * Add device debug output
656     * Added support for Kerui PIR sensor
657     * Fixes
658     * Cleanup related to devices disabled by default.
659     * new_template rework
660     * Make auto level limit the default
661     * Sun Mar 27 2016 mardnh@gmx.de
662     - Update to version 0.0.1.git1459106482.900fca7:
663     + use uintptr_t instead of unsigned long - fixes build error on win64
664     + fix: change doc comments from "samples" to "us"
665     + clean up casts regarding C Integer Promotions
666     + Oregon Scientific V1 Decoding
667     + add -U option to print timestamps in UTC
668     + Support for Proove
669     + Adjust pulse_tolerance to get all sensors to work
670     + Update calibeur rf104 to new data api
671     + add missing usage documentation for -n parameter: number of samples to read before quitting
672     + add -T option to set run duration
673     + Prevent crash when no output file is given with `-S`
674     + Fineoffset: Fix key/value printout
675     + pulse_analyzer: Add PCM detection
676     + Revert "add -T option to set run duration"
677     + Calibeur: Fix key/value printout
678     + pulse_demod_osv1: Only print preamble info when debugging
679     + Fix https://github.com/merbanan/rtl_433/issues/347
680     + use uintptr_t instead of unsigned long for the remaining devices
681     + mingw32 does not have setenv
682     + Remove spurious execute permission from README.md
683     * Fri Mar 11 2016 mardnh@gmx.de
684     - Update to version 0.0.1.git1457694384.7ab14a4:
685     + Added support for Fine Offset WH1080 weather station. Merging with Digitech XC0348 (it's a rebranded WH1080).
686     + Adding support for Fine Offset WH1080.
687     + Update fineoffset_wh1080.c
688     + Added support for Fine Offset WH1080
689     + Add remote control on chip HT680
690     + Rethinking algorithm
691     + fix decoders for WGR800 & THGR810 add decoder for PCR800
692     + adding a bitbuffer_find_repeated_row() with examples how it simplifies device code
693     + code cleanup
694     + starting to migrate to data_make
695     + only try the crc if the packet would match
696     + adding battery indicator for Nexus
697     + add labels for ambient_weather.c to match oregon_scientific.c printout
698     + Update README.md
699     + Added tristate coding.
700     + Correction data types in bitbuffer_find_repeated_row()
701     + new feature: allow multiple outputs (WIP)
702     + Decode device id from current_cost, and support more devices
703     + Add support for Conrad S3318P
704     + s3318p: use native temperature format
705     + Add support for Conrad S3318P
706     + also switch the labels on output conversion
707     + Spurious output for debug mode
708     + Remove some compiler warnings
709     + fix wind direction nibble extract for WGR800
710     + Remove some compiler warnings
711     + Remove some compiler warnings
712     + fix off-by-one and make the null explicit
713     + LaCrosse WS-2310 json output
714     + Fixed WS-2310 json gust_speed to gust_speed_ms
715     + Fix some memory leaks
716     + TFA Twin Plus 30.3049 json support
717     + Output less decimal places to get rid of bogus digits
718     + Update fineoffset_wh1080.c
719     + Switched to new data API
720     + Update generic_temperature_sensor.c
721     + KlikAanKlikUit json support
722     + Added data labels for KlikAanKlikUit output
723     + Added Akhan 100F14 RKE system
724     + Updated akhan_100F14 message passing
725     + Update CM180 Energy Sensor code - Add Checksum and new output system format
726     + Many sensor required a larger pulse tolerance
727     + Add Quhwa doorbell support
728     + Clearer code
729     + Add support for Quhwa doorbell
730     + Support for Quhwa doorbell
731     + data_make output for chuango
732     + Update device support
733     + add missing quhwa.c reference
734     * Thu Feb 4 2016 mardnh@gmx.de
735     - Update to version 0.0.0.git1454367220.e7bc33d:
736     + Auto level: Increase sensitivity to low signals
737     + FSK: Change FM demodulation to use integer atan2()
738     + Pulse_detect: Increase maximum number of pulses
739     + FSK: refactor FSK into own function for sanity
740     + Auto level: Make OOK level estimators a bit slower
741     + add a converter for cf32 (gnuradio output format)
742     + Convert Alecto to Pulse decoder
743     + Convert Inovalley to Pulse decoder
744     + Convert Nexus to Pulse decoder
745     + Convert Generic temperature sensor to Pulse decoder
746     + Convert Steffen to Pulse decoder
747     + Convert Mebus to Pulse decoder
748     + Convert Intertechno to Pulse Decoder
749     + Convert Newkaku / KlikAanKlikUit to Pulse decoder
750     + Convert Acurite to Pulse decoder
751     + Convert ELV to Pulse decoder
752     + Remove last sample based decoder OOK_PWM_D
753     + Remove OOK_PWM_D: Clean-up header
754     + Fix: Segmentation Fault in cf32 file support
755     + Update Wiki with new options
756     + only treat samples as cf32 when mode==3
757     + minor changes to support (cross-)compilation with MinGW
758     + newkaku: support APA3-1500R
759     + remove superfluous prototype
760     + fix loop syntax
761     + ignore buffers of all zeros.
762     + rewrite LaCrosse TX output to data fields
763     + adding data_make for humidity
764     + typo
765     + fix: broken bit operation
766     + Make quiet mode output at least test file name
767     + FSK: Change to F1/F2 estimation instead of F1/Fdelta
768     + emonTx: Add stub driver
769     + FSK: Increase initial frequency threshold
770     + Change pulse data from unsigned to int to avoid undefined behaviour
771     + fix limits for decoder
772     + [xc0348] Add CRC validation
773     + [xc0348] Don't filter on device id
774     + [xc0348] Fix temperature (top nibble doesn't belong)
775     + Include stdio for FILE
776     + [xc0348] Add json output
777     + [xc0348] Add csv fields
778     + FSK: Fix data is not cleared at End Of Package
779     + FSK: Fix for handling pulse overflow correctly
780     + new command line option `-C native|si|customary` that hooks into `data_acquired_handler` and if `si` and type is DATA_DOUBLE and key is temperature_C then celsius2fahrenheit, if `customary` and type is DATA_DOUBLE and key is temperature_F then fahrenheit2celsius. Also if there is a FORMAT the last character "C" / "F" will be switched accordingly.
781     + Emontx: Correct for sample frequency of 2.5 MHz
782     + FSK: Rework to make pulse polarity absolute (pulse = high frequency)
783     + bitbuffer: Add function to invert bits
784     + current_cost: Invert bits to compensate for absolute FSK
785     + FSK: correct comment
786     + FSK: Fix slow estimation at initial frequency
787     + Convert decoder limits to float instead of int, to allow more precision
788     + elv: Fix precision of bit limits
789     + rubicson: Fix precision of bit limits
790     + Switch protocol decoder limits to µs instead of "samples at 250000Hz"
791     + ec3k: Fix precision of bit limits
792     + valeo: Fix precision of bit limits
793     + dsc: Fix precision of bit limits
794     + current_cost: Fix precision of bit limits
795     + Add bitbuffer_extract_bytes() function for accessing unaligned data
796     + Add crc16() function
797     + Finish implementing emontx driver
798     + Change bit limits in r_device structure to float too
799     + Pulse detect: Make low level (noise) estimator even slower
800     + Pulse detect: supress spurious short gaps
801     + Pulse detect: Minor renaming for consistency
802     + Pulse analyzer: Print absolute timing
803     + Pulse analyzer: Print FSK frequencies
804     + Pulse analyzer: Print OOK carrier frequency
805     + Migrate fineoffset to new data format and add support for TFA 30.3157 Temperature sensor
806     + Fix building with autotools
807     + Migrate nexus to new data format and add support for Technoline TX 9116 Temperature sensor
808     + fineoffset: fix typo (unbreak humidity sensor)
809     + fix: missing NULL terminator
810     + fix: use fabsf() instead of abs()
811     + emontx: Increase size of words[] array for endianness conversion
812     + alecto: only accept 36 bit packets
813     + rubicson: only accept 36 bit packets
814     + oil_watchman: Return events count
815     + emontx: Return events count
816     + rubicson: switch to new data api
817     + change output of -F kv to resemble the custom fprintf output of the decoders
818     - add patch rtl_433-disable-test.diff to disable build-time-tests for now
819     * Sun Jan 3 2016 mardnh@gmx.de
820     - Update to version 0.0.0.git1450346637.879b467:
821     + Add support for new demodulation
822     + Add support for WT450 devices
823     + Fix automake builds Update source file list and set compiler in C99 mode
824     + rubicson: implement crc and other parameters
825     + nexus: clean up the nexus protocol
826     + WT450: Better packet detection, battery indicator
827     + WT450: Add missing the supported device label in README file.
828     + New Lacrosse Weather Station Decoding
829     + Added Esperanza EWS
830     + LaCrosse Weather Station WS-2310TWC changes
831     + Updated decoding of Lacrosse Weather Station
832     + DSC Security Contact added CRC-8 calc/check * Added "little-endian" CRC-8 calculation * Moved reverse8() to util.c * Quieted WT450 callback false positive messages
833     + Updated crc8 to take initial CRC value as a parameter
834     + Read data from stdin with '-'
835     + Added quiet mode (-q) to suppress non-data related messages
836     + Lacrosse Weather Station Decoding cleanup
837     + Added missing wt450.c for autoconf compile
838     + Minor documentation update
839     + Include the last sample when saving samples between filter runs
840     + Share memory between fm buffer and temporary buffer
841     + Add support for Efergy e2 classic
842     + Remove unused command line argument 'c' (used to be decimation level)
843     + Only allocate synchronous read buffer if synchronous reads are used
844     + WT450: Fix parity computation, error messages only in debug mode
845     + add Inovalley kw9015b rain and temperature weather station
846     + add new noname wireless wheather station
847     + fix makefile.am
848     + change r_device->name from ""KW9015B Transmitter" to "Inovalley kw9015b rain and Temperature weather station"
849     + rename source / callback generic_temperature_sensor
850     + rename r_device->name from "RF Wireless Temp Transmitter" to "Generic temperature sensor 1"
851     + Acurite 592TXR Temperature/Humidity Sensor
852     + Acurite 592TXR Temperature/Humidity Sensor
853     + Updated README.md with new device numbers
854     + Acurite 986 Refrig/Freezer Temp initial support
855     + Acurite 986, add CRC check, fix negative values
856     + Acurite 986 low battery detection
857     + Inovalley kw9015b : fix negative temperature
858     + General structural data support for generating (ie.) JSON
859     + Generic temperature sensor 1 : fix negative temperature
860     + Add support for RTGN318
861     + Correct indentation
862     + data: provide a key-value-printer
863     + data: added formatting support
864     + rtl_433: added JSON support
865     + wt450: use JSON output instead of fprintf
866     + data: introduce auxiliary data as an argument
867     + data: only format key-value-format, not JSON
868     + data: added CSV support
869     + rtl_433: added CSV support. Requires driver support.
870     + wt450: added CSV support (provide .fields)
871     + waveman: added structured data support
872     + Fix compilation with autotools
873     + util: Make comment consistent
874     + util: Fix mismatched comment
875     + ambient: Migrate to using common method for output
876     + Updated README.md
877     + Migrate "prologue" to new output handler
878     + Prevent data files from being overwritten
879     + README.md documentation updates
880     + README.md space to fab fix for consitency * fix table markdown typo
881     + waveman: added missing comma to fix CSV output
882     + data: fixed the filtering of CSV fields
883     + Convert Waveman to pulse decoder
884     + Changed acurite 5n1 to use pulse demodulator
885     + Convert Silvercrest to use pulse demodulator
886     + Remove pwm_p_decode() and OOK_PWM_P
887     + Convert from GNU to C99 syntax
888     + Update alecto driver to new "data" format
889     + Update oregon_scientific driver to new "data"
890     + Fix indentation
891     + Fix missing comma
892     + Add Hideki TS04 sensors
893     + Support framed FSK Manchester decoding compatible with Si4320/RFM01
894     + Add Watchman Sonic ultrasonic oil tank monitor
895     + Add heuristic for detecting RFM01-framed FSK
896     + hideki: Remove overzealous warning about invalid parity
897     + Add bitbuffer_search() and bitbuffer_manchester_decode() functions
898     + Convert oil_watchman to bitbuffer_search() + bitbuffer_manchester_decode()
899     + Revert "Support framed FSK Manchester decoding compatible with Si4320/RFM01"
900     + Add Watchman to readme
901     + Add CurrentCost TX device
902     + Fix indent + TODO (minor for CurrentCost sensor)
903     + Fix negatif temp value for Hideki TS04
904     + Use constant to define and check OS (v2) sensor_id
905     + Fix channel error with some OS devices
906     + Do not require first byte of Watchman packets to be 0x28
907     + Update Readme.md
908     + Sync usage messages and README.md
909     + README improvements, added typical command line * rtl_433: better description of ppm error option
910     + Added -W to overwrite files
911     + Added -W to README.md
912     + Auto level - initial implementation
913     + Auto level - suppress spurious initial pulses
914     + FSK spurious short pulse suppression
915     + Auto level - print level in analyzer
916     + Fix to read complete file
917     + Pass 0 into local_time_str() for current time instead of using time()
918     + When reading sample files, make local_time_str() show offset not time of day
919     + Add temperature output in °C to Watchman decode
920     + Auto level - minor fixes
921     + Improve comment about level estimates
922     + Fix automake build
923     + Sort source file lists in CMakeLists.txt and Makefile.am
924     * Sun Sep 27 2015 mardnh@gmx.de
925     - initial package

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed