/[smecontribs]/rpms/sane-backends/contribs7/sane-backends.spec
ViewVC logotype

Annotation of /rpms/sane-backends/contribs7/sane-backends.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Apr 15 15:01:47 2008 UTC (16 years, 1 month ago) by slords
Branch: MAIN
Import on branch contribs7 of package sane-backends-1.0.17-0.el4.sme.src.rpm

1 slords 1.1 # $Id$
2     # Authority: unnilennium
3     # Name: Jean-Philippe Pialasse
4    
5     # Disable gphoto2 backend by using --without gphoto2
6     %define gphoto2_support 0%{!?_without_gphoto2:1}
7    
8     Summary: Scanner access software
9     Name: sane-backends
10     Version: 1.0.17
11     Release: 0%{?dist}
12     License: GPL (programs), relaxed LGPL (libraries), and public domain (docs)
13     Group: System Environment/Libraries
14     Source0: ftp://ftp.sane-project.org/pub/sane/%{name}-%{version}/%{name}-%{version}.tar.gz
15     Source1: sane.png
16     Source2: libusbscanner
17     URL: http://www.sane-project.org
18     BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%__id_u -n)
19     BuildRequires: tetex-latex libusb-devel libieee1284-devel libjpeg-devel
20     Prereq: /sbin/ldconfig, /bin/mktemp, /bin/grep, /bin/cat, /bin/rm
21     Requires: pam >= 0.77-66
22     ExcludeArch: s390 s390x
23     Requires: hotplug >= 2004_04_01-7.8
24    
25     %description
26     Scanner Access Now Easy (SANE) is a universal scanner interface. The
27     SANE application programming interface (API) provides standardized
28     access to any raster image scanner hardware (flatbed scanner,
29     hand-held scanner, video and still cameras, frame-grabbers, etc.). If
30     they're using SANE, developers can write image-processing applications
31     without having to think about the peculiarities of individual devices.
32     SANE also makes it possible to write a device driver once, which can
33     then be used by any SANE-compliant application. SANE currently
34     includes drivers for some Epson SCSI scanners, HP ScanJet SCSI
35     scanners, Microtek SCSI scanners, Mustek SCSI flatbed scanners, PINT
36     devices, most UMAX SCSI scanners, Connectix QuickCam, and other SANE
37     devices via network. Note that this package does not enable network
38     scanning by default. If you wish to enable network scanning, read the
39     saned(1) manpage. If you'd like to develop SANE modules, you should
40     also install the sane-backends-devel package.
41    
42     %package devel
43     Summary: The SANE (a universal scanner interface) development toolkit.
44     Group: Development/Libraries
45     Requires: sane-backends = %{version}, libusb-devel, libieee1284-devel
46    
47     %description devel
48     Static libraries and header files for writing Scanner Access Now Easy
49     (SANE) modules. SANE is a universal scanner interface which is
50     included in the sane-backends package.
51    
52     %prep
53     %setup -q
54    
55     for i in agfafocus avision coolscan2 umax_pp; do
56     iconv -f iso-8859-1 -t utf-8 < "doc/sane-$i.man" > "doc/sane-$i.man_"
57     mv "doc/sane-$i.man_" "doc/sane-$i.man"
58     done
59    
60     # We patched configure.in, so regenerate configure.
61     sed '/^# libtool\.m4/,$d' < acinclude.m4 > acinclude.m4.new
62     mv -f acinclude.m4{.new,}
63     aclocal
64     libtoolize --force --copy
65     autoconf
66    
67     %build
68     %{expand:%%define optflags %{optflags} -DGIMP_ENABLE_COMPAT_CRUFT=1}
69     %if %{gphoto2_support}
70     %configure --with-gphoto2=%{_prefix} --with-docdir=%{_docdir}/%{name}-%{version}
71     %else
72     %configure --without-gphoto2 --with-docdir=%{_docdir}/%{name}-%{version}
73     %endif
74     make
75    
76    
77     %install
78     rm -rf %{buildroot}
79     %{makeinstall} docdir=%{buildroot}/%{_docdir}/%{name}-%{version}
80     perl -pi -e "s/installed.*/installed=yes/g" $RPM_BUILD_ROOT%{_libdir}/libsane.la
81     /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir} $RPM_BUILD_ROOT%{_libdir}/sane
82    
83     mkdir -p %{buildroot}%{_datadir}/pixmaps
84     install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps
85     rm -f %{buildroot}%{_bindir}/gamma4scanimage
86     rm -f %{buildroot}%{_libdir}/sane/*.a %{buildroot}%{_libdir}/*.a
87     mkdir -p %{buildroot}%{_sysconfdir}/hotplug/usb
88     install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/hotplug/usb
89     install -m 644 tools/hotplug/libsane.usermap %{buildroot}%{_sysconfdir}/hotplug/usb
90    
91     %find_lang %name
92    
93     %clean
94     rm -rf %{buildroot}
95    
96     %files -f %{name}.lang
97     %defattr(-,root,root)
98     %dir /etc/sane.d
99     %config(noreplace) /etc/sane.d/*
100     %{_sysconfdir}/hotplug/usb/*
101     %{_bindir}/sane-find-scanner
102     %{_bindir}/scanimage
103     %{_sbindir}/*
104     %{_libdir}/libsane*.so.*
105     %dir %{_libdir}/sane
106     %{_libdir}/sane/*.so.*
107     %{_mandir}/*/*
108     %{_datadir}/pixmaps/sane.png
109     %{_docdir}/*
110    
111     %files devel
112     %defattr(-,root,root)
113     %{_bindir}/sane-config
114     %{_includedir}/sane
115     %{_libdir}/libsane*.la
116     %{_libdir}/libsane*.so
117     %{_libdir}/sane/*.la
118     %{_libdir}/sane/*.so
119    
120     %changelog
121     * Wed Apr 05 2006 Nils Philippsen <nphilipp@redhat.com> 1.0.17-0.fc4.2
122     - update libusbscanner to handle cold-plugged USB scanners (#144444, slightly
123     changed patch by Michal Jaegermann)
124    
125     * Tue Dec 20 2005 Nils Philippsen <nphilipp@redhat.com> 1.0.17-1
126     - version 1.0.17
127     - reenable gphoto2 backend
128    
129     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
130     - rebuilt
131    
132     * Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
133     - rebuild
134    
135     * Fri Aug 19 2005 Nils Philippsen <nphilipp@redhat.com> 1.0.16-1
136     - version 1.0.16
137     - remove obsolete docdir patch
138    
139     * Mon Jul 25 2005 Tim Waugh <twaugh@redhat.com>
140     - Fixed libusbscanner comment (bug #162983).
141    
142     * Wed Mar 2 2005 Tim Waugh <twaugh@redhat.com> 1.0.15-9
143     - Rebuild for new GCC.
144    
145     * Fri Dec 10 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-8
146     - Further small fixes to libusbscanner script.
147    
148     * Fri Dec 3 2004 Tim Waugh <twaugh@redhat.com>
149     - Ship the correct libsane.usermap (part of bug #135802).
150    
151     * Wed Dec 1 2004 Tim Waugh <twaugh@redhat.com>
152     - No longer need ep2400 patch.
153    
154     * Tue Nov 30 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-7
155     - Updated libusbscanner script from Tomas Mraz, to use pam_console_apply.
156     - Requires pam >= 0.78-2 for targetted pam_console_apply.
157    
158     * Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-6
159     - Random changes in libusbscanner.
160    
161     * Tue Nov 23 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-5
162     - libusbscanner: Create /dev/usb if it doesn't exist after 30s.
163    
164     * Mon Nov 22 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-4
165     - Attempt to be more useful in libusbscanner by waiting a maximum of 30
166     seconds.
167     - Add a chcon call to libusbscanner (bug #140059). Based on contribution
168     from W. Michael Petullo.
169    
170     * Sat Nov 20 2004 Miloslav Trmac <mitr@redhat.com> - 1.0.15-3
171     - Convert man pages to UTF-8
172    
173     * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com>
174     - Require hotplug's remover to work.
175    
176     * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-2
177     - Applied the libusbscanner part of the patch for bug #121511, by Ian
178     Pilcher.
179    
180     * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-1
181     - 1.0.15.
182    
183     * Sun Oct 10 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-6
184     - Make man pages identical on multilib installations.
185    
186     * Thu Oct 7 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-5
187     - Build requires libjpeg-devel (bug #134964).
188    
189     * Thu Aug 26 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-4
190     - Apply patch from David Zeuthen to fix hotplug script (bug #130755).
191    
192     * Mon Aug 9 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-3
193     - Mark config files noreplace.
194    
195     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
196     - rebuilt
197    
198     * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-1
199     - 1.0.14.
200    
201     * Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
202     - s/ftp.mostang.com/ftp.sane-project.org/.
203    
204     * Fri May 7 2004 Tim Waugh <twaugh@redhat.com> 1.0.13-7
205     - Fix epson.conf for USB scanners (bug #122328).
206    
207     * Tue May 4 2004 Tim Waugh <twaugh@redhat.com> 1.0.13-6
208     - Ship libusb.usermap (from sane-backends-1.0.14) and a pam_console-aware
209     libusbscanner script.
210     - Fix epson.conf for Epson Perfection 2400 (bug #122328).
211    
212     * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
213     - rebuilt
214    
215     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
216     - rebuilt
217    
218     * Thu Feb 5 2004 Tim Waugh <twaugh@redhat.com> 1.0.13-4
219     - Fixed compilation with GCC 3.4.
220    
221     * Mon Dec 15 2003 Tim Waugh <twaugh@redhat.com> 1.0.13-3
222     - Take %%{_libdir}/sane out of ldconfig's search path altogether (Oliver
223     Rauch).
224    
225     * Tue Nov 25 2003 Thomas Woerner <twoerner@redhat.com> 1.0.13-2
226     - no rpath in sane-config anymore
227    
228     * Sun Nov 23 2003 Tim Waugh <twaugh@redhat.com> 1.0.13-1
229     - 1.0.13.
230     - No longer need autoload, gt68xx patches.
231    
232     * Thu Nov 20 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-6
233     - Don't add %%{_libdir}/sane to ld.so.conf (bug #110419).
234    
235     * Tue Nov 11 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-5
236     - Updated gt68xx driver to fix timeout problems.
237    
238     * Wed Oct 8 2003 Tim Waugh <twaugh@redhat.com>
239     - Avoided undefined behaviour in canon-sane.c (bug #106305).
240    
241     * Mon Sep 29 2003 Tim Waugh <twaugh@redhat.com>
242     - Updated URL.
243    
244     * Thu Jul 24 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-4
245     - The devel package requires libieee1284-devel.
246    
247     * Mon Jun 16 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-3
248     - Use libtoolize and aclocal to fix build.
249     - Build requires libieee1284-devel (to fix bug #75849).
250    
251     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
252     - rebuilt
253    
254     * Sun May 25 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-1
255     - 1.0.12.
256    
257     * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 1.0.11-1
258     - Shipped libtool is broken; use installed script instead.
259     - Remove files not shipped.
260     - Fix some /usr/lib references.
261     - 1.0.11.
262     - Drop sane-sparc, errorchk, hp101, security patches.
263     - Update rpath, docdir patches.
264     - Use %%find_lang.
265    
266     * Fri Mar 7 2003 Tim Waugh <twaugh@redhat.com>
267     - sane-backends-devel requires libusb-devel (bug #85742).
268    
269     * Mon Feb 10 2003 Tim Waugh <twaugh@redhat.com> 1.0.9-5
270     - Fix saned problems.
271    
272     * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.0.9-4
273     - rebuilt
274    
275     * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 1.0.9-3
276     - hp-backend 1.01 for 'error during device I/O' workaround (bug #81835).
277    
278     * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 1.0.9-2
279     - Better error checking in the Canon backend (bug #81332).
280    
281     * Fri Oct 25 2002 Tim Waugh <twaugh@redhat.com> 1.0.9-1
282     - 1.0.9.
283    
284     * Wed Oct 23 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-6
285     - Ship the installed documentation.
286     - Move sane-config to the devel subpackage (bug #68454).
287    
288     * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
289     - automated rebuild
290    
291     * Fri Jun 21 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-4
292     - Fix bug #62847.
293    
294     * Tue Jun 18 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-3
295     - Fix dangling symlink (bug #66672).
296    
297     * Wed Jun 12 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-2
298     - Don't tell SANE applications to use rpath (bug #66129, bug #66132).
299    
300     * Mon May 27 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-1
301     - 1.0.8.
302    
303     * Wed May 22 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-0.20020522.1
304     - Update to CVS. Release expected before the end of the month.
305     - No longer need defaultincl or argv patches.
306    
307     * Wed May 15 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-7
308     - Unconditionally run ldconfig after installation (bug #64964).
309    
310     * Mon Mar 4 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-6
311     - Re-apply the original 1.0.7-4 fix (oops):
312     - Make sure to load SCSI modules if not already loaded (bug #59979).
313    
314     * Mon Mar 4 2002 Tim Powers <timp@redhat.com> 1.0.7-5
315     - bump release number, wasn't bumped last time
316    
317     * Mon Mar 3 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-4
318     - Update sparc patch (Tom "spot" Callaway).
319    
320     * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-3
321     - Rebuild in new environment.
322     - Disable bad stdarg code in scanimage so that alpha builds succeed.
323    
324     * Mon Feb 11 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-2
325     - Make sure sane-config doesn't specify the default include path
326     (bug #59507).
327    
328     * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-1
329     - 1.0.7.
330    
331     * Sun Jan 27 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-0.beta2.1
332     - 1.0.7-beta2.
333    
334     * Wed Jan 23 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-0.beta1.1
335     - 1.0.7-beta1.
336     - Patches no longer needed: scsi, microtek2, format.
337    
338     * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.0.6-4
339     - automated rebuild
340    
341     * Wed Nov 21 2001 Tim Waugh <twaugh@redhat.com> 1.0.6-3
342     - Fix default file names format in batch scans (bug #56542).
343    
344     * Tue Nov 20 2001 Tim Waugh <twaugh@redhat.com> 1.0.6-2
345     - Apply Maurice Hilarius's patch to avoid kill(-1,SIGTERM) (bug #56540).
346    
347     * Mon Nov 5 2001 Tim Waugh <twaugh@redhat.com> 1.0.6-1
348     - 1.0.6.
349    
350     * Fri Jul 20 2001 Florian La Roche <Florian.LaRoche@redhat.de> 1.0.5-4
351     - exclude s390, s390x
352    
353     * Tue Jul 17 2001 Preston Brown <pbrown@redhat.com> 1.0.5-3
354     - sane.png included
355    
356     * Tue Jul 10 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-2
357     - sane-backends-devel provides sane-devel.
358    
359     * Sun Jul 1 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-1
360     - 1.0.5.
361    
362     * Wed Jun 20 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010620.0
363     - 2001-06-20 CVS update. PreReq /bin/cat, /bin/rm.
364    
365     * Mon Jun 11 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010610
366     - 2001-06-10 CVS snapshot. umax_pp update from CVS again to fix more
367     build problems.
368    
369     * Sun Jun 3 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010603.1000
370     - 2001-06-03 CVS snapshot (10:00). Fixes umax_pp build problems.
371    
372     * Sat Jun 2 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010530
373     - sane-backends (sane-frontends is in a separate package now).
374     - 2001-05-30 CVS snapshot.
375     - include.patch no longer needed.
376     - sg3timeout.patch no longer needed.
377    
378     * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.3-10
379     - Fix up the libtool config file /usr/lib/libsane.la
380     kscan should build now. ;)
381    
382     * Wed Jan 10 2001 Tim Waugh <twaugh@redhat.com>
383     - Increase timeout for SCSI commands sent via sg driver version 3
384     (bug #23447)
385    
386     * Mon Dec 25 2000 Matt Wilson <msw@redhat.com>
387     - rebuilt against gimp 1.2.0
388    
389     * Thu Dec 21 2000 Matt Wilson <msw@redhat.com>
390     - rebuilt against gimp 1.1.32
391     - use -DGIMP_ENABLE_COMPAT_CRUFT=1 to build with compat macros
392    
393     * Mon Dec 18 2000 Matt Wilson <msw@redhat.com>
394     - rebuilt against gimp 1.1.30
395    
396     * Fri Dec 1 2000 Tim Waugh <twaugh@redhat.com>
397     - Rebuild because of fileutils bug.
398    
399     * Thu Oct 26 2000 Bill Nottingham <notting@redhat.com>
400     - fix provides for ia64/sparc64
401    
402     * Thu Aug 29 2000 Trond Eivind Glomsrød <teg@redhat.com>
403     - don't include xscanimage desktop entry - it's a gimp
404     plugin. Doh. (part of #17076)
405     - add tetex-latex as a build requirement
406    
407     * Wed Aug 23 2000 Matt Wilson <msw@redhat.com>
408     - built against gimp 1.1.25
409    
410     * Tue Aug 22 2000 Preston Brown <pbrown@redhat.com>
411     - 1.0.3 bugfix release (#16726)
412     - rev patch removed, no longer needed
413    
414     * Tue Aug 15 2000 Than Ngo <than@redhat.com>
415     - add triggerpostun to fix removing path from ld.so.conf at update
416    
417     * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
418     - Add Swedish and German translations to desktop file, Bug #15317
419    
420     * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
421     - use mktemp in post and postun scripts
422     - fix incorrect usage of rev in backend/Makefile
423    
424     * Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
425     - workarounds for weird bug (all so-files had names with "s="
426     - except for sparc which has just "=" and IA64 which works)
427    
428     * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
429     - automatic rebuild
430    
431     * Mon Jul 3 2000 Matt Wilson <msw@redhat.com>
432     - rebuilt against gimp-1.1.24
433    
434     * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
435     - FHS paths
436     - work around ICE on intel. FIX ME!
437    
438     * Mon May 22 2000 Tim Powers <timp@redhat.com>
439     - rebuilt w/ glibc-2.1.90
440    
441     * Thu May 18 2000 Tim Powers <timp@redhat.com>
442     - updated to 1.0.2
443    
444     * Wed Jul 21 1999 Tim Powers <timp@redhat.com>
445     - rebuilt for 6.1
446    
447     * Tue May 11 1999 Bill Nottingham <notting@redhat.com>
448     - make it play nice with xsane, add ld.so.conf entries
449    
450     * Wed Apr 21 1999 Bill Nottingham <notting@redhat.com>
451     - update to 1.0.1
452    
453     * Tue Oct 13 1998 Michael Maher <mike@redhat.com>
454     - updated package
455    
456     * Thu May 21 1998 Cristian Gafton <gafton@redhat.com>
457     - upgraded to 0.73
458    
459     * Tue Jan 27 1998 Otto Hammersmith <otto@redhat.com>
460     - umax drivers were missing from the file list.
461    
462     * Sun Dec 7 1997 Otto Hammersmith <otto@redhat.com>
463     - added wmconfig
464     - fixed library problem
465    
466     * Tue Dec 2 1997 Otto Hammersmith <otto@redhat.com>
467     - added changelog
468     - got newer package from Sane web site than our old powertools one

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed