/[smecontribs]/rpms/sane-backends/contribs7/sane-backends.spec
ViewVC logotype

Annotation of /rpms/sane-backends/contribs7/sane-backends.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Tue Nov 25 16:20:16 2008 UTC (15 years, 6 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.4: +0 -0 lines
Restore

1 slords 1.4 # $Id: sane-backends.spec,v 1.3 2008/04/15 20:55:54 slords Exp $
2 slords 1.1 # Authority: unnilennium
3     # Name: Jean-Philippe Pialasse
4    
5     # Disable gphoto2 backend by using --without gphoto2
6     %define gphoto2_support 0%{!?_without_gphoto2:1}
7    
8     Summary: Scanner access software
9     Name: sane-backends
10     Version: 1.0.17
11     Release: 0%{?dist}
12     License: GPL (programs), relaxed LGPL (libraries), and public domain (docs)
13     Group: System Environment/Libraries
14     Source0: ftp://ftp.sane-project.org/pub/sane/%{name}-%{version}/%{name}-%{version}.tar.gz
15     Source1: sane.png
16     Source2: libusbscanner
17     URL: http://www.sane-project.org
18     BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%__id_u -n)
19 slords 1.3 BuildRequires: tetex-latex libusb-devel libieee1284-devel libjpeg-devel
20     BuildRequires: automake libtool gettext xorg-x11-devel pkgconfig
21     BuildRequires: gphoto2-devel
22 slords 1.1 Prereq: /sbin/ldconfig, /bin/mktemp, /bin/grep, /bin/cat, /bin/rm
23     Requires: pam >= 0.77-66
24     ExcludeArch: s390 s390x
25     Requires: hotplug >= 2004_04_01-7.8
26    
27     %description
28     Scanner Access Now Easy (SANE) is a universal scanner interface. The
29     SANE application programming interface (API) provides standardized
30     access to any raster image scanner hardware (flatbed scanner,
31     hand-held scanner, video and still cameras, frame-grabbers, etc.). If
32     they're using SANE, developers can write image-processing applications
33     without having to think about the peculiarities of individual devices.
34     SANE also makes it possible to write a device driver once, which can
35     then be used by any SANE-compliant application. SANE currently
36     includes drivers for some Epson SCSI scanners, HP ScanJet SCSI
37     scanners, Microtek SCSI scanners, Mustek SCSI flatbed scanners, PINT
38     devices, most UMAX SCSI scanners, Connectix QuickCam, and other SANE
39     devices via network. Note that this package does not enable network
40     scanning by default. If you wish to enable network scanning, read the
41     saned(1) manpage. If you'd like to develop SANE modules, you should
42     also install the sane-backends-devel package.
43    
44     %package devel
45     Summary: The SANE (a universal scanner interface) development toolkit.
46     Group: Development/Libraries
47     Requires: sane-backends = %{version}, libusb-devel, libieee1284-devel
48    
49     %description devel
50     Static libraries and header files for writing Scanner Access Now Easy
51     (SANE) modules. SANE is a universal scanner interface which is
52     included in the sane-backends package.
53    
54     %prep
55     %setup -q
56    
57     for i in agfafocus avision coolscan2 umax_pp; do
58     iconv -f iso-8859-1 -t utf-8 < "doc/sane-$i.man" > "doc/sane-$i.man_"
59     mv "doc/sane-$i.man_" "doc/sane-$i.man"
60     done
61    
62     # We patched configure.in, so regenerate configure.
63     sed '/^# libtool\.m4/,$d' < acinclude.m4 > acinclude.m4.new
64     mv -f acinclude.m4{.new,}
65     aclocal
66     libtoolize --force --copy
67     autoconf
68    
69     %build
70     %{expand:%%define optflags %{optflags} -DGIMP_ENABLE_COMPAT_CRUFT=1}
71     %if %{gphoto2_support}
72     %configure --with-gphoto2=%{_prefix} --with-docdir=%{_docdir}/%{name}-%{version}
73     %else
74     %configure --without-gphoto2 --with-docdir=%{_docdir}/%{name}-%{version}
75     %endif
76     make
77    
78    
79     %install
80     rm -rf %{buildroot}
81     %{makeinstall} docdir=%{buildroot}/%{_docdir}/%{name}-%{version}
82     perl -pi -e "s/installed.*/installed=yes/g" $RPM_BUILD_ROOT%{_libdir}/libsane.la
83     /sbin/ldconfig -n $RPM_BUILD_ROOT%{_libdir} $RPM_BUILD_ROOT%{_libdir}/sane
84    
85     mkdir -p %{buildroot}%{_datadir}/pixmaps
86     install -m 644 %{SOURCE1} %{buildroot}%{_datadir}/pixmaps
87     rm -f %{buildroot}%{_bindir}/gamma4scanimage
88     rm -f %{buildroot}%{_libdir}/sane/*.a %{buildroot}%{_libdir}/*.a
89     mkdir -p %{buildroot}%{_sysconfdir}/hotplug/usb
90     install -m 755 %{SOURCE2} %{buildroot}%{_sysconfdir}/hotplug/usb
91     install -m 644 tools/hotplug/libsane.usermap %{buildroot}%{_sysconfdir}/hotplug/usb
92    
93     %find_lang %name
94    
95     %clean
96     rm -rf %{buildroot}
97    
98     %files -f %{name}.lang
99     %defattr(-,root,root)
100     %dir /etc/sane.d
101     %config(noreplace) /etc/sane.d/*
102     %{_sysconfdir}/hotplug/usb/*
103     %{_bindir}/sane-find-scanner
104     %{_bindir}/scanimage
105     %{_sbindir}/*
106     %{_libdir}/libsane*.so.*
107     %dir %{_libdir}/sane
108     %{_libdir}/sane/*.so.*
109     %{_mandir}/*/*
110     %{_datadir}/pixmaps/sane.png
111     %{_docdir}/*
112    
113     %files devel
114     %defattr(-,root,root)
115     %{_bindir}/sane-config
116     %{_includedir}/sane
117     %{_libdir}/libsane*.la
118     %{_libdir}/libsane*.so
119     %{_libdir}/sane/*.la
120     %{_libdir}/sane/*.so
121    
122     %changelog
123     * Wed Apr 05 2006 Nils Philippsen <nphilipp@redhat.com> 1.0.17-0.fc4.2
124     - update libusbscanner to handle cold-plugged USB scanners (#144444, slightly
125     changed patch by Michal Jaegermann)
126    
127     * Tue Dec 20 2005 Nils Philippsen <nphilipp@redhat.com> 1.0.17-1
128     - version 1.0.17
129     - reenable gphoto2 backend
130    
131     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
132     - rebuilt
133    
134     * Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
135     - rebuild
136    
137     * Fri Aug 19 2005 Nils Philippsen <nphilipp@redhat.com> 1.0.16-1
138     - version 1.0.16
139     - remove obsolete docdir patch
140    
141     * Mon Jul 25 2005 Tim Waugh <twaugh@redhat.com>
142     - Fixed libusbscanner comment (bug #162983).
143    
144     * Wed Mar 2 2005 Tim Waugh <twaugh@redhat.com> 1.0.15-9
145     - Rebuild for new GCC.
146    
147     * Fri Dec 10 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-8
148     - Further small fixes to libusbscanner script.
149    
150     * Fri Dec 3 2004 Tim Waugh <twaugh@redhat.com>
151     - Ship the correct libsane.usermap (part of bug #135802).
152    
153     * Wed Dec 1 2004 Tim Waugh <twaugh@redhat.com>
154     - No longer need ep2400 patch.
155    
156     * Tue Nov 30 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-7
157     - Updated libusbscanner script from Tomas Mraz, to use pam_console_apply.
158     - Requires pam >= 0.78-2 for targetted pam_console_apply.
159    
160     * Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-6
161     - Random changes in libusbscanner.
162    
163     * Tue Nov 23 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-5
164     - libusbscanner: Create /dev/usb if it doesn't exist after 30s.
165    
166     * Mon Nov 22 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-4
167     - Attempt to be more useful in libusbscanner by waiting a maximum of 30
168     seconds.
169     - Add a chcon call to libusbscanner (bug #140059). Based on contribution
170     from W. Michael Petullo.
171    
172     * Sat Nov 20 2004 Miloslav Trmac <mitr@redhat.com> - 1.0.15-3
173     - Convert man pages to UTF-8
174    
175     * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com>
176     - Require hotplug's remover to work.
177    
178     * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-2
179     - Applied the libusbscanner part of the patch for bug #121511, by Ian
180     Pilcher.
181    
182     * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com> 1.0.15-1
183     - 1.0.15.
184    
185     * Sun Oct 10 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-6
186     - Make man pages identical on multilib installations.
187    
188     * Thu Oct 7 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-5
189     - Build requires libjpeg-devel (bug #134964).
190    
191     * Thu Aug 26 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-4
192     - Apply patch from David Zeuthen to fix hotplug script (bug #130755).
193    
194     * Mon Aug 9 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-3
195     - Mark config files noreplace.
196    
197     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
198     - rebuilt
199    
200     * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 1.0.14-1
201     - 1.0.14.
202    
203     * Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
204     - s/ftp.mostang.com/ftp.sane-project.org/.
205    
206     * Fri May 7 2004 Tim Waugh <twaugh@redhat.com> 1.0.13-7
207     - Fix epson.conf for USB scanners (bug #122328).
208    
209     * Tue May 4 2004 Tim Waugh <twaugh@redhat.com> 1.0.13-6
210     - Ship libusb.usermap (from sane-backends-1.0.14) and a pam_console-aware
211     libusbscanner script.
212     - Fix epson.conf for Epson Perfection 2400 (bug #122328).
213    
214     * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
215     - rebuilt
216    
217     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
218     - rebuilt
219    
220     * Thu Feb 5 2004 Tim Waugh <twaugh@redhat.com> 1.0.13-4
221     - Fixed compilation with GCC 3.4.
222    
223     * Mon Dec 15 2003 Tim Waugh <twaugh@redhat.com> 1.0.13-3
224     - Take %%{_libdir}/sane out of ldconfig's search path altogether (Oliver
225     Rauch).
226    
227     * Tue Nov 25 2003 Thomas Woerner <twoerner@redhat.com> 1.0.13-2
228     - no rpath in sane-config anymore
229    
230     * Sun Nov 23 2003 Tim Waugh <twaugh@redhat.com> 1.0.13-1
231     - 1.0.13.
232     - No longer need autoload, gt68xx patches.
233    
234     * Thu Nov 20 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-6
235     - Don't add %%{_libdir}/sane to ld.so.conf (bug #110419).
236    
237     * Tue Nov 11 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-5
238     - Updated gt68xx driver to fix timeout problems.
239    
240     * Wed Oct 8 2003 Tim Waugh <twaugh@redhat.com>
241     - Avoided undefined behaviour in canon-sane.c (bug #106305).
242    
243     * Mon Sep 29 2003 Tim Waugh <twaugh@redhat.com>
244     - Updated URL.
245    
246     * Thu Jul 24 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-4
247     - The devel package requires libieee1284-devel.
248    
249     * Mon Jun 16 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-3
250     - Use libtoolize and aclocal to fix build.
251     - Build requires libieee1284-devel (to fix bug #75849).
252    
253     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
254     - rebuilt
255    
256     * Sun May 25 2003 Tim Waugh <twaugh@redhat.com> 1.0.12-1
257     - 1.0.12.
258    
259     * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 1.0.11-1
260     - Shipped libtool is broken; use installed script instead.
261     - Remove files not shipped.
262     - Fix some /usr/lib references.
263     - 1.0.11.
264     - Drop sane-sparc, errorchk, hp101, security patches.
265     - Update rpath, docdir patches.
266     - Use %%find_lang.
267    
268     * Fri Mar 7 2003 Tim Waugh <twaugh@redhat.com>
269     - sane-backends-devel requires libusb-devel (bug #85742).
270    
271     * Mon Feb 10 2003 Tim Waugh <twaugh@redhat.com> 1.0.9-5
272     - Fix saned problems.
273    
274     * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.0.9-4
275     - rebuilt
276    
277     * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 1.0.9-3
278     - hp-backend 1.01 for 'error during device I/O' workaround (bug #81835).
279    
280     * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 1.0.9-2
281     - Better error checking in the Canon backend (bug #81332).
282    
283     * Fri Oct 25 2002 Tim Waugh <twaugh@redhat.com> 1.0.9-1
284     - 1.0.9.
285    
286     * Wed Oct 23 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-6
287     - Ship the installed documentation.
288     - Move sane-config to the devel subpackage (bug #68454).
289    
290     * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
291     - automated rebuild
292    
293     * Fri Jun 21 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-4
294     - Fix bug #62847.
295    
296     * Tue Jun 18 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-3
297     - Fix dangling symlink (bug #66672).
298    
299     * Wed Jun 12 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-2
300     - Don't tell SANE applications to use rpath (bug #66129, bug #66132).
301    
302     * Mon May 27 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-1
303     - 1.0.8.
304    
305     * Wed May 22 2002 Tim Waugh <twaugh@redhat.com> 1.0.8-0.20020522.1
306     - Update to CVS. Release expected before the end of the month.
307     - No longer need defaultincl or argv patches.
308    
309     * Wed May 15 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-7
310     - Unconditionally run ldconfig after installation (bug #64964).
311    
312     * Mon Mar 4 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-6
313     - Re-apply the original 1.0.7-4 fix (oops):
314     - Make sure to load SCSI modules if not already loaded (bug #59979).
315    
316     * Mon Mar 4 2002 Tim Powers <timp@redhat.com> 1.0.7-5
317     - bump release number, wasn't bumped last time
318    
319     * Mon Mar 3 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-4
320     - Update sparc patch (Tom "spot" Callaway).
321    
322     * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-3
323     - Rebuild in new environment.
324     - Disable bad stdarg code in scanimage so that alpha builds succeed.
325    
326     * Mon Feb 11 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-2
327     - Make sure sane-config doesn't specify the default include path
328     (bug #59507).
329    
330     * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-1
331     - 1.0.7.
332    
333     * Sun Jan 27 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-0.beta2.1
334     - 1.0.7-beta2.
335    
336     * Wed Jan 23 2002 Tim Waugh <twaugh@redhat.com> 1.0.7-0.beta1.1
337     - 1.0.7-beta1.
338     - Patches no longer needed: scsi, microtek2, format.
339    
340     * Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.0.6-4
341     - automated rebuild
342    
343     * Wed Nov 21 2001 Tim Waugh <twaugh@redhat.com> 1.0.6-3
344     - Fix default file names format in batch scans (bug #56542).
345    
346     * Tue Nov 20 2001 Tim Waugh <twaugh@redhat.com> 1.0.6-2
347     - Apply Maurice Hilarius's patch to avoid kill(-1,SIGTERM) (bug #56540).
348    
349     * Mon Nov 5 2001 Tim Waugh <twaugh@redhat.com> 1.0.6-1
350     - 1.0.6.
351    
352     * Fri Jul 20 2001 Florian La Roche <Florian.LaRoche@redhat.de> 1.0.5-4
353     - exclude s390, s390x
354    
355     * Tue Jul 17 2001 Preston Brown <pbrown@redhat.com> 1.0.5-3
356     - sane.png included
357    
358     * Tue Jul 10 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-2
359     - sane-backends-devel provides sane-devel.
360    
361     * Sun Jul 1 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-1
362     - 1.0.5.
363    
364     * Wed Jun 20 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010620.0
365     - 2001-06-20 CVS update. PreReq /bin/cat, /bin/rm.
366    
367     * Mon Jun 11 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010610
368     - 2001-06-10 CVS snapshot. umax_pp update from CVS again to fix more
369     build problems.
370    
371     * Sun Jun 3 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010603.1000
372     - 2001-06-03 CVS snapshot (10:00). Fixes umax_pp build problems.
373    
374     * Sat Jun 2 2001 Tim Waugh <twaugh@redhat.com> 1.0.5-0.20010530
375     - sane-backends (sane-frontends is in a separate package now).
376     - 2001-05-30 CVS snapshot.
377     - include.patch no longer needed.
378     - sg3timeout.patch no longer needed.
379    
380     * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.0.3-10
381     - Fix up the libtool config file /usr/lib/libsane.la
382     kscan should build now. ;)
383    
384     * Wed Jan 10 2001 Tim Waugh <twaugh@redhat.com>
385     - Increase timeout for SCSI commands sent via sg driver version 3
386     (bug #23447)
387    
388     * Mon Dec 25 2000 Matt Wilson <msw@redhat.com>
389     - rebuilt against gimp 1.2.0
390    
391     * Thu Dec 21 2000 Matt Wilson <msw@redhat.com>
392     - rebuilt against gimp 1.1.32
393     - use -DGIMP_ENABLE_COMPAT_CRUFT=1 to build with compat macros
394    
395     * Mon Dec 18 2000 Matt Wilson <msw@redhat.com>
396     - rebuilt against gimp 1.1.30
397    
398     * Fri Dec 1 2000 Tim Waugh <twaugh@redhat.com>
399     - Rebuild because of fileutils bug.
400    
401     * Thu Oct 26 2000 Bill Nottingham <notting@redhat.com>
402     - fix provides for ia64/sparc64
403    
404     * Thu Aug 29 2000 Trond Eivind Glomsrød <teg@redhat.com>
405     - don't include xscanimage desktop entry - it's a gimp
406     plugin. Doh. (part of #17076)
407     - add tetex-latex as a build requirement
408    
409     * Wed Aug 23 2000 Matt Wilson <msw@redhat.com>
410     - built against gimp 1.1.25
411    
412     * Tue Aug 22 2000 Preston Brown <pbrown@redhat.com>
413     - 1.0.3 bugfix release (#16726)
414     - rev patch removed, no longer needed
415    
416     * Tue Aug 15 2000 Than Ngo <than@redhat.com>
417     - add triggerpostun to fix removing path from ld.so.conf at update
418    
419     * Fri Aug 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
420     - Add Swedish and German translations to desktop file, Bug #15317
421    
422     * Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
423     - use mktemp in post and postun scripts
424     - fix incorrect usage of rev in backend/Makefile
425    
426     * Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
427     - workarounds for weird bug (all so-files had names with "s="
428     - except for sparc which has just "=" and IA64 which works)
429    
430     * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
431     - automatic rebuild
432    
433     * Mon Jul 3 2000 Matt Wilson <msw@redhat.com>
434     - rebuilt against gimp-1.1.24
435    
436     * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
437     - FHS paths
438     - work around ICE on intel. FIX ME!
439    
440     * Mon May 22 2000 Tim Powers <timp@redhat.com>
441     - rebuilt w/ glibc-2.1.90
442    
443     * Thu May 18 2000 Tim Powers <timp@redhat.com>
444     - updated to 1.0.2
445    
446     * Wed Jul 21 1999 Tim Powers <timp@redhat.com>
447     - rebuilt for 6.1
448    
449     * Tue May 11 1999 Bill Nottingham <notting@redhat.com>
450     - make it play nice with xsane, add ld.so.conf entries
451    
452     * Wed Apr 21 1999 Bill Nottingham <notting@redhat.com>
453     - update to 1.0.1
454    
455     * Tue Oct 13 1998 Michael Maher <mike@redhat.com>
456     - updated package
457    
458     * Thu May 21 1998 Cristian Gafton <gafton@redhat.com>
459     - upgraded to 0.73
460    
461     * Tue Jan 27 1998 Otto Hammersmith <otto@redhat.com>
462     - umax drivers were missing from the file list.
463    
464     * Sun Dec 7 1997 Otto Hammersmith <otto@redhat.com>
465     - added wmconfig
466     - fixed library problem
467    
468     * Tue Dec 2 1997 Otto Hammersmith <otto@redhat.com>
469     - added changelog
470     - got newer package from Sane web site than our old powertools one

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed