1 |
jpp |
1.1 |
%define major 0 |
2 |
|
|
%define libname %{name}-lib |
3 |
|
|
%define develname %{name}-devel |
4 |
|
|
%define release 1 |
5 |
|
|
Name: seafile |
6 |
|
|
Version: 5.1.3 |
7 |
|
|
Release: %{release} |
8 |
|
|
Summary: Open source cloud storage system with features on privacy protection and teamwork |
9 |
|
|
License: GPLv3+ |
10 |
|
|
Group: Networking/File transfer |
11 |
|
|
URL: https://github.com/haiwen/seafile |
12 |
|
|
Source0: https://github.com/haiwen/seafile/archive/v%{version}/%{name}-%{version}.tar.gz |
13 |
|
|
#Source0: https://github.com/haiwen/seafile-server/archive/v%{version}-server.tar.gz |
14 |
|
|
Patch0: seafile-5.1.1-evhtp.patch |
15 |
|
|
Patch1: seafile-5.1.3.libarchive.patch |
16 |
|
|
#seafile-server-6.1.1-server.libarchive.patch |
17 |
|
|
BuildRequires: intltool |
18 |
|
|
BuildRequires: pkgconfig(glib-2.0) |
19 |
|
|
BuildRequires: pkgconfig(jansson) |
20 |
|
|
#BuildRequires: pkgconfig(sqlite3) |
21 |
|
|
BuildRequires: sqlite-devel >= 3.7.17 |
22 |
|
|
BuildRequires: pkgconfig(openssl) |
23 |
|
|
BuildRequires: pkgconfig(libevent) |
24 |
|
|
BuildRequires: pkgconfig(uuid) >= 2.0 |
25 |
|
|
BuildRequires: pkgconfig(libcurl) |
26 |
|
|
BuildRequires: pkgconfig(libsearpc) |
27 |
|
|
#BuildRequires: pkgconfig(libccnet) |
28 |
|
|
BuildRequires: ccnet-devel |
29 |
|
|
##BuildRequires: pkgconfig(python) |
30 |
|
|
BuildRequires: python-devel |
31 |
|
|
#BuildRequires: vala >= 0.26 |
32 |
|
|
BuildRequires: vala |
33 |
|
|
# server requirements |
34 |
|
|
BuildRequires: pkgconfig(zdb) |
35 |
|
|
BuildRequires: pkgconfig(evhtp) |
36 |
|
|
BuildRequires: pkgconfig(libarchive) |
37 |
|
|
#add jpp epel |
38 |
|
|
BuildRequires: libedit |
39 |
|
|
BuildRequires: libtool |
40 |
|
|
BuildRequires: fuse-devel fuse |
41 |
|
|
Requires: fuse |
42 |
|
|
Requires: sqlite >= 3.7.17 |
43 |
|
|
#fin add jpp |
44 |
|
|
|
45 |
|
|
Requires: ccnet >= %{version} |
46 |
|
|
Requires: pythonegg(2)(seafile) = %{version}-%{release} |
47 |
|
|
%description |
48 |
|
|
Seafile is an open source cloud storage system with features on privacy |
49 |
|
|
protection and teamwork. Collections of files are called libraries, and |
50 |
|
|
each library can be synced separately. A library can also be encrypted |
51 |
|
|
with a user chosen password. Seafile also allows users to create groups |
52 |
|
|
and easily sharing files into groups. |
53 |
|
|
|
54 |
|
|
#---------------------------------------------------- |
55 |
|
|
|
56 |
|
|
%package server |
57 |
|
|
Summary: Seafile server |
58 |
|
|
Group: Networking/File transfer |
59 |
|
|
Requires: ccnet-server |
60 |
|
|
#>= %{version} |
61 |
|
|
#Requires: ccnet >= %{version} |
62 |
|
|
Requires: pythonegg(2)(seaserv) = %{version}-%{release} |
63 |
|
|
|
64 |
|
|
%description server |
65 |
|
|
Seafile is an open source cloud storage system with features on privacy |
66 |
|
|
protection and teamwork. Collections of files are called libraries, and |
67 |
|
|
each library can be synced separately. A library can also be encrypted |
68 |
|
|
with a user chosen password. Seafile also allows users to create groups |
69 |
|
|
and easily sharing files into groups. |
70 |
|
|
This package contains the server part for %{name}. |
71 |
|
|
|
72 |
|
|
#---------------------------------------------------- |
73 |
|
|
|
74 |
|
|
%package -n %{libname} |
75 |
|
|
Summary: Library for %{name} |
76 |
|
|
Group: System/Libraries |
77 |
|
|
|
78 |
|
|
%description -n %{libname} |
79 |
|
|
Seafile is an open source cloud storage system with features on privacy |
80 |
|
|
protection and teamwork. Collections of files are called libraries, and |
81 |
|
|
each library can be synced separately. A library can also be encrypted |
82 |
|
|
with a user chosen password. Seafile also allows users to create groups |
83 |
|
|
and easily sharing files into groups. |
84 |
|
|
This package contains library files for %{name}. |
85 |
|
|
|
86 |
|
|
#---------------------------------------------------- |
87 |
|
|
|
88 |
|
|
%package -n %{develname} |
89 |
|
|
Summary: Development files for %{name} |
90 |
|
|
Group: Development/C |
91 |
|
|
Requires: %{libname} = %{version}-%{release} |
92 |
|
|
Provides: %{name}-devel = %{version}-%{release} |
93 |
|
|
Provides: lib%{name}-devel = %{version}-%{release} |
94 |
|
|
|
95 |
|
|
%description -n %{develname} |
96 |
|
|
The %{develname} package contains libraries and header files for |
97 |
|
|
developing applications that use %{name}. |
98 |
|
|
|
99 |
|
|
#---------------------------------------------------- |
100 |
|
|
|
101 |
|
|
%package -n python-%{name} |
102 |
|
|
Summary: Python 2 bindings for %{name} |
103 |
|
|
Group: Development/Python |
104 |
|
|
BuildArch: noarch |
105 |
|
|
Provides: pythonegg(2)(seafile) = %{version}-%{release} |
106 |
|
|
Provides: pythonegg(2)(seaserv) = %{version}-%{release} |
107 |
|
|
|
108 |
|
|
%description -n python-%{name} |
109 |
|
|
Seafile is an open source cloud storage system with features on privacy |
110 |
|
|
protection and teamwork. Collections of files are called libraries, and |
111 |
|
|
each library can be synced separately. A library can also be encrypted |
112 |
|
|
with a user chosen password. Seafile also allows users to create groups |
113 |
|
|
and easily sharing files into groups. |
114 |
|
|
This package contains the python 2 bindings for %{name}. |
115 |
|
|
|
116 |
|
|
#---------------------------------------------------- |
117 |
|
|
|
118 |
|
|
%prep |
119 |
|
|
%setup -q |
120 |
|
|
#%#setup -q -n seafile-server-%{version}-server |
121 |
|
|
%patch0 -p1 |
122 |
|
|
%patch1 -p1 |
123 |
|
|
#%#autopatch -p1 |
124 |
|
|
|
125 |
|
|
sed -i -e /\(DESTDIR\)/d lib/libseafile.pc.in |
126 |
|
|
|
127 |
|
|
NOCONFIGURE=1 ./autogen.sh |
128 |
|
|
|
129 |
|
|
%build |
130 |
|
|
echo "hum1" |
131 |
|
|
#%configure2_5x |
132 |
|
|
%configure \ |
133 |
|
|
--disable-static \ |
134 |
|
|
--with-mysql \ |
135 |
|
|
--enable-server \ |
136 |
|
|
--enable-client \ |
137 |
|
|
# --disable-fuse |
138 |
|
|
echo "hum 2" |
139 |
|
|
ls -alR /usr/include/evhtp/ |
140 |
|
|
#%make_build |
141 |
|
|
make |
142 |
|
|
echo "hum 3" |
143 |
|
|
#ls -al %{buildroot} |
144 |
|
|
#ls -al /builddir/build/BUILD/seafile-6.1.1/ |
145 |
|
|
%install |
146 |
|
|
#%make_install |
147 |
|
|
make install DESTDIR=%{buildroot} |
148 |
|
|
|
149 |
|
|
# we don't want these |
150 |
|
|
find %{buildroot} -name '*.la' -delete |
151 |
|
|
#ls -alR /builddir/build/BUILDROOT/seafile-6.1.1-1.x86_64/ > /dev/stderr |
152 |
|
|
|
153 |
|
|
%files |
154 |
|
|
%doc README.markdown |
155 |
|
|
%doc LICENSE.txt |
156 |
|
|
%{_bindir}/seaf-cli |
157 |
|
|
%{_bindir}/seaf-daemon |
158 |
|
|
%{_mandir}/man1/*.1.* |
159 |
|
|
|
160 |
|
|
%files server |
161 |
|
|
%doc README.markdown |
162 |
|
|
%doc LICENSE.txt |
163 |
|
|
%{_bindir}/seaf-fsck |
164 |
|
|
%{_bindir}/seaf-fuse |
165 |
|
|
%{_bindir}/seaf-migrate |
166 |
|
|
%{_bindir}/seaf-server |
167 |
|
|
%{_bindir}/seaf-server-init |
168 |
|
|
%{_bindir}/seafserv-gc |
169 |
|
|
%{_bindir}/%{name}-admin |
170 |
|
|
%{_bindir}/%{name}-controller |
171 |
|
|
|
172 |
|
|
%files -n %{libname} |
173 |
|
|
%{_libdir}/lib%{name}.so.%{major} |
174 |
|
|
%{_libdir}/lib%{name}.so.%{major}.* |
175 |
|
|
|
176 |
|
|
%files -n %{develname} |
177 |
|
|
%doc README.markdown |
178 |
|
|
%{_includedir}/* |
179 |
|
|
%{_libdir}/lib%{name}.so |
180 |
|
|
%{_libdir}/pkgconfig/lib%{name}.pc |
181 |
|
|
|
182 |
|
|
%files -n python-%{name} |
183 |
|
|
%doc README.markdown |
184 |
|
|
%{python_sitearch}/%{name}/ |
185 |
|
|
%{python_sitearch}/seaserv/ |
186 |
|
|
|
187 |
|
|
|
188 |
|
|
%changelog |
189 |
|
|
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 6.1.1-1.sme |
190 |
|
|
- upgrade to 6.1.1 |
191 |
|
|
- First import to SME Server |
192 |
|
|
- test with vala < 0.26 : vala-0.10.4-1.el6 |
193 |
|
|
|
194 |
|
|
* Tue Nov 01 2016 daviddavid <daviddavid> 5.1.3-1.mga5 |
195 |
|
|
+ Revision: 1064503 |
196 |
|
|
- new version: 5.1.3 |
197 |
|
|
|
198 |
|
|
+ neoclust <neoclust> |
199 |
|
|
- Use version 5.1.2 on backports |
200 |
|
|
- Add to backports |
201 |
|
|
|
202 |
|
|
* Thu Jun 30 2016 daviddavid <daviddavid> 5.1.3-1.mga6 |
203 |
|
|
+ Revision: 1038172 |
204 |
|
|
- new version: 5.1.3 |
205 |
|
|
|
206 |
|
|
* Thu May 12 2016 daviddavid <daviddavid> 5.1.1-4.mga6 |
207 |
|
|
+ Revision: 1014279 |
208 |
|
|
- add the server part of seafile |
209 |
|
|
|
210 |
|
|
* Sat May 07 2016 daviddavid <daviddavid> 5.1.1-3.mga6 |
211 |
|
|
+ Revision: 1010167 |
212 |
|
|
- add another missing requires on ccnet |
213 |
|
|
|
214 |
|
|
* Sat May 07 2016 daviddavid <daviddavid> 5.1.1-2.mga6 |
215 |
|
|
+ Revision: 1010149 |
216 |
|
|
- add missing requires on python-seafile |
217 |
|
|
|
218 |
|
|
* Fri May 06 2016 daviddavid <daviddavid> 5.1.1-1.mga6 |
219 |
|
|
+ Revision: 1009890 |
220 |
|
|
- initial package seafile |
221 |
|
|
|