/[smecontribs]/rpms/seafile/contribs9/seafile.spec
ViewVC logotype

Annotation of /rpms/seafile/contribs9/seafile.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Fri Mar 9 04:57:10 2018 UTC (6 years, 2 months ago) by jpp
Branch: MAIN
Changes since 1.2: +71 -5 lines
Prep for smeserver-unifi import

1 jpp 1.3 # define name of the scl
2     %global scl python27
3     %scl_package %scl
4    
5     # Defaults for the values for the python27/rh-python35 Software Collection. These
6     # will be used when python27-scldevel (or rh-python35-scldevel) is not in the
7     # build root
8     %{!?scl_python:%global scl_python python27}
9     %{!?scl_no_vendor:%global scl_no_vendor python27}
10     %{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-}
11    
12     # Only for this build, you need to override default __os_install_post,
13     # because the default one would find /opt/.../lib/python2.7/ and try
14     # to bytecompile with the system /usr/bin/python2.7
15     %global __os_install_post %{%{scl_no_vendor}_os_install_post}
16     # Similarly, override __python_requires for automatic dependency generator
17     %global __python_requires %{%{scl_no_vendor}_python_requires}
18    
19     # The directory for site packages for this Software Collection
20     %global seafile_sitelib %(echo %{python27python_sitelib} | sed 's|%{scl_python}|%{scl}|')
21    
22    
23 jpp 1.1 %define major 0
24     %define libname %{name}-lib
25     %define develname %{name}-devel
26 jpp 1.3 %define release 2
27 jpp 1.1 Name: seafile
28     Version: 5.1.3
29 jpp 1.3 Release: %{release}%{?dist}
30 jpp 1.1 Summary: Open source cloud storage system with features on privacy protection and teamwork
31     License: GPLv3+
32     Group: Networking/File transfer
33     URL: https://github.com/haiwen/seafile
34     Source0: https://github.com/haiwen/seafile/archive/v%{version}/%{name}-%{version}.tar.gz
35     #Source0: https://github.com/haiwen/seafile-server/archive/v%{version}-server.tar.gz
36     Patch0: seafile-5.1.1-evhtp.patch
37     Patch1: seafile-5.1.3.libarchive.patch
38     #seafile-server-6.1.1-server.libarchive.patch
39     BuildRequires: intltool
40     BuildRequires: pkgconfig(glib-2.0)
41     BuildRequires: pkgconfig(jansson)
42     #BuildRequires: pkgconfig(sqlite3)
43     BuildRequires: sqlite-devel >= 3.7.17
44     BuildRequires: pkgconfig(openssl)
45     BuildRequires: pkgconfig(libevent)
46     BuildRequires: pkgconfig(uuid) >= 2.0
47     BuildRequires: pkgconfig(libcurl)
48     BuildRequires: pkgconfig(libsearpc)
49     #BuildRequires: pkgconfig(libccnet)
50     BuildRequires: ccnet-devel
51     ##BuildRequires: pkgconfig(python)
52 jpp 1.3 #BuildRequires: python-devel
53     BuildRequires: scl-utils-build
54     # Always make sure that there is the python27-sclbuild (or rh-python35-sclbuild)
55     # package in the build root
56     BuildRequires: %{scl_prefix_python}scldevel
57     # Require python27-python-devel, you will need macros from that package
58     BuildRequires: %{scl_prefix_python}python-devel
59     BuildRequires: %{scl_prefix_python}build
60     Requires: %{scl_prefix}python-versiontools
61     #BuildRequires: python27-python-devel
62 jpp 1.1 #BuildRequires: vala >= 0.26
63     BuildRequires: vala
64     # server requirements
65     BuildRequires: pkgconfig(zdb)
66     BuildRequires: pkgconfig(evhtp)
67     BuildRequires: pkgconfig(libarchive)
68     #add jpp epel
69     BuildRequires: libedit
70     BuildRequires: libtool
71     BuildRequires: fuse-devel fuse
72     Requires: fuse
73     Requires: sqlite >= 3.7.17
74     #fin add jpp
75    
76     Requires: ccnet >= %{version}
77     Requires: pythonegg(2)(seafile) = %{version}-%{release}
78     %description
79     Seafile is an open source cloud storage system with features on privacy
80     protection and teamwork. Collections of files are called libraries, and
81     each library can be synced separately. A library can also be encrypted
82     with a user chosen password. Seafile also allows users to create groups
83     and easily sharing files into groups.
84    
85     #----------------------------------------------------
86    
87     %package server
88     Summary: Seafile server
89     Group: Networking/File transfer
90     Requires: ccnet-server
91     #>= %{version}
92     #Requires: ccnet >= %{version}
93     Requires: pythonegg(2)(seaserv) = %{version}-%{release}
94    
95     %description server
96     Seafile is an open source cloud storage system with features on privacy
97     protection and teamwork. Collections of files are called libraries, and
98     each library can be synced separately. A library can also be encrypted
99     with a user chosen password. Seafile also allows users to create groups
100     and easily sharing files into groups.
101     This package contains the server part for %{name}.
102    
103     #----------------------------------------------------
104    
105     %package -n %{libname}
106     Summary: Library for %{name}
107     Group: System/Libraries
108    
109     %description -n %{libname}
110     Seafile is an open source cloud storage system with features on privacy
111     protection and teamwork. Collections of files are called libraries, and
112     each library can be synced separately. A library can also be encrypted
113     with a user chosen password. Seafile also allows users to create groups
114     and easily sharing files into groups.
115     This package contains library files for %{name}.
116    
117     #----------------------------------------------------
118    
119     %package -n %{develname}
120     Summary: Development files for %{name}
121     Group: Development/C
122     Requires: %{libname} = %{version}-%{release}
123     Provides: %{name}-devel = %{version}-%{release}
124     Provides: lib%{name}-devel = %{version}-%{release}
125    
126     %description -n %{develname}
127     The %{develname} package contains libraries and header files for
128     developing applications that use %{name}.
129    
130     #----------------------------------------------------
131    
132 jpp 1.3 %package -n %{name}-debug
133     Summary: Debug files for %{name}
134     Group: Development/C
135     Requires: %{libname} = %{version}-%{release}
136    
137     %description -n %{name}-debug
138     The %{name}-debug package contains debugs files and header files for
139     debuging applications that use %{name}.
140    
141     #----------------------------------------------------
142    
143 jpp 1.1 %package -n python-%{name}
144     Summary: Python 2 bindings for %{name}
145     Group: Development/Python
146     BuildArch: noarch
147     Provides: pythonegg(2)(seafile) = %{version}-%{release}
148     Provides: pythonegg(2)(seaserv) = %{version}-%{release}
149 jpp 1.3 Requires: scl-utils
150     Requires: %{scl_prefix_python}runtime
151 jpp 1.1
152     %description -n python-%{name}
153     Seafile is an open source cloud storage system with features on privacy
154     protection and teamwork. Collections of files are called libraries, and
155     each library can be synced separately. A library can also be encrypted
156     with a user chosen password. Seafile also allows users to create groups
157     and easily sharing files into groups.
158     This package contains the python 2 bindings for %{name}.
159    
160     #----------------------------------------------------
161    
162 jpp 1.3
163 jpp 1.1 %prep
164     %setup -q
165     %patch0 -p1
166     %patch1 -p1
167    
168     sed -i -e /\(DESTDIR\)/d lib/libseafile.pc.in
169    
170     NOCONFIGURE=1 ./autogen.sh
171    
172     %build
173 jpp 1.3 scl enable %{scl_python} "bash"
174     %{?scl:scl enable %{scl_python} - << \EOF}
175     export PYTHON='/opt/rh/python27/root/usr/bin/python'
176 jpp 1.1 %configure \
177     --disable-static \
178     --enable-server \
179 jpp 1.3 --enable-client
180    
181 jpp 1.1 make
182 jpp 1.3 %{?scl:EOF}
183     # --with-mysql unknown for 5.1.3
184 jpp 1.2
185 jpp 1.1 %install
186 jpp 1.3 %scl_install
187     %{?scl:scl enable %{scl_python} - << \EOF}
188     export PYTHON='/opt/rh/python27/root/usr/bin/python'
189 jpp 1.1 make install DESTDIR=%{buildroot}
190 jpp 1.3 %{?scl:EOF}
191 jpp 1.1
192     # we don't want these
193     find %{buildroot} -name '*.la' -delete
194 jpp 1.3 rm -rf %{buildroot}/etc/rpm/macros.python27-config
195     rm -rf %{buildroot}/etc/scl/prefixes/python27
196     rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp
197     rm -rf %{buildroot}/opt/rh/python27/root/var/mail
198 jpp 1.1
199     %files
200     %doc README.markdown
201     %doc LICENSE.txt
202     %{_bindir}/seaf-cli
203     %{_bindir}/seaf-daemon
204     %{_mandir}/man1/*.1.*
205    
206     %files server
207     %doc README.markdown
208     %doc LICENSE.txt
209     %{_bindir}/seaf-fsck
210     %{_bindir}/seaf-fuse
211     %{_bindir}/seaf-migrate
212     %{_bindir}/seaf-server
213     %{_bindir}/seaf-server-init
214     %{_bindir}/seafserv-gc
215     %{_bindir}/%{name}-admin
216     %{_bindir}/%{name}-controller
217    
218     %files -n %{libname}
219     %{_libdir}/lib%{name}.so.%{major}
220     %{_libdir}/lib%{name}.so.%{major}.*
221    
222     %files -n %{develname}
223     %doc README.markdown
224     %{_includedir}/*
225     %{_libdir}/lib%{name}.so
226     %{_libdir}/pkgconfig/lib%{name}.pc
227    
228     %files -n python-%{name}
229     %doc README.markdown
230     %{python_sitearch}/%{name}/
231     %{python_sitearch}/seaserv/
232    
233 jpp 1.3 %files -n %{name}-debug
234     /usr/src/debug/*
235     /usr/lib/debug/.build-id/*
236     /usr/lib/debug/opt/rh/python27/root/usr/bin/*
237     /usr/lib/debug/opt/rh/python27/root/usr/lib64/*
238 jpp 1.1
239     %changelog
240 jpp 1.3 * Wed Mar 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version: 5.1.3-2.sme
241     - build against python27 sclo, packaged as element of this sclo
242    
243 jpp 1.2 * Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-1.sme
244 jpp 1.1 - First import to SME Server
245     - test with vala < 0.26 : vala-0.10.4-1.el6
246    
247     * Tue Nov 01 2016 daviddavid <daviddavid> 5.1.3-1.mga5
248     + Revision: 1064503
249     - new version: 5.1.3
250    
251     + neoclust <neoclust>
252     - Use version 5.1.2 on backports
253     - Add to backports
254    
255     * Thu Jun 30 2016 daviddavid <daviddavid> 5.1.3-1.mga6
256     + Revision: 1038172
257     - new version: 5.1.3
258    
259     * Thu May 12 2016 daviddavid <daviddavid> 5.1.1-4.mga6
260     + Revision: 1014279
261     - add the server part of seafile
262    
263     * Sat May 07 2016 daviddavid <daviddavid> 5.1.1-3.mga6
264     + Revision: 1010167
265     - add another missing requires on ccnet
266    
267     * Sat May 07 2016 daviddavid <daviddavid> 5.1.1-2.mga6
268     + Revision: 1010149
269     - add missing requires on python-seafile
270    
271     * Fri May 06 2016 daviddavid <daviddavid> 5.1.1-1.mga6
272     + Revision: 1009890
273     - initial package seafile
274    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed