1 |
# define name of the scl |
2 |
%global scl python27 |
3 |
%scl_package %scl |
4 |
|
5 |
# Defaults for the values for the python27/rh-python35 Software Collection. These |
6 |
# will be used when python27-scldevel (or rh-python35-scldevel) is not in the |
7 |
# build root |
8 |
%{!?scl_python:%global scl_python python27} |
9 |
%{!?scl_no_vendor:%global scl_no_vendor python27} |
10 |
%{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-} |
11 |
|
12 |
# Only for this build, you need to override default __os_install_post, |
13 |
# because the default one would find /opt/.../lib/python2.7/ and try |
14 |
# to bytecompile with the system /usr/bin/python2.7 |
15 |
%global __os_install_post %{%{scl_no_vendor}_os_install_post} |
16 |
# Similarly, override __python_requires for automatic dependency generator |
17 |
%global __python_requires %{%{scl_no_vendor}_python_requires} |
18 |
|
19 |
# The directory for site packages for this Software Collection |
20 |
%global seafile_sitelib %(echo %{python27python_sitelib} | sed 's|%{scl_python}|%{scl}|') |
21 |
|
22 |
|
23 |
%define major 0 |
24 |
%define libname %{name}-lib |
25 |
%define develname %{name}-devel |
26 |
%define release 3 |
27 |
Name: seafile |
28 |
Version: 5.1.3 |
29 |
Release: %{release}%{?dist} |
30 |
Summary: Open source cloud storage system with features on privacy protection and teamwork |
31 |
License: GPLv3+ |
32 |
Group: Networking/File transfer |
33 |
URL: https://github.com/haiwen/seafile |
34 |
Source0: https://github.com/haiwen/seafile/archive/v%{version}/%{name}-%{version}.tar.gz |
35 |
#Source0: https://github.com/haiwen/seafile-server/archive/v%{version}-server.tar.gz |
36 |
Patch0: seafile-5.1.1-evhtp.patch |
37 |
Patch1: seafile-5.1.3.libarchive.patch |
38 |
#seafile-server-6.1.1-server.libarchive.patch |
39 |
BuildRequires: intltool |
40 |
BuildRequires: pkgconfig(glib-2.0) |
41 |
BuildRequires: pkgconfig(jansson) |
42 |
#BuildRequires: pkgconfig(sqlite3) |
43 |
BuildRequires: sqlite-devel >= 3.7.17 |
44 |
BuildRequires: pkgconfig(openssl) |
45 |
BuildRequires: pkgconfig(libevent) |
46 |
BuildRequires: pkgconfig(uuid) >= 2.0 |
47 |
BuildRequires: pkgconfig(libcurl) |
48 |
BuildRequires: pkgconfig(libsearpc) |
49 |
#BuildRequires: pkgconfig(libccnet) |
50 |
BuildRequires: ccnet-devel |
51 |
##BuildRequires: pkgconfig(python) |
52 |
#BuildRequires: python-devel |
53 |
BuildRequires: scl-utils-build |
54 |
# Always make sure that there is the python27-sclbuild (or rh-python35-sclbuild) |
55 |
# package in the build root |
56 |
BuildRequires: %{scl_prefix_python}scldevel |
57 |
# Require python27-python-devel, you will need macros from that package |
58 |
BuildRequires: %{scl_prefix_python}python-devel |
59 |
BuildRequires: %{scl_prefix_python}build |
60 |
Requires: %{scl_prefix}python-versiontools |
61 |
#BuildRequires: python27-python-devel |
62 |
#BuildRequires: vala >= 0.26 |
63 |
BuildRequires: vala |
64 |
# server requirements |
65 |
BuildRequires: pkgconfig(zdb) |
66 |
BuildRequires: pkgconfig(evhtp) |
67 |
BuildRequires: pkgconfig(libarchive) |
68 |
#add jpp epel |
69 |
BuildRequires: libedit |
70 |
BuildRequires: libtool |
71 |
BuildRequires: fuse-devel fuse |
72 |
Requires: fuse |
73 |
Requires: sqlite >= 3.7.17 |
74 |
BuildArch: x86_64 |
75 |
#fin add jpp |
76 |
|
77 |
Requires: ccnet >= %{version} |
78 |
Requires: pythonegg(2)(seafile) = %{version}-%{release} |
79 |
%description |
80 |
Seafile is an open source cloud storage system with features on privacy |
81 |
protection and teamwork. Collections of files are called libraries, and |
82 |
each library can be synced separately. A library can also be encrypted |
83 |
with a user chosen password. Seafile also allows users to create groups |
84 |
and easily sharing files into groups. |
85 |
|
86 |
#---------------------------------------------------- |
87 |
|
88 |
%package server |
89 |
Summary: Seafile server |
90 |
Group: Networking/File transfer |
91 |
Requires: ccnet-server |
92 |
#>= %{version} |
93 |
#Requires: ccnet >= %{version} |
94 |
Requires: pythonegg(2)(seaserv) = %{version}-%{release} |
95 |
|
96 |
%description server |
97 |
Seafile is an open source cloud storage system with features on privacy |
98 |
protection and teamwork. Collections of files are called libraries, and |
99 |
each library can be synced separately. A library can also be encrypted |
100 |
with a user chosen password. Seafile also allows users to create groups |
101 |
and easily sharing files into groups. |
102 |
This package contains the server part for %{name}. |
103 |
|
104 |
#---------------------------------------------------- |
105 |
|
106 |
%package -n %{libname} |
107 |
Summary: Library for %{name} |
108 |
Group: System/Libraries |
109 |
|
110 |
%description -n %{libname} |
111 |
Seafile is an open source cloud storage system with features on privacy |
112 |
protection and teamwork. Collections of files are called libraries, and |
113 |
each library can be synced separately. A library can also be encrypted |
114 |
with a user chosen password. Seafile also allows users to create groups |
115 |
and easily sharing files into groups. |
116 |
This package contains library files for %{name}. |
117 |
|
118 |
#---------------------------------------------------- |
119 |
|
120 |
%package -n %{develname} |
121 |
Summary: Development files for %{name} |
122 |
Group: Development/C |
123 |
Requires: %{libname} = %{version}-%{release} |
124 |
Provides: %{name}-devel = %{version}-%{release} |
125 |
Provides: lib%{name}-devel = %{version}-%{release} |
126 |
|
127 |
%description -n %{develname} |
128 |
The %{develname} package contains libraries and header files for |
129 |
developing applications that use %{name}. |
130 |
|
131 |
#---------------------------------------------------- |
132 |
|
133 |
%package -n %{name}-debug |
134 |
Summary: Debug files for %{name} |
135 |
Group: Development/C |
136 |
Requires: %{libname} = %{version}-%{release} |
137 |
|
138 |
%description -n %{name}-debug |
139 |
The %{name}-debug package contains debugs files and header files for |
140 |
debuging applications that use %{name}. |
141 |
|
142 |
#---------------------------------------------------- |
143 |
|
144 |
%package -n python-%{name} |
145 |
Summary: Python 2 bindings for %{name} |
146 |
Group: Development/Python |
147 |
BuildArch: noarch |
148 |
Provides: pythonegg(2)(seafile) = %{version}-%{release} |
149 |
Provides: pythonegg(2)(seaserv) = %{version}-%{release} |
150 |
Requires: scl-utils |
151 |
Requires: %{scl_prefix_python}runtime |
152 |
|
153 |
%description -n python-%{name} |
154 |
Seafile is an open source cloud storage system with features on privacy |
155 |
protection and teamwork. Collections of files are called libraries, and |
156 |
each library can be synced separately. A library can also be encrypted |
157 |
with a user chosen password. Seafile also allows users to create groups |
158 |
and easily sharing files into groups. |
159 |
This package contains the python 2 bindings for %{name}. |
160 |
|
161 |
#---------------------------------------------------- |
162 |
|
163 |
|
164 |
%prep |
165 |
%setup -q |
166 |
%patch0 -p1 |
167 |
%patch1 -p1 |
168 |
|
169 |
sed -i -e /\(DESTDIR\)/d lib/libseafile.pc.in |
170 |
|
171 |
NOCONFIGURE=1 ./autogen.sh |
172 |
|
173 |
%build |
174 |
scl enable %{scl_python} "bash" |
175 |
%{?scl:scl enable %{scl_python} - << \EOF} |
176 |
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
177 |
%configure \ |
178 |
--disable-static \ |
179 |
--enable-server \ |
180 |
--enable-client |
181 |
|
182 |
make |
183 |
%{?scl:EOF} |
184 |
# --with-mysql unknown for 5.1.3 |
185 |
|
186 |
%install |
187 |
%scl_install |
188 |
%{?scl:scl enable %{scl_python} - << \EOF} |
189 |
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
190 |
make install DESTDIR=%{buildroot} |
191 |
%{?scl:EOF} |
192 |
|
193 |
# we don't want these |
194 |
find %{buildroot} -name '*.la' -delete |
195 |
rm -rf %{buildroot}/etc/rpm/macros.python27-config |
196 |
rm -rf %{buildroot}/etc/scl/prefixes/python27 |
197 |
rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp |
198 |
rm -rf %{buildroot}/opt/rh/python27/root/var/mail |
199 |
|
200 |
%files |
201 |
%doc README.markdown |
202 |
%doc LICENSE.txt |
203 |
%{_bindir}/seaf-cli |
204 |
%{_bindir}/seaf-daemon |
205 |
%{_mandir}/man1/*.1.* |
206 |
|
207 |
%files server |
208 |
%doc README.markdown |
209 |
%doc LICENSE.txt |
210 |
%{_bindir}/seaf-fsck |
211 |
%{_bindir}/seaf-fuse |
212 |
%{_bindir}/seaf-migrate |
213 |
%{_bindir}/seaf-server |
214 |
%{_bindir}/seaf-server-init |
215 |
%{_bindir}/seafserv-gc |
216 |
%{_bindir}/%{name}-admin |
217 |
%{_bindir}/%{name}-controller |
218 |
|
219 |
%files -n %{libname} |
220 |
%{_libdir}/lib%{name}.so.%{major} |
221 |
%{_libdir}/lib%{name}.so.%{major}.* |
222 |
|
223 |
%files -n %{develname} |
224 |
%doc README.markdown |
225 |
%{_includedir}/* |
226 |
%{_libdir}/lib%{name}.so |
227 |
%{_libdir}/pkgconfig/lib%{name}.pc |
228 |
|
229 |
%files -n python-%{name} |
230 |
%doc README.markdown |
231 |
%{python_sitearch}/%{name}/ |
232 |
%{python_sitearch}/seaserv/ |
233 |
|
234 |
%files -n %{name}-debug |
235 |
/usr/src/debug/* |
236 |
/usr/lib/debug/.build-id/* |
237 |
/usr/lib/debug/opt/rh/python27/root/usr/bin/* |
238 |
/usr/lib/debug/opt/rh/python27/root/usr/lib64/* |
239 |
|
240 |
%changelog |
241 |
* Mon Mar 26 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version: 5.1.3-3.sme |
242 |
- TODO: rebuild with ccnet for python27 |
243 |
- TODO: fix pids folder path |
244 |
- TODO: fix seahub.db creation path |
245 |
|
246 |
* Wed Mar 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version: 5.1.3-2.sme |
247 |
- build against python27 sclo, packaged as element of this sclo |
248 |
- only for x86_64 arch |
249 |
|
250 |
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-1.sme |
251 |
- First import to SME Server |
252 |
- test with vala < 0.26 : vala-0.10.4-1.el6 |
253 |
|
254 |
* Tue Nov 01 2016 daviddavid <daviddavid> 5.1.3-1.mga5 |
255 |
+ Revision: 1064503 |
256 |
- new version: 5.1.3 |
257 |
|
258 |
+ neoclust <neoclust> |
259 |
- Use version 5.1.2 on backports |
260 |
- Add to backports |
261 |
|
262 |
* Thu Jun 30 2016 daviddavid <daviddavid> 5.1.3-1.mga6 |
263 |
+ Revision: 1038172 |
264 |
- new version: 5.1.3 |
265 |
|
266 |
* Thu May 12 2016 daviddavid <daviddavid> 5.1.1-4.mga6 |
267 |
+ Revision: 1014279 |
268 |
- add the server part of seafile |
269 |
|
270 |
* Sat May 07 2016 daviddavid <daviddavid> 5.1.1-3.mga6 |
271 |
+ Revision: 1010167 |
272 |
- add another missing requires on ccnet |
273 |
|
274 |
* Sat May 07 2016 daviddavid <daviddavid> 5.1.1-2.mga6 |
275 |
+ Revision: 1010149 |
276 |
- add missing requires on python-seafile |
277 |
|
278 |
* Fri May 06 2016 daviddavid <daviddavid> 5.1.1-1.mga6 |
279 |
+ Revision: 1009890 |
280 |
- initial package seafile |
281 |
|