1 |
jpp |
1.2 |
%define release 1 |
2 |
|
|
%define version 3.3.5 |
3 |
|
|
|
4 |
jpp |
1.1 |
Name: shairport-sync |
5 |
jpp |
1.2 |
Version: %{version} |
6 |
|
|
Release: %{release}%{?dist} |
7 |
jpp |
1.1 |
Summary: AirTunes emulator. Multi-Room with Audio Synchronisation |
8 |
|
|
# MIT licensed except for tinysvcmdns under BSD, |
9 |
|
|
# FFTConvolver/ under GPLv3+ and audio_sndio.c |
10 |
|
|
# under ISC |
11 |
|
|
License: MIT and BSD and GPLv3+ and ISC |
12 |
|
|
URL: https://github.com/mikebrady/shairport-sync |
13 |
|
|
Source0: https://github.com/mikebrady/%{name}/archive/%{version}/%{name}-%{version}.tar.gz |
14 |
|
|
|
15 |
|
|
%{?systemd_requires} |
16 |
|
|
BuildRequires: pkgconfig(libconfig) |
17 |
jpp |
1.2 |
BuildRequires: popt-devel |
18 |
|
|
#pkgconfig(popt) |
19 |
jpp |
1.1 |
BuildRequires: pkgconfig(openssl) |
20 |
|
|
BuildRequires: pkgconfig(libdaemon) |
21 |
|
|
BuildRequires: pkgconfig(avahi-core) |
22 |
|
|
BuildRequires: pkgconfig(alsa) |
23 |
|
|
BuildRequires: pkgconfig(soxr) |
24 |
jpp |
1.2 |
BuildRequires: libsndfile-devel |
25 |
jpp |
1.1 |
BuildRequires: autoconf |
26 |
|
|
BuildRequires: automake |
27 |
|
|
BuildRequires: gcc |
28 |
|
|
BuildRequires: gcc-c++ |
29 |
|
|
BuildRequires: pkgconfig(libpulse) |
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
Shairport Sync emulates an AirPort Express for the purpose of streaming audio |
33 |
|
|
from iTunes, iPods, iPhones, iPads and AppleTVs. Audio played by a Shairport |
34 |
|
|
Sync-powered device stays synchronised with the source and hence with similar |
35 |
|
|
devices playing the same source. Thus, for example, synchronised multi-room |
36 |
|
|
audio is possible without difficulty. (Hence the name Shairport Sync, BTW.) |
37 |
|
|
|
38 |
|
|
Shairport Sync does not support AirPlay video or photo streaming. |
39 |
|
|
|
40 |
|
|
%prep |
41 |
|
|
%setup -q |
42 |
|
|
|
43 |
|
|
%build |
44 |
|
|
autoreconf -i -f |
45 |
|
|
%configure --with-avahi --with-alsa --with-ssl=openssl --with-soxr \ |
46 |
jpp |
1.2 |
--with-pipe --with-dummy --with-stdout --with-soundio --with-pa --with-metadata --with-systemv --with-libdaemon --with-convolution |
47 |
jpp |
1.1 |
%make_build |
48 |
|
|
|
49 |
|
|
%install |
50 |
|
|
%make_install |
51 |
|
|
rm %{buildroot}/etc/shairport-sync.conf.sample |
52 |
|
|
install -p -m644 -D scripts/shairport-sync.service %{buildroot}%{_unitdir}/%{name}.service |
53 |
|
|
mkdir -p %{buildroot}/%{_sharedstatedir}/%{name} |
54 |
|
|
|
55 |
|
|
%pre |
56 |
|
|
getent group %{name} >/dev/null || groupadd --system %{name} |
57 |
|
|
getent passwd %{name} > /dev/null || useradd --system -c "%{name} User" \ |
58 |
|
|
-d %{_sharedstatedir}/%{name} -g %{name} -s /sbin/nologin \ |
59 |
|
|
-G audio %{name} |
60 |
|
|
exit 0 |
61 |
|
|
|
62 |
|
|
%post |
63 |
|
|
%systemd_post %{name}.service |
64 |
|
|
|
65 |
|
|
%preun |
66 |
|
|
%systemd_preun %{name}.service |
67 |
|
|
|
68 |
|
|
%postun |
69 |
|
|
%systemd_postun_with_restart %{name}.service |
70 |
|
|
|
71 |
|
|
%files |
72 |
|
|
%config(noreplace) /etc/shairport-sync.conf |
73 |
|
|
/usr/bin/shairport-sync |
74 |
|
|
/usr/share/man/man7/shairport-sync.7.gz |
75 |
|
|
%{_unitdir}/%{name}.service |
76 |
|
|
%doc README.md RELEASENOTES.md TROUBLESHOOTING.md |
77 |
|
|
%license LICENSES |
78 |
|
|
%attr(-, %{name}, %{name}) %{_sharedstatedir}/%{name} |
79 |
|
|
|
80 |
|
|
%changelog |
81 |
jpp |
1.2 |
* Sat Apr 25 2020 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.5-1.sme |
82 |
|
|
- first import for SME |
83 |
|
|
- add systemv support |
84 |
|
|
- add --with-convolution |
85 |
|
|
|
86 |
jpp |
1.1 |
* Tue Feb 11 2020 Bill Peck <bpeck@redhat.com> - 3.3.5-0 |
87 |
|
|
- New upstream release |
88 |
|
|
|
89 |
|
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.1-3 |
90 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
91 |
|
|
|
92 |
|
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.1-2 |
93 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
94 |
|
|
|
95 |
|
|
* Thu Jun 20 2019 Bill Peck <bpeck@redhat.com> - 3.3.1-1 |
96 |
|
|
- New upstream release |
97 |
|
|
|
98 |
|
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-2 |
99 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
100 |
|
|
|
101 |
|
|
* Thu Aug 09 2018 Bill Peck <bpeck@redhat.com> - 3.2.1-1 |
102 |
|
|
- New upstream release |
103 |
|
|
|
104 |
|
|
* Tue Jul 24 2018 Adam Williamson <awilliam@redhat.com> - 3.1.7-8 |
105 |
|
|
- Rebuild for new libconfig |
106 |
|
|
|
107 |
|
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.7-7 |
108 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
109 |
|
|
|
110 |
|
|
* Fri Jun 15 2018 Bill Peck <bpeck@redhat.com> 3.1.7-6 |
111 |
|
|
- Include pulseaudio support |
112 |
|
|
|
113 |
|
|
* Mon Feb 19 2018 Bill Peck <bpeck@redhat.com> 3.1.7-5 |
114 |
|
|
- Include gcc and gcc-c++ as BuildRequires now |
115 |
|
|
|
116 |
|
|
* Mon Feb 12 2018 Bill Peck <bpeck@redhat.com> 3.1.7-4 |
117 |
|
|
- Added additional backends, stdout, pipe and dummy |
118 |
|
|
|
119 |
|
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.7-2 |
120 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
121 |
|
|
|
122 |
|
|
* Thu Dec 21 2017 Bill Peck <bpeck@redhat.com> 3.1.7-1 |
123 |
|
|
- New upstream release |
124 |
|
|
- In recent versions of iOS (11.2) and mac OS (10.13.2), when play |
125 |
|
|
is resumed after a pause, the volume level is not always restored, |
126 |
|
|
and, if software volume control is being used, Shairport Sync plays |
127 |
|
|
at full volume. This issue has been addressed by storing the last |
128 |
|
|
airplay volume setting when a play session ends and using it as a |
129 |
|
|
default when a new play session begins. |
130 |
|
|
- Better AirPlay synchronisation. Older versions of Shairport Sync |
131 |
|
|
added an 11,025 frame (0.25 seconds) offset to all the latencies |
132 |
|
|
negotiated with the sender. This seems now only to be correct for |
133 |
|
|
iTunes and ForkedDaapd sources, but incorrect for AirPlay sources. |
134 |
|
|
Accordingly, the offset is only added for iTunes and ForkedDaapd. |
135 |
|
|
The result is better sync with videos, e.g, YouTube, while iTunes |
136 |
|
|
and ForkedDaapd synchronisation is unaffected. |
137 |
|
|
- A bug in the hardware volume control affected output devices that |
138 |
|
|
have hardware mixers but that do not allow the volume to be set in dB. |
139 |
|
|
One example is the Softvol plugin in ALSA. Shairport Sync failed |
140 |
|
|
silently when presented with such a device when hardware volume |
141 |
|
|
control is enabled: the volume events have no effect. The bug has been |
142 |
|
|
fixed by adding two missing lines of code to the init() function in |
143 |
|
|
audio_alsa.c. Thanks to Jakub Nabaglo for finding and fixing the bug. |
144 |
|
|
- A number of bug fixes due to belboj. Many thanks for these! |
145 |
|
|
- Enhancements to the handling of quit requests by threads, thanks(again) to belboj! |
146 |
|
|
* Wed Sep 13 2017 Bill Peck <bpeck@redhat.com> 3.1.2-1 |
147 |
|
|
- New upstream release |
148 |
|
|
- The default value for the alsa setting mute_using_playback_switch has |
149 |
|
|
been changed to "no" for compatability with other audio players on the |
150 |
|
|
same machine. Because of this you may need to unmute your audio device |
151 |
|
|
if you are upgrading from an older release. |
152 |
|
|
- Fixed bugs that made Shairport Sync drop out or become unavailable when |
153 |
|
|
playing YouTube videos, SoundCloud streams etc. from the Mac. |
154 |
|
|
* Sun Aug 20 2017 Bill Peck <bpeck@redhat.com> 3.1.1-1 |
155 |
|
|
- A bug in the sndio backend has been fixed that caused problems on some |
156 |
|
|
versions of Linux. |
157 |
|
|
- A change has been made to how Shairport Sync responds to a TEARDOWN request, |
158 |
|
|
which should make it respond better to sequences of rapid termination and |
159 |
|
|
restarting of play sessions. This can happen, for example, playing YouTube |
160 |
|
|
videos in Safari or Chrome on a Mac. |
161 |
|
|
- Choosing soxr interpolation in the configuration file will now cause |
162 |
|
|
Shairport Sync to terminate with a message if Shairport Sync has not been |
163 |
|
|
compiled with SoX support. |
164 |
|
|
- Other small changes. |
165 |
|
|
* Thu Aug 17 2017 Bill Peck <bpeck@redhat.com> 3.1-1 |
166 |
|
|
- new backend offering synchronised PulseAudio support. |
167 |
|
|
- new optional loudness and convolution filters |
168 |
|
|
- improvements in non-synchronised backends |
169 |
|
|
- enhancements, stability improvements and bug fixes |
170 |
|
|
* Fri Feb 24 2017 Mike Brady <mikebrady@eircom.net> 2.8.6 |
171 |
|
|
- Many changes including 8- 16- 24- and 32-bit output |
172 |
|
|
* Fri Oct 21 2016 Mike Brady <mikebrady@eircom.net> 2.8.6 |
173 |
|
|
- Advertise self as ShairportSync rather than AirPort device 2.8.6 |
174 |
|
|
* Sun Sep 25 2016 Mike Brady <mikebrady@eircom.net> 2.8.5 |
175 |
|
|
- Bug fixes and small enhancements 2.8.5 |
176 |
|
|
* Sat May 28 2016 Mike Brady <mikebrady@eircom.net> 2.8.4 |
177 |
|
|
- Bug fixes and a few small enhancements 2.8.4 |
178 |
|
|
* Fri Apr 15 2016 Mike Brady <mikebrady@eircom.net> 2.8.2 |
179 |
|
|
- Stability improvements, bug fixes and a few special-purpose settings 2.8.2 |
180 |
|
|
* Wed Mar 02 2016 Mike Brady <mikebrady@eircom.net> 2.8.1 |
181 |
|
|
- Stability improvements and important bug fixes 2.8.1 |
182 |
|
|
* Sat Jan 30 2016 Mike Brady <mikebrady@eircom.net> 2.8.0 |
183 |
|
|
- Enhancements and bug fixes 2.8.0 |
184 |
|
|
* Sun Oct 18 2015 Mike Brady <mikebrady@eircom.net> 2.6 |
185 |
|
|
- Important enhancements and bug fixes 2.6 |
186 |
|
|
* Thu Aug 27 2015 Mike Brady <mikebrady@eircom.net> 2.4.1 |
187 |
|
|
- Minor bug fixes 2.4.1 |
188 |
|
|
* Thu Aug 27 2015 Mike Brady <mikebrady@eircom.net> 2.4 |
189 |
|
|
- Prepare for stable release 2.4 |
190 |
|
|
* Wed Aug 26 2015 Mike Brady <mikebrady@eircom.net> 2.3.13.1-1 |
191 |
|
|
- Harmonise release numbers |
192 |
|
|
* Fri Jul 24 2015 Bill Peck <bill@pecknet.com> 2.3.7-1 |
193 |
|
|
- Initial spec file |