1 |
# $Id: smeserver-adv-samba.spec,v 1.1 2021/01/05 06:50:16 brianr Exp $ |
2 |
# Authority: gzartman |
3 |
# Name: Greg Zartman |
4 |
|
5 |
Summary: SME Server specific advanced Samba configuration files and templates |
6 |
%define name smeserver-adv-samba |
7 |
Name: %{name} |
8 |
%define version 0.2.0 |
9 |
%define release 2 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
Group: Networking/Daemons |
14 |
Source: %{name}-%{version}.tar.xz |
15 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
BuildArchitectures: noarch |
17 |
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
Requires: e-smith-samba >= 2.0.0 |
19 |
Requires: e-smith-base >= 5.0.0 |
20 |
Requires: samba-common >= 3.0.25b |
21 |
AutoReqProv: no |
22 |
|
23 |
%changelog |
24 |
* Tue Jan 05 2021 Brian Read <brianr@bjsystems.co.uk> 0.2.0-2.sme |
25 |
- Initial import to SME10 [SME: 11305] |
26 |
|
27 |
* Tue Nov 12 2013 Daniel Berteaud <daniel@firewall-services.com> 0.2.0-1.sme |
28 |
- Rebuild for SME9 |
29 |
|
30 |
* Thu Dec 2 2010 Shad L. Lords <slords@mail.com> 0.1.0-7.sme |
31 |
- Fix logging directory for winbind |
32 |
|
33 |
* Thu Dec 2 2010 Shad L. Lords <slords@mail.com> 0.1.0-6.sme |
34 |
- Reduce requires to samba-common to fix upgrades. |
35 |
|
36 |
* Tue Nov 5 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-5 |
37 |
- Add nsswitch.conf and pam.d/login fragments to workgroup-update |
38 |
templates2expand [SME: 4729]. |
39 |
|
40 |
* Wed Oct 15 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-4 |
41 |
- Update winbindd-service-status action to set service to disabled if |
42 |
service is enabled and ServerRole is changed. |
43 |
|
44 |
* Tue Oct 14 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-3 |
45 |
- Set winbindd to disabled by default and on initial install, was |
46 |
previouslly enabled by default. |
47 |
- Create action to start winbindd if the DM or ADM server roles are designated. |
48 |
|
49 |
* Tue Sep 30 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-2 |
50 |
- Add template fragments to etc/pam.d/login to look for winbindd auth is |
51 |
winbindd is running [SME: 4196]. |
52 |
- Add a template fragment to ibays to set the samba 'force group' |
53 |
parameter to the current ibay group or the group shared when SME is |
54 |
configured as a Domain Member of Active Directory Member. The is required |
55 |
so that domain members can have write access to domain member shares. At |
56 |
some point, we may decide to fully support domain groups transparently |
57 |
at the domain member or active directory member server [SME: 4196]. |
58 |
|
59 |
* Fri Apr 11 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-1 |
60 |
- Roll initial package. |
61 |
- Provide configuration parameters to deploy Samba winbindd deamon. |
62 |
- Add template to nsswitch.conf to configure nss to include winbindd auth. |
63 |
The configuration parameters included in this fragment really belong |
64 |
in e-smith-base, but we are including it in this package until it is |
65 |
deemed appropriate to move it to e-smith-base. |
66 |
|
67 |
%description |
68 |
This package shall serve as a testbed for advanced Samba functions on the |
69 |
SME Server. This package will not conflict with e-smith-samba, but will |
70 |
expand upon it. The PRIMARY design objective of new functions included in |
71 |
this package is to implement them with the intent of including them in the |
72 |
SME Core packages in a "drop in" fashion (i.e., cut and paste). |
73 |
|
74 |
Ever effort will be made to maintain this package for use in a |
75 |
production network. However, certain functions provided by this package |
76 |
could introduce situations that might comprise the stability of |
77 |
the SME Server if not used properly. This is the nature of a testbed. |
78 |
smeserver-adv-samba is to e-smith-samba as Fedora Core is to RHEL. |
79 |
|
80 |
%prep |
81 |
%setup |
82 |
|
83 |
%build |
84 |
perl createlinks |
85 |
|
86 |
# Manage supervise and multilog for winbindd. |
87 |
mkdir -p root/service |
88 |
ln -s ../var/service/winbindd root/service/winbindd |
89 |
mkdir -p root/var/service/winbindd/supervise |
90 |
touch root/var/service/winbindd/down |
91 |
mkdir -p root/var/service/winbindd/log/supervise |
92 |
mkdir -p root/var/log/winbindd |
93 |
|
94 |
%install |
95 |
rm -rf $RPM_BUILD_ROOT |
96 |
|
97 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
98 |
/sbin/e-smith/genfilelist \ |
99 |
--dir '/var/service/winbindd' 'attr(1755,root,root)' \ |
100 |
--file '/var/service/winbindd/down' 'attr(0644,root,root)' \ |
101 |
--file '/var/service/winbindd/run' 'attr(0755,root,root)' \ |
102 |
--dir '/var/service/winbindd/supervise' 'attr(0700,root,root)' \ |
103 |
--dir '/var/service/winbindd/log' 'attr(1755,root,root)' \ |
104 |
--file '/var/service/winbindd/log/run' 'attr(0755,root,root)' \ |
105 |
--dir '/var/log/winbindd' 'attr(2750,smelog,smelog)' \ |
106 |
$RPM_BUILD_ROOT \ |
107 |
> %{name}-%{version}-filelist |
108 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
109 |
|
110 |
%clean |
111 |
rm -rf $RPM_BUILD_ROOT |
112 |
|
113 |
%post |
114 |
chown -R smelog.smelog /var/log/winbindd |
115 |
|
116 |
%files -f %{name}-%{version}-filelist |
117 |
%defattr(-,root,root) |