/[smecontribs]/rpms/smeserver-adv-samba/contribs7/smeserver-adv-samba.spec
ViewVC logotype

Annotation of /rpms/smeserver-adv-samba/contribs7/smeserver-adv-samba.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.11 - (hide annotations) (download)
Tue Mar 3 15:50:17 2009 UTC (15 years, 3 months ago) by slords
Branch: MAIN
Changes since 1.10: +4 -0 lines
Fix spec

1 slords 1.11 # $Id$
2     # Authority: gzartman
3     # Name: Greg Zartman
4    
5 slords 1.1 Summary: SME Server specific advanced Samba configuration files and templates
6     %define name smeserver-adv-samba
7     Name: %{name}
8     %define version 0.1.0
9 gzartman 1.8 %define release 5
10 slords 1.1 Version: %{version}
11     Release: %{release}%{?dist}
12     License: GPL
13     Group: Networking/Daemons
14     Source: %{name}-%{version}.tar.gz
15 gregzartman 1.3 Patch1: smeserver-adv-samba-0.1.0-2.patch
16 gregzartman 1.4 Patch2: smeserver-adv-samba-0.1.0-safe_winbind.patch
17 gregzartman 1.6 Patch3: smeserver-adv-samba-0.1.0-winbind2.patch
18 gzartman 1.8 Patch4: smeserver-adv-samba-0.1.0-auth.patch
19 slords 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
20     BuildArchitectures: noarch
21     BuildRequires: e-smith-devtools >= 1.13.1-03
22 gregzartman 1.4 Requires: e-smith-samba >= 2.0.0
23     Requires: e-smith-base >= 5.0.0
24 slords 1.1 Requires: samba >= 3.0.25b
25     Requires: samba-client >= 3.0.25b
26 gregzartman 1.3 Requires: samba-common >= 3.0.25b
27 slords 1.1 AutoReqProv: no
28    
29     %changelog
30 gzartman 1.8 * Tue Nov 5 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-5
31     - Add nsswitch.conf and pam.d/login fragments to workgroup-update
32     templates2expand [SME: 4729].
33    
34 gregzartman 1.6 * Wed Oct 15 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-4
35     - Update winbindd-service-status action to set service to disabled if
36     service is enabled and ServerRole is changed.
37 gzartman 1.8
38 gregzartman 1.6 * Tue Oct 14 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-3
39 gregzartman 1.4 - Set winbindd to disabled by default and on initial install, was
40     previouslly enabled by default.
41     - Create action to start winbindd if the DM or ADM server roles are designated.
42    
43 gregzartman 1.3 * Tue Sep 30 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-2
44     - Add template fragments to etc/pam.d/login to look for winbindd auth is
45     winbindd is running [SME: 4196].
46     - Add a template fragment to ibays to set the samba 'force group'
47     parameter to the current ibay group or the group shared when SME is
48     configured as a Domain Member of Active Directory Member. The is required
49     so that domain members can have write access to domain member shares. At
50     some point, we may decide to fully support domain groups transparently
51     at the domain member or active directory member server [SME: 4196].
52    
53     * Fri Apr 11 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-1
54 slords 1.1 - Roll initial package.
55     - Provide configuration parameters to deploy Samba winbindd deamon.
56     - Add template to nsswitch.conf to configure nss to include winbindd auth.
57     The configuration parameters included in this fragment really belong
58 gregzartman 1.3 in e-smith-base, but we are including it in this package until it is
59 slords 1.1 deemed appropriate to move it to e-smith-base.
60    
61     %description
62     This package shall serve as a testbed for advanced Samba functions on the
63     SME Server. This package will not conflict with e-smith-samba, but will
64     expand upon it. The PRIMARY design objective of new functions included in
65     this package is to implement them with the intent of including them in the
66     SME Core packages in a "drop in" fashion (i.e., cut and paste).
67    
68     Ever effort will be made to maintain this package for use in a
69     production network. However, certain functions provided by this package
70     could introduce situations that might comprise the stability of
71     the SME Server if not used properly. This is the nature of a testbed.
72     smeserver-adv-samba is to e-smith-samba as Fedora Core is to RHEL.
73    
74     %prep
75     %setup
76 gregzartman 1.3 %patch1 -p1
77 gregzartman 1.4 %patch2 -p1
78 gregzartman 1.6 %patch3 -p1
79 gzartman 1.8 %patch4 -p1
80 dungog 1.7
81 slords 1.1 %build
82     perl createlinks
83    
84     # Manage supervise and multilog for winbindd.
85     mkdir -p root/service
86     ln -s ../var/service/winbindd root/service/winbindd
87     mkdir -p root/var/service/winbindd/supervise
88     touch root/var/service/winbindd/down
89     mkdir -p root/var/service/winbindd/log/supervise
90     mkdir -p root/var/log/winbindd
91    
92     %install
93     rm -rf $RPM_BUILD_ROOT
94 gregzartman 1.4
95 slords 1.1 (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
96     /sbin/e-smith/genfilelist \
97     --dir '/var/service/winbindd' 'attr(1755,root,root)' \
98     --file '/var/service/winbindd/down' 'attr(0644,root,root)' \
99     --file '/var/service/winbindd/run' 'attr(0755,root,root)' \
100     --dir '/var/service/winbindd/supervise' 'attr(0700,root,root)' \
101     --dir '/var/service/winbindd/log' 'attr(1755,root,root)' \
102     --file '/var/service/winbindd/log/run' 'attr(0755,root,root)' \
103     --dir '/var/log/winbindd' 'attr(2750,smelog,smelog)' \
104     $RPM_BUILD_ROOT \
105     > %{name}-%{version}-filelist
106     echo "%doc COPYING" >> %{name}-%{version}-filelist
107    
108     %clean
109     rm -rf $RPM_BUILD_ROOT
110    
111     %post
112     chown -R smelog.smelog /var/log/winbindd
113    
114     %files -f %{name}-%{version}-filelist
115     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed