1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
# Authority: gregzartman |
3 |
|
|
# Name: Greg J. Zartman |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: SME Server specific advanced Samba configuration files and templates |
6 |
|
|
%define name smeserver-adv-samba |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1.0 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
16 |
|
|
BuildArchitectures: noarch |
17 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
18 |
|
|
Requires: e-smith-samba >= 1.14.1-6 |
19 |
|
|
Requires: samba >= 3.0.25b |
20 |
|
|
Requires: samba-client >= 3.0.25b |
21 |
|
|
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
|
|
* Fri Apr 11 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0 |
25 |
|
|
- Roll initial package. |
26 |
|
|
- Provide configuration parameters to deploy Samba winbindd deamon. |
27 |
|
|
- Add template to nsswitch.conf to configure nss to include winbindd auth. |
28 |
|
|
The configuration parameters included in this fragment really belong |
29 |
|
|
in e-smith-base, but we are including it in this package until it it |
30 |
|
|
deemed appropriate to move it to e-smith-base. |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
This package shall serve as a testbed for advanced Samba functions on the |
34 |
|
|
SME Server. This package will not conflict with e-smith-samba, but will |
35 |
|
|
expand upon it. The PRIMARY design objective of new functions included in |
36 |
|
|
this package is to implement them with the intent of including them in the |
37 |
|
|
SME Core packages in a "drop in" fashion (i.e., cut and paste). |
38 |
|
|
|
39 |
|
|
Ever effort will be made to maintain this package for use in a |
40 |
|
|
production network. However, certain functions provided by this package |
41 |
|
|
could introduce situations that might comprise the stability of |
42 |
|
|
the SME Server if not used properly. This is the nature of a testbed. |
43 |
|
|
smeserver-adv-samba is to e-smith-samba as Fedora Core is to RHEL. |
44 |
|
|
|
45 |
|
|
%prep |
46 |
|
|
%setup |
47 |
|
|
|
48 |
|
|
%build |
49 |
|
|
mkdir -p root/etc/e-smith/tests |
50 |
|
|
perl createlinks |
51 |
|
|
|
52 |
|
|
# Manage supervise and multilog for winbindd. |
53 |
|
|
mkdir -p root/service |
54 |
|
|
ln -s ../var/service/winbindd root/service/winbindd |
55 |
|
|
mkdir -p root/var/service/winbindd/supervise |
56 |
|
|
touch root/var/service/winbindd/down |
57 |
|
|
mkdir -p root/var/service/winbindd/log/supervise |
58 |
|
|
mkdir -p root/var/log/winbindd |
59 |
|
|
|
60 |
|
|
# Make storage point for shadowcopies |
61 |
|
|
mkdir -p root/home/e-smith/files/.shadow |
62 |
|
|
|
63 |
|
|
%install |
64 |
|
|
rm -rf $RPM_BUILD_ROOT |
65 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
66 |
|
|
/sbin/e-smith/genfilelist \ |
67 |
|
|
--dir '/var/service/winbindd' 'attr(1755,root,root)' \ |
68 |
|
|
--file '/var/service/winbindd/down' 'attr(0644,root,root)' \ |
69 |
|
|
--file '/var/service/winbindd/run' 'attr(0755,root,root)' \ |
70 |
|
|
--dir '/var/service/winbindd/supervise' 'attr(0700,root,root)' \ |
71 |
|
|
--dir '/var/service/winbindd/log' 'attr(1755,root,root)' \ |
72 |
|
|
--file '/var/service/winbindd/log/run' 'attr(0755,root,root)' \ |
73 |
|
|
--dir '/var/log/winbindd' 'attr(2750,smelog,smelog)' \ |
74 |
|
|
$RPM_BUILD_ROOT \ |
75 |
|
|
> %{name}-%{version}-filelist |
76 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
77 |
|
|
|
78 |
|
|
%clean |
79 |
|
|
rm -rf $RPM_BUILD_ROOT |
80 |
|
|
|
81 |
|
|
%post |
82 |
|
|
chown -R smelog.smelog /var/log/winbindd |
83 |
|
|
|
84 |
|
|
%files -f %{name}-%{version}-filelist |
85 |
|
|
%defattr(-,root,root) |