1 |
slords |
1.1 |
Summary: SME Server specific advanced Samba configuration files and templates |
2 |
|
|
%define name smeserver-adv-samba |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 0.1.0 |
5 |
gregzartman |
1.5 |
%define release 3 |
6 |
slords |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: GPL |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
Source: %{name}-%{version}.tar.gz |
11 |
gregzartman |
1.3 |
Patch1: smeserver-adv-samba-0.1.0-2.patch |
12 |
gregzartman |
1.4 |
Patch2: smeserver-adv-samba-0.1.0-safe_winbind.patch |
13 |
slords |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
14 |
|
|
BuildArchitectures: noarch |
15 |
|
|
BuildRequires: e-smith-devtools >= 1.13.1-03 |
16 |
gregzartman |
1.4 |
Requires: e-smith-samba >= 2.0.0 |
17 |
|
|
Requires: e-smith-base >= 5.0.0 |
18 |
slords |
1.1 |
Requires: samba >= 3.0.25b |
19 |
|
|
Requires: samba-client >= 3.0.25b |
20 |
gregzartman |
1.3 |
Requires: samba-common >= 3.0.25b |
21 |
slords |
1.1 |
AutoReqProv: no |
22 |
|
|
|
23 |
|
|
%changelog |
24 |
gregzartman |
1.4 |
* Tue Oct 15 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-3 |
25 |
|
|
- Set winbindd to disabled by default and on initial install, was |
26 |
|
|
previouslly enabled by default. |
27 |
|
|
- Create action to start winbindd if the DM or ADM server roles are designated. |
28 |
|
|
|
29 |
gregzartman |
1.3 |
* Tue Sep 30 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-2 |
30 |
|
|
- Add template fragments to etc/pam.d/login to look for winbindd auth is |
31 |
|
|
winbindd is running [SME: 4196]. |
32 |
|
|
- Add a template fragment to ibays to set the samba 'force group' |
33 |
|
|
parameter to the current ibay group or the group shared when SME is |
34 |
|
|
configured as a Domain Member of Active Directory Member. The is required |
35 |
|
|
so that domain members can have write access to domain member shares. At |
36 |
|
|
some point, we may decide to fully support domain groups transparently |
37 |
|
|
at the domain member or active directory member server [SME: 4196]. |
38 |
|
|
|
39 |
|
|
* Fri Apr 11 2008 Greg J. Zartman <greg@leiinc.com> 0.1.0-1 |
40 |
slords |
1.1 |
- Roll initial package. |
41 |
|
|
- Provide configuration parameters to deploy Samba winbindd deamon. |
42 |
|
|
- Add template to nsswitch.conf to configure nss to include winbindd auth. |
43 |
|
|
The configuration parameters included in this fragment really belong |
44 |
gregzartman |
1.3 |
in e-smith-base, but we are including it in this package until it is |
45 |
slords |
1.1 |
deemed appropriate to move it to e-smith-base. |
46 |
|
|
|
47 |
|
|
%description |
48 |
|
|
This package shall serve as a testbed for advanced Samba functions on the |
49 |
|
|
SME Server. This package will not conflict with e-smith-samba, but will |
50 |
|
|
expand upon it. The PRIMARY design objective of new functions included in |
51 |
|
|
this package is to implement them with the intent of including them in the |
52 |
|
|
SME Core packages in a "drop in" fashion (i.e., cut and paste). |
53 |
|
|
|
54 |
|
|
Ever effort will be made to maintain this package for use in a |
55 |
|
|
production network. However, certain functions provided by this package |
56 |
|
|
could introduce situations that might comprise the stability of |
57 |
|
|
the SME Server if not used properly. This is the nature of a testbed. |
58 |
|
|
smeserver-adv-samba is to e-smith-samba as Fedora Core is to RHEL. |
59 |
|
|
|
60 |
|
|
%prep |
61 |
|
|
%setup |
62 |
gregzartman |
1.3 |
%patch1 -p1 |
63 |
gregzartman |
1.4 |
%patch2 -p1 |
64 |
slords |
1.1 |
|
65 |
|
|
%build |
66 |
|
|
mkdir -p root/etc/e-smith/tests |
67 |
|
|
perl createlinks |
68 |
|
|
|
69 |
|
|
# Manage supervise and multilog for winbindd. |
70 |
|
|
mkdir -p root/service |
71 |
|
|
ln -s ../var/service/winbindd root/service/winbindd |
72 |
|
|
mkdir -p root/var/service/winbindd/supervise |
73 |
|
|
touch root/var/service/winbindd/down |
74 |
|
|
mkdir -p root/var/service/winbindd/log/supervise |
75 |
|
|
mkdir -p root/var/log/winbindd |
76 |
|
|
|
77 |
|
|
# Make storage point for shadowcopies |
78 |
|
|
mkdir -p root/home/e-smith/files/.shadow |
79 |
|
|
|
80 |
|
|
%install |
81 |
|
|
rm -rf $RPM_BUILD_ROOT |
82 |
gregzartman |
1.4 |
|
83 |
slords |
1.1 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
84 |
|
|
/sbin/e-smith/genfilelist \ |
85 |
|
|
--dir '/var/service/winbindd' 'attr(1755,root,root)' \ |
86 |
|
|
--file '/var/service/winbindd/down' 'attr(0644,root,root)' \ |
87 |
|
|
--file '/var/service/winbindd/run' 'attr(0755,root,root)' \ |
88 |
|
|
--dir '/var/service/winbindd/supervise' 'attr(0700,root,root)' \ |
89 |
|
|
--dir '/var/service/winbindd/log' 'attr(1755,root,root)' \ |
90 |
|
|
--file '/var/service/winbindd/log/run' 'attr(0755,root,root)' \ |
91 |
|
|
--dir '/var/log/winbindd' 'attr(2750,smelog,smelog)' \ |
92 |
|
|
$RPM_BUILD_ROOT \ |
93 |
|
|
> %{name}-%{version}-filelist |
94 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
95 |
|
|
|
96 |
|
|
%clean |
97 |
|
|
rm -rf $RPM_BUILD_ROOT |
98 |
|
|
|
99 |
|
|
%post |
100 |
|
|
chown -R smelog.smelog /var/log/winbindd |
101 |
|
|
|
102 |
|
|
%files -f %{name}-%{version}-filelist |
103 |
|
|
%defattr(-,root,root) |