/[smecontribs]/rpms/smeserver-affa/contribs10/smeserver-affa.spec
ViewVC logotype

Annotation of /rpms/smeserver-affa/contribs10/smeserver-affa.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Oct 7 09:57:10 2020 UTC (3 years, 7 months ago) by brianr
Branch: MAIN
Initial import

1 brianr 1.1 Summary: A rsync-based backup program for linux, adapted to sme server 8-9
2     %define name smeserver-affa
3     Name: %{name}
4     %define version 3.2.2.3
5     %define release 8
6     Version: %{version}
7     Release: %{release}%{?dist}
8     Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu>
9     License: GNU General Public License
10     Group: Applications/Archiving
11     Source: %{name}-%{version}.tar.gz
12     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
13     BuildArch: noarch
14     AutoReq: no
15    
16     Requires: openssh-clients
17     Requires: perl-Config-IniFiles
18     Requires: perl-Filesys-DiskFree
19     Requires: perl-MailTools
20     Requires: perl-Proc-ProcessTable
21     Requires: perl-TimeDate
22     Requires: rsync
23    
24     Patch1: smeserver-affa-fix-typo.patch
25     Patch2: smeserver-affa-fix-rise_RPMCheck_smb_diskusage.patch
26     Patch3: smeserver-affa-fix-ssh-port.patch
27     Patch4: smeserver-affa-fix-blanks-conf.patch
28     Patch5: smeserver-affa-fix-imapfiles-find.patch
29     Patch6: smeserver-affa-fix-show-schedule.patch
30    
31     %description
32     Affa is a rsync-based backup program
33     Documentation: http://affa.sf.net
34     with SMEServer + RPMCheck + Watchdog + rise
35    
36     %prep
37     %setup -q -n %{name}-%{version}
38     %patch1 -p1
39     %patch2 -p1
40     %patch3 -p1
41     %patch4 -p1
42     %patch5 -p1
43     %patch6 -p1
44    
45     %build
46    
47     %install
48     rm -rf $RPM_BUILD_ROOT
49     rm -f %{name}-%{version}-filelist
50     (cd root ;find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
51    
52    
53     # Set version String
54     cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp
55     VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'`
56     sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa
57     rm -f $RPM_BUILD_ROOT/sbin/affa.tmp
58    
59     rm -f %{name}-%{version}-filelist
60    
61     find $RPM_BUILD_ROOT -depth -type f -print |\
62     sed -e "s@^$RPM_BUILD_ROOT@@g" \
63     -e "s@^/sbin/@%attr(0750,root,root) &@"\
64     -e "s@^/etc/profile.d/@%attr(0555,root,root) &@"\
65     -e "s@^/etc/sudoers.d/@%attr(0440,root,root) &@"\
66     -e "s@^/etc/cron.d/@%attr(0444,root,root)%config(noreplace) &@"\
67     -e "s@^/usr/lib/affa/LICENSE@%attr(0444,root,root) &@"\
68     -e "s@^/usr/lib/affa/WARRANTY@%attr(0444,root,root) &@"\
69     -e "s@^/usr/man/man1/@%attr(0444,root,root) &@"\
70     -e "s@^/etc/affa/scripts/@%attr(0750,root,root)%config(noreplace) &@"\
71     -e "s@^/etc/affa/@%attr(0640,root,root)%config(noreplace) &@"\
72     >> %{name}-%{version}-filelist
73    
74    
75     find $RPM_BUILD_ROOT -depth -type d -print |\
76     sed -e "s@^$RPM_BUILD_ROOT@%dir @g" >> %{name}-%{version}-filelist
77    
78     find $RPM_BUILD_ROOT -depth -type l -print |\
79     sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist
80    
81     %clean
82     rm -rf $RPM_BUILD_ROOT
83    
84     %files -f %{name}-%{version}-filelist
85     %defattr(-,root,root)
86    
87     %pre
88     exit 0
89    
90     %post
91     exit 0
92    
93     %preun
94     exit 0
95    
96     %postun
97     exit 0
98    
99     %changelog
100     * Mon Apr 10 2017 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-8.sme
101     - Fix issue when multiple times are in an Affa configuration file, show-schedule only displays the last [SME: 10196]
102    
103     * Wed Nov 23 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-7.sme
104     - Fix find command error in delete imap dovecot files [SME: 9874]
105    
106     * Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-6.sme
107     - Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449]
108    
109     * Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-5.sme
110     - Fix ssh port [SME: 8904]
111     - Modify changelog number to track define release number
112    
113     * Wed Mar 23 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-4.sme
114     - Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139]
115     - Fix "RPMCheck" not working [SME: 9270]
116     - Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298]
117     - Fix affa --diskusage does not umount attached storage [SME: 9147]
118    
119     * Mon Feb 29 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-3.sme
120     - Fix typos in config files [SME: 9094]
121    
122     * Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme
123     - Initial release to contribs9
124    
125     * Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1
126     - fixed column ExecTime shift
127     - Adjusted column indices in report
128     - Fixed typo in remoteHostName [SME: 9062]
129     - Code done by mats schuh <m.schuh@neckargeo.net>
130    
131     * Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1
132     - Added TotalBytesSent to archive reports and fixed report layout
133    
134     * Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2
135     - integration of the patch of Mats Schuh in order to enable check for external disk label before unmount
136     * Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1
137     - adapted to the new release of rsync (bug by calculating the number and the size of the transfered files)
138     * Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0
139     - first adaptation for sme server8
140     * Sun Mar 04 2012 Michael Weinberger 3.2.2
141     - Improved NRPE and sudoers config
142     - Fixed bug in DiskUsageRaw()
143     - Added NRPE command affa_diskusagenrpe
144     * Fri Mar 02 2012 Michael Weinberger 3.2.1
145     - Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg
146     * Thu Mar 01 2012 Michael Weinberger 3.2.0
147     - Bugfix: remoteRsyncBinary and localRsyncBinary was not used
148     * Sun Feb 26 2012 Michael Weinberger 3.1.7
149     - Bugfixes in showSchedule()
150     * Sun Feb 26 2012 Michael Weinberger 3.1.6
151     - added ICINGA/Nagios auto-configuration
152     * Fri Feb 24 2012 Michael Weinberger 3.1.4
153     - do not show Dedup interrupted in --status after the very first run
154     - improved --nrpe function
155     - added script yum_install_packages.sh
156     * Tue Oct 11 2011 Michael Weinberger 3.1.3
157     - MINOR IMPROVEMENTS
158     --send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist
159     --log-tail: show last rotated if current log is empty or too short
160     --check-conncetions: allow jobs as arguments
161     * Sun Aug 29 2011 Michael Weinberger 3.1.2
162     - Bugfix: postJobCommand and postJobCommandRemote were not executed
163     * Sat Aug 13 2011 Michael Weinberger 3.1.1
164     - process state 'rsync interrupted' and 'dedup interrupted'
165     - --resume-interrupted
166     - resume interrupted jobs after server boot
167     * Sun Aug 07 2011 Michael Weinberger 3.1.0-1
168     - introduced status 'interrupted'(with --status)
169     * Fri Aug 05 2011 Michael Weinberger 3.1.0-0
170     - Release of 3.1.0
171     * Thu Aug 04 2011 Michael Weinberger 3.0.2-14
172     - de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run
173     - removed Command arg from sample scripts
174     - Fixed: Concatenated config in /tmp was world readable
175     - De-duplication info added to --show-schedule
176     * Tue Aug 02 2011 Michael Weinberger 3.0.2-6
177     - De-Duplication (freedup)
178     - De-Dup info in --status and --list-archives
179     - --status: only show enabled jobs. All with --all
180     - Fix: property globalStatus was not working
181     - Running state rsync or de-deduplicating display in --status
182     - Show de-deduplicating busy in --list-archives for scheduled.0
183     - new property dedupKill. When set no, --kill does not kill a job when de-duplicating
184     - new option --show-property
185    
186     * Wed Jul 27 2011 Michael Weinberger 3.0.1-7
187     - Bug fixes: RemoteUser was not always used in ssh commands
188    
189     * Sun Jul 24 2011 Michael Weinberger 3.0.1-6
190     - fixed bug in affa --status
191     - GlobalAffaConfig was mounted as Samba share
192     - call setupSamba() only in cronSetup()
193     - updated man
194    
195     * Sat Jul 23 2011 Michael Weinberger 3.0.1-5
196     - new key NRPEtrigger
197     - full affa path required when starting re-run from cronjob
198     - improved deletion of shift out archives, --delete-job and --cleanup
199     - added --single-transaction to /etc/affa/scripts/mysql-dump-tables
200    
201     * Wed Jul 20 2011 Michael Weinberger 3.0.0-0
202     - generic linux version made from Affa 2.0 (SME Version)
203    
204     * Mon Apr 02 2007 Michael Weinberger
205     - bash version re-written in Perl
206    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed