1 |
jcrisp |
1.2 |
Summary: A rsync-based backup program for linux, adapted to Koozali SME server 10 |
2 |
brianr |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
jcrisp |
1.3 |
%define version 3.3.1 |
5 |
jcrisp |
1.11 |
%define release 9 |
6 |
brianr |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
|
|
License: GNU General Public License |
10 |
|
|
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
jcrisp |
1.2 |
BuildRequires: e-smith-devtools |
15 |
|
|
|
16 |
brianr |
1.1 |
AutoReq: no |
17 |
|
|
|
18 |
jcrisp |
1.2 |
Requires: e-smith-release >= 10 |
19 |
jcrisp |
1.4 |
Requires: smeserver-systemd-control |
20 |
brianr |
1.1 |
Requires: openssh-clients |
21 |
|
|
Requires: perl-Config-IniFiles |
22 |
|
|
Requires: perl-Filesys-DiskFree |
23 |
|
|
Requires: perl-MailTools |
24 |
|
|
Requires: perl-Proc-ProcessTable |
25 |
|
|
Requires: perl-TimeDate |
26 |
jcrisp |
1.2 |
Requires: perl-List-MoreUtils |
27 |
brianr |
1.1 |
Requires: rsync |
28 |
|
|
|
29 |
jcrisp |
1.4 |
Patch1: smeserver-affa-add-some-systemd-support.patch |
30 |
jcrisp |
1.5 |
Patch2: smeserver-affa-change-host-domain.patch |
31 |
jcrisp |
1.6 |
Patch3: smeserver-affa-change_to_rsa_keys.patch |
32 |
jcrisp |
1.7 |
Patch4: smeserver-affa-update-ssh-keys-links.patch |
33 |
jcrisp |
1.8 |
Patch5: smeserver-affa-fix-config-directory-name-spaces.patch |
34 |
jcrisp |
1.9 |
Patch6: smeserver-affa-fix-reporting-error.patch |
35 |
jcrisp |
1.10 |
Patch7: smeserver-affa-fix-ssh-knownhosts-error.patch |
36 |
jcrisp |
1.11 |
Patch8: smeserver-affa-fix-reporting-error-syntax.patch |
37 |
brianr |
1.1 |
|
38 |
|
|
%description |
39 |
jcrisp |
1.2 |
Affa is a rsync-based backup program for SMEServer + RPMCheck + Watchdog + rise. Documentation: http://affa.sf.net |
40 |
brianr |
1.1 |
|
41 |
|
|
%prep |
42 |
jcrisp |
1.2 |
rm -rf $RPM_BUILD_ROOT |
43 |
|
|
|
44 |
brianr |
1.1 |
%setup -q -n %{name}-%{version} |
45 |
jcrisp |
1.4 |
%patch1 -p1 |
46 |
jcrisp |
1.5 |
%patch2 -p1 |
47 |
jcrisp |
1.6 |
%patch3 -p1 |
48 |
jcrisp |
1.7 |
%patch4 -p1 |
49 |
jcrisp |
1.8 |
%patch5 -p1 |
50 |
jcrisp |
1.9 |
%patch6 -p1 |
51 |
jcrisp |
1.10 |
%patch7 -p1 |
52 |
jcrisp |
1.11 |
%patch8 -p1 |
53 |
jcrisp |
1.9 |
|
54 |
brianr |
1.1 |
|
55 |
|
|
%build |
56 |
jcrisp |
1.2 |
# perl createlinks << if required |
57 |
|
|
find . \( -name .gitinclude -o -name .gitignore \) -print0 | \ |
58 |
|
|
xargs -0 rm -f |
59 |
brianr |
1.1 |
|
60 |
|
|
%install |
61 |
|
|
|
62 |
jcrisp |
1.2 |
/bin/rm -rf $RPM_BUILD_ROOT |
63 |
|
|
(cd root ;/usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
64 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
65 |
brianr |
1.1 |
|
66 |
|
|
# Set version String |
67 |
|
|
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
68 |
|
|
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
69 |
|
|
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
70 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
71 |
|
|
|
72 |
jcrisp |
1.2 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
73 |
|
|
--ignoredir "/etc/sudoers.d" \ |
74 |
|
|
--ignoredir "/etc/profile.d" \ |
75 |
|
|
--file "/etc/profile.d/affa.sh" "attr(0555,root,root)" \ |
76 |
|
|
--file "/etc/sudoers.d/affa" "attr(0440,root,root)" \ |
77 |
|
|
> %{name}-%{version}-filelist |
78 |
brianr |
1.1 |
|
79 |
jcrisp |
1.2 |
# We could use this for docs I guess - we should standardise this sort of thing |
80 |
|
|
#%doc README LICENSE README |
81 |
jcrisp |
1.3 |
echo "%doc LICENSE COPYING README WARRANTY" >> %{name}-%{version}-filelist |
82 |
|
|
|
83 |
|
|
|
84 |
|
|
|
85 |
|
|
%files -f %{name}-%{version}-filelist |
86 |
brianr |
1.1 |
|
87 |
|
|
%clean |
88 |
|
|
rm -rf $RPM_BUILD_ROOT |
89 |
|
|
|
90 |
|
|
%pre |
91 |
|
|
exit 0 |
92 |
|
|
|
93 |
|
|
%post |
94 |
|
|
exit 0 |
95 |
|
|
|
96 |
|
|
%preun |
97 |
|
|
exit 0 |
98 |
|
|
|
99 |
|
|
%postun |
100 |
|
|
exit 0 |
101 |
|
|
|
102 |
|
|
%changelog |
103 |
jcrisp |
1.11 |
* Mon Jul 04 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-9 |
104 |
|
|
- Fix my syntax errors from [SME: 11784] |
105 |
|
|
|
106 |
jcrisp |
1.10 |
* Thu Jun 30 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-8 |
107 |
|
|
- Fix KnownHosts error [SME: 12081] |
108 |
|
|
- Thanks to 'gieres' for finding this |
109 |
|
|
|
110 |
jcrisp |
1.9 |
* Thu Jun 30 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-7 |
111 |
|
|
- Fix logging parse errors [SME:12084] |
112 |
|
|
- Thanks to 'sti' for finding it |
113 |
|
|
|
114 |
jcrisp |
1.8 |
* Thu Jun 30 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-6 |
115 |
|
|
- Fix error with files with spaces in names - Credit to Trevor Drake-Brockman [SME: 11784] |
116 |
|
|
- Fix directory search - Credit to Trevor Drake-Brockman [SME: 11784] |
117 |
|
|
|
118 |
jcrisp |
1.7 |
* Wed Sep 22 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-5 |
119 |
|
|
- Modify ssh key links [SME: 10783] |
120 |
|
|
- Untidy the ssh commands so I can see them and tidy them more easily |
121 |
|
|
|
122 |
jcrisp |
1.6 |
* Wed Sep 22 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-4 |
123 |
|
|
- Change ssh keys from DSA to RSA 4096 [SME: 10783] |
124 |
|
|
- Fix missing /var/affa store dir |
125 |
|
|
|
126 |
jcrisp |
1.5 |
* Tue Sep 21 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-3.sme |
127 |
|
|
- Fix some syntax errors. Migrate to using HostName/DomainName |
128 |
|
|
|
129 |
jcrisp |
1.4 |
* Tue Sep 21 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-2.sme |
130 |
|
|
- Add some systemd support [SME: 11024] |
131 |
|
|
|
132 |
jcrisp |
1.3 |
* Mon Mar 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-1.sme |
133 |
|
|
- Fix Warranty [SME: 11500] |
134 |
|
|
- Fix Licence [SME: 11501] |
135 |
|
|
- Remove atalk [SME: 11503] |
136 |
|
|
|
137 |
|
|
* Tue Mar 23 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.0-1.sme |
138 |
jcrisp |
1.2 |
- New version for Koozali SME v10 [SME: 11024] |
139 |
|
|
- incorporated old patches |
140 |
|
|
- tidied up some old git files |
141 |
|
|
- Very Alpha - see bug for details |
142 |
|
|
|
143 |
brianr |
1.1 |
* Mon Apr 10 2017 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-8.sme |
144 |
|
|
- Fix issue when multiple times are in an Affa configuration file, show-schedule only displays the last [SME: 10196] |
145 |
|
|
|
146 |
|
|
* Wed Nov 23 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-7.sme |
147 |
|
|
- Fix find command error in delete imap dovecot files [SME: 9874] |
148 |
|
|
|
149 |
|
|
* Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-6.sme |
150 |
|
|
- Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449] |
151 |
|
|
|
152 |
|
|
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-5.sme |
153 |
|
|
- Fix ssh port [SME: 8904] |
154 |
|
|
- Modify changelog number to track define release number |
155 |
|
|
|
156 |
|
|
* Wed Mar 23 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-4.sme |
157 |
|
|
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
158 |
|
|
- Fix "RPMCheck" not working [SME: 9270] |
159 |
|
|
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
160 |
|
|
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
161 |
|
|
|
162 |
|
|
* Mon Feb 29 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-3.sme |
163 |
|
|
- Fix typos in config files [SME: 9094] |
164 |
|
|
|
165 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
166 |
|
|
- Initial release to contribs9 |
167 |
|
|
|
168 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
169 |
|
|
- fixed column ExecTime shift |
170 |
|
|
- Adjusted column indices in report |
171 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
172 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
173 |
|
|
|
174 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
175 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
176 |
|
|
|
177 |
|
|
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
178 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
179 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
180 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
181 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
182 |
|
|
- first adaptation for sme server8 |
183 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
184 |
|
|
- Improved NRPE and sudoers config |
185 |
|
|
- Fixed bug in DiskUsageRaw() |
186 |
|
|
- Added NRPE command affa_diskusagenrpe |
187 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
188 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
189 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
190 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
191 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
192 |
|
|
- Bugfixes in showSchedule() |
193 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
194 |
|
|
- added ICINGA/Nagios auto-configuration |
195 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
196 |
|
|
- do not show Dedup interrupted in --status after the very first run |
197 |
|
|
- improved --nrpe function |
198 |
|
|
- added script yum_install_packages.sh |
199 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
200 |
|
|
- MINOR IMPROVEMENTS |
201 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
202 |
|
|
--log-tail: show last rotated if current log is empty or too short |
203 |
|
|
--check-conncetions: allow jobs as arguments |
204 |
jcrisp |
1.2 |
* Mon Aug 29 2011 Michael Weinberger 3.1.2 |
205 |
brianr |
1.1 |
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
206 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
207 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
208 |
|
|
- --resume-interrupted |
209 |
|
|
- resume interrupted jobs after server boot |
210 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
211 |
|
|
- introduced status 'interrupted'(with --status) |
212 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
213 |
|
|
- Release of 3.1.0 |
214 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
215 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
216 |
|
|
- removed Command arg from sample scripts |
217 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
218 |
|
|
- De-duplication info added to --show-schedule |
219 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
220 |
|
|
- De-Duplication (freedup) |
221 |
|
|
- De-Dup info in --status and --list-archives |
222 |
|
|
- --status: only show enabled jobs. All with --all |
223 |
|
|
- Fix: property globalStatus was not working |
224 |
|
|
- Running state rsync or de-deduplicating display in --status |
225 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
226 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
227 |
|
|
- new option --show-property |
228 |
|
|
|
229 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
230 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
231 |
|
|
|
232 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
233 |
|
|
- fixed bug in affa --status |
234 |
|
|
- GlobalAffaConfig was mounted as Samba share |
235 |
|
|
- call setupSamba() only in cronSetup() |
236 |
|
|
- updated man |
237 |
|
|
|
238 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
239 |
|
|
- new key NRPEtrigger |
240 |
|
|
- full affa path required when starting re-run from cronjob |
241 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
242 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
243 |
|
|
|
244 |
|
|
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
245 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
246 |
|
|
|
247 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
248 |
|
|
- bash version re-written in Perl |
249 |
|
|
|