1 |
jcrisp |
1.2 |
Summary: A rsync-based backup program for linux, adapted to Koozali SME server 10 |
2 |
brianr |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
jcrisp |
1.2 |
%define version 3.3.0 |
5 |
|
|
%define release 1 |
6 |
brianr |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
|
|
License: GNU General Public License |
10 |
|
|
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
jcrisp |
1.2 |
BuildRequires: e-smith-devtools |
15 |
|
|
|
16 |
brianr |
1.1 |
AutoReq: no |
17 |
|
|
|
18 |
jcrisp |
1.2 |
Requires: e-smith-release >= 10 |
19 |
brianr |
1.1 |
Requires: openssh-clients |
20 |
|
|
Requires: perl-Config-IniFiles |
21 |
|
|
Requires: perl-Filesys-DiskFree |
22 |
|
|
Requires: perl-MailTools |
23 |
|
|
Requires: perl-Proc-ProcessTable |
24 |
|
|
Requires: perl-TimeDate |
25 |
jcrisp |
1.2 |
Requires: perl-List-MoreUtils |
26 |
brianr |
1.1 |
Requires: rsync |
27 |
|
|
|
28 |
jcrisp |
1.2 |
#Patch1: smeserver-affa-something.patch |
29 |
brianr |
1.1 |
|
30 |
|
|
%description |
31 |
jcrisp |
1.2 |
Affa is a rsync-based backup program for SMEServer + RPMCheck + Watchdog + rise. Documentation: http://affa.sf.net |
32 |
brianr |
1.1 |
|
33 |
|
|
%prep |
34 |
jcrisp |
1.2 |
rm -rf $RPM_BUILD_ROOT |
35 |
|
|
|
36 |
brianr |
1.1 |
%setup -q -n %{name}-%{version} |
37 |
jcrisp |
1.2 |
#%patch1 -p1 |
38 |
brianr |
1.1 |
|
39 |
|
|
%build |
40 |
jcrisp |
1.2 |
# perl createlinks << if required |
41 |
|
|
find . \( -name .gitinclude -o -name .gitignore \) -print0 | \ |
42 |
|
|
xargs -0 rm -f |
43 |
brianr |
1.1 |
|
44 |
|
|
%install |
45 |
|
|
|
46 |
jcrisp |
1.2 |
/bin/rm -rf $RPM_BUILD_ROOT |
47 |
|
|
(cd root ;/usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
48 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
49 |
brianr |
1.1 |
|
50 |
|
|
# Set version String |
51 |
|
|
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
52 |
|
|
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
53 |
|
|
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
54 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
55 |
|
|
|
56 |
jcrisp |
1.2 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
57 |
|
|
--ignoredir "/etc/sudoers.d" \ |
58 |
|
|
--ignoredir "/etc/profile.d" \ |
59 |
|
|
--file "/etc/profile.d/affa.sh" "attr(0555,root,root)" \ |
60 |
|
|
--file "/etc/sudoers.d/affa" "attr(0440,root,root)" \ |
61 |
|
|
> %{name}-%{version}-filelist |
62 |
brianr |
1.1 |
|
63 |
jcrisp |
1.2 |
%files -f %{name}-%{version}-filelist |
64 |
brianr |
1.1 |
|
65 |
jcrisp |
1.2 |
# We could use this for docs I guess - we should standardise this sort of thing |
66 |
|
|
#%doc README LICENSE README |
67 |
brianr |
1.1 |
|
68 |
|
|
%clean |
69 |
|
|
rm -rf $RPM_BUILD_ROOT |
70 |
|
|
|
71 |
|
|
%pre |
72 |
|
|
exit 0 |
73 |
|
|
|
74 |
|
|
%post |
75 |
|
|
exit 0 |
76 |
|
|
|
77 |
|
|
%preun |
78 |
|
|
exit 0 |
79 |
|
|
|
80 |
|
|
%postun |
81 |
|
|
exit 0 |
82 |
|
|
|
83 |
|
|
%changelog |
84 |
jcrisp |
1.2 |
* Tue Mar 23 2020 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.0-1.sme |
85 |
|
|
- New version for Koozali SME v10 [SME: 11024] |
86 |
|
|
- incorporated old patches |
87 |
|
|
- tidied up some old git files |
88 |
|
|
- Very Alpha - see bug for details |
89 |
|
|
|
90 |
brianr |
1.1 |
* Mon Apr 10 2017 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-8.sme |
91 |
|
|
- Fix issue when multiple times are in an Affa configuration file, show-schedule only displays the last [SME: 10196] |
92 |
|
|
|
93 |
|
|
* Wed Nov 23 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-7.sme |
94 |
|
|
- Fix find command error in delete imap dovecot files [SME: 9874] |
95 |
|
|
|
96 |
|
|
* Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-6.sme |
97 |
|
|
- Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449] |
98 |
|
|
|
99 |
|
|
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-5.sme |
100 |
|
|
- Fix ssh port [SME: 8904] |
101 |
|
|
- Modify changelog number to track define release number |
102 |
|
|
|
103 |
|
|
* Wed Mar 23 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-4.sme |
104 |
|
|
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
105 |
|
|
- Fix "RPMCheck" not working [SME: 9270] |
106 |
|
|
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
107 |
|
|
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
108 |
|
|
|
109 |
|
|
* Mon Feb 29 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-3.sme |
110 |
|
|
- Fix typos in config files [SME: 9094] |
111 |
|
|
|
112 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
113 |
|
|
- Initial release to contribs9 |
114 |
|
|
|
115 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
116 |
|
|
- fixed column ExecTime shift |
117 |
|
|
- Adjusted column indices in report |
118 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
119 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
120 |
|
|
|
121 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
122 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
123 |
|
|
|
124 |
|
|
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
125 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
126 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
127 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
128 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
129 |
|
|
- first adaptation for sme server8 |
130 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
131 |
|
|
- Improved NRPE and sudoers config |
132 |
|
|
- Fixed bug in DiskUsageRaw() |
133 |
|
|
- Added NRPE command affa_diskusagenrpe |
134 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
135 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
136 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
137 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
138 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
139 |
|
|
- Bugfixes in showSchedule() |
140 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
141 |
|
|
- added ICINGA/Nagios auto-configuration |
142 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
143 |
|
|
- do not show Dedup interrupted in --status after the very first run |
144 |
|
|
- improved --nrpe function |
145 |
|
|
- added script yum_install_packages.sh |
146 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
147 |
|
|
- MINOR IMPROVEMENTS |
148 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
149 |
|
|
--log-tail: show last rotated if current log is empty or too short |
150 |
|
|
--check-conncetions: allow jobs as arguments |
151 |
jcrisp |
1.2 |
* Mon Aug 29 2011 Michael Weinberger 3.1.2 |
152 |
brianr |
1.1 |
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
153 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
154 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
155 |
|
|
- --resume-interrupted |
156 |
|
|
- resume interrupted jobs after server boot |
157 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
158 |
|
|
- introduced status 'interrupted'(with --status) |
159 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
160 |
|
|
- Release of 3.1.0 |
161 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
162 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
163 |
|
|
- removed Command arg from sample scripts |
164 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
165 |
|
|
- De-duplication info added to --show-schedule |
166 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
167 |
|
|
- De-Duplication (freedup) |
168 |
|
|
- De-Dup info in --status and --list-archives |
169 |
|
|
- --status: only show enabled jobs. All with --all |
170 |
|
|
- Fix: property globalStatus was not working |
171 |
|
|
- Running state rsync or de-deduplicating display in --status |
172 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
173 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
174 |
|
|
- new option --show-property |
175 |
|
|
|
176 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
177 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
178 |
|
|
|
179 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
180 |
|
|
- fixed bug in affa --status |
181 |
|
|
- GlobalAffaConfig was mounted as Samba share |
182 |
|
|
- call setupSamba() only in cronSetup() |
183 |
|
|
- updated man |
184 |
|
|
|
185 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
186 |
|
|
- new key NRPEtrigger |
187 |
|
|
- full affa path required when starting re-run from cronjob |
188 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
189 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
190 |
|
|
|
191 |
|
|
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
192 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
193 |
|
|
|
194 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
195 |
|
|
- bash version re-written in Perl |
196 |
|
|
|