1 |
jcrisp |
1.2 |
Summary: A rsync-based backup program for linux, adapted to Koozali SME server 10 |
2 |
brianr |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
jcrisp |
1.3 |
%define version 3.3.1 |
5 |
jcrisp |
1.4 |
%define release 2 |
6 |
brianr |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
|
|
License: GNU General Public License |
10 |
|
|
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
jcrisp |
1.2 |
BuildRequires: e-smith-devtools |
15 |
|
|
|
16 |
brianr |
1.1 |
AutoReq: no |
17 |
|
|
|
18 |
jcrisp |
1.2 |
Requires: e-smith-release >= 10 |
19 |
jcrisp |
1.4 |
Requires: smeserver-systemd-control |
20 |
brianr |
1.1 |
Requires: openssh-clients |
21 |
|
|
Requires: perl-Config-IniFiles |
22 |
|
|
Requires: perl-Filesys-DiskFree |
23 |
|
|
Requires: perl-MailTools |
24 |
|
|
Requires: perl-Proc-ProcessTable |
25 |
|
|
Requires: perl-TimeDate |
26 |
jcrisp |
1.2 |
Requires: perl-List-MoreUtils |
27 |
brianr |
1.1 |
Requires: rsync |
28 |
|
|
|
29 |
jcrisp |
1.4 |
Patch1: smeserver-affa-add-some-systemd-support.patch |
30 |
brianr |
1.1 |
|
31 |
|
|
%description |
32 |
jcrisp |
1.2 |
Affa is a rsync-based backup program for SMEServer + RPMCheck + Watchdog + rise. Documentation: http://affa.sf.net |
33 |
brianr |
1.1 |
|
34 |
|
|
%prep |
35 |
jcrisp |
1.2 |
rm -rf $RPM_BUILD_ROOT |
36 |
|
|
|
37 |
brianr |
1.1 |
%setup -q -n %{name}-%{version} |
38 |
jcrisp |
1.4 |
%patch1 -p1 |
39 |
brianr |
1.1 |
|
40 |
|
|
%build |
41 |
jcrisp |
1.2 |
# perl createlinks << if required |
42 |
|
|
find . \( -name .gitinclude -o -name .gitignore \) -print0 | \ |
43 |
|
|
xargs -0 rm -f |
44 |
brianr |
1.1 |
|
45 |
|
|
%install |
46 |
|
|
|
47 |
jcrisp |
1.2 |
/bin/rm -rf $RPM_BUILD_ROOT |
48 |
|
|
(cd root ;/usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
49 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
50 |
brianr |
1.1 |
|
51 |
|
|
# Set version String |
52 |
|
|
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
53 |
|
|
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
54 |
|
|
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
55 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
56 |
|
|
|
57 |
jcrisp |
1.2 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
58 |
|
|
--ignoredir "/etc/sudoers.d" \ |
59 |
|
|
--ignoredir "/etc/profile.d" \ |
60 |
|
|
--file "/etc/profile.d/affa.sh" "attr(0555,root,root)" \ |
61 |
|
|
--file "/etc/sudoers.d/affa" "attr(0440,root,root)" \ |
62 |
|
|
> %{name}-%{version}-filelist |
63 |
brianr |
1.1 |
|
64 |
jcrisp |
1.2 |
# We could use this for docs I guess - we should standardise this sort of thing |
65 |
|
|
#%doc README LICENSE README |
66 |
jcrisp |
1.3 |
echo "%doc LICENSE COPYING README WARRANTY" >> %{name}-%{version}-filelist |
67 |
|
|
|
68 |
|
|
|
69 |
|
|
|
70 |
|
|
%files -f %{name}-%{version}-filelist |
71 |
brianr |
1.1 |
|
72 |
|
|
%clean |
73 |
|
|
rm -rf $RPM_BUILD_ROOT |
74 |
|
|
|
75 |
|
|
%pre |
76 |
|
|
exit 0 |
77 |
|
|
|
78 |
|
|
%post |
79 |
|
|
exit 0 |
80 |
|
|
|
81 |
|
|
%preun |
82 |
|
|
exit 0 |
83 |
|
|
|
84 |
|
|
%postun |
85 |
|
|
exit 0 |
86 |
|
|
|
87 |
|
|
%changelog |
88 |
jcrisp |
1.4 |
* Tue Sep 21 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-2.sme |
89 |
|
|
- Add some systemd support [SME: 11024] |
90 |
|
|
|
91 |
jcrisp |
1.3 |
* Mon Mar 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-1.sme |
92 |
|
|
- Fix Warranty [SME: 11500] |
93 |
|
|
- Fix Licence [SME: 11501] |
94 |
|
|
- Remove atalk [SME: 11503] |
95 |
|
|
|
96 |
|
|
* Tue Mar 23 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.0-1.sme |
97 |
jcrisp |
1.2 |
- New version for Koozali SME v10 [SME: 11024] |
98 |
|
|
- incorporated old patches |
99 |
|
|
- tidied up some old git files |
100 |
|
|
- Very Alpha - see bug for details |
101 |
|
|
|
102 |
brianr |
1.1 |
* Mon Apr 10 2017 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-8.sme |
103 |
|
|
- Fix issue when multiple times are in an Affa configuration file, show-schedule only displays the last [SME: 10196] |
104 |
|
|
|
105 |
|
|
* Wed Nov 23 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-7.sme |
106 |
|
|
- Fix find command error in delete imap dovecot files [SME: 9874] |
107 |
|
|
|
108 |
|
|
* Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-6.sme |
109 |
|
|
- Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449] |
110 |
|
|
|
111 |
|
|
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-5.sme |
112 |
|
|
- Fix ssh port [SME: 8904] |
113 |
|
|
- Modify changelog number to track define release number |
114 |
|
|
|
115 |
|
|
* Wed Mar 23 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-4.sme |
116 |
|
|
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
117 |
|
|
- Fix "RPMCheck" not working [SME: 9270] |
118 |
|
|
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
119 |
|
|
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
120 |
|
|
|
121 |
|
|
* Mon Feb 29 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-3.sme |
122 |
|
|
- Fix typos in config files [SME: 9094] |
123 |
|
|
|
124 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
125 |
|
|
- Initial release to contribs9 |
126 |
|
|
|
127 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
128 |
|
|
- fixed column ExecTime shift |
129 |
|
|
- Adjusted column indices in report |
130 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
131 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
132 |
|
|
|
133 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
134 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
135 |
|
|
|
136 |
|
|
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
137 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
138 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
139 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
140 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
141 |
|
|
- first adaptation for sme server8 |
142 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
143 |
|
|
- Improved NRPE and sudoers config |
144 |
|
|
- Fixed bug in DiskUsageRaw() |
145 |
|
|
- Added NRPE command affa_diskusagenrpe |
146 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
147 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
148 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
149 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
150 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
151 |
|
|
- Bugfixes in showSchedule() |
152 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
153 |
|
|
- added ICINGA/Nagios auto-configuration |
154 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
155 |
|
|
- do not show Dedup interrupted in --status after the very first run |
156 |
|
|
- improved --nrpe function |
157 |
|
|
- added script yum_install_packages.sh |
158 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
159 |
|
|
- MINOR IMPROVEMENTS |
160 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
161 |
|
|
--log-tail: show last rotated if current log is empty or too short |
162 |
|
|
--check-conncetions: allow jobs as arguments |
163 |
jcrisp |
1.2 |
* Mon Aug 29 2011 Michael Weinberger 3.1.2 |
164 |
brianr |
1.1 |
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
165 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
166 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
167 |
|
|
- --resume-interrupted |
168 |
|
|
- resume interrupted jobs after server boot |
169 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
170 |
|
|
- introduced status 'interrupted'(with --status) |
171 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
172 |
|
|
- Release of 3.1.0 |
173 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
174 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
175 |
|
|
- removed Command arg from sample scripts |
176 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
177 |
|
|
- De-duplication info added to --show-schedule |
178 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
179 |
|
|
- De-Duplication (freedup) |
180 |
|
|
- De-Dup info in --status and --list-archives |
181 |
|
|
- --status: only show enabled jobs. All with --all |
182 |
|
|
- Fix: property globalStatus was not working |
183 |
|
|
- Running state rsync or de-deduplicating display in --status |
184 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
185 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
186 |
|
|
- new option --show-property |
187 |
|
|
|
188 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
189 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
190 |
|
|
|
191 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
192 |
|
|
- fixed bug in affa --status |
193 |
|
|
- GlobalAffaConfig was mounted as Samba share |
194 |
|
|
- call setupSamba() only in cronSetup() |
195 |
|
|
- updated man |
196 |
|
|
|
197 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
198 |
|
|
- new key NRPEtrigger |
199 |
|
|
- full affa path required when starting re-run from cronjob |
200 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
201 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
202 |
|
|
|
203 |
|
|
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
204 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
205 |
|
|
|
206 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
207 |
|
|
- bash version re-written in Perl |
208 |
|
|
|