1 |
jcrisp |
1.2 |
Summary: A rsync-based backup program for linux, adapted to Koozali SME server 10 |
2 |
brianr |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
jcrisp |
1.3 |
%define version 3.3.1 |
5 |
jcrisp |
1.8 |
%define release 6 |
6 |
brianr |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
|
|
License: GNU General Public License |
10 |
|
|
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
jcrisp |
1.2 |
BuildRequires: e-smith-devtools |
15 |
|
|
|
16 |
brianr |
1.1 |
AutoReq: no |
17 |
|
|
|
18 |
jcrisp |
1.2 |
Requires: e-smith-release >= 10 |
19 |
jcrisp |
1.4 |
Requires: smeserver-systemd-control |
20 |
brianr |
1.1 |
Requires: openssh-clients |
21 |
|
|
Requires: perl-Config-IniFiles |
22 |
|
|
Requires: perl-Filesys-DiskFree |
23 |
|
|
Requires: perl-MailTools |
24 |
|
|
Requires: perl-Proc-ProcessTable |
25 |
|
|
Requires: perl-TimeDate |
26 |
jcrisp |
1.2 |
Requires: perl-List-MoreUtils |
27 |
brianr |
1.1 |
Requires: rsync |
28 |
|
|
|
29 |
jcrisp |
1.4 |
Patch1: smeserver-affa-add-some-systemd-support.patch |
30 |
jcrisp |
1.5 |
Patch2: smeserver-affa-change-host-domain.patch |
31 |
jcrisp |
1.6 |
Patch3: smeserver-affa-change_to_rsa_keys.patch |
32 |
jcrisp |
1.7 |
Patch4: smeserver-affa-update-ssh-keys-links.patch |
33 |
jcrisp |
1.8 |
Patch5: smeserver-affa-fix-config-directory-name-spaces.patch |
34 |
brianr |
1.1 |
|
35 |
|
|
%description |
36 |
jcrisp |
1.2 |
Affa is a rsync-based backup program for SMEServer + RPMCheck + Watchdog + rise. Documentation: http://affa.sf.net |
37 |
brianr |
1.1 |
|
38 |
|
|
%prep |
39 |
jcrisp |
1.2 |
rm -rf $RPM_BUILD_ROOT |
40 |
|
|
|
41 |
brianr |
1.1 |
%setup -q -n %{name}-%{version} |
42 |
jcrisp |
1.4 |
%patch1 -p1 |
43 |
jcrisp |
1.5 |
%patch2 -p1 |
44 |
jcrisp |
1.6 |
%patch3 -p1 |
45 |
jcrisp |
1.7 |
%patch4 -p1 |
46 |
jcrisp |
1.8 |
%patch5 -p1 |
47 |
brianr |
1.1 |
|
48 |
|
|
%build |
49 |
jcrisp |
1.2 |
# perl createlinks << if required |
50 |
|
|
find . \( -name .gitinclude -o -name .gitignore \) -print0 | \ |
51 |
|
|
xargs -0 rm -f |
52 |
brianr |
1.1 |
|
53 |
|
|
%install |
54 |
|
|
|
55 |
jcrisp |
1.2 |
/bin/rm -rf $RPM_BUILD_ROOT |
56 |
|
|
(cd root ;/usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
57 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
58 |
brianr |
1.1 |
|
59 |
|
|
# Set version String |
60 |
|
|
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
61 |
|
|
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
62 |
|
|
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
63 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
64 |
|
|
|
65 |
jcrisp |
1.2 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
66 |
|
|
--ignoredir "/etc/sudoers.d" \ |
67 |
|
|
--ignoredir "/etc/profile.d" \ |
68 |
|
|
--file "/etc/profile.d/affa.sh" "attr(0555,root,root)" \ |
69 |
|
|
--file "/etc/sudoers.d/affa" "attr(0440,root,root)" \ |
70 |
|
|
> %{name}-%{version}-filelist |
71 |
brianr |
1.1 |
|
72 |
jcrisp |
1.2 |
# We could use this for docs I guess - we should standardise this sort of thing |
73 |
|
|
#%doc README LICENSE README |
74 |
jcrisp |
1.3 |
echo "%doc LICENSE COPYING README WARRANTY" >> %{name}-%{version}-filelist |
75 |
|
|
|
76 |
|
|
|
77 |
|
|
|
78 |
|
|
%files -f %{name}-%{version}-filelist |
79 |
brianr |
1.1 |
|
80 |
|
|
%clean |
81 |
|
|
rm -rf $RPM_BUILD_ROOT |
82 |
|
|
|
83 |
|
|
%pre |
84 |
|
|
exit 0 |
85 |
|
|
|
86 |
|
|
%post |
87 |
|
|
exit 0 |
88 |
|
|
|
89 |
|
|
%preun |
90 |
|
|
exit 0 |
91 |
|
|
|
92 |
|
|
%postun |
93 |
|
|
exit 0 |
94 |
|
|
|
95 |
|
|
%changelog |
96 |
jcrisp |
1.8 |
* Thu Jun 30 2022 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-6 |
97 |
|
|
- Fix error with files with spaces in names - Credit to Trevor Drake-Brockman [SME: 11784] |
98 |
|
|
- Fix directory search - Credit to Trevor Drake-Brockman [SME: 11784] |
99 |
|
|
|
100 |
jcrisp |
1.7 |
* Wed Sep 22 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-5 |
101 |
|
|
- Modify ssh key links [SME: 10783] |
102 |
|
|
- Untidy the ssh commands so I can see them and tidy them more easily |
103 |
|
|
|
104 |
jcrisp |
1.6 |
* Wed Sep 22 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-4 |
105 |
|
|
- Change ssh keys from DSA to RSA 4096 [SME: 10783] |
106 |
|
|
- Fix missing /var/affa store dir |
107 |
|
|
|
108 |
jcrisp |
1.5 |
* Tue Sep 21 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-3.sme |
109 |
|
|
- Fix some syntax errors. Migrate to using HostName/DomainName |
110 |
|
|
|
111 |
jcrisp |
1.4 |
* Tue Sep 21 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-2.sme |
112 |
|
|
- Add some systemd support [SME: 11024] |
113 |
|
|
|
114 |
jcrisp |
1.3 |
* Mon Mar 29 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.1-1.sme |
115 |
|
|
- Fix Warranty [SME: 11500] |
116 |
|
|
- Fix Licence [SME: 11501] |
117 |
|
|
- Remove atalk [SME: 11503] |
118 |
|
|
|
119 |
|
|
* Tue Mar 23 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 3.3.0-1.sme |
120 |
jcrisp |
1.2 |
- New version for Koozali SME v10 [SME: 11024] |
121 |
|
|
- incorporated old patches |
122 |
|
|
- tidied up some old git files |
123 |
|
|
- Very Alpha - see bug for details |
124 |
|
|
|
125 |
brianr |
1.1 |
* Mon Apr 10 2017 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-8.sme |
126 |
|
|
- Fix issue when multiple times are in an Affa configuration file, show-schedule only displays the last [SME: 10196] |
127 |
|
|
|
128 |
|
|
* Wed Nov 23 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-7.sme |
129 |
|
|
- Fix find command error in delete imap dovecot files [SME: 9874] |
130 |
|
|
|
131 |
|
|
* Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-6.sme |
132 |
|
|
- Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449] |
133 |
|
|
|
134 |
|
|
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-5.sme |
135 |
|
|
- Fix ssh port [SME: 8904] |
136 |
|
|
- Modify changelog number to track define release number |
137 |
|
|
|
138 |
|
|
* Wed Mar 23 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-4.sme |
139 |
|
|
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
140 |
|
|
- Fix "RPMCheck" not working [SME: 9270] |
141 |
|
|
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
142 |
|
|
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
143 |
|
|
|
144 |
|
|
* Mon Feb 29 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-3.sme |
145 |
|
|
- Fix typos in config files [SME: 9094] |
146 |
|
|
|
147 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
148 |
|
|
- Initial release to contribs9 |
149 |
|
|
|
150 |
|
|
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
151 |
|
|
- fixed column ExecTime shift |
152 |
|
|
- Adjusted column indices in report |
153 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
154 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
155 |
|
|
|
156 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
157 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
158 |
|
|
|
159 |
|
|
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
160 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
161 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
162 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
163 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
164 |
|
|
- first adaptation for sme server8 |
165 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
166 |
|
|
- Improved NRPE and sudoers config |
167 |
|
|
- Fixed bug in DiskUsageRaw() |
168 |
|
|
- Added NRPE command affa_diskusagenrpe |
169 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
170 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
171 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
172 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
173 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
174 |
|
|
- Bugfixes in showSchedule() |
175 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
176 |
|
|
- added ICINGA/Nagios auto-configuration |
177 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
178 |
|
|
- do not show Dedup interrupted in --status after the very first run |
179 |
|
|
- improved --nrpe function |
180 |
|
|
- added script yum_install_packages.sh |
181 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
182 |
|
|
- MINOR IMPROVEMENTS |
183 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
184 |
|
|
--log-tail: show last rotated if current log is empty or too short |
185 |
|
|
--check-conncetions: allow jobs as arguments |
186 |
jcrisp |
1.2 |
* Mon Aug 29 2011 Michael Weinberger 3.1.2 |
187 |
brianr |
1.1 |
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
188 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
189 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
190 |
|
|
- --resume-interrupted |
191 |
|
|
- resume interrupted jobs after server boot |
192 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
193 |
|
|
- introduced status 'interrupted'(with --status) |
194 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
195 |
|
|
- Release of 3.1.0 |
196 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
197 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
198 |
|
|
- removed Command arg from sample scripts |
199 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
200 |
|
|
- De-duplication info added to --show-schedule |
201 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
202 |
|
|
- De-Duplication (freedup) |
203 |
|
|
- De-Dup info in --status and --list-archives |
204 |
|
|
- --status: only show enabled jobs. All with --all |
205 |
|
|
- Fix: property globalStatus was not working |
206 |
|
|
- Running state rsync or de-deduplicating display in --status |
207 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
208 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
209 |
|
|
- new option --show-property |
210 |
|
|
|
211 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
212 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
213 |
|
|
|
214 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
215 |
|
|
- fixed bug in affa --status |
216 |
|
|
- GlobalAffaConfig was mounted as Samba share |
217 |
|
|
- call setupSamba() only in cronSetup() |
218 |
|
|
- updated man |
219 |
|
|
|
220 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
221 |
|
|
- new key NRPEtrigger |
222 |
|
|
- full affa path required when starting re-run from cronjob |
223 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
224 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
225 |
|
|
|
226 |
|
|
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
227 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
228 |
|
|
|
229 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
230 |
|
|
- bash version re-written in Perl |
231 |
|
|
|