1 |
stephdl |
1.4 |
Summary: A rsync-based backup program for linux, adapted to sme server 8 |
2 |
unnilennium |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
stephdl |
1.4 |
%define version 3.2.2.3 |
5 |
|
|
%define release 2 |
6 |
unnilennium |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
stephdl |
1.4 |
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
unnilennium |
1.2 |
License: GNU General Public License |
10 |
unnilennium |
1.1 |
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
|
|
AutoReq: no |
15 |
stephdl |
1.4 |
Requires: openssh-clients |
16 |
|
|
Requires: perl-Config-IniFiles |
17 |
unnilennium |
1.1 |
Requires: perl-Filesys-DiskFree |
18 |
stephdl |
1.4 |
Requires: perl-MailTools |
19 |
|
|
Requires: perl-Proc-ProcessTable |
20 |
|
|
Requires: perl-TimeDate |
21 |
|
|
Requires: rsync |
22 |
unnilennium |
1.1 |
|
23 |
|
|
%description |
24 |
stephdl |
1.4 |
Affa is a rsync-based backup program |
25 |
|
|
Documentation: http://affa.sf.net |
26 |
|
|
with SMEServer + RPMCheck + Watchdog + rise |
27 |
unnilennium |
1.2 |
|
28 |
|
|
%prep |
29 |
|
|
%setup -q -n %{name}-%{version} |
30 |
|
|
|
31 |
|
|
%build |
32 |
|
|
|
33 |
|
|
%install |
34 |
|
|
rm -rf $RPM_BUILD_ROOT |
35 |
|
|
rm -f %{name}-%{version}-filelist |
36 |
stephdl |
1.4 |
(cd root ;find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
37 |
unnilennium |
1.2 |
|
38 |
|
|
|
39 |
|
|
# Set version String |
40 |
stephdl |
1.4 |
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
41 |
unnilennium |
1.2 |
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
42 |
stephdl |
1.4 |
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
43 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
44 |
unnilennium |
1.2 |
|
45 |
|
|
rm -f %{name}-%{version}-filelist |
46 |
|
|
|
47 |
|
|
find $RPM_BUILD_ROOT -depth -type f -print |\ |
48 |
|
|
sed -e "s@^$RPM_BUILD_ROOT@@g" \ |
49 |
stephdl |
1.4 |
-e "s@^/sbin/@%attr(0750,root,root) &@"\ |
50 |
unnilennium |
1.2 |
-e "s@^/etc/profile.d/@%attr(0555,root,root) &@"\ |
51 |
stephdl |
1.4 |
-e "s@^/etc/sudoers.d/@%attr(0440,root,root) &@"\ |
52 |
|
|
-e "s@^/etc/cron.d/@%attr(0444,root,root)%config(noreplace) &@"\ |
53 |
|
|
-e "s@^/usr/lib/affa/LICENSE@%attr(0444,root,root) &@"\ |
54 |
|
|
-e "s@^/usr/lib/affa/WARRANTY@%attr(0444,root,root) &@"\ |
55 |
|
|
-e "s@^/usr/man/man1/@%attr(0444,root,root) &@"\ |
56 |
|
|
-e "s@^/etc/affa/scripts/@%attr(0750,root,root)%config(noreplace) &@"\ |
57 |
|
|
-e "s@^/etc/affa/@%attr(0640,root,root)%config(noreplace) &@"\ |
58 |
unnilennium |
1.2 |
>> %{name}-%{version}-filelist |
59 |
|
|
|
60 |
stephdl |
1.4 |
|
61 |
|
|
find $RPM_BUILD_ROOT -depth -type d -print |\ |
62 |
|
|
sed -e "s@^$RPM_BUILD_ROOT@%dir @g" >> %{name}-%{version}-filelist |
63 |
|
|
|
64 |
unnilennium |
1.2 |
find $RPM_BUILD_ROOT -depth -type l -print |\ |
65 |
|
|
sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist |
66 |
|
|
|
67 |
|
|
%clean |
68 |
|
|
rm -rf $RPM_BUILD_ROOT |
69 |
stephdl |
1.4 |
|
70 |
|
|
%files -f %{name}-%{version}-filelist |
71 |
|
|
%defattr(-,root,root) |
72 |
|
|
|
73 |
|
|
%pre |
74 |
unnilennium |
1.2 |
exit 0 |
75 |
|
|
|
76 |
stephdl |
1.4 |
%post |
77 |
|
|
exit 0 |
78 |
|
|
|
79 |
|
|
%preun |
80 |
|
|
exit 0 |
81 |
unnilennium |
1.2 |
|
82 |
stephdl |
1.4 |
%postun |
83 |
|
|
exit 0 |
84 |
unnilennium |
1.1 |
|
85 |
|
|
%changelog |
86 |
stephdl |
1.4 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
87 |
|
|
- Initial release to contribs8 |
88 |
unnilennium |
1.3 |
|
89 |
stephdl |
1.4 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
90 |
|
|
- fixed column ExecTime shift |
91 |
|
|
- Adjusted column indices in report |
92 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
93 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
94 |
|
|
|
95 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
96 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
97 |
|
|
|
98 |
|
|
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
99 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
100 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
101 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
102 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
103 |
|
|
- first adaptation for sme server8 |
104 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
105 |
|
|
- Improved NRPE and sudoers config |
106 |
|
|
- Fixed bug in DiskUsageRaw() |
107 |
|
|
- Added NRPE command affa_diskusagenrpe |
108 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
109 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
110 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
111 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
112 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
113 |
|
|
- Bugfixes in showSchedule() |
114 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
115 |
|
|
- added ICINGA/Nagios auto-configuration |
116 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
117 |
|
|
- do not show Dedup interrupted in --status after the very first run |
118 |
|
|
- improved --nrpe function |
119 |
|
|
- added script yum_install_packages.sh |
120 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
121 |
|
|
- MINOR IMPROVEMENTS |
122 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
123 |
|
|
--log-tail: show last rotated if current log is empty or too short |
124 |
|
|
--check-conncetions: allow jobs as arguments |
125 |
|
|
* Sun Aug 29 2011 Michael Weinberger 3.1.2 |
126 |
|
|
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
127 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
128 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
129 |
|
|
- --resume-interrupted |
130 |
|
|
- resume interrupted jobs after server boot |
131 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
132 |
|
|
- introduced status 'interrupted'(with --status) |
133 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
134 |
|
|
- Release of 3.1.0 |
135 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
136 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
137 |
|
|
- removed Command arg from sample scripts |
138 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
139 |
|
|
- De-duplication info added to --show-schedule |
140 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
141 |
|
|
- De-Duplication (freedup) |
142 |
|
|
- De-Dup info in --status and --list-archives |
143 |
|
|
- --status: only show enabled jobs. All with --all |
144 |
|
|
- Fix: property globalStatus was not working |
145 |
|
|
- Running state rsync or de-deduplicating display in --status |
146 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
147 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
148 |
|
|
- new option --show-property |
149 |
|
|
|
150 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
151 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
152 |
|
|
|
153 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
154 |
|
|
- fixed bug in affa --status |
155 |
|
|
- GlobalAffaConfig was mounted as Samba share |
156 |
|
|
- call setupSamba() only in cronSetup() |
157 |
|
|
- updated man |
158 |
|
|
|
159 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
160 |
|
|
- new key NRPEtrigger |
161 |
|
|
- full affa path required when starting re-run from cronjob |
162 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
163 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
164 |
unnilennium |
1.1 |
|
165 |
stephdl |
1.4 |
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
166 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
167 |
unnilennium |
1.1 |
|
168 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
169 |
stephdl |
1.4 |
- bash version re-written in Perl |
170 |
unnilennium |
1.1 |
|