1 |
stephdl |
1.4 |
Summary: A rsync-based backup program for linux, adapted to sme server 8 |
2 |
unnilennium |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
stephdl |
1.4 |
%define version 3.2.2.3 |
5 |
reetspetit |
1.6 |
%define release 4 |
6 |
unnilennium |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
stephdl |
1.4 |
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
unnilennium |
1.2 |
License: GNU General Public License |
10 |
unnilennium |
1.1 |
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
|
|
AutoReq: no |
15 |
stephdl |
1.4 |
Requires: openssh-clients |
16 |
|
|
Requires: perl-Config-IniFiles |
17 |
unnilennium |
1.1 |
Requires: perl-Filesys-DiskFree |
18 |
stephdl |
1.4 |
Requires: perl-MailTools |
19 |
|
|
Requires: perl-Proc-ProcessTable |
20 |
|
|
Requires: perl-TimeDate |
21 |
|
|
Requires: rsync |
22 |
unnilennium |
1.1 |
|
23 |
guedel |
1.5 |
Patch1: smeserver-affa-fix-typo_rise_smb_diskusage.patch |
24 |
reetspetit |
1.6 |
Patch2: smeserver-affa-fix-ssh-port.patch |
25 |
unnilennium |
1.1 |
%description |
26 |
stephdl |
1.4 |
Affa is a rsync-based backup program |
27 |
|
|
Documentation: http://affa.sf.net |
28 |
|
|
with SMEServer + RPMCheck + Watchdog + rise |
29 |
unnilennium |
1.2 |
|
30 |
|
|
%prep |
31 |
|
|
%setup -q -n %{name}-%{version} |
32 |
guedel |
1.5 |
%patch1 -p1 |
33 |
reetspetit |
1.6 |
%patch2 -p1 |
34 |
unnilennium |
1.2 |
|
35 |
|
|
%build |
36 |
|
|
|
37 |
|
|
%install |
38 |
|
|
rm -rf $RPM_BUILD_ROOT |
39 |
|
|
rm -f %{name}-%{version}-filelist |
40 |
stephdl |
1.4 |
(cd root ;find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
41 |
unnilennium |
1.2 |
|
42 |
|
|
|
43 |
|
|
# Set version String |
44 |
stephdl |
1.4 |
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
45 |
unnilennium |
1.2 |
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
46 |
stephdl |
1.4 |
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
47 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
48 |
unnilennium |
1.2 |
|
49 |
|
|
rm -f %{name}-%{version}-filelist |
50 |
|
|
|
51 |
|
|
find $RPM_BUILD_ROOT -depth -type f -print |\ |
52 |
|
|
sed -e "s@^$RPM_BUILD_ROOT@@g" \ |
53 |
stephdl |
1.4 |
-e "s@^/sbin/@%attr(0750,root,root) &@"\ |
54 |
unnilennium |
1.2 |
-e "s@^/etc/profile.d/@%attr(0555,root,root) &@"\ |
55 |
stephdl |
1.4 |
-e "s@^/etc/sudoers.d/@%attr(0440,root,root) &@"\ |
56 |
|
|
-e "s@^/etc/cron.d/@%attr(0444,root,root)%config(noreplace) &@"\ |
57 |
|
|
-e "s@^/usr/lib/affa/LICENSE@%attr(0444,root,root) &@"\ |
58 |
|
|
-e "s@^/usr/lib/affa/WARRANTY@%attr(0444,root,root) &@"\ |
59 |
|
|
-e "s@^/usr/man/man1/@%attr(0444,root,root) &@"\ |
60 |
|
|
-e "s@^/etc/affa/scripts/@%attr(0750,root,root)%config(noreplace) &@"\ |
61 |
|
|
-e "s@^/etc/affa/@%attr(0640,root,root)%config(noreplace) &@"\ |
62 |
unnilennium |
1.2 |
>> %{name}-%{version}-filelist |
63 |
|
|
|
64 |
stephdl |
1.4 |
|
65 |
|
|
find $RPM_BUILD_ROOT -depth -type d -print |\ |
66 |
|
|
sed -e "s@^$RPM_BUILD_ROOT@%dir @g" >> %{name}-%{version}-filelist |
67 |
|
|
|
68 |
unnilennium |
1.2 |
find $RPM_BUILD_ROOT -depth -type l -print |\ |
69 |
|
|
sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist |
70 |
|
|
|
71 |
|
|
%clean |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
stephdl |
1.4 |
|
74 |
|
|
%files -f %{name}-%{version}-filelist |
75 |
|
|
%defattr(-,root,root) |
76 |
|
|
|
77 |
|
|
%pre |
78 |
unnilennium |
1.2 |
exit 0 |
79 |
|
|
|
80 |
stephdl |
1.4 |
%post |
81 |
|
|
exit 0 |
82 |
|
|
|
83 |
|
|
%preun |
84 |
|
|
exit 0 |
85 |
unnilennium |
1.2 |
|
86 |
stephdl |
1.4 |
%postun |
87 |
|
|
exit 0 |
88 |
unnilennium |
1.1 |
|
89 |
|
|
%changelog |
90 |
reetspetit |
1.6 |
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-4.sme |
91 |
|
|
- Fix ssh port [SME: 8904] |
92 |
|
|
|
93 |
guedel |
1.5 |
* Wed Mar 23 2016 Arnaud Guillaume <affa@guedel.eu> 3.2.2.3-3.sme |
94 |
|
|
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
95 |
|
|
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
96 |
|
|
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
97 |
|
|
- Fix typos in config files (John Crisp <jcrisp@safeandsoundit.co.uk> 29.01.2016) [SME: 9094] |
98 |
|
|
|
99 |
stephdl |
1.4 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
100 |
|
|
- Initial release to contribs8 |
101 |
unnilennium |
1.3 |
|
102 |
stephdl |
1.4 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
103 |
|
|
- fixed column ExecTime shift |
104 |
|
|
- Adjusted column indices in report |
105 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
106 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
107 |
|
|
|
108 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
109 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
110 |
|
|
|
111 |
|
|
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
112 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
113 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
114 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
115 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
116 |
|
|
- first adaptation for sme server8 |
117 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
118 |
|
|
- Improved NRPE and sudoers config |
119 |
|
|
- Fixed bug in DiskUsageRaw() |
120 |
|
|
- Added NRPE command affa_diskusagenrpe |
121 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
122 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
123 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
124 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
125 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
126 |
|
|
- Bugfixes in showSchedule() |
127 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
128 |
|
|
- added ICINGA/Nagios auto-configuration |
129 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
130 |
|
|
- do not show Dedup interrupted in --status after the very first run |
131 |
|
|
- improved --nrpe function |
132 |
|
|
- added script yum_install_packages.sh |
133 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
134 |
|
|
- MINOR IMPROVEMENTS |
135 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
136 |
|
|
--log-tail: show last rotated if current log is empty or too short |
137 |
|
|
--check-conncetions: allow jobs as arguments |
138 |
|
|
* Sun Aug 29 2011 Michael Weinberger 3.1.2 |
139 |
|
|
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
140 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
141 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
142 |
|
|
- --resume-interrupted |
143 |
|
|
- resume interrupted jobs after server boot |
144 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
145 |
|
|
- introduced status 'interrupted'(with --status) |
146 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
147 |
|
|
- Release of 3.1.0 |
148 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
149 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
150 |
|
|
- removed Command arg from sample scripts |
151 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
152 |
|
|
- De-duplication info added to --show-schedule |
153 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
154 |
|
|
- De-Duplication (freedup) |
155 |
|
|
- De-Dup info in --status and --list-archives |
156 |
|
|
- --status: only show enabled jobs. All with --all |
157 |
|
|
- Fix: property globalStatus was not working |
158 |
|
|
- Running state rsync or de-deduplicating display in --status |
159 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
160 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
161 |
|
|
- new option --show-property |
162 |
|
|
|
163 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
164 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
165 |
|
|
|
166 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
167 |
|
|
- fixed bug in affa --status |
168 |
|
|
- GlobalAffaConfig was mounted as Samba share |
169 |
|
|
- call setupSamba() only in cronSetup() |
170 |
|
|
- updated man |
171 |
|
|
|
172 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
173 |
|
|
- new key NRPEtrigger |
174 |
|
|
- full affa path required when starting re-run from cronjob |
175 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
176 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
177 |
unnilennium |
1.1 |
|
178 |
stephdl |
1.4 |
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
179 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
180 |
unnilennium |
1.1 |
|
181 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
182 |
stephdl |
1.4 |
- bash version re-written in Perl |
183 |
unnilennium |
1.1 |
|