1 |
Summary: A rsync-based backup program for linux, adapted to sme server 8 |
2 |
%define name smeserver-affa |
3 |
Name: %{name} |
4 |
%define version 3.2.2.3 |
5 |
%define release 5 |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
License: GNU General Public License |
10 |
Group: Applications/Archiving |
11 |
Source: %{name}-%{version}.tar.gz |
12 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
BuildArch: noarch |
14 |
AutoReq: no |
15 |
Requires: openssh-clients |
16 |
Requires: perl-Config-IniFiles |
17 |
Requires: perl-Filesys-DiskFree |
18 |
Requires: perl-MailTools |
19 |
Requires: perl-Proc-ProcessTable |
20 |
Requires: perl-TimeDate |
21 |
Requires: rsync |
22 |
|
23 |
Patch1: smeserver-affa-fix-typo_rise_smb_diskusage.patch |
24 |
Patch2: smeserver-affa-fix-ssh-port.patch |
25 |
Patch3: smeserver-affa-fix-blanks-conf.patch |
26 |
|
27 |
%description |
28 |
Affa is a rsync-based backup program |
29 |
Documentation: http://affa.sf.net |
30 |
with SMEServer + RPMCheck + Watchdog + rise |
31 |
|
32 |
%prep |
33 |
%setup -q -n %{name}-%{version} |
34 |
%patch1 -p1 |
35 |
%patch2 -p1 |
36 |
%patch3 -p1 |
37 |
|
38 |
%build |
39 |
|
40 |
%install |
41 |
rm -rf $RPM_BUILD_ROOT |
42 |
rm -f %{name}-%{version}-filelist |
43 |
(cd root ;find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
44 |
|
45 |
|
46 |
# Set version String |
47 |
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
48 |
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
49 |
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
50 |
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
51 |
|
52 |
rm -f %{name}-%{version}-filelist |
53 |
|
54 |
find $RPM_BUILD_ROOT -depth -type f -print |\ |
55 |
sed -e "s@^$RPM_BUILD_ROOT@@g" \ |
56 |
-e "s@^/sbin/@%attr(0750,root,root) &@"\ |
57 |
-e "s@^/etc/profile.d/@%attr(0555,root,root) &@"\ |
58 |
-e "s@^/etc/sudoers.d/@%attr(0440,root,root) &@"\ |
59 |
-e "s@^/etc/cron.d/@%attr(0444,root,root)%config(noreplace) &@"\ |
60 |
-e "s@^/usr/lib/affa/LICENSE@%attr(0444,root,root) &@"\ |
61 |
-e "s@^/usr/lib/affa/WARRANTY@%attr(0444,root,root) &@"\ |
62 |
-e "s@^/usr/man/man1/@%attr(0444,root,root) &@"\ |
63 |
-e "s@^/etc/affa/scripts/@%attr(0750,root,root)%config(noreplace) &@"\ |
64 |
-e "s@^/etc/affa/@%attr(0640,root,root)%config(noreplace) &@"\ |
65 |
>> %{name}-%{version}-filelist |
66 |
|
67 |
|
68 |
find $RPM_BUILD_ROOT -depth -type d -print |\ |
69 |
sed -e "s@^$RPM_BUILD_ROOT@%dir @g" >> %{name}-%{version}-filelist |
70 |
|
71 |
find $RPM_BUILD_ROOT -depth -type l -print |\ |
72 |
sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist |
73 |
|
74 |
%clean |
75 |
rm -rf $RPM_BUILD_ROOT |
76 |
|
77 |
%files -f %{name}-%{version}-filelist |
78 |
%defattr(-,root,root) |
79 |
|
80 |
%pre |
81 |
exit 0 |
82 |
|
83 |
%post |
84 |
exit 0 |
85 |
|
86 |
%preun |
87 |
exit 0 |
88 |
|
89 |
%postun |
90 |
exit 0 |
91 |
|
92 |
%changelog |
93 |
*Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-5.sme |
94 |
- Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449] |
95 |
|
96 |
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-4.sme |
97 |
- Fix ssh port [SME: 8904] |
98 |
|
99 |
* Wed Mar 23 2016 Arnaud Guillaume <affa@guedel.eu> 3.2.2.3-3.sme |
100 |
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
101 |
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
102 |
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
103 |
- Fix typos in config files (John Crisp <jcrisp@safeandsoundit.co.uk> 29.01.2016) [SME: 9094] |
104 |
|
105 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
106 |
- Initial release to contribs8 |
107 |
|
108 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
109 |
- fixed column ExecTime shift |
110 |
- Adjusted column indices in report |
111 |
- Fixed typo in remoteHostName [SME: 9062] |
112 |
- Code done by mats schuh <m.schuh@neckargeo.net> |
113 |
|
114 |
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
115 |
- Added TotalBytesSent to archive reports and fixed report layout |
116 |
|
117 |
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
118 |
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
119 |
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
120 |
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
121 |
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
122 |
- first adaptation for sme server8 |
123 |
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
124 |
- Improved NRPE and sudoers config |
125 |
- Fixed bug in DiskUsageRaw() |
126 |
- Added NRPE command affa_diskusagenrpe |
127 |
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
128 |
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
129 |
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
130 |
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
131 |
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
132 |
- Bugfixes in showSchedule() |
133 |
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
134 |
- added ICINGA/Nagios auto-configuration |
135 |
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
136 |
- do not show Dedup interrupted in --status after the very first run |
137 |
- improved --nrpe function |
138 |
- added script yum_install_packages.sh |
139 |
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
140 |
- MINOR IMPROVEMENTS |
141 |
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
142 |
--log-tail: show last rotated if current log is empty or too short |
143 |
--check-conncetions: allow jobs as arguments |
144 |
* Sun Aug 29 2011 Michael Weinberger 3.1.2 |
145 |
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
146 |
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
147 |
- process state 'rsync interrupted' and 'dedup interrupted' |
148 |
- --resume-interrupted |
149 |
- resume interrupted jobs after server boot |
150 |
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
151 |
- introduced status 'interrupted'(with --status) |
152 |
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
153 |
- Release of 3.1.0 |
154 |
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
155 |
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
156 |
- removed Command arg from sample scripts |
157 |
- Fixed: Concatenated config in /tmp was world readable |
158 |
- De-duplication info added to --show-schedule |
159 |
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
160 |
- De-Duplication (freedup) |
161 |
- De-Dup info in --status and --list-archives |
162 |
- --status: only show enabled jobs. All with --all |
163 |
- Fix: property globalStatus was not working |
164 |
- Running state rsync or de-deduplicating display in --status |
165 |
- Show de-deduplicating busy in --list-archives for scheduled.0 |
166 |
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
167 |
- new option --show-property |
168 |
|
169 |
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
170 |
- Bug fixes: RemoteUser was not always used in ssh commands |
171 |
|
172 |
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
173 |
- fixed bug in affa --status |
174 |
- GlobalAffaConfig was mounted as Samba share |
175 |
- call setupSamba() only in cronSetup() |
176 |
- updated man |
177 |
|
178 |
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
179 |
- new key NRPEtrigger |
180 |
- full affa path required when starting re-run from cronjob |
181 |
- improved deletion of shift out archives, --delete-job and --cleanup |
182 |
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
183 |
|
184 |
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
185 |
- generic linux version made from Affa 2.0 (SME Version) |
186 |
|
187 |
* Mon Apr 02 2007 Michael Weinberger |
188 |
- bash version re-written in Perl |
189 |
|