1 |
guedel |
1.5 |
Summary: A rsync-based backup program for linux, adapted to sme server 8-9 |
2 |
vip-ire |
1.1 |
%define name smeserver-affa |
3 |
|
|
Name: %{name} |
4 |
stephdl |
1.3 |
%define version 3.2.2.3 |
5 |
guedel |
1.7 |
%define release 6 |
6 |
vip-ire |
1.1 |
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
stephdl |
1.2 |
Vendor: Michael Weinberger <mweinber AT users DOT sourceforge DOT net> //// adaptation to sme-server Arnaud Guillaume <smeserver-affa AT guedel DOT eu> |
9 |
vip-ire |
1.1 |
License: GNU General Public License |
10 |
|
|
Group: Applications/Archiving |
11 |
|
|
Source: %{name}-%{version}.tar.gz |
12 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
13 |
|
|
BuildArch: noarch |
14 |
|
|
AutoReq: no |
15 |
reetspetit |
1.4 |
|
16 |
stephdl |
1.2 |
Requires: openssh-clients |
17 |
|
|
Requires: perl-Config-IniFiles |
18 |
vip-ire |
1.1 |
Requires: perl-Filesys-DiskFree |
19 |
stephdl |
1.2 |
Requires: perl-MailTools |
20 |
|
|
Requires: perl-Proc-ProcessTable |
21 |
|
|
Requires: perl-TimeDate |
22 |
|
|
Requires: rsync |
23 |
vip-ire |
1.1 |
|
24 |
reetspetit |
1.4 |
Patch1: smeserver-affa-fix-typo.patch |
25 |
guedel |
1.5 |
Patch2: smeserver-affa-fix-rise_RPMCheck_smb_diskusage.patch |
26 |
reetspetit |
1.6 |
Patch3: smeserver-affa-fix-ssh-port.patch |
27 |
guedel |
1.7 |
Patch4: smeserver-affa-fix-blanks-conf.patch |
28 |
reetspetit |
1.4 |
|
29 |
vip-ire |
1.1 |
%description |
30 |
stephdl |
1.2 |
Affa is a rsync-based backup program |
31 |
|
|
Documentation: http://affa.sf.net |
32 |
|
|
with SMEServer + RPMCheck + Watchdog + rise |
33 |
vip-ire |
1.1 |
|
34 |
|
|
%prep |
35 |
|
|
%setup -q -n %{name}-%{version} |
36 |
guedel |
1.5 |
%patch1 -p1 |
37 |
|
|
%patch2 -p1 |
38 |
reetspetit |
1.6 |
%patch3 -p1 |
39 |
guedel |
1.7 |
%patch4 -p1 |
40 |
vip-ire |
1.1 |
|
41 |
|
|
%build |
42 |
|
|
|
43 |
|
|
%install |
44 |
|
|
rm -rf $RPM_BUILD_ROOT |
45 |
|
|
rm -f %{name}-%{version}-filelist |
46 |
stephdl |
1.2 |
(cd root ;find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
47 |
vip-ire |
1.1 |
|
48 |
|
|
|
49 |
|
|
# Set version String |
50 |
stephdl |
1.2 |
cp -a $RPM_BUILD_ROOT/sbin/affa $RPM_BUILD_ROOT/sbin/affa.tmp |
51 |
vip-ire |
1.1 |
VERSIONSTRING=%{version}-`echo %{release}|sed -e 's/\..*$//'` |
52 |
stephdl |
1.2 |
sed -e "s/my \$VERSION.*;/my \$VERSION='$VERSIONSTRING';/" < $RPM_BUILD_ROOT/sbin/affa.tmp > $RPM_BUILD_ROOT/sbin/affa |
53 |
|
|
rm -f $RPM_BUILD_ROOT/sbin/affa.tmp |
54 |
vip-ire |
1.1 |
|
55 |
|
|
rm -f %{name}-%{version}-filelist |
56 |
|
|
|
57 |
|
|
find $RPM_BUILD_ROOT -depth -type f -print |\ |
58 |
|
|
sed -e "s@^$RPM_BUILD_ROOT@@g" \ |
59 |
stephdl |
1.2 |
-e "s@^/sbin/@%attr(0750,root,root) &@"\ |
60 |
vip-ire |
1.1 |
-e "s@^/etc/profile.d/@%attr(0555,root,root) &@"\ |
61 |
stephdl |
1.2 |
-e "s@^/etc/sudoers.d/@%attr(0440,root,root) &@"\ |
62 |
|
|
-e "s@^/etc/cron.d/@%attr(0444,root,root)%config(noreplace) &@"\ |
63 |
|
|
-e "s@^/usr/lib/affa/LICENSE@%attr(0444,root,root) &@"\ |
64 |
|
|
-e "s@^/usr/lib/affa/WARRANTY@%attr(0444,root,root) &@"\ |
65 |
|
|
-e "s@^/usr/man/man1/@%attr(0444,root,root) &@"\ |
66 |
|
|
-e "s@^/etc/affa/scripts/@%attr(0750,root,root)%config(noreplace) &@"\ |
67 |
|
|
-e "s@^/etc/affa/@%attr(0640,root,root)%config(noreplace) &@"\ |
68 |
vip-ire |
1.1 |
>> %{name}-%{version}-filelist |
69 |
|
|
|
70 |
stephdl |
1.2 |
|
71 |
|
|
find $RPM_BUILD_ROOT -depth -type d -print |\ |
72 |
|
|
sed -e "s@^$RPM_BUILD_ROOT@%dir @g" >> %{name}-%{version}-filelist |
73 |
|
|
|
74 |
vip-ire |
1.1 |
find $RPM_BUILD_ROOT -depth -type l -print |\ |
75 |
|
|
sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist |
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
stephdl |
1.2 |
|
80 |
|
|
%files -f %{name}-%{version}-filelist |
81 |
|
|
%defattr(-,root,root) |
82 |
|
|
|
83 |
|
|
%pre |
84 |
vip-ire |
1.1 |
exit 0 |
85 |
|
|
|
86 |
stephdl |
1.2 |
%post |
87 |
|
|
exit 0 |
88 |
vip-ire |
1.1 |
|
89 |
stephdl |
1.2 |
%preun |
90 |
|
|
exit 0 |
91 |
|
|
|
92 |
|
|
%postun |
93 |
|
|
exit 0 |
94 |
vip-ire |
1.1 |
|
95 |
|
|
%changelog |
96 |
guedel |
1.7 |
*Fri Aug 19 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-6.sme |
97 |
|
|
- Fix issue due to blank characters into file /etc/affa/job.conf [SME: 9449] |
98 |
|
|
|
99 |
reetspetit |
1.6 |
* Fri Aug 19 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-5.sme |
100 |
|
|
- Fix ssh port [SME: 8904] |
101 |
|
|
- Modify changelog number to track define release number |
102 |
|
|
|
103 |
guedel |
1.5 |
* Wed Mar 23 2016 Arnaud Guillaume <smeserver-affa@guedel.eu> 3.2.2.3-4.sme |
104 |
|
|
- Fix use of uninitialized value $1 in concatentation (.) or string at /sbin/affa/ line 4059 [SME: 9139] |
105 |
|
|
- Fix "RPMCheck" not working [SME: 9270] |
106 |
|
|
- Fix Inconsistent smb.conf when samba share option set to "yes" [SME: 9298] |
107 |
|
|
- Fix affa --diskusage does not umount attached storage [SME: 9147] |
108 |
|
|
|
109 |
reetspetit |
1.4 |
* Mon Feb 29 2016 John Crisp <jcrisp@safeandsoundit.co.uk> 3.2.2.3-3.sme |
110 |
|
|
- Fix typos in config files [SME: 9094] |
111 |
|
|
|
112 |
stephdl |
1.3 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-2.sme |
113 |
stephdl |
1.2 |
- Initial release to contribs9 |
114 |
|
|
|
115 |
stephdl |
1.3 |
* Tue Sep 22 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 3.2.2.3-1 |
116 |
|
|
- fixed column ExecTime shift |
117 |
|
|
- Adjusted column indices in report |
118 |
|
|
- Fixed typo in remoteHostName [SME: 9062] |
119 |
|
|
- Code done by mats schuh <m.schuh@neckargeo.net> |
120 |
|
|
|
121 |
|
|
* Tue Jan 13 2015 mats schuh <m.schuh@neckargeo.net> 3.2.2.2-1 |
122 |
|
|
- Added TotalBytesSent to archive reports and fixed report layout |
123 |
|
|
|
124 |
stephdl |
1.2 |
* Sun Dec 07 2014 Arnaud Guillaume 3.2.2.2 |
125 |
|
|
- integration of the patch of Mats Schuh in order to enable check for external disk label before unmount |
126 |
|
|
* Sat Aug 23 2014 Arnaud Guillaume 3.2.2.1 |
127 |
|
|
- adapted to the new release of rsync (bug by calculating the number and the size of the transfered files) |
128 |
|
|
* Sat Apr 05 2014 Arnaud Guillaume 3.2.2.0 |
129 |
|
|
- first adaptation for sme server8 |
130 |
|
|
* Sun Mar 04 2012 Michael Weinberger 3.2.2 |
131 |
|
|
- Improved NRPE and sudoers config |
132 |
|
|
- Fixed bug in DiskUsageRaw() |
133 |
|
|
- Added NRPE command affa_diskusagenrpe |
134 |
|
|
* Fri Mar 02 2012 Michael Weinberger 3.2.1 |
135 |
|
|
- Bugfix: command_prefix definiton was not added to /etc/nagios/affa-nrpe.cfg |
136 |
|
|
* Thu Mar 01 2012 Michael Weinberger 3.2.0 |
137 |
|
|
- Bugfix: remoteRsyncBinary and localRsyncBinary was not used |
138 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.7 |
139 |
|
|
- Bugfixes in showSchedule() |
140 |
|
|
* Sun Feb 26 2012 Michael Weinberger 3.1.6 |
141 |
|
|
- added ICINGA/Nagios auto-configuration |
142 |
|
|
* Fri Feb 24 2012 Michael Weinberger 3.1.4 |
143 |
|
|
- do not show Dedup interrupted in --status after the very first run |
144 |
|
|
- improved --nrpe function |
145 |
|
|
- added script yum_install_packages.sh |
146 |
|
|
* Tue Oct 11 2011 Michael Weinberger 3.1.3 |
147 |
|
|
- MINOR IMPROVEMENTS |
148 |
|
|
--send-key: mkdir of RemoteAuthorizedKeysFile. Avoid errors if dir does not exist |
149 |
|
|
--log-tail: show last rotated if current log is empty or too short |
150 |
|
|
--check-conncetions: allow jobs as arguments |
151 |
|
|
* Sun Aug 29 2011 Michael Weinberger 3.1.2 |
152 |
|
|
- Bugfix: postJobCommand and postJobCommandRemote were not executed |
153 |
|
|
* Sat Aug 13 2011 Michael Weinberger 3.1.1 |
154 |
|
|
- process state 'rsync interrupted' and 'dedup interrupted' |
155 |
|
|
- --resume-interrupted |
156 |
|
|
- resume interrupted jobs after server boot |
157 |
|
|
* Sun Aug 07 2011 Michael Weinberger 3.1.0-1 |
158 |
|
|
- introduced status 'interrupted'(with --status) |
159 |
|
|
* Fri Aug 05 2011 Michael Weinberger 3.1.0-0 |
160 |
|
|
- Release of 3.1.0 |
161 |
|
|
* Thu Aug 04 2011 Michael Weinberger 3.0.2-14 |
162 |
|
|
- de-duplicate, execPreJobCommand and execPostJobCommand only on scheduled run |
163 |
|
|
- removed Command arg from sample scripts |
164 |
|
|
- Fixed: Concatenated config in /tmp was world readable |
165 |
|
|
- De-duplication info added to --show-schedule |
166 |
|
|
* Tue Aug 02 2011 Michael Weinberger 3.0.2-6 |
167 |
|
|
- De-Duplication (freedup) |
168 |
|
|
- De-Dup info in --status and --list-archives |
169 |
|
|
- --status: only show enabled jobs. All with --all |
170 |
|
|
- Fix: property globalStatus was not working |
171 |
|
|
- Running state rsync or de-deduplicating display in --status |
172 |
|
|
- Show de-deduplicating busy in --list-archives for scheduled.0 |
173 |
|
|
- new property dedupKill. When set no, --kill does not kill a job when de-duplicating |
174 |
|
|
- new option --show-property |
175 |
|
|
|
176 |
|
|
* Wed Jul 27 2011 Michael Weinberger 3.0.1-7 |
177 |
|
|
- Bug fixes: RemoteUser was not always used in ssh commands |
178 |
|
|
|
179 |
|
|
* Sun Jul 24 2011 Michael Weinberger 3.0.1-6 |
180 |
|
|
- fixed bug in affa --status |
181 |
|
|
- GlobalAffaConfig was mounted as Samba share |
182 |
|
|
- call setupSamba() only in cronSetup() |
183 |
|
|
- updated man |
184 |
|
|
|
185 |
|
|
* Sat Jul 23 2011 Michael Weinberger 3.0.1-5 |
186 |
|
|
- new key NRPEtrigger |
187 |
|
|
- full affa path required when starting re-run from cronjob |
188 |
|
|
- improved deletion of shift out archives, --delete-job and --cleanup |
189 |
|
|
- added --single-transaction to /etc/affa/scripts/mysql-dump-tables |
190 |
vip-ire |
1.1 |
|
191 |
stephdl |
1.2 |
* Wed Jul 20 2011 Michael Weinberger 3.0.0-0 |
192 |
|
|
- generic linux version made from Affa 2.0 (SME Version) |
193 |
vip-ire |
1.1 |
|
194 |
|
|
* Mon Apr 02 2007 Michael Weinberger |
195 |
stephdl |
1.2 |
- bash version re-written in Perl |
196 |
vip-ire |
1.1 |
|