1 |
# $Id: smeserver-ajaxterm.spec,v 1.4 2013/06/27 00:09:08 unnilennium Exp $ |
2 |
# Authority: mweinber |
3 |
# Name: Michael Weinberger |
4 |
|
5 |
Summary: ajaxterm is a web-based terminal |
6 |
%define realname smeserver-ajaxterm |
7 |
%define version 1.0.5 |
8 |
%define release 6 |
9 |
Name: %{realname} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
BuildArch: noarch |
13 |
License: GPL |
14 |
Group: System Environment/Libraries |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Source1: Ajaxterm-0.10.tar.gz |
17 |
Patch0: smeserver-ajaxterm-1.0.5-DocumentationFromSpecFile.patch |
18 |
Patch1: smeserver-ajaxterm-1.0.5-patch1.patch |
19 |
Patch2: smeserver-ajaxterm-1.0.5-patch2.patch |
20 |
Patch3: smeserver-ajaxterm-1.0.5-patch3.patch |
21 |
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot |
22 |
URL: http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm |
23 |
Requires: smeserver-release > 7.1.3 |
24 |
BuildRequires: e-smith-devtools |
25 |
BuildRequires: python2-devel python-setuptools |
26 |
|
27 |
%changelog |
28 |
* Thu Jun 27 2013 JP Pialasse <tests@pialasse.com> 1.0.5-6 |
29 |
- fix Allowoverride [SME: 7711] |
30 |
- patch3 |
31 |
|
32 |
* Wed Jun 26 2013 JP Pialasse <tests@pialasse.com> 1.0.5-5 |
33 |
- fix lib64 issue to auth [SME: 7309 ] |
34 |
- patch2 |
35 |
|
36 |
* Wed Feb 06 2013 JP Pialasse <tests@pialasse.com> 1.0.5-4 |
37 |
- fix user ajaxterm [SME: 6442] |
38 |
- creating default database |
39 |
|
40 |
* Tue Feb 05 2013 JP Pialasse <tests@pialasse.com> 1.0.5-3 |
41 |
- import into SME8 tree [SME: 7309] |
42 |
- fix brp-python in spec file |
43 |
|
44 |
* Sat Mar 01 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 1.0.5-2 |
45 |
- Moved documentation from spec file |
46 |
- Changed description (copied from http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm) |
47 |
- Fixed whitelines in changelog between entries |
48 |
|
49 |
* Fri Feb 29 2008 Michael Weinberger <mweinber@neddix.de> 1.0.5-1 |
50 |
Fix spec file |
51 |
|
52 |
* Thu Nov 15 2007 Michael Weinberger <mweinber@neddix.de> |
53 |
Version 1.0.5 |
54 |
Bug fix: SysV start: do not fall back do user root if user ajaxterm does not exist |
55 |
added config properties 'width' and 'height' |
56 |
|
57 |
* Thu Nov 15 2007 Michael Weinberger <mweinber@neddix.de> |
58 |
Version 1.0.4 |
59 |
added config property basicAuthUsers |
60 |
|
61 |
* Wed Nov 14 2007 Michael Weinberger <mweinber@neddix.de> |
62 |
Version 1.0.3 |
63 |
added config properties allowOnlyLocalhost and servicePort |
64 |
login with 'su' when localhost, otherwise with ssh |
65 |
Promtps for SSHPort at ssh login |
66 |
|
67 |
%description |
68 |
Ajaxterm is a web based terminal. It was totally inspired and works almost exactly like http://anyterm.org/ except it's much easier to install (see comparaison with anyterm below). |
69 |
|
70 |
%pre |
71 |
if ! /usr/bin/id ajaxterm &>/dev/null; then |
72 |
/usr/sbin/useradd -c 'Ajaxterm User' -s /sbin/nologin -r -d /opt/ajaxterm ajaxterm &>/dev/null || \ |
73 |
%logmsg "Unexpected error adding user \"ajaxterm\". Abort installation." |
74 |
fi |
75 |
|
76 |
%prep |
77 |
%setup -n %{realname}-%{version} |
78 |
%patch0 -p1 |
79 |
%patch1 -p1 |
80 |
%patch2 -p1 |
81 |
%patch3 -p1 |
82 |
|
83 |
%build |
84 |
|
85 |
%install |
86 |
rm -rf $RPM_BUILD_ROOT |
87 |
tar xzvf $RPM_SOURCE_DIR/Ajaxterm-0.10.tar.gz |
88 |
mv Ajaxterm-0.10/* root/opt/ajaxterm |
89 |
rm -rf Ajaxterm-0.10 |
90 |
ls root/opt/ajaxterm |
91 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
92 |
rm -f %{name}-%{version}-filelist |
93 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
94 |
--dir /opt/ajaxterm 'attr(0750,ajaxterm,www)' \ |
95 |
--file /opt/ajaxterm/ 'attr(0640,ajaxterm,www)' \ |
96 |
--file /opt/ajaxterm/ajaxterm.py 'attr(0550,ajaxterm,www)' \ |
97 |
--file /opt/ajaxterm/login.pl 'attr(0550,ajaxterm,www)' \ |
98 |
--dir /usr/share/doc/smeserver-ajaxterm-1.0.5 'attr(0755,root,root)' \ |
99 |
>> %{name}-%{version}-filelist |
100 |
find $RPM_BUILD_ROOT -depth -type l -print |
101 |
# following make 4 files listed twice, and show no more |
102 |
#find $RPM_BUILD_ROOT -depth -type l -print |\ |
103 |
# sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist |
104 |
cat %{name}-%{version}-filelist |
105 |
/usr/lib/rpm/brp-python-bytecompile |
106 |
|
107 |
%clean |
108 |
[ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT |
109 |
|
110 |
%files -f %{name}-%{version}-filelist |
111 |
%defattr(-,root,root) |
112 |
#following make folder listed twice |
113 |
#%attr(0755,root,root) %doc %dir /usr/share/doc/smeserver-ajaxterm-1.0.5/ |
114 |
|
115 |
|