1 |
# $Id: smeserver-ajaxterm.spec,v 1.1 2013/11/12 19:00:52 vip-ire Exp $ |
2 |
# Authority: mweinber |
3 |
# Name: Michael Weinberger |
4 |
|
5 |
Summary: ajaxterm is a web-based terminal |
6 |
%define realname smeserver-ajaxterm |
7 |
%define version 1.0.5 |
8 |
%define release 7 |
9 |
Name: %{realname} |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
BuildArch: noarch |
13 |
License: GPL |
14 |
Group: System Environment/Libraries |
15 |
Source: %{name}-%{version}.tar.gz |
16 |
Source1: Ajaxterm-0.10.tar.gz |
17 |
Patch0: smeserver-ajaxterm-1.0.5-DocumentationFromSpecFile.patch |
18 |
Patch1: smeserver-ajaxterm-1.0.5-patch1.patch |
19 |
Patch2: smeserver-ajaxterm-1.0.5-patch2.patch |
20 |
Patch3: smeserver-ajaxterm-1.0.5-patch3.patch |
21 |
Patch4: smeserver-ajaxterm-1.0.5-auth.patch |
22 |
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot |
23 |
URL: http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm |
24 |
Requires: smeserver-release > 7.1.3 |
25 |
BuildRequires: e-smith-devtools |
26 |
BuildRequires: python2-devel python-setuptools |
27 |
|
28 |
%changelog |
29 |
* Mon Jun 13 2016 Jean-Philipe Pialasse <tests@pialasse.com> 1.0.5-7.sme |
30 |
- fix [SME: 8899] |
31 |
- smeserver-ajaxterm-1.0.5-auth.patch |
32 |
|
33 |
* Thu Jun 27 2013 JP Pialasse <tests@pialasse.com> 1.0.5-6 |
34 |
- fix Allowoverride [SME: 7711] |
35 |
- patch3 |
36 |
|
37 |
* Wed Jun 26 2013 JP Pialasse <tests@pialasse.com> 1.0.5-5 |
38 |
- fix lib64 issue to auth [SME: 7309 ] |
39 |
- patch2 |
40 |
|
41 |
* Wed Feb 06 2013 JP Pialasse <tests@pialasse.com> 1.0.5-4 |
42 |
- fix user ajaxterm [SME: 6442] |
43 |
- creating default database |
44 |
|
45 |
* Tue Feb 05 2013 JP Pialasse <tests@pialasse.com> 1.0.5-3 |
46 |
- import into SME8 tree [SME: 7309] |
47 |
- fix brp-python in spec file |
48 |
|
49 |
* Sat Mar 01 2008 Jonathan Martens <smeserver-contribs@snetram.nl> 1.0.5-2 |
50 |
- Moved documentation from spec file |
51 |
- Changed description (copied from http://antony.lesuisse.org/qweb/trac/wiki/AjaxTerm) |
52 |
- Fixed whitelines in changelog between entries |
53 |
|
54 |
* Fri Feb 29 2008 Michael Weinberger <mweinber@neddix.de> 1.0.5-1 |
55 |
Fix spec file |
56 |
|
57 |
* Thu Nov 15 2007 Michael Weinberger <mweinber@neddix.de> |
58 |
Version 1.0.5 |
59 |
Bug fix: SysV start: do not fall back do user root if user ajaxterm does not exist |
60 |
added config properties 'width' and 'height' |
61 |
|
62 |
* Thu Nov 15 2007 Michael Weinberger <mweinber@neddix.de> |
63 |
Version 1.0.4 |
64 |
added config property basicAuthUsers |
65 |
|
66 |
* Wed Nov 14 2007 Michael Weinberger <mweinber@neddix.de> |
67 |
Version 1.0.3 |
68 |
added config properties allowOnlyLocalhost and servicePort |
69 |
login with 'su' when localhost, otherwise with ssh |
70 |
Promtps for SSHPort at ssh login |
71 |
|
72 |
%description |
73 |
Ajaxterm is a web based terminal. It was totally inspired and works almost exactly like http://anyterm.org/ except it's much easier to install (see comparaison with anyterm below). |
74 |
|
75 |
%pre |
76 |
if ! /usr/bin/id ajaxterm &>/dev/null; then |
77 |
/usr/sbin/useradd -c 'Ajaxterm User' -s /sbin/nologin -r -d /opt/ajaxterm ajaxterm &>/dev/null || \ |
78 |
%logmsg "Unexpected error adding user \"ajaxterm\". Abort installation." |
79 |
fi |
80 |
|
81 |
%prep |
82 |
%setup -n %{realname}-%{version} |
83 |
%patch0 -p1 |
84 |
%patch1 -p1 |
85 |
%patch2 -p1 |
86 |
%patch3 -p1 |
87 |
%patch4 -p1 |
88 |
|
89 |
%build |
90 |
|
91 |
%install |
92 |
rm -rf $RPM_BUILD_ROOT |
93 |
tar xzvf $RPM_SOURCE_DIR/Ajaxterm-0.10.tar.gz |
94 |
mv Ajaxterm-0.10/* root/opt/ajaxterm |
95 |
rm -rf Ajaxterm-0.10 |
96 |
ls root/opt/ajaxterm |
97 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
98 |
rm -f %{name}-%{version}-filelist |
99 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
100 |
--dir /opt/ajaxterm 'attr(0750,ajaxterm,www)' \ |
101 |
--file /opt/ajaxterm/ 'attr(0640,ajaxterm,www)' \ |
102 |
--file /opt/ajaxterm/ajaxterm.py 'attr(0550,ajaxterm,www)' \ |
103 |
--file /opt/ajaxterm/login.pl 'attr(0550,ajaxterm,www)' \ |
104 |
--dir /usr/share/doc/smeserver-ajaxterm-1.0.5 'attr(0755,root,root)' \ |
105 |
>> %{name}-%{version}-filelist |
106 |
find $RPM_BUILD_ROOT -depth -type l -print |
107 |
# following make 4 files listed twice, and show no more |
108 |
#find $RPM_BUILD_ROOT -depth -type l -print |\ |
109 |
# sed "s@^$RPM_BUILD_ROOT@@g" >> %{name}-%{version}-filelist |
110 |
cat %{name}-%{version}-filelist |
111 |
/usr/lib/rpm/brp-python-bytecompile |
112 |
|
113 |
%clean |
114 |
[ "$RPM_BUILD_ROOT" != "/" ] && %{__rm} -rf $RPM_BUILD_ROOT |
115 |
|
116 |
%files -f %{name}-%{version}-filelist |
117 |
%defattr(-,root,root) |
118 |
#following make folder listed twice |
119 |
#%attr(0755,root,root) %doc %dir /usr/share/doc/smeserver-ajaxterm-1.0.5/ |
120 |
|
121 |
|