1 |
# $Id: smeserver-arpwatch.spec,v 1.11 2022/07/26 03:35:50 terryfage Exp $ |
2 |
# Authority: vip-ire |
3 |
# Name: Daniel Berteaud |
4 |
|
5 |
Summary: Arpwatch is a tool that monitors ethernet activity |
6 |
%define name smeserver-arpwatch |
7 |
Name: %{name} |
8 |
%define version 0.3 |
9 |
%define release 9 |
10 |
Version: %{version} |
11 |
Release: %{release}%{?dist} |
12 |
License: GPL |
13 |
Group: Monitoring |
14 |
Source: %{name}-%{version}.tar.gz |
15 |
Patch0: smeserver-arpwatch-0.3-Add-in-systemd-stuff.patch |
16 |
Patch1: smeserver-arpwatch-0.3-Add-After-in-service-file-to-delay-startup.patch |
17 |
Patch2: smeserver-arpwatch-0.3-Log-bz11949.patch |
18 |
Patch3: smeserver-arpwatch-0.3-Log2-bz11949.patch |
19 |
Patch4: smeserver-arpwatch-bz12261-partof-network-restart5.patch |
20 |
|
21 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
22 |
BuildArchitectures: noarch |
23 |
|
24 |
BuildRequires: e-smith-devtools |
25 |
|
26 |
Requires: e-smith-base |
27 |
Requires: arpwatch |
28 |
|
29 |
%description |
30 |
Arpwatch is a tool that monitors ethernet activity and keeps |
31 |
a database of ethernet/ip address pairings. |
32 |
It also reports certain changes via email. |
33 |
Arpwatch uses libpcap, a system-independent interface for |
34 |
user-level packet capture. |
35 |
|
36 |
%changelog |
37 |
* Thu Dec 22 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 0.3-9.sme |
38 |
- Arpwatch fails on network restart patch [SME: 12261] |
39 |
|
40 |
* Tue Jul 26 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 0.3-8.sme |
41 |
- 2nd typo fix added, part of previous patch [SME: 11949] |
42 |
|
43 |
* Tue Jul 19 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 0.3-7.sme |
44 |
- typo fix added, part of previous patch [SME: 11949] |
45 |
|
46 |
* Mon Jul 18 2022 zsolt vasarhelyi <vasarhelyizsolt@hotmail.com> 0.3-6.sme |
47 |
- arpwatch logs to messages, typo fix added [SME: 11949] |
48 |
|
49 |
* Sat Feb 27 2021 Brian Read <brianr@bjsystems.co.uk> 0.3-5.sme |
50 |
- Fix service dropin file with proper extension [SME: 11026] |
51 |
|
52 |
* Fri Feb 26 2021 Brian Read <brianr@bjsystems.co.uk> 0.3-4.sme |
53 |
- Add-After-in-service-file-to-delay-startup [SME: 11026] |
54 |
|
55 |
* Tue Feb 02 2021 Brian Read <brianr@bjsystems.co.uk> 0.3-3.sme |
56 |
- Add in Createlink stuff for systemd [SME: 11026] |
57 |
|
58 |
* Wed Nov 04 2020 Brian Read <brianr@bjsystems.co.uk> 0.3-2.sme |
59 |
- Add in systemd startup for arpwatch to spec file [SME: 11026] |
60 |
|
61 |
* Mon Oct 12 2020 John Crisp <jcrisp@safeandsoundit.co.uk> 0.3-1.sme |
62 |
- based on work by Brian Read [SME: 11026] |
63 |
- Build for Koozali SME v10 |
64 |
- remove createlinks safetouch to fix conflict |
65 |
- remove /var/lib/arpwatch lines in genfilelist |
66 |
|
67 |
* Mon Sep 07 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.2-3.sme |
68 |
- changed the user pcap to arpwatch [SME: 8429] |
69 |
|
70 |
* Mon Jun 16 2014 JP Pialasse <tests@pialasse.com> 0.2-1.sme |
71 |
- initial import to SME9 contribs |
72 |
|
73 |
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
74 |
- Add e-smith-devtools as a build dependency |
75 |
|
76 |
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
77 |
- Service not supervised (as the only option to disable forking is -d |
78 |
which also disable email alerts) |
79 |
|
80 |
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-0] |
81 |
- Initial release |
82 |
|
83 |
%prep |
84 |
|
85 |
%setup -q -n %{name}-%{version} |
86 |
%patch0 -p1 |
87 |
%patch1 -p1 |
88 |
%patch2 -p1 |
89 |
%patch3 -p1 |
90 |
%patch4 -p1 |
91 |
|
92 |
%build |
93 |
perl createlinks |
94 |
|
95 |
%install |
96 |
/bin/rm -rf $RPM_BUILD_ROOT |
97 |
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
98 |
/bin/rm -f %{name}-%{version}-filelist |
99 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
100 |
> %{name}-%{version}-filelist |
101 |
|
102 |
%files -f %{name}-%{version}-filelist |
103 |
%defattr(-,root,root) |
104 |
|
105 |
%clean |
106 |
rm -rf $RPM_BUILD_ROOT |
107 |
%pre |
108 |
|
109 |
%post |
110 |
#systemctl enable arpwatch |
111 |
#systemctl start arpwatch |
112 |
|
113 |
%preun |
114 |
if [ $1 -eq 0 ] ; then |
115 |
/sbin/e-smith/db configuration setprop arpwatch status disabled |
116 |
#/etc/init.d/arpwatch stop |
117 |
fi |
118 |
|
119 |
true |