1 |
vip-ire |
1.3 |
# $Id: smeserver-arpwatch.spec,v 1.2 2009/03/02 23:53:29 slords Exp $ |
2 |
slords |
1.2 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: Arpwatch is a tool that monitors ethernet activity |
6 |
|
|
%define name smeserver-arpwatch |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.1 |
9 |
vip-ire |
1.3 |
%define release 2 |
10 |
slords |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Monitoring |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
|
16 |
|
|
Patch0: smeserver-arpwatch-0.1-not_supervised.patch |
17 |
|
|
|
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
BuildArchitectures: noarch |
20 |
vip-ire |
1.3 |
|
21 |
|
|
BuildRequires: e-smith-devtools |
22 |
|
|
|
23 |
slords |
1.1 |
Requires: e-smith-base |
24 |
|
|
Requires: arpwatch |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Arpwatch is a tool that monitors ethernet activity and keeps |
28 |
|
|
a database of ethernet/ip address pairings. |
29 |
|
|
It also reports certain changes via email. |
30 |
|
|
Arpwatch uses libpcap, a system-independent interface for |
31 |
|
|
user-level packet capture. |
32 |
|
|
|
33 |
|
|
%changelog |
34 |
vip-ire |
1.3 |
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
35 |
|
|
- Add e-smith-devtools as a build dependency |
36 |
|
|
|
37 |
slords |
1.1 |
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
38 |
|
|
- Service not supervised (as the only option to disable forking is -d |
39 |
|
|
which also disable email alerts) |
40 |
|
|
|
41 |
|
|
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-0] |
42 |
|
|
- Initial release |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
|
46 |
|
|
%setup -q -n %{name}-%{version} |
47 |
|
|
%patch0 -p1 |
48 |
|
|
|
49 |
|
|
%build |
50 |
|
|
perl createlinks |
51 |
|
|
|
52 |
|
|
%install |
53 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
54 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
55 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
56 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
57 |
|
|
--dir /var/lib/arpwatch 'attr(0750,pcap,pcap)' \ |
58 |
|
|
--file /var/lib/arpwatch/arp.dat 'attr(0750,pcap,pcap) %config(noreplace)' \ |
59 |
|
|
> %{name}-%{version}-filelist |
60 |
|
|
|
61 |
|
|
%files -f %{name}-%{version}-filelist |
62 |
|
|
%defattr(-,root,root) |
63 |
|
|
|
64 |
|
|
%clean |
65 |
|
|
rm -rf $RPM_BUILD_ROOT |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
%post |
69 |
|
|
|
70 |
|
|
%preun |
71 |
|
|
if [ $1 -eq 0 ] ; then |
72 |
|
|
/sbin/e-smith/db configuration setprop arpwatch status disabled |
73 |
|
|
/etc/init.d/arpwatch stop |
74 |
|
|
fi |
75 |
|
|
|
76 |
|
|
true |
77 |
|
|
|