1 |
vip-ire |
1.2 |
# $Id: smeserver-arpwatch.spec,v 1.1 2013/11/12 18:44:35 vip-ire Exp $ |
2 |
vip-ire |
1.1 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
Summary: Arpwatch is a tool that monitors ethernet activity |
6 |
|
|
%define name smeserver-arpwatch |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.2 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Monitoring |
14 |
vip-ire |
1.2 |
Source: %{name}-%{version}.tar.xz |
15 |
vip-ire |
1.1 |
|
16 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
BuildArchitectures: noarch |
18 |
|
|
|
19 |
|
|
BuildRequires: e-smith-devtools |
20 |
|
|
|
21 |
|
|
Requires: e-smith-base |
22 |
|
|
Requires: arpwatch |
23 |
|
|
|
24 |
|
|
%description |
25 |
|
|
Arpwatch is a tool that monitors ethernet activity and keeps |
26 |
|
|
a database of ethernet/ip address pairings. |
27 |
|
|
It also reports certain changes via email. |
28 |
|
|
Arpwatch uses libpcap, a system-independent interface for |
29 |
|
|
user-level packet capture. |
30 |
|
|
|
31 |
|
|
%changelog |
32 |
|
|
* Tue Nov 12 2013 Daniel B. <daniel@firewall-services.com> [0.2-1] |
33 |
|
|
- Rebuild for SME9 |
34 |
|
|
|
35 |
|
|
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
36 |
|
|
- Add e-smith-devtools as a build dependency |
37 |
|
|
|
38 |
|
|
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
39 |
|
|
- Service not supervised (as the only option to disable forking is -d |
40 |
|
|
which also disable email alerts) |
41 |
|
|
|
42 |
|
|
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-0] |
43 |
|
|
- Initial release |
44 |
|
|
|
45 |
|
|
%prep |
46 |
|
|
|
47 |
|
|
%setup -q -n %{name}-%{version} |
48 |
|
|
|
49 |
|
|
%build |
50 |
|
|
perl createlinks |
51 |
|
|
|
52 |
|
|
%install |
53 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
54 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
55 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
56 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
57 |
|
|
--dir /var/lib/arpwatch 'attr(0750,pcap,pcap)' \ |
58 |
|
|
--file /var/lib/arpwatch/arp.dat 'attr(0750,pcap,pcap) %config(noreplace)' \ |
59 |
|
|
> %{name}-%{version}-filelist |
60 |
|
|
|
61 |
|
|
%files -f %{name}-%{version}-filelist |
62 |
|
|
%defattr(-,root,root) |
63 |
|
|
|
64 |
|
|
%clean |
65 |
|
|
rm -rf $RPM_BUILD_ROOT |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
%post |
69 |
|
|
|
70 |
|
|
%preun |
71 |
|
|
if [ $1 -eq 0 ] ; then |
72 |
|
|
/sbin/e-smith/db configuration setprop arpwatch status disabled |
73 |
|
|
/etc/init.d/arpwatch stop |
74 |
|
|
fi |
75 |
|
|
|
76 |
|
|
true |
77 |
|
|
|