1 |
stephdl |
1.5 |
# $Id: smeserver-arpwatch.spec,v 1.4 2015/09/07 19:16:40 stephdl Exp $ |
2 |
vip-ire |
1.1 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
Summary: Arpwatch is a tool that monitors ethernet activity |
6 |
|
|
%define name smeserver-arpwatch |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 0.2 |
9 |
stephdl |
1.5 |
%define release 3 |
10 |
vip-ire |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: GPL |
13 |
|
|
Group: Monitoring |
14 |
unnilennium |
1.3 |
Source: %{name}-%{version}.tar.gz |
15 |
stephdl |
1.5 |
Patch0: smeserver-arpwatch-0.2.bz8429.change-user2arpwatch.patch |
16 |
unnilennium |
1.3 |
#REM contribs9 Patch0: smeserver-arpwatch-0.2-not_supervised.patch |
17 |
vip-ire |
1.1 |
|
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
BuildArchitectures: noarch |
20 |
|
|
|
21 |
|
|
BuildRequires: e-smith-devtools |
22 |
|
|
|
23 |
|
|
Requires: e-smith-base |
24 |
|
|
Requires: arpwatch |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
Arpwatch is a tool that monitors ethernet activity and keeps |
28 |
|
|
a database of ethernet/ip address pairings. |
29 |
|
|
It also reports certain changes via email. |
30 |
|
|
Arpwatch uses libpcap, a system-independent interface for |
31 |
|
|
user-level packet capture. |
32 |
|
|
|
33 |
|
|
%changelog |
34 |
stephdl |
1.5 |
* Mon Sep 07 2015 stephane de Labrusse <stephdl@de-labrusse.fr> 0.2-3.sme |
35 |
stephdl |
1.4 |
- changed the user pcap to arpwatch [SME: 8429] |
36 |
|
|
|
37 |
unnilennium |
1.3 |
* Mon Jun 16 2014 JP Pialasse <tests@pialasse.com> 0.2-1.sme |
38 |
|
|
- initial import to SME9 contribs |
39 |
vip-ire |
1.1 |
|
40 |
|
|
* Tue Mar 03 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
41 |
|
|
- Add e-smith-devtools as a build dependency |
42 |
|
|
|
43 |
|
|
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-1] |
44 |
|
|
- Service not supervised (as the only option to disable forking is -d |
45 |
|
|
which also disable email alerts) |
46 |
|
|
|
47 |
|
|
* Tue Jan 27 2009 Daniel B. <daniel@firewall-services.com> [0.1-0] |
48 |
|
|
- Initial release |
49 |
|
|
|
50 |
|
|
%prep |
51 |
|
|
|
52 |
|
|
%setup -q -n %{name}-%{version} |
53 |
unnilennium |
1.3 |
#REM contribs9 %patch0 -p1 |
54 |
stephdl |
1.5 |
%patch0 -p1 |
55 |
vip-ire |
1.1 |
|
56 |
|
|
%build |
57 |
|
|
perl createlinks |
58 |
|
|
|
59 |
|
|
%install |
60 |
|
|
/bin/rm -rf $RPM_BUILD_ROOT |
61 |
|
|
(cd root ; /usr/bin/find . -depth -print | /bin/cpio -dump $RPM_BUILD_ROOT) |
62 |
|
|
/bin/rm -f %{name}-%{version}-filelist |
63 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
64 |
stephdl |
1.4 |
--dir /var/lib/arpwatch 'attr(0750,arpwatch,arpwatch)' \ |
65 |
|
|
--file /var/lib/arpwatch/arp.dat 'attr(0750,arpwatch,arpwatch) %config(noreplace)' \ |
66 |
vip-ire |
1.1 |
> %{name}-%{version}-filelist |
67 |
|
|
|
68 |
|
|
%files -f %{name}-%{version}-filelist |
69 |
|
|
%defattr(-,root,root) |
70 |
|
|
|
71 |
|
|
%clean |
72 |
|
|
rm -rf $RPM_BUILD_ROOT |
73 |
stephdl |
1.4 |
%pre |
74 |
vip-ire |
1.1 |
|
75 |
|
|
%post |
76 |
|
|
|
77 |
|
|
%preun |
78 |
|
|
if [ $1 -eq 0 ] ; then |
79 |
|
|
/sbin/e-smith/db configuration setprop arpwatch status disabled |
80 |
|
|
/etc/init.d/arpwatch stop |
81 |
|
|
fi |
82 |
|
|
|
83 |
|
|
true |
84 |
|
|
|