1 |
Summary: base for SME server |
2 |
%define name smeserver-base |
3 |
Name: %{name} |
4 |
%define version 1.2.2 |
5 |
%define release 1 |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
License: Freely distributable |
9 |
Group: Apache |
10 |
Source: %{name}-%{version}.tar.gz |
11 |
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
12 |
BuildRoot: /var/tmp/e-smith-buildroot |
13 |
BuildRequires: e-smith-devtools |
14 |
BuildArchitectures: noarch |
15 |
Requires: smeserver-release >= 7, smeserver-snort > 2.4 |
16 |
AutoReqProv: no |
17 |
|
18 |
%changelog |
19 |
* Sat Mar 03 2006 Michel Van hees <mvanhees@vanhees.homeip.net> |
20 |
- initial release |
21 |
|
22 |
%description |
23 |
SME server - base for snort |
24 |
|
25 |
%prep |
26 |
%setup |
27 |
#%patch0 -p1 |
28 |
#%patch1 -p1 |
29 |
|
30 |
%build |
31 |
perl createlinks |
32 |
|
33 |
%install |
34 |
rm -rf $RPM_BUILD_ROOT |
35 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
36 |
rm -f %{name}-%{version}-filelist |
37 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
38 |
echo "%doc COPYING" >> %{name}-%{version}-filelist |
39 |
|
40 |
%clean |
41 |
rm -rf $RPM_BUILD_ROOT |
42 |
|
43 |
%pre |
44 |
|
45 |
%preun |
46 |
|
47 |
%post |
48 |
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
49 |
/sbin/e-smith/expand-template /opt/administration/base/base_conf.php |
50 |
service httpd-e-smith restart |
51 |
echo ---------------------------------------------------------------- |
52 |
echo -- modify database to fit with base -- |
53 |
echo ---------------------------------------------------------------- |
54 |
mysql snort_log < /opt/administration/base/sql/create_base_tbls_mysql.sql |
55 |
mysql snort_archive < /opt/administration/base/sql/create_base_tbls_mysql.sql |
56 |
echo ---------------------------------------------------------------- |
57 |
echo -- installing pear package -- |
58 |
echo ---------------------------------------------------------------- |
59 |
/usr/bin/pear install /opt/administration/base/add_pkgs/Image_Color-1.0.2.tgz |
60 |
/usr/bin/pear install /opt/administration/base/add_pkgs/Image_Canvas-0.3.0.tgz |
61 |
/usr/bin/pear install /opt/administration/base/add_pkgs/Numbers_Roman-1.0.1.tgz |
62 |
/usr/bin/pear install /opt/administration/base/add_pkgs/Numbers_Words-0.14.0.tgz |
63 |
/usr/bin/pear install /opt/administration/base/add_pkgs/Image_Graph-0.7.2.tgz |
64 |
echo ---------------------------------------------------------------- |
65 |
echo -- -- |
66 |
echo -- Installation complete -- |
67 |
echo -- -- |
68 |
echo -- Now you can acces base interface at -- |
69 |
echo -- https://server-ip-adress/base -- |
70 |
echo -- -- |
71 |
echo ---------------------------------------------------------------- |
72 |
|
73 |
|
74 |
%postun |
75 |
|
76 |
%files -f %{name}-%{version}-filelist |
77 |
%defattr(-,root,root) |