1 |
slords |
1.2 |
# $Id$ |
2 |
|
|
# Authority: nocvs |
3 |
|
|
# Name: Michel Van hees |
4 |
|
|
|
5 |
slords |
1.1 |
Summary: base for SME server |
6 |
|
|
%define name smeserver-base |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 1.2.2 |
9 |
|
|
%define release 1 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: Freely distributable |
13 |
|
|
Group: Apache |
14 |
|
|
Source: %{name}-%{version}.tar.gz |
15 |
|
|
#Patch0: %{name}-%{version}.patch.yyyymmddnn |
16 |
|
|
BuildRoot: /var/tmp/e-smith-buildroot |
17 |
|
|
BuildRequires: e-smith-devtools |
18 |
|
|
BuildArchitectures: noarch |
19 |
|
|
Requires: smeserver-release >= 7, smeserver-snort > 2.4 |
20 |
|
|
AutoReqProv: no |
21 |
|
|
|
22 |
|
|
%changelog |
23 |
|
|
* Sat Mar 03 2006 Michel Van hees <mvanhees@vanhees.homeip.net> |
24 |
|
|
- initial release |
25 |
|
|
|
26 |
|
|
%description |
27 |
|
|
SME server - base for snort |
28 |
|
|
|
29 |
|
|
%prep |
30 |
|
|
%setup |
31 |
|
|
#%patch0 -p1 |
32 |
|
|
#%patch1 -p1 |
33 |
|
|
|
34 |
|
|
%build |
35 |
|
|
perl createlinks |
36 |
|
|
|
37 |
|
|
%install |
38 |
|
|
rm -rf $RPM_BUILD_ROOT |
39 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
40 |
|
|
rm -f %{name}-%{version}-filelist |
41 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT > %{name}-%{version}-filelist |
42 |
|
|
echo "%doc COPYING" >> %{name}-%{version}-filelist |
43 |
|
|
|
44 |
|
|
%clean |
45 |
|
|
rm -rf $RPM_BUILD_ROOT |
46 |
|
|
|
47 |
|
|
%pre |
48 |
|
|
|
49 |
|
|
%preun |
50 |
|
|
|
51 |
|
|
%post |
52 |
|
|
/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf |
53 |
|
|
/sbin/e-smith/expand-template /opt/administration/base/base_conf.php |
54 |
|
|
service httpd-e-smith restart |
55 |
|
|
echo ---------------------------------------------------------------- |
56 |
|
|
echo -- modify database to fit with base -- |
57 |
|
|
echo ---------------------------------------------------------------- |
58 |
|
|
mysql snort_log < /opt/administration/base/sql/create_base_tbls_mysql.sql |
59 |
|
|
mysql snort_archive < /opt/administration/base/sql/create_base_tbls_mysql.sql |
60 |
|
|
echo ---------------------------------------------------------------- |
61 |
|
|
echo -- installing pear package -- |
62 |
|
|
echo ---------------------------------------------------------------- |
63 |
|
|
/usr/bin/pear install /opt/administration/base/add_pkgs/Image_Color-1.0.2.tgz |
64 |
|
|
/usr/bin/pear install /opt/administration/base/add_pkgs/Image_Canvas-0.3.0.tgz |
65 |
|
|
/usr/bin/pear install /opt/administration/base/add_pkgs/Numbers_Roman-1.0.1.tgz |
66 |
|
|
/usr/bin/pear install /opt/administration/base/add_pkgs/Numbers_Words-0.14.0.tgz |
67 |
|
|
/usr/bin/pear install /opt/administration/base/add_pkgs/Image_Graph-0.7.2.tgz |
68 |
|
|
echo ---------------------------------------------------------------- |
69 |
|
|
echo -- -- |
70 |
|
|
echo -- Installation complete -- |
71 |
|
|
echo -- -- |
72 |
|
|
echo -- Now you can acces base interface at -- |
73 |
|
|
echo -- https://server-ip-adress/base -- |
74 |
|
|
echo -- -- |
75 |
|
|
echo ---------------------------------------------------------------- |
76 |
|
|
|
77 |
|
|
|
78 |
|
|
%postun |
79 |
|
|
|
80 |
|
|
%files -f %{name}-%{version}-filelist |
81 |
|
|
%defattr(-,root,root) |