1 |
brianr |
1.1 |
# $Id: smeserver-bridge-interface.spec,v 1.1 2013/11/11 17:21:01 vip-ire Exp $ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
%define version 0.2 |
6 |
|
|
%define release 1 |
7 |
|
|
%define name smeserver-bridge-interface |
8 |
|
|
|
9 |
|
|
|
10 |
|
|
Summary: Configure a bridge interface |
11 |
|
|
Name: %{name} |
12 |
|
|
Version: %{version} |
13 |
|
|
Release: %{release}%{?dist} |
14 |
|
|
License: GPL |
15 |
|
|
Group: System/Servers |
16 |
|
|
Source: %{name}-%{version}.tar.xz |
17 |
|
|
|
18 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
19 |
|
|
URL: http://www.firewall-services.com/ |
20 |
|
|
|
21 |
|
|
BuildRequires: e-smith-devtools |
22 |
|
|
|
23 |
|
|
Requires: bridge-utils |
24 |
|
|
Requires: openvpn |
25 |
|
|
Buildarch: noarch |
26 |
|
|
Conflicts: smeserver-openvpn-bridge.fws |
27 |
|
|
Conflicts: smeserver-openvpn-bridge-fws |
28 |
|
|
AutoReqProv: no |
29 |
|
|
|
30 |
|
|
%description |
31 |
|
|
This package allows you to replace the internal interface with a bridge |
32 |
|
|
interface (and the original internal interface enslaved to it). |
33 |
|
|
It's usefull for OpenVPN in bridge mode but can also be used for virtual host |
34 |
|
|
configuration |
35 |
|
|
|
36 |
|
|
%changelog |
37 |
|
|
* Mon Nov 11 2013 Daniel B. <daniel@firewall-services.com> - 0.2-1.sme |
38 |
|
|
- Rebuild for SME9 |
39 |
|
|
|
40 |
|
|
* Tue Jun 19 2012 Daniel B. <daniel@firewall-services.com> - 0.1-6.sme |
41 |
|
|
- Wait after physical interface config |
42 |
|
|
(fix a random bug in serveronly mode) |
43 |
|
|
- Ensure the bridge takes the MAC address of the physical interface |
44 |
|
|
- Optionally set the bridge interface in promiscuous mode |
45 |
|
|
|
46 |
|
|
* Tue Apr 19 2011 Daniel B. <daniel@firewall-services.com> - 0.1-5.sme |
47 |
|
|
- Fix ifcfg templates expension on SME8 [SME: 6092] |
48 |
|
|
|
49 |
|
|
* Fri May 29 2009 Daniel B. <daniel@firewall-services.com> [0.1-4] |
50 |
|
|
- Enhance init script to display what it's doing (starting/stoping etc...) |
51 |
|
|
- Cleanup in spec file |
52 |
|
|
|
53 |
|
|
* Fri Jan 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-3] |
54 |
|
|
- Set default status to enabled |
55 |
|
|
|
56 |
|
|
* Mon Jan 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
57 |
|
|
- possibility to set multiple tap interfaces separated with commas |
58 |
|
|
|
59 |
|
|
* Fri Dec 12 2008 Daniel B. <daniel@firewall-services.com> [0.1-1] |
60 |
|
|
- Set the Name of InternalInterface to br0 when starting |
61 |
|
|
- Do not set the Name of InternalInterface to br0 if service is disabled |
62 |
|
|
(during databases initialization) |
63 |
|
|
|
64 |
|
|
* Tue Dec 02 2008 Daniel B. <daniel@firewall-services.com> [0.1-0] |
65 |
|
|
- initial release |
66 |
|
|
|
67 |
|
|
%prep |
68 |
|
|
|
69 |
|
|
%setup -q -n %{name}-%{version} |
70 |
|
|
|
71 |
|
|
%build |
72 |
|
|
# Build symlinks |
73 |
|
|
perl createlinks |
74 |
|
|
|
75 |
|
|
%install |
76 |
|
|
rm -rf $RPM_BUILD_ROOT |
77 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
78 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
79 |
|
|
> %{name}-%{version}-%{release}-filelist |
80 |
|
|
|
81 |
|
|
%clean |
82 |
|
|
rm -rf $RPM_BUILD_ROOT |
83 |
|
|
|
84 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
85 |
|
|
%defattr(-,root,root) |
86 |
|
|
|
87 |
|
|
|
88 |
|
|
%post |
89 |
|
|
|
90 |
|
|
%preun |
91 |
|
|
if [ $1 = 0 ] ; then |
92 |
|
|
/etc/rc.d/init.d/bridge stop >& /dev/null || : |
93 |
|
|
fi |
94 |
|
|
|
95 |
|
|
true |
96 |
|
|
|