1 |
slords |
1.1 |
# Authority: vip-ire |
2 |
|
|
# Name: Daniel Berteaud |
3 |
|
|
|
4 |
|
|
|
5 |
|
|
%define version 0.1 |
6 |
|
|
%define release 3 |
7 |
|
|
%define name smeserver-bridge-interface |
8 |
|
|
|
9 |
|
|
|
10 |
|
|
Summary: Configure a bridge interface |
11 |
|
|
Name: %{name} |
12 |
|
|
Version: %{version} |
13 |
|
|
Release: %{release}%{?dist} |
14 |
|
|
License: GPL |
15 |
|
|
Group: System/Servers |
16 |
|
|
Source: %{name}-%{version}.tar.gz |
17 |
|
|
|
18 |
|
|
Patch0: smeserver-bridge-interface-0.1-set_internal_to_br.patch |
19 |
|
|
Patch1: smeserver-bridge-interface-0.1-migrate_db_when_disabled.patch |
20 |
|
|
Patch2: smeserver-bridge-interface-0.1-init_script.patch |
21 |
|
|
Patch3: smeserver-bridge-interface-0.1-status_enabled.patch |
22 |
|
|
|
23 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
24 |
|
|
URL: http://www.freepbx.org/ |
25 |
|
|
|
26 |
|
|
BuildRequires: e-smith-devtools |
27 |
|
|
|
28 |
|
|
Requires: bridge-utils |
29 |
|
|
Requires: openvpn |
30 |
|
|
Buildarch: noarch |
31 |
|
|
Conflicts: smeserver-openvpn-bridge.fws |
32 |
|
|
Conflicts: smeserver-openvpn-bridge-fws |
33 |
|
|
AutoReqProv: no |
34 |
|
|
|
35 |
|
|
%description |
36 |
|
|
This package allows you to replace the internal interface with a bridge |
37 |
|
|
interface (and the original internal interface enslaved to it). |
38 |
|
|
It's usefull for OpenVPN in bridge mode but can also be used for virtual host |
39 |
|
|
configuration |
40 |
|
|
|
41 |
|
|
%changelog |
42 |
|
|
* Fri Jan 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-3] |
43 |
|
|
- Set default status to enabled |
44 |
|
|
|
45 |
|
|
* Mon Jan 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
46 |
|
|
- possibility to set multiple tap interfaces separated with commas |
47 |
|
|
|
48 |
|
|
* Fri Dec 12 2008 Daniel B. <daniel@firewall-services.com> [0.1-1] |
49 |
|
|
- Set the Name of InternalInterface to br0 when starting |
50 |
|
|
- Do not set the Name of InternalInterface to br0 if service is disabled |
51 |
|
|
(during databases initialization) |
52 |
|
|
|
53 |
|
|
* Tue Dec 02 2008 Daniel B. <daniel@firewall-services.com> [0.1-0] |
54 |
|
|
- initial release |
55 |
|
|
|
56 |
|
|
%prep |
57 |
|
|
|
58 |
|
|
%setup -q -n %{name}-%{version} |
59 |
|
|
%patch0 -p1 |
60 |
|
|
%patch1 -p1 |
61 |
|
|
%patch2 -p1 |
62 |
|
|
%patch3 -p1 |
63 |
|
|
|
64 |
|
|
%build |
65 |
|
|
# Build symlinks |
66 |
|
|
perl createlinks |
67 |
|
|
|
68 |
|
|
%install |
69 |
|
|
rm -rf $RPM_BUILD_ROOT |
70 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
71 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
72 |
|
|
> %{name}-%{version}-%{release}-filelist |
73 |
|
|
|
74 |
|
|
%clean |
75 |
|
|
rm -rf $RPM_BUILD_ROOT |
76 |
|
|
|
77 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
78 |
|
|
%defattr(-,root,root) |
79 |
|
|
|
80 |
|
|
|
81 |
|
|
%post |
82 |
|
|
|
83 |
|
|
%preun |
84 |
|
|
if [ $1 = 0 ] ; then |
85 |
|
|
/etc/rc.d/init.d/bridge stop >& /dev/null || : |
86 |
|
|
fi |
87 |
|
|
|
88 |
|
|
true |
89 |
|
|
|