1 |
vip-ire |
1.3 |
# $Id: smeserver-bridge-interface.spec,v 1.2 2009/03/02 23:53:29 slords Exp $ |
2 |
slords |
1.1 |
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
%define version 0.1 |
6 |
vip-ire |
1.3 |
%define release 4 |
7 |
slords |
1.1 |
%define name smeserver-bridge-interface |
8 |
|
|
|
9 |
|
|
|
10 |
|
|
Summary: Configure a bridge interface |
11 |
|
|
Name: %{name} |
12 |
|
|
Version: %{version} |
13 |
|
|
Release: %{release}%{?dist} |
14 |
|
|
License: GPL |
15 |
|
|
Group: System/Servers |
16 |
|
|
Source: %{name}-%{version}.tar.gz |
17 |
|
|
|
18 |
vip-ire |
1.3 |
Patch0: smeserver-bridge-interface-0.1-set_internal_to_br.patch |
19 |
|
|
Patch1: smeserver-bridge-interface-0.1-migrate_db_when_disabled.patch |
20 |
|
|
Patch2: smeserver-bridge-interface-0.1-init_script.patch |
21 |
|
|
Patch3: smeserver-bridge-interface-0.1-status_enabled.patch |
22 |
|
|
Patch4: smeserver-bridge-interface-0.1-display_stop_start.patch |
23 |
slords |
1.1 |
|
24 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
25 |
|
|
URL: http://www.freepbx.org/ |
26 |
|
|
|
27 |
|
|
BuildRequires: e-smith-devtools |
28 |
|
|
|
29 |
|
|
Requires: bridge-utils |
30 |
|
|
Requires: openvpn |
31 |
|
|
Buildarch: noarch |
32 |
|
|
Conflicts: smeserver-openvpn-bridge.fws |
33 |
|
|
Conflicts: smeserver-openvpn-bridge-fws |
34 |
|
|
AutoReqProv: no |
35 |
|
|
|
36 |
|
|
%description |
37 |
|
|
This package allows you to replace the internal interface with a bridge |
38 |
|
|
interface (and the original internal interface enslaved to it). |
39 |
|
|
It's usefull for OpenVPN in bridge mode but can also be used for virtual host |
40 |
|
|
configuration |
41 |
|
|
|
42 |
|
|
%changelog |
43 |
vip-ire |
1.3 |
* Fri May 29 2009 Daniel B. <daniel@firewall-services.com> [0.1-4] |
44 |
|
|
- Enhance init script to display what it's doing (starting/stoping etc...) |
45 |
|
|
- Cleanup in spec file |
46 |
|
|
|
47 |
slords |
1.1 |
* Fri Jan 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-3] |
48 |
|
|
- Set default status to enabled |
49 |
|
|
|
50 |
|
|
* Mon Jan 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
51 |
|
|
- possibility to set multiple tap interfaces separated with commas |
52 |
|
|
|
53 |
|
|
* Fri Dec 12 2008 Daniel B. <daniel@firewall-services.com> [0.1-1] |
54 |
|
|
- Set the Name of InternalInterface to br0 when starting |
55 |
|
|
- Do not set the Name of InternalInterface to br0 if service is disabled |
56 |
|
|
(during databases initialization) |
57 |
|
|
|
58 |
|
|
* Tue Dec 02 2008 Daniel B. <daniel@firewall-services.com> [0.1-0] |
59 |
|
|
- initial release |
60 |
|
|
|
61 |
|
|
%prep |
62 |
|
|
|
63 |
|
|
%setup -q -n %{name}-%{version} |
64 |
|
|
%patch0 -p1 |
65 |
|
|
%patch1 -p1 |
66 |
|
|
%patch2 -p1 |
67 |
|
|
%patch3 -p1 |
68 |
vip-ire |
1.3 |
%patch4 -p1 |
69 |
slords |
1.1 |
|
70 |
|
|
%build |
71 |
|
|
# Build symlinks |
72 |
|
|
perl createlinks |
73 |
|
|
|
74 |
|
|
%install |
75 |
|
|
rm -rf $RPM_BUILD_ROOT |
76 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
77 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
78 |
|
|
> %{name}-%{version}-%{release}-filelist |
79 |
|
|
|
80 |
|
|
%clean |
81 |
|
|
rm -rf $RPM_BUILD_ROOT |
82 |
|
|
|
83 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
84 |
|
|
%defattr(-,root,root) |
85 |
|
|
|
86 |
|
|
|
87 |
|
|
%post |
88 |
|
|
|
89 |
|
|
%preun |
90 |
|
|
if [ $1 = 0 ] ; then |
91 |
|
|
/etc/rc.d/init.d/bridge stop >& /dev/null || : |
92 |
|
|
fi |
93 |
|
|
|
94 |
|
|
true |
95 |
|
|
|