1 |
unnilennium |
1.1 |
# $Id: smeserver-bridge-interface.spec,v 1.5 2012/06/19 19:44:49 vip-ire Exp $ |
2 |
|
|
# Authority: vip-ire |
3 |
|
|
# Name: Daniel Berteaud |
4 |
|
|
|
5 |
|
|
%define version 0.1 |
6 |
|
|
%define release 6 |
7 |
|
|
%define name smeserver-bridge-interface |
8 |
|
|
|
9 |
|
|
|
10 |
|
|
Summary: Configure a bridge interface |
11 |
|
|
Name: %{name} |
12 |
|
|
Version: %{version} |
13 |
|
|
Release: %{release}%{?dist} |
14 |
|
|
License: GPL |
15 |
|
|
Group: System/Servers |
16 |
|
|
Source: %{name}-%{version}.tar.gz |
17 |
|
|
|
18 |
|
|
Patch0: smeserver-bridge-interface-0.1-set_internal_to_br.patch |
19 |
|
|
Patch1: smeserver-bridge-interface-0.1-migrate_db_when_disabled.patch |
20 |
|
|
Patch2: smeserver-bridge-interface-0.1-init_script.patch |
21 |
|
|
Patch3: smeserver-bridge-interface-0.1-status_enabled.patch |
22 |
|
|
Patch4: smeserver-bridge-interface-0.1-display_stop_start.patch |
23 |
|
|
Patch5: smeserver-bridge-interface-0.1-disable_bridge_during_console_save.patch |
24 |
|
|
Patch6: smeserver-bridge-interface-0.1-sleep_after_ifconfig_eth.patch |
25 |
|
|
Patch7: smeserver-bridge-interface-0.1-br_takes_eth_mac.patch |
26 |
|
|
Patch8: smeserver-bridge-interface-0.1-bridge_promisc.patch |
27 |
|
|
|
28 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
29 |
|
|
URL: http://www.firewall-services.com/ |
30 |
|
|
|
31 |
|
|
BuildRequires: e-smith-devtools |
32 |
|
|
|
33 |
|
|
Requires: bridge-utils |
34 |
|
|
Requires: openvpn |
35 |
|
|
Buildarch: noarch |
36 |
|
|
Conflicts: smeserver-openvpn-bridge.fws |
37 |
|
|
Conflicts: smeserver-openvpn-bridge-fws |
38 |
|
|
AutoReqProv: no |
39 |
|
|
|
40 |
|
|
%description |
41 |
|
|
This package allows you to replace the internal interface with a bridge |
42 |
|
|
interface (and the original internal interface enslaved to it). |
43 |
|
|
It's usefull for OpenVPN in bridge mode but can also be used for virtual host |
44 |
|
|
configuration |
45 |
|
|
|
46 |
|
|
%changelog |
47 |
|
|
* Tue Jun 19 2012 Daniel B. <daniel@firewall-services.com> - 0.1-6.sme |
48 |
|
|
- Wait after physical interface config |
49 |
|
|
(fix a random bug in serveronly mode) |
50 |
|
|
- Ensure the bridge takes the MAC address of the physical interface |
51 |
|
|
- Optionally set the bridge interface in promiscuous mode |
52 |
|
|
|
53 |
|
|
* Tue Apr 19 2011 Daniel B. <daniel@firewall-services.com> - 0.1-5.sme |
54 |
|
|
- Fix ifcfg templates expension on SME8 [SME: 6092] |
55 |
|
|
|
56 |
|
|
* Fri May 29 2009 Daniel B. <daniel@firewall-services.com> [0.1-4] |
57 |
|
|
- Enhance init script to display what it's doing (starting/stoping etc...) |
58 |
|
|
- Cleanup in spec file |
59 |
|
|
|
60 |
|
|
* Fri Jan 16 2009 Daniel B. <daniel@firewall-services.com> [0.1-3] |
61 |
|
|
- Set default status to enabled |
62 |
|
|
|
63 |
|
|
* Mon Jan 12 2009 Daniel B. <daniel@firewall-services.com> [0.1-2] |
64 |
|
|
- possibility to set multiple tap interfaces separated with commas |
65 |
|
|
|
66 |
|
|
* Fri Dec 12 2008 Daniel B. <daniel@firewall-services.com> [0.1-1] |
67 |
|
|
- Set the Name of InternalInterface to br0 when starting |
68 |
|
|
- Do not set the Name of InternalInterface to br0 if service is disabled |
69 |
|
|
(during databases initialization) |
70 |
|
|
|
71 |
|
|
* Tue Dec 02 2008 Daniel B. <daniel@firewall-services.com> [0.1-0] |
72 |
|
|
- initial release |
73 |
|
|
|
74 |
|
|
%prep |
75 |
|
|
|
76 |
|
|
%setup -q -n %{name}-%{version} |
77 |
|
|
%patch0 -p1 |
78 |
|
|
%patch1 -p1 |
79 |
|
|
%patch2 -p1 |
80 |
|
|
%patch3 -p1 |
81 |
|
|
%patch4 -p1 |
82 |
|
|
%patch5 -p1 |
83 |
|
|
%patch6 -p1 |
84 |
|
|
%patch7 -p1 |
85 |
|
|
%patch8 -p1 |
86 |
|
|
|
87 |
|
|
%build |
88 |
|
|
# Build symlinks |
89 |
|
|
perl createlinks |
90 |
|
|
|
91 |
|
|
%install |
92 |
|
|
rm -rf $RPM_BUILD_ROOT |
93 |
|
|
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
94 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
95 |
|
|
> %{name}-%{version}-%{release}-filelist |
96 |
|
|
|
97 |
|
|
%clean |
98 |
|
|
rm -rf $RPM_BUILD_ROOT |
99 |
|
|
|
100 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
101 |
|
|
%defattr(-,root,root) |
102 |
|
|
|
103 |
|
|
|
104 |
|
|
%post |
105 |
|
|
|
106 |
|
|
%preun |
107 |
|
|
if [ $1 = 0 ] ; then |
108 |
|
|
/etc/rc.d/init.d/bridge stop >& /dev/null || : |
109 |
|
|
fi |
110 |
|
|
|
111 |
|
|
true |
112 |
|
|
|