/[smecontribs]/rpms/smeserver-bugzilla/contribs10/smeserver-bugzilla.spec
ViewVC logotype

Annotation of /rpms/smeserver-bugzilla/contribs10/smeserver-bugzilla.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Mon May 30 14:44:12 2022 UTC (2 years ago) by brianr
Branch: MAIN
CVS Tags: smeserver-bugzilla-1_0-5_el7_sme
Changes since 1.2: +14 -3 lines
* Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-5.sme
- Switch-to-mariadb-105 for SME10 and add -update event [SME: 11977]

1 brianr 1.3 # $Id: smeserver-bugzilla.spec,v 1.2 2022/05/30 10:20:29 brianr Exp $
2 jpp 1.1 # Authority: snetram
3     # Name: Jonathan Martens
4    
5     Summary: Set up bugzilla for SME Server.
6     %define name smeserver-bugzilla
7     %define version 1.0
8 brianr 1.3 %define release 5
9 jpp 1.1 Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://www.contribs.org
14     Group: SMEserver/addon
15     Source: %{name}-%{version}.tar.gz
16 brianr 1.3
17 jpp 1.1 Patch0: smeserver-bugzilla-1.0-adminpass.patch
18 brianr 1.3 Patch1: smeserver-bugzilla-1.0-Switch-to-mariadb-105.patch
19    
20 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
21     BuildArchitectures: noarch
22     BuildRequires: e-smith-devtools >= 1.13.1-03
23     Requires: e-smith-release >= 8.0
24     Requires: bugzilla >= 3.2.10
25     Requires: bugzilla-contrib
26     Requires: bugzilla-doc
27     #Requires: perl-CGI >= 3.21
28     #Requires: perl(Digest::SHA)
29     #Requires: perl-TimeDate
30     #Requires: perl(DateTime) >= 0.28
31     #Requires: perl(DateTime::TimeZone) >= 0.71
32     Requires: perl(DBI) >= 1.41
33     Requires: perl(DBD::mysql) >= 4.00
34 brianr 1.3
35     Requires: smeserver-mysql >= 2.7.0-5
36     Requires: smeserver-mariadb105
37    
38 jpp 1.1 #Requires: perl-Template-Toolkit >= 2.22
39     #Requires: perl(Email::Send) >= 2.00
40     #Requires: perl(Email::MIME) >= 1.861
41     #Requires: perl(Email::MIME::Encodings) >= 1.313
42     #Requires: perl(Email::MIME::Modifier) >= 1.442
43     #Requires: perl(URI)
44    
45     Requires: e-smith-base
46     AutoReqProv: no
47    
48     %description
49     rpm to setup bugzilla
50    
51     %changelog
52 brianr 1.3 * Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-5.sme
53     - Switch-to-mariadb-105 for SME10 and add -update event [SME: 11977]
54    
55 brianr 1.2 * Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-4.sme
56     - Fix transaction failure with --ignoredirs in genfilelist [SME: 11977]
57    
58 jpp 1.1 * Sun Oct 13 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-3.sme
59     - fixing admin pass too long [SME: 7902]
60    
61     * Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-2.sme
62     - fixing localconfig path to etc
63    
64     * Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-6.sme
65     - fixing requirement
66    
67     * Sat Mar 6 2010 Jonathan Martens <smeserver-contribs@snetram.nl>
68     - Fix date in previous changelog entry
69     - Fix SPEC header to generate proper version and release data
70    
71     * Fri Mar 5 2010 Jonathan Martens <smeserver-contribs@snetram.nl>
72     - Create strong password
73    
74     * Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
75     - Apply a more restricted set of privileges to the bugzilla database user
76    
77     * Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
78     - Update minimal requirements to match at least bugzilla 3.4.2
79     - Reserve the /bugzilla URL namespace in the configuration database
80     - Simplify webserver configuration fragment and rely on .htaccess files
81     generated by checksetup.pl
82     - Generate localconfig and populate it with the database settings
83     - Create default input configuration file (/etc/bugzilla.conf) for
84     checksetup.pl so it can be executed unattended
85     - Add a custom template so the initial welcome page will remind the admin to
86     change the password for the admin account
87     - Enable InnoDB as this is required for Bugzilla
88    
89     * Tue Aug 14 2007 Greg Swallow <greg@runlevle7.ca> - 0.1-1
90     - initial release
91    
92     %prep
93     %setup
94     %patch0 -p1
95 brianr 1.3 %patch1 -p1
96    
97 jpp 1.1 #%patch2 -p1
98     #%patch3 -p1
99     #%patch4 -p1
100     #%patch5 -p1
101     #%patch6 -p1
102     #%patch7 -p1
103     #%patch8 -p1
104    
105     %build
106     perl createlinks
107    
108     %install
109     rm -rf $RPM_BUILD_ROOT
110     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
111     rm -f %{name}-%{version}-filelist
112     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
113 brianr 1.2 --ignoredir "/usr/share/bugzilla" \
114     > %{name}-%{version}-filelist
115 jpp 1.1 echo "%doc COPYING" >> %{name}-%{version}-filelist
116    
117     %clean
118     rm -rf $RPM_BUILD_ROOT
119    
120     %files -f %{name}-%{version}-filelist
121     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed