/[smecontribs]/rpms/smeserver-bugzilla/contribs10/smeserver-bugzilla.spec
ViewVC logotype

Annotation of /rpms/smeserver-bugzilla/contribs10/smeserver-bugzilla.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Tue Jul 26 02:30:16 2022 UTC (22 months, 1 week ago) by jpp
Branch: MAIN
CVS Tags: smeserver-bugzilla-1_0-6_el7_sme
Changes since 1.3: +8 -3 lines
* Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-6.sme
- update to httpd 2.4 access syntax [SME: 12038]
  added option for private /public access default remains public

1 jpp 1.4 # $Id: smeserver-bugzilla.spec,v 1.3 2022/05/30 14:44:12 brianr Exp $
2 jpp 1.1 # Authority: snetram
3     # Name: Jonathan Martens
4    
5     Summary: Set up bugzilla for SME Server.
6     %define name smeserver-bugzilla
7     %define version 1.0
8 jpp 1.4 %define release 6
9 jpp 1.1 Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://www.contribs.org
14     Group: SMEserver/addon
15     Source: %{name}-%{version}.tar.gz
16 brianr 1.3
17 jpp 1.1 Patch0: smeserver-bugzilla-1.0-adminpass.patch
18 brianr 1.3 Patch1: smeserver-bugzilla-1.0-Switch-to-mariadb-105.patch
19 jpp 1.4 Patch2: smeserver-bugzilla-1.0-bz12038-24syntax.patch
20 brianr 1.3
21 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
22     BuildArchitectures: noarch
23     BuildRequires: e-smith-devtools >= 1.13.1-03
24     Requires: e-smith-release >= 8.0
25     Requires: bugzilla >= 3.2.10
26     Requires: bugzilla-contrib
27     Requires: bugzilla-doc
28     #Requires: perl-CGI >= 3.21
29     #Requires: perl(Digest::SHA)
30     #Requires: perl-TimeDate
31     #Requires: perl(DateTime) >= 0.28
32     #Requires: perl(DateTime::TimeZone) >= 0.71
33     Requires: perl(DBI) >= 1.41
34     Requires: perl(DBD::mysql) >= 4.00
35 brianr 1.3
36     Requires: smeserver-mysql >= 2.7.0-5
37     Requires: smeserver-mariadb105
38    
39 jpp 1.1 #Requires: perl-Template-Toolkit >= 2.22
40     #Requires: perl(Email::Send) >= 2.00
41     #Requires: perl(Email::MIME) >= 1.861
42     #Requires: perl(Email::MIME::Encodings) >= 1.313
43     #Requires: perl(Email::MIME::Modifier) >= 1.442
44     #Requires: perl(URI)
45    
46     Requires: e-smith-base
47     AutoReqProv: no
48    
49     %description
50     rpm to setup bugzilla
51    
52     %changelog
53 jpp 1.4 * Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-6.sme
54     - update to httpd 2.4 access syntax [SME: 12038]
55     added option for private /public access default remains public
56    
57 brianr 1.3 * Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-5.sme
58     - Switch-to-mariadb-105 for SME10 and add -update event [SME: 11977]
59    
60 brianr 1.2 * Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-4.sme
61     - Fix transaction failure with --ignoredirs in genfilelist [SME: 11977]
62    
63 jpp 1.1 * Sun Oct 13 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-3.sme
64     - fixing admin pass too long [SME: 7902]
65    
66     * Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-2.sme
67     - fixing localconfig path to etc
68    
69     * Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-6.sme
70     - fixing requirement
71    
72     * Sat Mar 6 2010 Jonathan Martens <smeserver-contribs@snetram.nl>
73     - Fix date in previous changelog entry
74     - Fix SPEC header to generate proper version and release data
75    
76     * Fri Mar 5 2010 Jonathan Martens <smeserver-contribs@snetram.nl>
77     - Create strong password
78    
79     * Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
80     - Apply a more restricted set of privileges to the bugzilla database user
81    
82     * Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
83     - Update minimal requirements to match at least bugzilla 3.4.2
84     - Reserve the /bugzilla URL namespace in the configuration database
85     - Simplify webserver configuration fragment and rely on .htaccess files
86     generated by checksetup.pl
87     - Generate localconfig and populate it with the database settings
88     - Create default input configuration file (/etc/bugzilla.conf) for
89     checksetup.pl so it can be executed unattended
90     - Add a custom template so the initial welcome page will remind the admin to
91     change the password for the admin account
92     - Enable InnoDB as this is required for Bugzilla
93    
94     * Tue Aug 14 2007 Greg Swallow <greg@runlevle7.ca> - 0.1-1
95     - initial release
96    
97     %prep
98     %setup
99     %patch0 -p1
100 brianr 1.3 %patch1 -p1
101 jpp 1.4 %patch2 -p1
102 brianr 1.3
103 jpp 1.1 #%patch3 -p1
104     #%patch4 -p1
105     #%patch5 -p1
106     #%patch6 -p1
107     #%patch7 -p1
108     #%patch8 -p1
109    
110     %build
111     perl createlinks
112    
113     %install
114     rm -rf $RPM_BUILD_ROOT
115     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
116     rm -f %{name}-%{version}-filelist
117     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
118 brianr 1.2 --ignoredir "/usr/share/bugzilla" \
119     > %{name}-%{version}-filelist
120 jpp 1.1 echo "%doc COPYING" >> %{name}-%{version}-filelist
121    
122     %clean
123     rm -rf $RPM_BUILD_ROOT
124    
125     %files -f %{name}-%{version}-filelist
126     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed