/[smecontribs]/rpms/smeserver-bugzilla/contribs10/smeserver-bugzilla.spec
ViewVC logotype

Annotation of /rpms/smeserver-bugzilla/contribs10/smeserver-bugzilla.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Mon Aug 1 01:56:32 2022 UTC (22 months, 1 week ago) by jpp
Branch: MAIN
CVS Tags: smeserver-bugzilla-1_0-7_el7_sme, HEAD
Changes since 1.4: +5 -4 lines
* Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-7.sme
- update to httpd 2.4 access syntax [SME: 12038]
  added option for private /public access default remains public

1 jpp 1.5 # $Id: smeserver-bugzilla.spec,v 1.4 2022/07/26 02:30:16 jpp Exp $
2 jpp 1.1 # Authority: snetram
3     # Name: Jonathan Martens
4    
5     Summary: Set up bugzilla for SME Server.
6     %define name smeserver-bugzilla
7     %define version 1.0
8 jpp 1.5 %define release 7
9 jpp 1.1 Name: %{name}
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: GNU GPL version 2
13     URL: http://www.contribs.org
14     Group: SMEserver/addon
15     Source: %{name}-%{version}.tar.gz
16 brianr 1.3
17 jpp 1.1 Patch0: smeserver-bugzilla-1.0-adminpass.patch
18 brianr 1.3 Patch1: smeserver-bugzilla-1.0-Switch-to-mariadb-105.patch
19 jpp 1.4 Patch2: smeserver-bugzilla-1.0-bz12038-24syntax.patch
20 brianr 1.3
21 jpp 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
22     BuildArchitectures: noarch
23     BuildRequires: e-smith-devtools >= 1.13.1-03
24 jpp 1.5 Requires: e-smith-release >= 10.0
25     Requires: e-smith-apache >= 2.6.0-19
26 jpp 1.1 Requires: bugzilla >= 3.2.10
27     Requires: bugzilla-contrib
28     Requires: bugzilla-doc
29     #Requires: perl-CGI >= 3.21
30     #Requires: perl(Digest::SHA)
31     #Requires: perl-TimeDate
32     #Requires: perl(DateTime) >= 0.28
33     #Requires: perl(DateTime::TimeZone) >= 0.71
34     Requires: perl(DBI) >= 1.41
35     Requires: perl(DBD::mysql) >= 4.00
36 brianr 1.3
37     Requires: smeserver-mysql >= 2.7.0-5
38     Requires: smeserver-mariadb105
39    
40 jpp 1.1 #Requires: perl-Template-Toolkit >= 2.22
41     #Requires: perl(Email::Send) >= 2.00
42     #Requires: perl(Email::MIME) >= 1.861
43     #Requires: perl(Email::MIME::Encodings) >= 1.313
44     #Requires: perl(Email::MIME::Modifier) >= 1.442
45     #Requires: perl(URI)
46    
47     Requires: e-smith-base
48     AutoReqProv: no
49    
50     %description
51     rpm to setup bugzilla
52    
53     %changelog
54 jpp 1.5 * Mon Jul 25 2022 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-7.sme
55 jpp 1.4 - update to httpd 2.4 access syntax [SME: 12038]
56     added option for private /public access default remains public
57    
58 brianr 1.3 * Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-5.sme
59     - Switch-to-mariadb-105 for SME10 and add -update event [SME: 11977]
60    
61 brianr 1.2 * Mon May 30 2022 Brian Read <brianr@bjsystems.co.uk> 1.0-4.sme
62     - Fix transaction failure with --ignoredirs in genfilelist [SME: 11977]
63    
64 jpp 1.1 * Sun Oct 13 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-3.sme
65     - fixing admin pass too long [SME: 7902]
66    
67     * Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 1.0-2.sme
68     - fixing localconfig path to etc
69    
70     * Sat Oct 12 2013 Jean-Philippe Pialasse <tests@pialasse.com> 0.1-6.sme
71     - fixing requirement
72    
73     * Sat Mar 6 2010 Jonathan Martens <smeserver-contribs@snetram.nl>
74     - Fix date in previous changelog entry
75     - Fix SPEC header to generate proper version and release data
76    
77     * Fri Mar 5 2010 Jonathan Martens <smeserver-contribs@snetram.nl>
78     - Create strong password
79    
80     * Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
81     - Apply a more restricted set of privileges to the bugzilla database user
82    
83     * Mon Dec 7 2009 Jonathan Martens <smeserver-contribs@snetram.nl>
84     - Update minimal requirements to match at least bugzilla 3.4.2
85     - Reserve the /bugzilla URL namespace in the configuration database
86     - Simplify webserver configuration fragment and rely on .htaccess files
87     generated by checksetup.pl
88     - Generate localconfig and populate it with the database settings
89     - Create default input configuration file (/etc/bugzilla.conf) for
90     checksetup.pl so it can be executed unattended
91     - Add a custom template so the initial welcome page will remind the admin to
92     change the password for the admin account
93     - Enable InnoDB as this is required for Bugzilla
94    
95     * Tue Aug 14 2007 Greg Swallow <greg@runlevle7.ca> - 0.1-1
96     - initial release
97    
98     %prep
99     %setup
100     %patch0 -p1
101 brianr 1.3 %patch1 -p1
102 jpp 1.4 %patch2 -p1
103 brianr 1.3
104 jpp 1.1 #%patch3 -p1
105     #%patch4 -p1
106     #%patch5 -p1
107     #%patch6 -p1
108     #%patch7 -p1
109     #%patch8 -p1
110    
111     %build
112     perl createlinks
113    
114     %install
115     rm -rf $RPM_BUILD_ROOT
116     (cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
117     rm -f %{name}-%{version}-filelist
118     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
119 brianr 1.2 --ignoredir "/usr/share/bugzilla" \
120     > %{name}-%{version}-filelist
121 jpp 1.1 echo "%doc COPYING" >> %{name}-%{version}-filelist
122    
123     %clean
124     rm -rf $RPM_BUILD_ROOT
125    
126     %files -f %{name}-%{version}-filelist
127     %defattr(-,root,root)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed